somme.si()

Le
EFI
bonjour

j'ai un tableau avec les éléments suivants


A B C
date montants mois
01/01 1000 janvier
05/01 2000 janvier
02/02 3000 février


Dans la colonne C j'ai mis la formule =A avec le format date MMMM

Mon objectif est de calculer les totaux mensuels. J'ai utilisé la fonction
=somme.si() mais cela ne fonctionne pas. (même avec le second urgument entre
guillements).

Quelqu'un a-t-il une idée ?

merci

Jean-Marie
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas B.
Le #1336710
Salut,

Définir un affichage de mois seul pour une cellule ne modifie pas son
contenu. La valeur contenue en C2 sera exactement la même qu'en A2.
Tu peux donc supprimer la colonne C qui ne sert à rien.

Utilise ensuite une formule comme celle-ci :
=sommeprod((mois(A2:A20)=5)*B2:B20)

5 représente le mois de mai.


A+
--
Nicolas B.


bonjour

j'ai un tableau avec les éléments suivants


A B C
date montants mois
01/01 1000 janvier
05/01 2000 janvier
02/02 3000 février


Dans la colonne C j'ai mis la formule =A avec le format date MMMM

Mon objectif est de calculer les totaux mensuels. J'ai utilisé la
fonction =somme.si() mais cela ne fonctionne pas. (même avec le
second urgument entre guillements).

Quelqu'un a-t-il une idée ?

merci

Jean-Marie


EFI
Le #1336708
merci

j'ai trouvé une autre solution avec =mois(); cela me donne le chiffre
correspondant au mois; puis j'utilise le somme.si

mais ta solution est plus élégante

merci
jm



"Nicolas B." news: OJ5lK#
Salut,

Définir un affichage de mois seul pour une cellule ne modifie pas son
contenu. La valeur contenue en C2 sera exactement la même qu'en A2.
Tu peux donc supprimer la colonne C qui ne sert à rien.

Utilise ensuite une formule comme celle-ci :
=sommeprod((mois(A2:A20)=5)*B2:B20)

5 représente le mois de mai.


A+
--
Nicolas B.


bonjour

j'ai un tableau avec les éléments suivants


A B C
date montants mois
01/01 1000 janvier
05/01 2000 janvier
02/02 3000 février


Dans la colonne C j'ai mis la formule =A avec le format date MMMM

Mon objectif est de calculer les totaux mensuels. J'ai utilisé la
fonction =somme.si() mais cela ne fonctionne pas. (même avec le
second urgument entre guillements).

Quelqu'un a-t-il une idée ?

merci

Jean-Marie






michdenis
Le #1333725
Bonjour EFI,

Il y a aussi celle-ci avec validation matricielle :

=SOMME(SI(C1:C3="AVRIL";B1:B3))


Salutations!



"EFI" bonjour

j'ai un tableau avec les éléments suivants


A B C
date montants mois
01/01 1000 janvier
05/01 2000 janvier
02/02 3000 février


Dans la colonne C j'ai mis la formule =A avec le format date MMMM

Mon objectif est de calculer les totaux mensuels. J'ai utilisé la fonction
=somme.si() mais cela ne fonctionne pas. (même avec le second urgument entre
guillements).

Quelqu'un a-t-il une idée ?

merci

Jean-Marie
Publicité
Poster une réponse
Anonyme