Twitter iPhone pliant OnePlus 11 PS5 Disney+ Orange Livebox Windows 11

Sommeprod année décaler

4 réponses
Avatar
syleg35
Bonjour =E0 tous

SVP besoin d'aide pour modifier formule

J'ai cette formule pour avoir le total des valeurs par ann=E9e, en colonne =
(D) les ann=E9es de 2005 =E0 2013, en col (A) les mois et en (B) les valeur=
s

=3DSOMMEPROD((ANNEE($A$2:$A$200)=3DD2)*($B$2:$B$200))

mais pour raison propre =E0 mon organisation, mon calcul ann=E9e doit ce fa=
ire de d=E9cembre =E0 novembre

Exemple : pour 2005 c'est =E9gale =E0 d=E9cembre 2004 =E0 novembre 2005=20

pour 2006 c'est =E9gale =E0 d=E9cembre 2005 =E0 novembre 2006

Merci =E0 vous
Bonne journ=E9e

4 réponses

Avatar
DanielCo
Bonjour,
Formule matricielle (valider avec Ctrl+Maj+Entrée) :
=SOMMEPROD(((ANNEE($A$2:$A$200)Ò-1)*(MOIS($A$2:$A$200))+(ANNEE($A$2:$A$200)Ò)*(MOIS($A$2:$A$200)))*$B$2:$B$200)
Cordialement.
Daniel


Bonjour à tous

SVP besoin d'aide pour modifier formule

J'ai cette formule pour avoir le total des valeurs par année, en colonne (D)
les années de 2005 à 2013, en col (A) les mois et en (B) les valeurs

=SOMMEPROD((ANNEE($A$2:$A$200)Ò)*($B$2:$B$200))

mais pour raison propre à mon organisation, mon calcul année doit ce faire de
décembre à novembre

Exemple : pour 2005 c'est égale à décembre 2004 à novembre 2005

pour 2006 c'est égale à décembre 2005 à novembre 2006

Merci à vous
Bonne journée
Avatar
Jacquouille
Bonjour
Pour déc2004 et jan à nov inclus 2005
=Sommeprod((( année = 2004)*(mois)*(b2:b200))+(sommeprod((année =
2005)*(mois=<11)*(b2:b200)))
ou D2 04 --> =sommeprod(((annéeÒ)*(mois
)*(b2:b200))+(sommeprod((annéeÒ+1)*(mois=<11)*(b2:b200)))
Pas testé, mais les Dieux de SP veillent

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
a écrit dans le message de groupe de discussion :


Bonjour à tous

SVP besoin d'aide pour modifier formule

J'ai cette formule pour avoir le total des valeurs par année, en colonne (D)
les années de 2005 à 2013, en col (A) les mois et en (B) les valeurs

=SOMMEPROD((ANNEE($A$2:$A$200)Ò)*($B$2:$B$200))

mais pour raison propre à mon organisation, mon calcul année doit ce faire
de décembre à novembre

Exemple : pour 2005 c'est égale à décembre 2004 à novembre 2005

pour 2006 c'est égale à décembre 2005 à novembre 2006

Merci à vous
Bonne journée
Avatar
DanielCo
Oups, en relisant la formule de Jacquoouille, je me suis aperçu de mon
erreur :
=SOMMEPROD(((ANNEE($A$2:$A$200)Ò-1)*(MOIS($A$2:$A$200))+(ANNEE($A$2:$A$200)Ò)*(MOIS($A$2:$A$200)<12))*$B$2:$B$200)
Daniel


Bonjour,
Formule matricielle (valider avec Ctrl+Maj+Entrée) :
=SOMMEPROD(((ANNEE($A$2:$A$200)Ò-1)*(MOIS($A$2:$A$200))+(ANNEE($A$2:$A$200)Ò)*(MOIS($A$2:$A$200)))*$B$2:$B$200)
Cordialement.
Daniel


Bonjour à tous

SVP besoin d'aide pour modifier formule

J'ai cette formule pour avoir le total des valeurs par année, en colonne
(D) les années de 2005 à 2013, en col (A) les mois et en (B) les valeurs

=SOMMEPROD((ANNEE($A$2:$A$200)Ò)*($B$2:$B$200))

mais pour raison propre à mon organisation, mon calcul année doit ce faire
de décembre à novembre

Exemple : pour 2005 c'est égale à décembre 2004 à novembre 2005

pour 2006 c'est égale à décembre 2005 à novembre 2006

Merci à vous
Bonne journée
Avatar
syleg35
Bonjour ;
DanielCo

Merci !
la deuxième fonctionne c'est Ok

Bonne journée

Le samedi 11 janvier 2014 15:18:45 UTC+1, DanielCo a écrit :
Oups, en relisant la formule de Jacquoouille, je me suis aperï¿œu d e mon

erreur :

=SOMMEPROD(((ANNEE($A$2:$A$200)-1)*(MOIS($A$2:$A$200))+(ANNEE ($A$2:$A$200))*(MOIS($A$2:$A$200)<12))*$B$2:$B$200)

Daniel





> Bonjour,

> Formule matricielle (valider avec Ctrl+Maj+Entrï¿œe) :

> =SOMMEPROD(((ANNEE($A$2:$A$200)-1)*(MOIS($A$2:$A$200))+(ANN EE($A$2:$A$200))*(MOIS($A$2:$A$200)))*$B$2:$B$200)

> Cordialement.

> Daniel

>

>

>> Bonjour ᅵ tous

>>

>> SVP besoin d'aide pour modifier formule

>>

>> J'ai cette formule pour avoir le total des valeurs par annï¿œe, en colonne

>> (D) les annᅵes de 2005 ᅵ 2013, en col (A) les mois et en (B) les valeurs

>>

>> =SOMMEPROD((ANNEE($A$2:$A$200))*($B$2:$B$200))

>>

>> mais pour raison propre ï¿œ mon organisation, mon calcul annï ¿œe doit ce faire

>> de dᅵcembre ᅵ novembre

>>

>> Exemple : pour 2005 c'est ᅵgale ᅵ dᅵcembre 200 4 ᅵ novembre 2005

>>

>> pour 2006 c'est ᅵgale ᅵ dᅵcembre 2005 ᅵ novembre 2006

>>

>> Merci ᅵ vous

>> Bonne journï¿œe