Sommeprod année deux critères

Le
Syleg
Bonjour à tous

Dans la feuil « Revenus mensuel » j’ai des montant par mo=
is et par libellé et je voudrais dans la feuil « Annuel » fa=
ire une somme par année et par libellé.

Dans la feuil « Revenus mensuel » la colonne (B) date au (format =
11/01/2007), colonne (D) libellé, colonne (E) montant.

Dans la feuil « Annuel » les année en colonne (A) et Libell=
é en ligne (B1) (C1) etc.

Formule que je n’arrive pas a validé :

=SOMMEPROD((ANNEE('Revenus mensuel'!$B$2:$B$500)=A3)*('Revenus mensuel'=
!$D$2:$D$500)=B1)*('Revenus mensuel'!$E$2:$E$500))))=0;"";SOMMEPROD((AN=
NEE('Revenus mensuel'!$B$2:$B$500)=A3)*('Revenus mensuel'!$D$2:$D$500)==
B1)*('Revenus mensuel'!$E$2:$E$500)))
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Michd
Le #26465648
Tu as pensé à utiliser un tableau croisé dynamique. Utilise le champ "Date"
comme filtre.
MichD
Syleg
Le #26465733
Bonjour Michd
Merci pour la réponse mais je préfère utiliser Sommeprod pou r une présentation préférencielle
Par contre quand j'utilise la première formule j'ai bien la somme par année et quand je rajoute le deuxième critère (libellé) sa met une erreur #VALEUR!
=SOMMEPROD((ANNEE(Revenusmensuel!$B$2:$B$500))*(Revenusmensuel!$E$2: $E$500))
=SOMMEPROD((ANNEE(Revenusmensuel!$B$2:$B$500))*(Revenusmensuel!$D$2: $D$500))*(Revenusmensuel!$E$2:$E$500)

Le samedi 24 février 2018 23:28:38 UTC+1, Michd a écrit :
Bonjour,
Pourquoi 2 "sommeprod() dans la même formule ?
Ceci n'est pas suffisant?
=SOMMEPROD((ANNEE('Revenus mensuel'!$B$2:$B$500))*('Revenus
mensuel'!$D$2:$D$500))*('Revenus mensuel'!$E$2:$E$500)
MichD
Publicité
Poster une réponse
Anonyme