SommeProd

Le
phil.aline.naudin
Bonsoir,

Depuis peu j'utilise la fonction SommeProd. Je suis arrivé à mes fins en
recopiant sur le net une formule. Elle fonctionne mais je ne sais pas
pourquoi !!!

Par curiosité je vous livre mon problème et la soluce .
Trouver une année ou les Data sont sous la forme "22/05/2006" et calculer la
somme sui se trouve dans une autre colonne.
la soluce que j'ai pompé est :
"=SOMMEPROD((ANNEE($I$9:$I$1523) 05)*1;$N$9:$N$1523)"

Pourquoi faut il mettre "1" dans cette formule ?

Merci d"avance pour la réponse.
Vos réponses
Trier par : date / pertinence
François
Le #4073941
Bonsoir,

Le principe de la fonction "sommeprod" est que, quand on appelle une
condition du genre (vrai-faux), exemple
ANNEE($I$9:$I$1523) 05), si la condition est vraie pour la cellule I9 ,
cela donne à ce bloc (pour la seule valeur I9) la valeur 1, sinon la valeur
0 ... Lorsque plusieurs conditions s'enchaînent, dès qu'il y a une valeur 0
dans la sommeprod, le résultat est 0, ou, si l'ensemble des conditions est
couplé à une valeur réelle (A1:A100 ou une valeur réelle telle PI ou ...),
cela donne une valeur autre que 0 ou 1. La somme de ces produit de valeur
donne le résultat attendu ...

Cordialement

François

"phil.aline.naudin" de news: 4569cd9f$0$5085$
Bonsoir,

Depuis peu j'utilise la fonction SommeProd. Je suis arrivé à mes fins en
recopiant sur le net une formule. Elle fonctionne mais je ne sais pas
pourquoi !!!

Par curiosité je vous livre mon problème et la soluce .
Trouver une année ou les Data sont sous la forme "22/05/2006" et calculer
la somme sui se trouve dans une autre colonne.
la soluce que j'ai pompé est :
"=SOMMEPROD((ANNEE($I$9:$I$1523) 05)*1;$N$9:$N$1523)"

Pourquoi faut il mettre "1" dans cette formule ?

Merci d"avance pour la réponse.



MichDenis
Le #4073881
Aux gens de l'académie de traduire ce truc technique en français !!!

Formule I
"=SOMMEPROD((ANNEE($I$9:$I$1523) 05)*1;$N$9:$N$1523)"

Si dans ta plage à addionner : $N$9:$N$1523 , tu n'avais que des valeurs numériques,
tu pourrais utiliser la formule suivante :
Formule II
"=SOMMEPROD((ANNEE($I$9:$I$1523) 05)*($N$9:$N$1523))"

Dans le cas de la Formule II
Comme tu vois, c'est le produit de 2 matrices
Pour chacune des lignes de la matrice 1, excel évalue si
l'affirmation de la formule est vrai ou fausse et il inscrit
le résultat dans un tableau temporaire qu'il conserve en
mémoire vive :
Matrice 1 matrice 2
$I$9:$I$1523) 05 $N$9:$N$1523
Vrai toto
Vrai 2
Faux 3

Comme l'indique le nom de la fonction sommeProd()
Prod étant le produit des matrices 1 par la matrice 2
Si tu avais dans la matrice 2 des entrées textes, la multiplication
des 2 matrices généraient des résultats affichant #VALEUR!
dans le tableau temporaire.
(Vrai = 1 et Faux = 0)

Vrai * toto = #VALEUR!
Vrai * 2 = 2
Faux * 3 = 0

Quand arrive l'opération "somme de la matrice résultante"
de la fonction SommeProd()
=SOMME({#VALEUR!.1.2}) Résultat = #VALEUR!


Le fait d'ajouter à la formule le *1 et d'ajouter le séparateur ";"
Excel résout la première matrice
Matrice 1 matrice 2
$I$9:$I$1523) 05 $N$9:$N$1523
Vrai * 1 = 1 toto
Vrai * 1 = 1 2
Faux * 1 = 0 3

=SOMMEPROD({1.1.0};{"toto".2.3}) = 2





"phil.aline.naudin" 4569cd9f$0$5085$
Bonsoir,

Depuis peu j'utilise la fonction SommeProd. Je suis arrivé à mes fins en
recopiant sur le net une formule. Elle fonctionne mais je ne sais pas
pourquoi !!!

Par curiosité je vous livre mon problème et la soluce .
Trouver une année ou les Data sont sous la forme "22/05/2006" et calculer la
somme sui se trouve dans une autre colonne.
la soluce que j'ai pompé est :
"=SOMMEPROD((ANNEE($I$9:$I$1523) 05)*1;$N$9:$N$1523)"

Pourquoi faut il mettre "1" dans cette formule ?

Merci d"avance pour la réponse.
phil.aline.naudin
Le #4073851
Merci pour vos réponses.
J'avais tenté de résoudre mon problème avec "Somme_Si" mais je me suis vite
retrouvé avec des résultats bizarres. Essentiellement expliqué par le format
de la cellule où je prenais l'info.

Encore merci




"MichDenis"
Aux gens de l'académie de traduire ce truc technique en français !!!

Formule I
"=SOMMEPROD((ANNEE($I$9:$I$1523) 05)*1;$N$9:$N$1523)"

Si dans ta plage à addionner : $N$9:$N$1523 , tu n'avais que des valeurs
numériques,
tu pourrais utiliser la formule suivante :
Formule II
"=SOMMEPROD((ANNEE($I$9:$I$1523) 05)*($N$9:$N$1523))"

Dans le cas de la Formule II
Comme tu vois, c'est le produit de 2 matrices
Pour chacune des lignes de la matrice 1, excel évalue si
l'affirmation de la formule est vrai ou fausse et il inscrit
le résultat dans un tableau temporaire qu'il conserve en
mémoire vive :
Matrice 1 matrice 2
$I$9:$I$1523) 05 $N$9:$N$1523
Vrai toto
Vrai 2
Faux 3

Comme l'indique le nom de la fonction sommeProd()
Prod étant le produit des matrices 1 par la matrice 2
Si tu avais dans la matrice 2 des entrées textes, la multiplication
des 2 matrices généraient des résultats affichant #VALEUR!
dans le tableau temporaire.
(Vrai = 1 et Faux = 0)

Vrai * toto = #VALEUR!
Vrai * 2 = 2
Faux * 3 = 0

Quand arrive l'opération "somme de la matrice résultante"
de la fonction SommeProd()
=SOMME({#VALEUR!.1.2}) Résultat = #VALEUR!


Le fait d'ajouter à la formule le *1 et d'ajouter le séparateur ";"
Excel résout la première matrice
Matrice 1 matrice 2
$I$9:$I$1523) 05 $N$9:$N$1523
Vrai * 1 = 1 toto
Vrai * 1 = 1 2
Faux * 1 = 0 3

=SOMMEPROD({1.1.0};{"toto".2.3}) = 2





"phil.aline.naudin" de news:
4569cd9f$0$5085$
Bonsoir,

Depuis peu j'utilise la fonction SommeProd. Je suis arrivé à mes fins en
recopiant sur le net une formule. Elle fonctionne mais je ne sais pas
pourquoi !!!

Par curiosité je vous livre mon problème et la soluce .
Trouver une année ou les Data sont sous la forme "22/05/2006" et calculer
la
somme sui se trouve dans une autre colonne.
la soluce que j'ai pompé est :
"=SOMMEPROD((ANNEE($I$9:$I$1523) 05)*1;$N$9:$N$1523)"

Pourquoi faut il mettre "1" dans cette formule ?

Merci d"avance pour la réponse.





Publicité
Poster une réponse
Anonyme