[SPS 2003] Erreur dans l'event viewer lors de l'utilisation du SSO

Le
Hugo
Bonjour à tous,

J'ai un soucis technique concernant l'utilisation du SSO sous SPS 2003.

J'ai développé une page aspx qui permet pour chaque utilisateur de gérer,
depuis son profil, l'ensemble des comptes d'applications d'entreprise dont il
dispose.

Cette page liste donc les applications d'entreprises définis et recherche
par rapport à l'utilisateur courant son login et mot de passe pour cette
application (utilisation d'un dataset et d'un datagrid rien de bien
méchant)

Là ou mon problème survient est lorsque l'utilisateur n'a pas encore entré
d'informations pour une application d'entreprise J'ai suivi l'exemple
fournit dans le SDK de SharePoint et mon code est le suivant :

try
{
Credentials.GetCredentials(1, oAppInfo.ApplicationName, ref
rgGetCredentialData);
-- traitement --
}
catch (SingleSignonException ssoe)
{
// Si ils ne sont pas renseignés
if (SSOReturnCodes.SSO_E_CREDS_NOT_FOUND == ssoe.LastErrorCode)
{
-- traitement --
}
}
catch (Exception ex)
{
traitement de l'erreur --
}

Tout fonctionne parfaitement l'utilisateur obtient un message lui indiquant
qu'il n'a pas encore fournit d'information pour cette application.

Le problème est qu'une exception (SingleSignonException) est levée et cette
exception est gérer par mon code MAIS j'ai une entrée dans l'event viewer
application de mon serveur qui apparait (un petit message d'erreur indiquant
que SharePoint n'a pas trouvé d'information dans la base SSO pour tel ou tel
utilisateur) du coup mon eventviewer se retrouve très rapidement pollué
par toutes ces entrées qui sont en fait de faux problèmes.

Je me tourne donc vers vous, spécialistes de ce produit, pour savoir s'il
existe un moyen de desactiver par code ce message d'erreur qui pollue
inutilement mon eventviewer

Merci pour vos réponses.

Cordialement,

-Hugo PAIN
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
EROL MVP SPS - Club SharePoint
Le #17142361
Bonjour Hugo,

Vous avez vu ceci :
http://www.microsoft.com/technet/prodtechnol/sppt/reskit/c2661881x.mspx
protected override void RenderWebPart(HtmlTextWriter writer) //RenderWebPart
Cdlt
--
--
EROL
http://www.clubsps.org
http://sharepointerol.blogspot.com/

Pour vous inscrire gratuitement au club SPS,
cliquer ici : http://inscrits.clubsps.org/ .


"Hugo"
Bonjour à tous,

J'ai un soucis technique concernant l'utilisation du SSO sous SPS 2003.

J'ai développé une page aspx qui permet pour chaque utilisateur de gérer,
depuis son profil, l'ensemble des comptes d'applications d'entreprise dont
il
dispose.

Cette page liste donc les applications d'entreprises définis et recherche
par rapport à l'utilisateur courant son login et mot de passe pour cette
application (utilisation d'un dataset et d'un datagrid ... rien de bien
méchant)

Là ou mon problème survient est lorsque l'utilisateur n'a pas encore entré
d'informations pour une application d'entreprise... J'ai suivi l'exemple
fournit dans le SDK de SharePoint et mon code est le suivant :

try
{
Credentials.GetCredentials(1, oAppInfo.ApplicationName, ref
rgGetCredentialData);
----- traitement --------
}
catch (SingleSignonException ssoe)
{
// Si ils ne sont pas renseignés
if (SSOReturnCodes.SSO_E_CREDS_NOT_FOUND == ssoe.LastErrorCode)
{
----- traitement --------
}
}
catch (Exception ex)
{
--- traitement de l'erreur --
}

Tout fonctionne parfaitement l'utilisateur obtient un message lui
indiquant
qu'il n'a pas encore fournit d'information pour cette application.

Le problème est qu'une exception (SingleSignonException) est levée et
cette
exception est gérer par mon code MAIS j'ai une entrée dans l'event viewer
application de mon serveur qui apparait (un petit message d'erreur
indiquant
que SharePoint n'a pas trouvé d'information dans la base SSO pour tel ou
tel
utilisateur)... du coup mon eventviewer se retrouve très rapidement pollué
par toutes ces entrées qui sont en fait de faux problèmes....

Je me tourne donc vers vous, spécialistes de ce produit, pour savoir s'il
existe un moyen de desactiver par code ce message d'erreur qui pollue
inutilement mon eventviewer...

Merci pour vos réponses.

Cordialement,

-Hugo PAIN






Publicité
Poster une réponse
Anonyme