[SPS 2003] Résultat de recherche vide

Le
Christophe DE LA BARRE
Bonjour,

J'ai une plate-forme SPS 2003 sur laquelle, brusquement, le moteur de
recherche s'est mis à ne plus fonctionner. L'indexation se déroule bien, mais
les recherches renvoient systématiquement une page vide lorsqu'il devrait y
avoir un résultat.
Lorsqu'il ne doit pas y avoir de résultat, on a bien une page indiquant
aucun résultat. J'ai testé la destruction du portail, puis sa recréation
vierge, sans succès.
J'ai ensuite déinstallé, détruit les bases de données, réinstallé SPS 2003
puis le SP1, sans succès non plus, la recherche renvoie toujours vide.

Nous avons déjà rencontrer un problème similaire, il y a quelques mois, qui
s'est résolus parla réinstallation complète de l'OS.
Cette solution, ne nous satisfait evidement pas.

Si quelqu'un a déjà vu un cas semblable et a trouvé une solution, je suis
preneur.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
EROL MVP SPS
Le #17176091
Bonjour,

Vous avez une autre application sur le serveur ou il y a SPS 2003 ?
Ou est basé le serveur SQL ?
Ce serveur ne fonctionne que pour SPS ?
Avez vous juste fait l'essai de réinitialiser la table d'index?

Vous avez lu ceci :
Microsoft SharePointPSSearch SQL Syntax
http://www.microsoft.com/downloads/details.aspx?FamilyIDÖA10783-A4E4-4463-8444-F88BE48760B3&displaylang=en

Bonne lecture

Pensez aussi à voir :
http://www.sharepoint-france.com/Products/DocumentRecovery/Default.aspx

La base SQL peut avoir des PB...

Microsoft Office SharePoint Portal Server 2003 Management Pack Guide
http://www.microsoft.com/technet/prodtechnol/mom/mom2000/maintain/sps03mpg.mspx
Cdlt
--
EROL MVP SharePoint. www.mysps.info
http://aspnet2.com/mvp.ashx?ErolGiraudy

"Christophe DE LA BARRE" écrit dans le message de news:

Bonjour,

J'ai une plate-forme SPS 2003 sur laquelle, brusquement, le moteur de
recherche s'est mis à ne plus fonctionner. L'indexation se déroule bien,
mais
les recherches renvoient systématiquement une page vide lorsqu'il devrait
y
avoir un résultat.
Lorsqu'il ne doit pas y avoir de résultat, on a bien une page indiquant
aucun résultat. J'ai testé la destruction du portail, puis sa recréation
vierge, sans succès.
J'ai ensuite déinstallé, détruit les bases de données, réinstallé SPS 2003
puis le SP1, sans succès non plus, la recherche renvoie toujours vide.

Nous avons déjà rencontrer un problème similaire, il y a quelques mois,
qui
s'est résolus parla réinstallation complète de l'OS.
Cette solution, ne nous satisfait evidement pas.

Si quelqu'un a déjà vu un cas semblable et a trouvé une solution, je suis
preneur.


Christophe DE LA BARRE
Le #17176061
Bonjour,

Non, il n'y a pas d'autre application sur le serveur SPS 2003.
La plate-forme est composée de 2 serveurs complètement dédié à SPS 2003.
Un serveur pour avec SPS proprement dit (WEB,INDEX,RECHERCHE,TRAVAIL).
Un serveur SQL 2000 SP3.

Il n'y a rien d'autre sur ces serveurs et il ne font que ça.
Evidement, on a commencer par tester une réindexation intégrale.
Sans résultat, on a détruit et recréer un portail complètement VIERGE.
Toujours sans résultat, on a désinstaller SPS 2003, WSS, détruit les bases
de données, réinstaller SPS (qui installer WSS), puis le SP1 de WSS puis le
SP1 de SPS, et recréer un portail VIERGE. Sans résultat ...

Exemple, lorsqu'on recherche le mot "rapide", on a pas de résultats (même
pas le message indiquant qu'il n'y a pas de résultat), alors qu'il est
présent dans un article de la page d'accueil "Explorer le portail avec le
Guide de démarrage rapide"

Cdlt.

"EROL MVP SPS" a écrit :

Bonjour,

Vous avez une autre application sur le serveur ou il y a SPS 2003 ?
Ou est basé le serveur SQL ?
Ce serveur ne fonctionne que pour SPS ?
Avez vous juste fait l'essai de réinitialiser la table d'index?

Vous avez lu ceci :
Microsoft SharePointPSSearch SQL Syntax
http://www.microsoft.com/downloads/details.aspx?FamilyIDÖA10783-A4E4-4463-8444-F88BE48760B3&displaylang=en

Bonne lecture

Pensez aussi à voir :
http://www.sharepoint-france.com/Products/DocumentRecovery/Default.aspx

La base SQL peut avoir des PB...

Microsoft Office SharePoint Portal Server 2003 Management Pack Guide
http://www.microsoft.com/technet/prodtechnol/mom/mom2000/maintain/sps03mpg.mspx
Cdlt
--
EROL MVP SharePoint. www.mysps.info
http://aspnet2.com/mvp.ashx?ErolGiraudy

"Christophe DE LA BARRE" écrit dans le message de news:

> Bonjour,
>
> J'ai une plate-forme SPS 2003 sur laquelle, brusquement, le moteur de
> recherche s'est mis à ne plus fonctionner. L'indexation se déroule bien,
> mais
> les recherches renvoient systématiquement une page vide lorsqu'il devrait
> y
> avoir un résultat.
> Lorsqu'il ne doit pas y avoir de résultat, on a bien une page indiquant
> aucun résultat. J'ai testé la destruction du portail, puis sa recréation
> vierge, sans succès.
> J'ai ensuite déinstallé, détruit les bases de données, réinstallé SPS 2003
> puis le SP1, sans succès non plus, la recherche renvoie toujours vide.
>
> Nous avons déjà rencontrer un problème similaire, il y a quelques mois,
> qui
> s'est résolus parla réinstallation complète de l'OS.
> Cette solution, ne nous satisfait evidement pas.
>
> Si quelqu'un a déjà vu un cas semblable et a trouvé une solution, je suis
> preneur.





EROL MVP SPS
Le #17176031
Bonjour Christophe,


Avez vous fait ces actions ?

Réinitialisation d'un index de contenu :

Lorsque vous réinitialisez un index de contenu, vous le videz, mais vous ne
perdez pas les données statistiques compilées au cours des mises à jour
spéculatives.

La réinitialisation d'un index peut s'avérer utile dans les conditions
suivantes :

a.. Vous savez ou vous supposez que l'index contient des données
anciennes.

b.. Vous savez ou vous supposez que l'index contient des données
corrompues.

c.. Vous avez modifié beaucoup de contenu ou de nombreux paramètres (par
exemple, vous avez modifié les règles des sources de contenu) et vous
souhaitez effectuer une mise à jour intégrale pour refléter ces
modifications.

d.. Vous constatez qu'il existe un problème de sécurité et que les
utilisateurs peuvent afficher des données auxquelles ils ne devraient pas
accéder. La réinitialisation de l'index les empêche immédiatement d'accéder
à ces données.

Remarque :
Dans une configuration de batterie de serveurs, vous devez
forcer la propagation si vous voulez supprimer immédiatement l'accès
utilisateur à ces données. Si un utilisateur lance une recherche après que
vous avez réinitialisé un index mais avant que vous ayez créé un nouvel
index, la recherche ne donne lieu à aucun résultat.

Remarque :
Vous pouvez réinitialiser un index uniquement si vous avez activé
le mode

++++ Administration de la recherche avancée. ++++ Attention à ceci
!

Réinitialiser un index de contenu

1.. Dans la page Paramètres du site, dans la section Paramètres de
recherche et contenu indexé, cliquez sur Configurer la recherche et
l'indexation.

2.. Dans la page Configurer la recherche et l'indexation, dans la section
Index de contenu, cliquez sur Gérer les index de contenu.

3.. Dans la page Gérer les index de contenu, positionnez le pointeur sur
le nom de l'index et cliquez sur la flèche qui apparaît.

4.. Dans le menu qui s'affiche, cliquez sur Réinitialiser l'index de
contenu.

5.. Dans la zone de message qui apparaît, cliquez sur OK.
La réinitialisation de l'index interrompt les mises à jour en cours et
vide entièrement l'index.

Dans une configuration de batterie de serveurs, l'ancien index existe
toujours sur les serveurs de recherche tant que vous ne forcez pas la
propagation.

6.. Après avoir réinitialisé un index de contenu, vous devez effectuer une
mise à jour intégrale. Pour cela, procédez comme suit :

1.. Dans la page Gérer les index de contenu, positionnez le pointeur sur
le nom de l'index et cliquez sur la flèche qui apparaît.
2.. Dans le menu qui s'affiche, cliquez sur Mise à jour intégrale.
---------------------------------------------------------

Activation du mode Administration de la recherche avancée
Dans le mode d'administration de la recherche par défaut, deux index de
contenu sont utilisés pour le contenu des sites portail et le contenu
n'appartenant pas au portail.

Vous ne pouvez pas supprimer ces index.

Toutes les nouvelles sources de contenu et le contenu d'annuaire de sites
sont analysés et inclus dans l'index de contenu n'appartenant pas au
portail.

Le mode Administration de la recherche avancée permet de créer et de gérer
des index supplémentaires.

Les listes d'index s'avèrent utiles pour les analyses à grande échelle et le
ciblage personnalisé de l'étendue des requêtes, mais leur gestion est
complexe.

Une fois que le mode Administration de la recherche avancée a été activé
pour
un site portail, vous ne pouvez plus activer le mode standard (par défaut).

Le mode Administration de la recherche avancée permet d'effectuer les
opérations suivantes :

a.. Créer plusieurs sources de contenu d'annuaire de sites. Ceci permet de
disposer de plusieurs étendues sur les sites dans l'annuaire de sites.

b.. Organiser les sources de contenu dans des groupes de sources. Ceci
permet une installation avec une longue liste de sources de contenu pour les
traiter en groupes. Les groupes de sources apparaissent dans l'interface
utilisateur pour la définition de l'étendue. La définition des étendues est
basée sur des groupes de sources et non sur des sources individuelles. Le
résultat constaté est une performance améliorée des requêtes lancées sur ces
groupes, car elles vérifient un groupe de sources au lieu d'effectuer
plusieurs vérifications pour chaque source de contenu.

Si vous activez le mode Administration de la recherche avancée, vous pouvez
effectuer les tâches supplémentaires suivantes qui ne sont pas disponibles
dans le mode par défaut :

a.. Créer un index
b.. Réinitialiser un index
c.. Supprimer un index
d.. Spécifier l'index où inclure une source de contenu
e.. Gérer un index

Activer le mode Administration de la recherche avancée:
1.. Dans la page Paramètres du site, dans la section Paramètres de
recherche et contenu indexé, cliquez sur Configurer la recherche et
l'indexation.

2.. Dans la page Configurer la recherche et l'indexation, dans la section
Paramètres généraux de contenu et état d'indexation, cliquez sur Activer le
mode Administration de la recherche avancée.

3.. Dans la page Activer le mode Administration de la recherche avancée,
cliquez sur OK.

Une fois que vous avez activé le mode Administration de la recherche
avancée, une section supplémentaire appelée Index de contenu apparaît dans
la page Configurer la recherche et l'indexation.


--
EROL MVP SharePoint. www.mysps.info
http://aspnet2.com/mvp.ashx?ErolGiraudy


"Christophe DE LA BARRE" écrit dans le message de news:

Bonjour,

Non, il n'y a pas d'autre application sur le serveur SPS 2003.
La plate-forme est composée de 2 serveurs complètement dédié à SPS 2003.
Un serveur pour avec SPS proprement dit (WEB,INDEX,RECHERCHE,TRAVAIL).
Un serveur SQL 2000 SP3.

Il n'y a rien d'autre sur ces serveurs et il ne font que ça.
Evidement, on a commencer par tester une réindexation intégrale.
Sans résultat, on a détruit et recréer un portail complètement VIERGE.
Toujours sans résultat, on a désinstaller SPS 2003, WSS, détruit les bases
de données, réinstaller SPS (qui installer WSS), puis le SP1 de WSS puis
le
SP1 de SPS, et recréer un portail VIERGE. Sans résultat ...

Exemple, lorsqu'on recherche le mot "rapide", on a pas de résultats (même
pas le message indiquant qu'il n'y a pas de résultat), alors qu'il est
présent dans un article de la page d'accueil "Explorer le portail avec le
Guide de démarrage rapide"

Cdlt.

"EROL MVP SPS" a écrit :

Bonjour,

Vous avez une autre application sur le serveur ou il y a SPS 2003 ?
Ou est basé le serveur SQL ?
Ce serveur ne fonctionne que pour SPS ?
Avez vous juste fait l'essai de réinitialiser la table d'index?

Vous avez lu ceci :
Microsoft SharePointPSSearch SQL Syntax
http://www.microsoft.com/downloads/details.aspx?FamilyIDÖA10783-A4E4-4463-8444-F88BE48760B3&displaylang=en

Bonne lecture

Pensez aussi à voir :
http://www.sharepoint-france.com/Products/DocumentRecovery/Default.aspx

La base SQL peut avoir des PB...

Microsoft Office SharePoint Portal Server 2003 Management Pack Guide
http://www.microsoft.com/technet/prodtechnol/mom/mom2000/maintain/sps03mpg.mspx
Cdlt
--
EROL MVP SharePoint. www.mysps.info
http://aspnet2.com/mvp.ashx?ErolGiraudy

"Christophe DE LA BARRE" a
écrit dans le message de news:

> Bonjour,
>
> J'ai une plate-forme SPS 2003 sur laquelle, brusquement, le moteur de
> recherche s'est mis à ne plus fonctionner. L'indexation se déroule
> bien,
> mais
> les recherches renvoient systématiquement une page vide lorsqu'il
> devrait
> y
> avoir un résultat.
> Lorsqu'il ne doit pas y avoir de résultat, on a bien une page indiquant
> aucun résultat. J'ai testé la destruction du portail, puis sa
> recréation
> vierge, sans succès.
> J'ai ensuite déinstallé, détruit les bases de données, réinstallé SPS
> 2003
> puis le SP1, sans succès non plus, la recherche renvoie toujours vide.
>
> Nous avons déjà rencontrer un problème similaire, il y a quelques mois,
> qui
> s'est résolus parla réinstallation complète de l'OS.
> Cette solution, ne nous satisfait evidement pas.
>
> Si quelqu'un a déjà vu un cas semblable et a trouvé une solution, je
> suis
> preneur.







Amadeus
Le #17176011
Bonjour

je confirme ce genre de probleme avec sps2003, j'ai eu le meme probleme sur
une plate forme de teste et j'ai due tout reinstaller( meme l'os) pour que
l'indexation marche a nouveau



"Christophe DE LA BARRE" a écrit :

Bonjour,

Non, il n'y a pas d'autre application sur le serveur SPS 2003.
La plate-forme est composée de 2 serveurs complètement dédié à SPS 2003.
Un serveur pour avec SPS proprement dit (WEB,INDEX,RECHERCHE,TRAVAIL).
Un serveur SQL 2000 SP3.

Il n'y a rien d'autre sur ces serveurs et il ne font que ça.
Evidement, on a commencer par tester une réindexation intégrale.
Sans résultat, on a détruit et recréer un portail complètement VIERGE.
Toujours sans résultat, on a désinstaller SPS 2003, WSS, détruit les bases
de données, réinstaller SPS (qui installer WSS), puis le SP1 de WSS puis le
SP1 de SPS, et recréer un portail VIERGE. Sans résultat ...

Exemple, lorsqu'on recherche le mot "rapide", on a pas de résultats (même
pas le message indiquant qu'il n'y a pas de résultat), alors qu'il est
présent dans un article de la page d'accueil "Explorer le portail avec le
Guide de démarrage rapide"

Cdlt.

"EROL MVP SPS" a écrit :

> Bonjour,
>
> Vous avez une autre application sur le serveur ou il y a SPS 2003 ?
> Ou est basé le serveur SQL ?
> Ce serveur ne fonctionne que pour SPS ?
> Avez vous juste fait l'essai de réinitialiser la table d'index?
>
> Vous avez lu ceci :
> Microsoft SharePointPSSearch SQL Syntax
> http://www.microsoft.com/downloads/details.aspx?FamilyIDÖA10783-A4E4-4463-8444-F88BE48760B3&displaylang=en
>
> Bonne lecture
>
> Pensez aussi à voir :
> http://www.sharepoint-france.com/Products/DocumentRecovery/Default.aspx
>
> La base SQL peut avoir des PB...
>
> Microsoft Office SharePoint Portal Server 2003 Management Pack Guide
> http://www.microsoft.com/technet/prodtechnol/mom/mom2000/maintain/sps03mpg.mspx
> Cdlt
> --
> EROL MVP SharePoint. www.mysps.info
> http://aspnet2.com/mvp.ashx?ErolGiraudy
>
> "Christophe DE LA BARRE" > écrit dans le message de news:
>
> > Bonjour,
> >
> > J'ai une plate-forme SPS 2003 sur laquelle, brusquement, le moteur de
> > recherche s'est mis à ne plus fonctionner. L'indexation se déroule bien,
> > mais
> > les recherches renvoient systématiquement une page vide lorsqu'il devrait
> > y
> > avoir un résultat.
> > Lorsqu'il ne doit pas y avoir de résultat, on a bien une page indiquant
> > aucun résultat. J'ai testé la destruction du portail, puis sa recréation
> > vierge, sans succès.
> > J'ai ensuite déinstallé, détruit les bases de données, réinstallé SPS 2003
> > puis le SP1, sans succès non plus, la recherche renvoie toujours vide.
> >
> > Nous avons déjà rencontrer un problème similaire, il y a quelques mois,
> > qui
> > s'est résolus parla réinstallation complète de l'OS.
> > Cette solution, ne nous satisfait evidement pas.
> >
> > Si quelqu'un a déjà vu un cas semblable et a trouvé une solution, je suis
> > preneur.
>
>
>


EROL MVP SPS
Le #17175991
Bonjour,

Moi aussi j'ai eut qq PB ;+)
Cdlt

--
EROL MVP SharePoint. www.mysps.info
http://aspnet2.com/mvp.ashx?ErolGiraudy
"Amadeus" news:
Bonjour

je confirme ce genre de probleme avec sps2003, j'ai eu le meme probleme
sur
une plate forme de teste et j'ai due tout reinstaller( meme l'os) pour que
l'indexation marche a nouveau



"Christophe DE LA BARRE" a écrit :

Bonjour,

Non, il n'y a pas d'autre application sur le serveur SPS 2003.
La plate-forme est composée de 2 serveurs complètement dédié à SPS 2003.
Un serveur pour avec SPS proprement dit (WEB,INDEX,RECHERCHE,TRAVAIL).
Un serveur SQL 2000 SP3.

Il n'y a rien d'autre sur ces serveurs et il ne font que ça.
Evidement, on a commencer par tester une réindexation intégrale.
Sans résultat, on a détruit et recréer un portail complètement VIERGE.
Toujours sans résultat, on a désinstaller SPS 2003, WSS, détruit les
bases
de données, réinstaller SPS (qui installer WSS), puis le SP1 de WSS puis
le
SP1 de SPS, et recréer un portail VIERGE. Sans résultat ...

Exemple, lorsqu'on recherche le mot "rapide", on a pas de résultats (même
pas le message indiquant qu'il n'y a pas de résultat), alors qu'il est
présent dans un article de la page d'accueil "Explorer le portail avec le
Guide de démarrage rapide"

Cdlt.

"EROL MVP SPS" a écrit :

> Bonjour,
>
> Vous avez une autre application sur le serveur ou il y a SPS 2003 ?
> Ou est basé le serveur SQL ?
> Ce serveur ne fonctionne que pour SPS ?
> Avez vous juste fait l'essai de réinitialiser la table d'index?
>
> Vous avez lu ceci :
> Microsoft SharePointPSSearch SQL Syntax
> http://www.microsoft.com/downloads/details.aspx?FamilyIDÖA10783-A4E4-4463-8444-F88BE48760B3&displaylang=en
>
> Bonne lecture
>
> Pensez aussi à voir :
> http://www.sharepoint-france.com/Products/DocumentRecovery/Default.aspx
>
> La base SQL peut avoir des PB...
>
> Microsoft Office SharePoint Portal Server 2003 Management Pack Guide
> http://www.microsoft.com/technet/prodtechnol/mom/mom2000/maintain/sps03mpg.mspx
> Cdlt
> --
> EROL MVP SharePoint. www.mysps.info
> http://aspnet2.com/mvp.ashx?ErolGiraudy
>
> "Christophe DE LA BARRE"
> > écrit dans le message de news:
>
> > Bonjour,
> >
> > J'ai une plate-forme SPS 2003 sur laquelle, brusquement, le moteur de
> > recherche s'est mis à ne plus fonctionner. L'indexation se déroule
> > bien,
> > mais
> > les recherches renvoient systématiquement une page vide lorsqu'il
> > devrait
> > y
> > avoir un résultat.
> > Lorsqu'il ne doit pas y avoir de résultat, on a bien une page
> > indiquant
> > aucun résultat. J'ai testé la destruction du portail, puis sa
> > recréation
> > vierge, sans succès.
> > J'ai ensuite déinstallé, détruit les bases de données, réinstallé SPS
> > 2003
> > puis le SP1, sans succès non plus, la recherche renvoie toujours
> > vide.
> >
> > Nous avons déjà rencontrer un problème similaire, il y a quelques
> > mois,
> > qui
> > s'est résolus parla réinstallation complète de l'OS.
> > Cette solution, ne nous satisfait evidement pas.
> >
> > Si quelqu'un a déjà vu un cas semblable et a trouvé une solution, je
> > suis
> > preneur.
>
>
>




Christophe DE LA BARRE
Le #17175971
J'ai été jusqu'à desinstaller SPS et WSS, et détruire toutes les bases SQL du
serveur SQL, puis tout réinstaller d'origine.

Même si l'index est costaud et bien planqué, ça m'étonnerait qu'il ait
survécu à ça ?

J'ai ouvert un SR chez Microsoft et eu un contact Live Meeting ce matin.
Ils ont apparement déjà eu un SR similaire, semble-t-il du à un problème de
code de langue sur SQL. On a vérifié et ça ne semble pas être ça. Ils
continuent à chercher ...

On a également retirer tout les rôle de la machine (WEB, INDEX, RECHERCHE,
APPLICATION), puis remis, ce qui a pour conséquence de reconstruire l'index.
Sans succès ...

Sur SPS 2001, il existait un problème similaire du aux Regional Settings.
Serait-ce un héritage de ce problème ... ?

"EROL MVP SPS" a écrit :

Bonjour Christophe,


Avez vous fait ces actions ?

Réinitialisation d'un index de contenu :

Lorsque vous réinitialisez un index de contenu, vous le videz, mais vous ne
perdez pas les données statistiques compilées au cours des mises à jour
spéculatives.

La réinitialisation d'un index peut s'avérer utile dans les conditions
suivantes :

a.. Vous savez ou vous supposez que l'index contient des données
anciennes.

b.. Vous savez ou vous supposez que l'index contient des données
corrompues.

c.. Vous avez modifié beaucoup de contenu ou de nombreux paramètres (par
exemple, vous avez modifié les règles des sources de contenu) et vous
souhaitez effectuer une mise à jour intégrale pour refléter ces
modifications.

d.. Vous constatez qu'il existe un problème de sécurité et que les
utilisateurs peuvent afficher des données auxquelles ils ne devraient pas
accéder. La réinitialisation de l'index les empêche immédiatement d'accéder
à ces données.

Remarque :
Dans une configuration de batterie de serveurs, vous devez
forcer la propagation si vous voulez supprimer immédiatement l'accès
utilisateur à ces données. Si un utilisateur lance une recherche après que
vous avez réinitialisé un index mais avant que vous ayez créé un nouvel
index, la recherche ne donne lieu à aucun résultat.

Remarque :
Vous pouvez réinitialiser un index uniquement si vous avez activé
le mode

++++ Administration de la recherche avancée. ++++ Attention à ceci
!

Réinitialiser un index de contenu

1.. Dans la page Paramètres du site, dans la section Paramètres de
recherche et contenu indexé, cliquez sur Configurer la recherche et
l'indexation.

2.. Dans la page Configurer la recherche et l'indexation, dans la section
Index de contenu, cliquez sur Gérer les index de contenu.

3.. Dans la page Gérer les index de contenu, positionnez le pointeur sur
le nom de l'index et cliquez sur la flèche qui apparaît.

4.. Dans le menu qui s'affiche, cliquez sur Réinitialiser l'index de
contenu.

5.. Dans la zone de message qui apparaît, cliquez sur OK.
La réinitialisation de l'index interrompt les mises à jour en cours et
vide entièrement l'index.

Dans une configuration de batterie de serveurs, l'ancien index existe
toujours sur les serveurs de recherche tant que vous ne forcez pas la
propagation.

6.. Après avoir réinitialisé un index de contenu, vous devez effectuer une
mise à jour intégrale. Pour cela, procédez comme suit :

1.. Dans la page Gérer les index de contenu, positionnez le pointeur sur
le nom de l'index et cliquez sur la flèche qui apparaît.
2.. Dans le menu qui s'affiche, cliquez sur Mise à jour intégrale.
---------------------------------------------------------

Activation du mode Administration de la recherche avancée
Dans le mode d'administration de la recherche par défaut, deux index de
contenu sont utilisés pour le contenu des sites portail et le contenu
n'appartenant pas au portail.

Vous ne pouvez pas supprimer ces index.

Toutes les nouvelles sources de contenu et le contenu d'annuaire de sites
sont analysés et inclus dans l'index de contenu n'appartenant pas au
portail.

Le mode Administration de la recherche avancée permet de créer et de gérer
des index supplémentaires.

Les listes d'index s'avèrent utiles pour les analyses à grande échelle et le
ciblage personnalisé de l'étendue des requêtes, mais leur gestion est
complexe.

Une fois que le mode Administration de la recherche avancée a été activé
pour
un site portail, vous ne pouvez plus activer le mode standard (par défaut).

Le mode Administration de la recherche avancée permet d'effectuer les
opérations suivantes :

a.. Créer plusieurs sources de contenu d'annuaire de sites. Ceci permet de
disposer de plusieurs étendues sur les sites dans l'annuaire de sites.

b.. Organiser les sources de contenu dans des groupes de sources. Ceci
permet une installation avec une longue liste de sources de contenu pour les
traiter en groupes. Les groupes de sources apparaissent dans l'interface
utilisateur pour la définition de l'étendue. La définition des étendues est
basée sur des groupes de sources et non sur des sources individuelles. Le
résultat constaté est une performance améliorée des requêtes lancées sur ces
groupes, car elles vérifient un groupe de sources au lieu d'effectuer
plusieurs vérifications pour chaque source de contenu.

Si vous activez le mode Administration de la recherche avancée, vous pouvez
effectuer les tâches supplémentaires suivantes qui ne sont pas disponibles
dans le mode par défaut :

a.. Créer un index
b.. Réinitialiser un index
c.. Supprimer un index
d.. Spécifier l'index où inclure une source de contenu
e.. Gérer un index

Activer le mode Administration de la recherche avancée:
1.. Dans la page Paramètres du site, dans la section Paramètres de
recherche et contenu indexé, cliquez sur Configurer la recherche et
l'indexation.

2.. Dans la page Configurer la recherche et l'indexation, dans la section
Paramètres généraux de contenu et état d'indexation, cliquez sur Activer le
mode Administration de la recherche avancée.

3.. Dans la page Activer le mode Administration de la recherche avancée,
cliquez sur OK.

Une fois que vous avez activé le mode Administration de la recherche
avancée, une section supplémentaire appelée Index de contenu apparaît dans
la page Configurer la recherche et l'indexation.


--
EROL MVP SharePoint. www.mysps.info
http://aspnet2.com/mvp.ashx?ErolGiraudy


"Christophe DE LA BARRE" écrit dans le message de news:

> Bonjour,
>
> Non, il n'y a pas d'autre application sur le serveur SPS 2003.
> La plate-forme est composée de 2 serveurs complètement dédié à SPS 2003.
> Un serveur pour avec SPS proprement dit (WEB,INDEX,RECHERCHE,TRAVAIL).
> Un serveur SQL 2000 SP3.
>
> Il n'y a rien d'autre sur ces serveurs et il ne font que ça.
> Evidement, on a commencer par tester une réindexation intégrale.
> Sans résultat, on a détruit et recréer un portail complètement VIERGE.
> Toujours sans résultat, on a désinstaller SPS 2003, WSS, détruit les bases
> de données, réinstaller SPS (qui installer WSS), puis le SP1 de WSS puis
> le
> SP1 de SPS, et recréer un portail VIERGE. Sans résultat ...
>
> Exemple, lorsqu'on recherche le mot "rapide", on a pas de résultats (même
> pas le message indiquant qu'il n'y a pas de résultat), alors qu'il est
> présent dans un article de la page d'accueil "Explorer le portail avec le
> Guide de démarrage rapide"
>
> Cdlt.
>
> "EROL MVP SPS" a écrit :
>
>> Bonjour,
>>
>> Vous avez une autre application sur le serveur ou il y a SPS 2003 ?
>> Ou est basé le serveur SQL ?
>> Ce serveur ne fonctionne que pour SPS ?
>> Avez vous juste fait l'essai de réinitialiser la table d'index?
>>
>> Vous avez lu ceci :
>> Microsoft SharePointPSSearch SQL Syntax
>> http://www.microsoft.com/downloads/details.aspx?FamilyIDÖA10783-A4E4-4463-8444-F88BE48760B3&displaylang=en
>>
>> Bonne lecture
>>
>> Pensez aussi à voir :
>> http://www.sharepoint-france.com/Products/DocumentRecovery/Default.aspx
>>
>> La base SQL peut avoir des PB...
>>
>> Microsoft Office SharePoint Portal Server 2003 Management Pack Guide
>> http://www.microsoft.com/technet/prodtechnol/mom/mom2000/maintain/sps03mpg.mspx
>> Cdlt
>> --
>> EROL MVP SharePoint. www.mysps.info
>> http://aspnet2.com/mvp.ashx?ErolGiraudy
>>
>> "Christophe DE LA BARRE" >> a
>> écrit dans le message de news:
>>
>> > Bonjour,
>> >
>> > J'ai une plate-forme SPS 2003 sur laquelle, brusquement, le moteur de
>> > recherche s'est mis à ne plus fonctionner. L'indexation se déroule
>> > bien,
>> > mais
>> > les recherches renvoient systématiquement une page vide lorsqu'il
>> > devrait
>> > y
>> > avoir un résultat.
>> > Lorsqu'il ne doit pas y avoir de résultat, on a bien une page indiquant
>> > aucun résultat. J'ai testé la destruction du portail, puis sa
>> > recréation
>> > vierge, sans succès.
>> > J'ai ensuite déinstallé, détruit les bases de données, réinstallé SPS
>> > 2003
>> > puis le SP1, sans succès non plus, la recherche renvoie toujours vide.
>> >
>> > Nous avons déjà rencontrer un problème similaire, il y a quelques mois,
>> > qui
>> > s'est résolus parla réinstallation complète de l'OS.
>> > Cette solution, ne nous satisfait evidement pas.
>> >
>> > Si quelqu'un a déjà vu un cas semblable et a trouvé une solution, je
>> > suis
>> > preneur.
>>
>>
>>







Christophe DE LA BARRE
Le #17174611
Suite au SR, ils ont trouvé l'origine du problème :

Pour information, dans les paramètres de SQL Serveur, la case à cocher "Use
Windows NT Fibers" était cochée. Elle doit rester absolument décochée.

"Christophe DE LA BARRE" a écrit :

J'ai été jusqu'à desinstaller SPS et WSS, et détruire toutes les bases SQL du
serveur SQL, puis tout réinstaller d'origine.

Même si l'index est costaud et bien planqué, ça m'étonnerait qu'il ait
survécu à ça ?

J'ai ouvert un SR chez Microsoft et eu un contact Live Meeting ce matin.
Ils ont apparement déjà eu un SR similaire, semble-t-il du à un problème de
code de langue sur SQL. On a vérifié et ça ne semble pas être ça. Ils
continuent à chercher ...

On a également retirer tout les rôle de la machine (WEB, INDEX, RECHERCHE,
APPLICATION), puis remis, ce qui a pour conséquence de reconstruire l'index.
Sans succès ...

Sur SPS 2001, il existait un problème similaire du aux Regional Settings.
Serait-ce un héritage de ce problème ... ?

"EROL MVP SPS" a écrit :

> Bonjour Christophe,
>
>
> Avez vous fait ces actions ?
>
> Réinitialisation d'un index de contenu :
>
> Lorsque vous réinitialisez un index de contenu, vous le videz, mais vous ne
> perdez pas les données statistiques compilées au cours des mises à jour
> spéculatives.
>
> La réinitialisation d'un index peut s'avérer utile dans les conditions
> suivantes :
>
> a.. Vous savez ou vous supposez que l'index contient des données
> anciennes.
>
> b.. Vous savez ou vous supposez que l'index contient des données
> corrompues.
>
> c.. Vous avez modifié beaucoup de contenu ou de nombreux paramètres (par
> exemple, vous avez modifié les règles des sources de contenu) et vous
> souhaitez effectuer une mise à jour intégrale pour refléter ces
> modifications.
>
> d.. Vous constatez qu'il existe un problème de sécurité et que les
> utilisateurs peuvent afficher des données auxquelles ils ne devraient pas
> accéder. La réinitialisation de l'index les empêche immédiatement d'accéder
> à ces données.
>
> Remarque :
> Dans une configuration de batterie de serveurs, vous devez
> forcer la propagation si vous voulez supprimer immédiatement l'accès
> utilisateur à ces données. Si un utilisateur lance une recherche après que
> vous avez réinitialisé un index mais avant que vous ayez créé un nouvel
> index, la recherche ne donne lieu à aucun résultat.
>
> Remarque :
> Vous pouvez réinitialiser un index uniquement si vous avez activé
> le mode
>
> ++++ Administration de la recherche avancée. ++++ Attention à ceci
> !
>
> Réinitialiser un index de contenu
>
> 1.. Dans la page Paramètres du site, dans la section Paramètres de
> recherche et contenu indexé, cliquez sur Configurer la recherche et
> l'indexation.
>
> 2.. Dans la page Configurer la recherche et l'indexation, dans la section
> Index de contenu, cliquez sur Gérer les index de contenu.
>
> 3.. Dans la page Gérer les index de contenu, positionnez le pointeur sur
> le nom de l'index et cliquez sur la flèche qui apparaît.
>
> 4.. Dans le menu qui s'affiche, cliquez sur Réinitialiser l'index de
> contenu.
>
> 5.. Dans la zone de message qui apparaît, cliquez sur OK.
> La réinitialisation de l'index interrompt les mises à jour en cours et
> vide entièrement l'index.
>
> Dans une configuration de batterie de serveurs, l'ancien index existe
> toujours sur les serveurs de recherche tant que vous ne forcez pas la
> propagation.
>
> 6.. Après avoir réinitialisé un index de contenu, vous devez effectuer une
> mise à jour intégrale. Pour cela, procédez comme suit :
>
> 1.. Dans la page Gérer les index de contenu, positionnez le pointeur sur
> le nom de l'index et cliquez sur la flèche qui apparaît.
> 2.. Dans le menu qui s'affiche, cliquez sur Mise à jour intégrale.
> ---------------------------------------------------------
>
> Activation du mode Administration de la recherche avancée
> Dans le mode d'administration de la recherche par défaut, deux index de
> contenu sont utilisés pour le contenu des sites portail et le contenu
> n'appartenant pas au portail.
>
> Vous ne pouvez pas supprimer ces index.
>
> Toutes les nouvelles sources de contenu et le contenu d'annuaire de sites
> sont analysés et inclus dans l'index de contenu n'appartenant pas au
> portail.
>
> Le mode Administration de la recherche avancée permet de créer et de gérer
> des index supplémentaires.
>
> Les listes d'index s'avèrent utiles pour les analyses à grande échelle et le
> ciblage personnalisé de l'étendue des requêtes, mais leur gestion est
> complexe.
>
> Une fois que le mode Administration de la recherche avancée a été activé
> pour
> un site portail, vous ne pouvez plus activer le mode standard (par défaut).
>
> Le mode Administration de la recherche avancée permet d'effectuer les
> opérations suivantes :
>
> a.. Créer plusieurs sources de contenu d'annuaire de sites. Ceci permet de
> disposer de plusieurs étendues sur les sites dans l'annuaire de sites.
>
> b.. Organiser les sources de contenu dans des groupes de sources. Ceci
> permet une installation avec une longue liste de sources de contenu pour les
> traiter en groupes. Les groupes de sources apparaissent dans l'interface
> utilisateur pour la définition de l'étendue. La définition des étendues est
> basée sur des groupes de sources et non sur des sources individuelles. Le
> résultat constaté est une performance améliorée des requêtes lancées sur ces
> groupes, car elles vérifient un groupe de sources au lieu d'effectuer
> plusieurs vérifications pour chaque source de contenu.
>
> Si vous activez le mode Administration de la recherche avancée, vous pouvez
> effectuer les tâches supplémentaires suivantes qui ne sont pas disponibles
> dans le mode par défaut :
>
> a.. Créer un index
> b.. Réinitialiser un index
> c.. Supprimer un index
> d.. Spécifier l'index où inclure une source de contenu
> e.. Gérer un index
>
> Activer le mode Administration de la recherche avancée:
> 1.. Dans la page Paramètres du site, dans la section Paramètres de
> recherche et contenu indexé, cliquez sur Configurer la recherche et
> l'indexation.
>
> 2.. Dans la page Configurer la recherche et l'indexation, dans la section
> Paramètres généraux de contenu et état d'indexation, cliquez sur Activer le
> mode Administration de la recherche avancée.
>
> 3.. Dans la page Activer le mode Administration de la recherche avancée,
> cliquez sur OK.
>
> Une fois que vous avez activé le mode Administration de la recherche
> avancée, une section supplémentaire appelée Index de contenu apparaît dans
> la page Configurer la recherche et l'indexation.
>
>
> --
> EROL MVP SharePoint. www.mysps.info
> http://aspnet2.com/mvp.ashx?ErolGiraudy
>
>
> "Christophe DE LA BARRE" > écrit dans le message de news:
>
> > Bonjour,
> >
> > Non, il n'y a pas d'autre application sur le serveur SPS 2003.
> > La plate-forme est composée de 2 serveurs complètement dédié à SPS 2003.
> > Un serveur pour avec SPS proprement dit (WEB,INDEX,RECHERCHE,TRAVAIL).
> > Un serveur SQL 2000 SP3.
> >
> > Il n'y a rien d'autre sur ces serveurs et il ne font que ça.
> > Evidement, on a commencer par tester une réindexation intégrale.
> > Sans résultat, on a détruit et recréer un portail complètement VIERGE.
> > Toujours sans résultat, on a désinstaller SPS 2003, WSS, détruit les bases
> > de données, réinstaller SPS (qui installer WSS), puis le SP1 de WSS puis
> > le
> > SP1 de SPS, et recréer un portail VIERGE. Sans résultat ...
> >
> > Exemple, lorsqu'on recherche le mot "rapide", on a pas de résultats (même
> > pas le message indiquant qu'il n'y a pas de résultat), alors qu'il est
> > présent dans un article de la page d'accueil "Explorer le portail avec le
> > Guide de démarrage rapide"
> >
> > Cdlt.
> >
> > "EROL MVP SPS" a écrit :
> >
> >> Bonjour,
> >>
> >> Vous avez une autre application sur le serveur ou il y a SPS 2003 ?
> >> Ou est basé le serveur SQL ?
> >> Ce serveur ne fonctionne que pour SPS ?
> >> Avez vous juste fait l'essai de réinitialiser la table d'index?
> >>
> >> Vous avez lu ceci :
> >> Microsoft SharePointPSSearch SQL Syntax
> >> http://www.microsoft.com/downloads/details.aspx?FamilyIDÖA10783-A4E4-4463-8444-F88BE48760B3&displaylang=en
> >>
> >> Bonne lecture
> >>
> >> Pensez aussi à voir :
> >> http://www.sharepoint-france.com/Products/DocumentRecovery/Default.aspx
> >>
> >> La base SQL peut avoir des PB...
> >>
> >> Microsoft Office SharePoint Portal Server 2003 Management Pack Guide
> >> http://www.microsoft.com/technet/prodtechnol/mom/mom2000/maintain/sps03mpg.mspx
> >> Cdlt
> >> --
> >> EROL MVP SharePoint. www.mysps.info
> >> http://aspnet2.com/mvp.ashx?ErolGiraudy
> >>
> >> "Christophe DE LA BARRE" > >> a
> >> écrit dans le message de news:
> >>
> >> > Bonjour,
> >> >
> >> > J'ai une plate-forme SPS 2003 sur laquelle, brusquement, le moteur de
> >> > recherche s'est mis à ne plus fonctionner. L'indexation se déroule
> >> > bien,
> >> > mais
> >> > les recherches renvoient systématiquement une page vide lorsqu'il
> >> > devrait
> >> > y
> >> > avoir un résultat.
> >> > Lorsqu'il ne doit pas y avoir de résultat, on a bien une page indiquant
> >> > aucun résultat. J'ai testé la destruction du portail, puis sa
> >> > recréation
> >> > vierge, sans succès.
> >> > J'ai ensuite déinstallé, détruit les bases de données, réinstallé SPS
> >> > 2003
> >> > puis le SP1, sans succès non plus, la recherche renvoie toujours vide.
> >> >
> >> > Nous avons déjà rencontrer un problème similaire, il y a quelques mois,
> >> > qui
> >> > s'est résolus parla réinstallation complète de l'OS.
> >> > Cette solution, ne nous satisfait evidement pas.
> >> >
> >> > Si quelqu'un a déjà vu un cas semblable et a trouvé une solution, je
> >> > suis
> >> > preneur.
> >>
> >>
> >>
>
>
>
>
>


Publicité
Poster une réponse
Anonyme