Twitter iPhone pliant OnePlus 11 PS5 Disney+ Orange Livebox Windows 11

Statut de Java : 6 ou 7 ?

10 réponses
Avatar
Franck Ditter
Hello,
Je réponds ok à chaque mise à jour de Java 6 par Apple
et Java 7 par Oracle. C'est un peu le souk de ce côté-là.
Au final, comment savoir ce qui tourne au juste, du 6 ou du 7 ?

franck

10 réponses

Avatar
jperrocheau
Franck Ditter wrote:

Je réponds ok à chaque mise à jour de Java 6 par Apple
et Java 7 par Oracle. C'est un peu le souk de ce côté-là.
Au final, comment savoir ce qui tourne au juste, du 6 ou du 7 ?



Quelle version de Mac OS X ?

Pour savoir laquelle est effectivement appelée tu testes avec cette
page:

<http://www.java.com/en/download/testjava.jsp&gt;

AMHA si tu as intallé la version 1.7.x, elle a surement effacé (sauf si
tu as pris la précaution d'en faire une sauvegarde) l'application
"/Applications/Utilities/Java Preferences.app" qui permet d'activer ou
de désactiver la version 1.6.x.

--
Jacques Perrocheau
______________________________________________________________________
Avatar
mvaukois
Franck Ditter wrote:

Je réponds ok à chaque mise à jour de Java 6 par Apple
et Java 7 par Oracle. C'est un peu le souk de ce côté-là.
Au final, comment savoir ce qui tourne au juste, du 6 ou du 7 ?



Tu as quoi comme OS ? ML ?
Chez moi, sous ML, Safari et Firefox utilisent la version d'Oracle et
mon OpenOffice.org utilise la version d'Apple.

--
Michel Vauquois
Que Dieu vous garde... Moi j'ai pas le temps (RD)
Avatar
Aegidius
Le 10/03/13 19:50, MV a écrit :
Franck Ditter wrote:

Je réponds ok à chaque mise à jour de Java 6 par Apple
et Java 7 par Oracle. C'est un peu le souk de ce côté-là.
Au final, comment savoir ce qui tourne au juste, du 6 ou du 7 ?



Tu as quoi comme OS ? ML ?
Chez moi, sous ML, Safari et Firefox utilisent la version d'Oracle et
mon OpenOffice.org utilise la version d'Apple.



Chez moi j'ai les 2 qui semblent cohabiter...
Avatar
gilbert.olivier
Jacques Perrocheau wrote:

Franck Ditter wrote:

> Je réponds ok à chaque mise à jour de Java 6 par Apple
> et Java 7 par Oracle. C'est un peu le souk de ce côté-là.
> Au final, comment savoir ce qui tourne au juste, du 6 ou du 7 ?

Quelle version de Mac OS X ?

Pour savoir laquelle est effectivement appelée tu testes avec cette
page:

<http://www.java.com/en/download/testjava.jsp&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.java.com/en/download/testjava.jsp&gt;

AMHA si tu as intallé la version 1.7.x, elle a surement effacé (sauf si
tu as pris la précaution d'en faire une sauvegarde) l'application
"/Applications/Utilities/Java Preferences.app" qui permet d'activer ou
de désactiver la version 1.6.x.



Sous Mountain Lion, ce n'est pas le cas:

<http://www.java.com/en/download/testjava.jsp&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.java.com/en/download/testjava.jsp&gt; m'indique une version SE
7 Update 17

Et dans le terminal un java -version me retourne:
Java version "1.6.0_43"
Java(TM) SE Runtime Environment (build 1.6.0_43-b01-447-11M4203)
Java HotSpot(TM) 64-Bit Server VM (build 20.14-b01-447, mixed mode)

A l'utilisation chacun choisi celui qu'il veut ;-)
Open Office la version Apple

Safari la version Oracle


--
Gilbert
Avatar
mvaukois
Aegidius wrote:

Chez moi j'ai les 2 qui semblent cohabiter...



Curieux (ou alors j'ai mal compris ce que tu voulais dire). Regarde dans
/Bibliothèque/Inernet Plug-Ins : la seule version présente de
JavaAppletPlugin.plugin est la version 7 d'Oracle et je ne pense pas que
Safari ou autre navigateur aille chercher ailleurs.
--
Michel Vauquois
Que Dieu vous garde... Moi j'ai pas le temps (RD)
Avatar
g4fleurot
MV wrote:

Curieux (ou alors j'ai mal compris ce que tu voulais dire). Regarde dans
/Bibliothèque/Inernet Plug-Ins : la seule version présente de
JavaAppletPlugin.plugin est la version 7 d'Oracle et je ne pense pas que
Safari ou autre navigateur aille chercher ailleurs.



Effectivement, pour utiliser la v 1.6, il faut sortir ce Plug_in du
dossier et le remplacer par un alias qui pointe sur
/System/Bibliothèque/Java/JavaVirtualMachines/1.6.0.jdk

C'est ce qu'a fait Apple après la première alerte dans la procédure de
désactivation de la v 1.7

--
Gérard FLEUROT plus un
Avatar
chabada
Fleuger wrote:

MV wrote:

> Curieux (ou alors j'ai mal compris ce que tu voulais dire). Regarde dans
> /Bibliothèque/Inernet Plug-Ins : la seule version présente de
> JavaAppletPlugin.plugin est la version 7 d'Oracle et je ne pense pas que
> Safari ou autre navigateur aille chercher ailleurs.

Effectivement, pour utiliser la v 1.6, il faut sortir ce Plug_in du
dossier et le remplacer par un alias qui pointe sur
/System/Bibliothèque/Java/JavaVirtualMachines/1.6.0.jdk

C'est ce qu'a fait Apple après la première alerte dans la procédure de
désactivation de la v 1.7



Bonjour Gérard,
A-t-on intérêt à procéder ainsi? où on reste en l'état.

--
René
Lascia la spina cogli la rosa
http://
Avatar
g4fleurot
René Chamayou wrote:

A-t-on intérêt à procéder ainsi? où on reste en l'état.



Bonjour René,

Pour moi, on reste en l'état.
On désactive Java dans les préférences de Safari (onglet sécurité) et on
réactive au coup par coup si nécessaire.
Pour Firefox Menu Outils, modules complémentaires, onglet Plugins et
bouton désactiver.

--
Gérard FLEUROT plus un
Avatar
chabada
Fleuger wrote:

René Chamayou wrote:

> A-t-on intérêt à procéder ainsi? où on reste en l'état.

Bonjour René,

Pour moi, on reste en l'état.
On désactive Java dans les préférences de Safari (onglet sécurité) et on
réactive au coup par coup si nécessaire.
Pour Firefox Menu Outils, modules complémentaires, onglet Plugins et
bouton désactiver.



Je te remercie, je vais faire comme tu me l'indiques.


--
René
Lascia la spina cogli la rosa
http://
Avatar
Une Bévue
Le 10/03/13 20:05, Gilbert OLIVIER a écrit :
java -version


me donne :
java version "1.7.0_17"
Java(TM) SE Runtime Environment (build 1.7.0_17-b02)
Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)

alors que <http://www.java.com/en/download/testjava.jsp&gt; me donne :

<http://cjoint.com/13ma/CClm67kVMKU_13-03-11--12-57-44--java-on-safari-on-imac.png&gt;
sur Safari

"Chrome does not support Java 7. Java 7 runs only on 64-bit browsers and
Chrome is a 32-bit browser.

If you download Java 7, you will not be able to run Java content in
Chrome and will need to use a 64-bit browser (such as Safari or Firefox)
to run Java content within a browser. Additionally, installing Java 7
will disable the ability to use Apple Java 6 on your system."

sur Chrome.

sur ML, sous SL cette version de java ne s'installe pas.
--
La philosophie bouche le trou de la politique.
Jacques Lacan