Syntaxe NB.SI avec deux conditions

Le
Swansea
Bonjour à tous,

Dans une plage de cellules on peut trouver 3 valeurs différentes :
- texte,
- 0,
- #REF!

Coment écrire la formule pour compter le nombre de cellules contenant
"texte" en utilisant la fonction NB.SI (ou une autre) ?

Avec mes remerciements anticipés.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
papou
Le #1345942
Bonjour
=NB.SI(Plage;"texte")
(Où Plage est soit un nom défini soit une adresse de cellules soit la forme
A1:B1)

Cordialement
Pascal

"Swansea" c6qfd1$paa$
Bonjour à tous,

Dans une plage de cellules on peut trouver 3 valeurs différentes :
- texte,
- 0,
- #REF!

Coment écrire la formule pour compter le nombre de cellules contenant
"texte" en utilisant la fonction NB.SI (ou une autre) ?

Avec mes remerciements anticipés.


Swansea
Le #1345931

Bonjour
=NB.SI(Plage;"texte")
(Où Plage est soit un nom défini soit une adresse de cellules soit la forme
A1:B1)

Cordialement
Pascal

"Swansea" c6qfd1$paa$

Bonjour à tous,

Dans une plage de cellules on peut trouver 3 valeurs différentes :
- texte,
- 0,
- #REF!

Coment écrire la formule pour compter le nombre de cellules contenant
"texte" en utilisant la fonction NB.SI (ou une autre) ?




Bonjour,

J'aurais dû préciser que "texte" est indéfini et que son apparition est
quelque chose de nouveau.

Jusqu'à présent j'utilisais la formule :
=NB.SI(plage;"<>#REF!") qui fonctionne bien pour un critère.

Je voudrais maintenant ne pas compter #REF! et 0.

Mais comment faire pour éliminer ces deux critères ?

Cordialement.


AV
Le #1345930
Je subodore (pas sur évidemment...) que tu veux dénombrer les cellules contenant
du texte :

=SOMME(ESTTEXTE(plage)/1)

AV
jean esselin
Le #1345883
Bonjour

=NBVAL(plage)-NB.SI(plage;"=0")-NB.SI(plage;"=#REF!")

C'est pas beau,mais si toutes tes cellules sont remplies ça marche.

--

physique biologie maths
http://perso.club-internet.fr/trois
Swansea
Le #1328094

Bonjour

=NBVAL(plage)-NB.SI(plage;"=0")-NB.SI(plage;"=#REF!")

C'est pas beau,mais si toutes tes cellules sont remplies ça marche.



Un grand merci !
Effectivement, toutes les cellules sont remplies.
Qu'importe la beauté, c'est le résultat qui compte !
Cordialement

AV
Le #1328086
Un grand merci !


Ben fallait pas, c'est beaucoup trop !
........
T'es allergique aux matricielles ?
AV

Swansea
Le #1327899
Un grand merci !



Ben fallait pas, c'est beaucoup trop !
........
T'es allergique aux matricielles ?
AV


ça marche également avec une matricielle

faut prévenir quand tu mets des accolades invisibles (voir ton post
original)...
l'enthousiasme étant retombé depuis la découverte de la 1ère solution,
je t'adresse malgré tout mes remerciements
Cordialement


Publicité
Poster une réponse
Anonyme