[testing] PC ne boot plus

Le
=?iso-8859-1?q?Ga=EBtan?= Perrier
--=-K+K4KxvlvD110mnAt6Vs
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

Bonjour,

Suite à la mise à jour grub sur testing mon PC ne boote plus du t=
out.
Pour démarrer je suis obligé de booter avec une clé rEFInd p=
our pouvoir lancer
debian.
Quelqu'un d'autre rencontre-t'il ce problème?

A+

Gaëtan

--=-K+K4KxvlvD110mnAt6Vs
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit

--BEGIN PGP SIGNATURE--

iQEzBAABCgAdFiEEd7zcTjS9jiJYzB4MTEjQapSg6ZkFAlvgwtUACgkQTEjQapSg
6ZmFoAf+L1nXAJ82v7Sj5qfsZQCxnKH7V+vDpl5Q7hbI3q69fdUVbIqKWX7BUE34
9BKvK1GjaB0UQMIpY+Fi6in0JDtWUAtPrHF2XNyQYEzcY06n3UjHkTvYB6aITSyR
MLpQsYa9/OS5WF80XhSLvviq/v7Qo1HZ7HmRC7zlZrATSqQ+ehpTo5/NI8Uz4jAT
dZVaYpYRzTTE6a+In/Ll7kc3oYJcTNAQvJeLvPhSSnG5KoA7IuJDD1sztqv2cTcz
jpBpSBby1ZedRHCR+WlExHveFexemAq2pINSHw53tstvMIcixEo/UvggKFdiF8Qn
ACgh3evR0gz+CoVUniKfqHXLZ2bT8A==
8Q
--END PGP SIGNATURE--

--=-K+K4KxvlvD110mnAt6Vs--
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Haricophile
Le #26495596
Le Mon, 05 Nov 2018 23:23:17 +0100,
Gaëtan Perrier
Bonjour,
Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir lancer
debian.
Quelqu'un d'autre rencontre-t'il ce problème?

Non, mais ça ne serait pas un problème UFI, voire un grub-pc remp laçant un
grub-efi ?
Pierre ESTREM
Le #26495597
Bonjour,
Il m'est arrivé de perdre le GRUB2 de mon système base Debian Jessie.
Pour restaurer ce GRUB je boote sur une clé comportant le même grub et
je fais :
$ sudo grub-install /dev/sdx
( /devsdx est le ddur dont le GRUB est HS)
Si tu suis cette méthode avec TA clé tu devrais pouvoir booter sur ton
disque.
pierre estrem
Le 05/11/2018 à 23:23, Gaëtan Perrier a écrit :
Bonjour,
Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir lancer
debian.
Quelqu'un d'autre rencontre-t'il ce problème?
A+
Gaëtan
Pascal Hambourg
Le #26495749
Le 05/11/2018 à 23:23, Gaëtan Perrier a écrit :
Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.

C'est-à-dire ? Qu'est-il censé se passer et que se passe-t-il ?
Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir lancer
debian.

Donc amorçage EFI avec grub-efi-*, je présume.
Une fois le système démarré, qu'affiche
efibootmgr -v
Pascal Hambourg
Le #26495748
Le 06/11/2018 à 00:09, Haricophile a écrit :
Non, mais ça ne serait pas un problème UFI, voire un grub-pc remplaçant un
grub-efi ?

Le remplacement du *paquet* grub-efi par le *paquet* grub-pc ne
remplacerait pas le *chargeur* GRUB EFI par le *chargeur* GRUB BIOS.
=?iso-8859-1?q?Ga=EBtan?= Perrier
Le #26495790
--=-7jbNoWAQnYft2MX1552O
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Le mardi 06 novembre 2018 à 19:48 +0100, Pascal Hambourg a écrit :
Le 05/11/2018 à 23:23, Gaëtan Perrier a écrit :
Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.

C'est-à-dire ? Qu'est-il censé se passer et que se passe-t-il ?

Le système est censé démarré et là il ne déma rre pas ...
Il demande d'insérer un disque de boot.
Pour démarrer je suis obligé de booter avec une clé rEFI nd pour pouvoir
lancer
debian.

Donc amorçage EFI avec grub-efi-*, je présume.

Tout à fait.
Une fois le système démarré, qu'affiche
efibootmgr -v


# efibootmgr -v
BootCurrent: 0003
Timeout: 1 seconds
BootOrder: 0002,0003,0001
Boot0001* CD/DVD Drive BBS(CDROM,,0x0)AMGOAMNO........o.P.L.E.X.T.O.R.
.D.V.D.R. . . .P.X.-
.8.8.0.S.A....................A...........................>..Gd-.;.A..MQ..L . .
. . . . . . . . . . . . . . . . . . ......AMBO
Boot0002* Hard Drive BBS(HD,,0x0)AMGOAMNO........o.C.r.u.c.i.a.l._.C.T.2.5 .0
.M.X.2.0.0.S.S.D.1....................A...........................>..Gd-
.;.A..MQ..L. . . . . . . .
.5.1.5.0.E.0.E.9.4.6.F.E......AMBOAMNO........o.C.3.0.0.-
.C.T.F.D.D.A.C.0.6.4.M.A.G....................A...........................> ..Gd
-.;.A..MQ..L.0.0.0.0.0.0.0.0.1.1.6.1.3.0.5.0.2.B.9.C......AMBOAMNO........o .T.O
.S.H.I.B.A.
.D.T.0.1.A.C.A.2.0.0....................A...........................>..Gd-
.;.A..MQ..L. . . . . . . . . . .4.
.R.5.8.6.Y.D.S.A......AMBOAMNOu.......[.C.B.M....................A......... ....
...............................Gd-.;.A..MQ..L.C.B.M......AMBO
Boot0003* UEFI: CBM PciRoot(0x0)/Pci(0x1c,0x7)/Pci(0x0,0x0)/USB(3,0)/USB(1,
0)/USB(1,0)/HD(1,GPT,30d07d2b-cd7f-44d6-aa6f-db03ee9f3911,0x800,0x2f9f)AMBO
Boot0004 Crucial_CT250MX200SSD1 BBS(HD,,0x0)AMBO
--=-7jbNoWAQnYft2MX1552O
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit
-----BEGIN PGP SIGNATURE-----
iQEzBAABCgAdFiEEd7zcTjS9jiJYzB4MTEjQapSg6ZkFAlviHuYACgkQTEjQapSg
6Zl2XQf/VgLIqleUVPh15Wo1QxDKHcQ75G2NpFzYf0MmjqJm4UYtsa0bPudmYRAs
NM36FGl0UtqasKPhGdcjihM0kDB0YM+8BICcWNJCzXlUUCXDRnhdA23Zv6D08jcl
Vg4CPb7yAXHSl6XanonRCe0+ZoD54POI4G1rHP7Q+vVtUgIF3Nny38/jAdNRMvkG
1LYoSCj4RugXAL1HTHVMg1BDlo0IknJ2ErpkzMtFqeP3w2fhYfjP6ncWwsTudSp0
baJUm85sH2h0zl6cdAKo3vsvHMMW4hVMwp28OM2KidUEq7TjWoReh60cPps5aw2s
dfu4VYgmc2e9/iQbPABLRKmgxUZUuA= =3W0J
-----END PGP SIGNATURE-----
--=-7jbNoWAQnYft2MX1552O--
=?iso-8859-1?q?Ga=EBtan?= Perrier
Le #26495792
--=-5qSMm9R9ARhVaD8M1lNc
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Le mardi 06 novembre 2018 à 09:38 +0100, ajh-valmer a écrit :
On Monday 05 November 2018 23:23:17 Gaëtan Perrier wrote:
Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
Pour démarrer je suis obligé de booter avec une clé rEFI nd pour
pouvoir lancer
debian.
Quelqu'un d'autre rencontre-t'il ce problème?

Oui, je l'ai souvent.
Quel message as tu lors du boot ?
Je résoud le problème en éditant le fichier "/boot/grub/gr ub.cfg"
et constate que les UUID dans une séquence de boot
ne sont pas les mêmes (donc crash assuré au boot).
Et pourtant avant, j'avais tapé "update-grub2".
Il est aussi préférable de copier le même grub.cfg
sur toutes les partitions Linux de ton ordinateur.
Une fois les bons UUID remis, je tape :
grub-install /dev/sda
et ça remarche.
Mais peut-être chez toi, c'est une autre cause ?


Il me semble que ce que tu indiques c'est valable pour du grub-pc mais pas pour
de l'efi.
Gaëtan

--=-5qSMm9R9ARhVaD8M1lNc
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit
-----BEGIN PGP SIGNATURE-----
iQEzBAABCgAdFiEEd7zcTjS9jiJYzB4MTEjQapSg6ZkFAlviICsACgkQTEjQapSg
6ZmNvAgAihFsqxeQ1zk4F0igHd8fFnL6+HXZQ9F2L6K40aCssW/8cArbj3mbP/2A
FzAVaE4HVmjC5b5FnVAquqYb91LYXe1PTrzj1O0YJ7LoQBRHNataxi7AHAQ/6h7s
tPb9k1iekZy/EE0zWsbeDyx4clpgj1zhTlIv0yHWFXP12MYo9D8yh8EB0Krs9EzJ
g2M1IJm++8NGn1EJ8BB4iw22tydWvPBSPhET5CfOLD1MPDDLwl5MZzzFqb50z9p+
ns4l80G6eO4qKJAPlCxRyNzW6h2ZkQ9a5sQPuTmaZ/9wfIkhp2UGZiFbH5vZhfwT
CdXNvbp0TELAJ1cvmN27MmVG6mFh/A= =1yo0
-----END PGP SIGNATURE-----
--=-5qSMm9R9ARhVaD8M1lNc--
=?iso-8859-1?q?Ga=EBtan?= Perrier
Le #26495795
--=-Anfd8GwoystS90hbLRbr
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Le lundi 05 novembre 2018 à 23:23 +0100, Gaëtan Perrier a éc rit :
Bonjour,
Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir
lancer
debian.
Quelqu'un d'autre rencontre-t'il ce problème?


J'ai résolu le problème en suivant les instructions de la premi ère réponse de
cette page:
https://unix.stackexchange.com/questions/379774/grub-installation-failed
----------------------------------------------
Fixed that by deleting dump files :
# rm /sys/firmware/efi/efivars/dump-*
And then ran the usual
update-grub
grub-install -v --target=x86_64-efi --recheck /dev/sda
and it ran successfully!
----------------------------------------------
Maintenant ça boote correctement.
Gaëtan
--=-Anfd8GwoystS90hbLRbr
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit
-----BEGIN PGP SIGNATURE-----
iQEzBAABCgAdFiEEd7zcTjS9jiJYzB4MTEjQapSg6ZkFAlviKJgACgkQTEjQapSg
6ZlQjgf+Pc/8BWCzJ/2k/BJTF2KHdVNe4ALLYQ5vskXDM6No37JIxLuAdIzAnTQy
TWjGTIqy0UbDBwkks7N1EBHhW3BQlpfNiuvAM+x9POutDGTWecSIVlZaikls2Cpt
kzHv807KowsyPDCOsOqwU0Qehd2YUJuCU61FTxo1mGqqRUDPEQyUDHQQFbQAClyB
2MYXhuWOQRiISAzdb+ouuWuczhOsISQSNTdNXJSFtJgJIwHp7ClK63mftC6eEuCl
CQMf3TFBi8oqTqUuHQ8xCx+tg8kp6aBDJTlWwoc3GY43fpAUEmSgNfi9cFA7t/Uy
mvsxyl/uynsoTDN40qvbd0Uoj5EHuw= =OHi/
-----END PGP SIGNATURE-----
--=-Anfd8GwoystS90hbLRbr--
Pascal Hambourg
Le #26495817
Le 07/11/2018 à 00:49, Gaëtan Perrier a écrit :
Suite à la mise à jour grub sur testing mon PC ne boote plus du tout.
Pour démarrer je suis obligé de booter avec une clé rEFInd pour pouvoir
lancer
debian.

J'ai résolu le problème en suivant les instructions de la première réponse de
cette page:
https://unix.stackexchange.com/questions/379774/grub-installation-failed
----------------------------------------------
Fixed that by deleting dump files :
# rm /sys/firmware/efi/efivars/dump-*

L'as-tu fait spontanément ou après avoir constaté que grub-install
échouait avec une erreur relative à la création de l'entrée d'amorçage EFI ?
Cette action sert à libérer de la mémoire dans la NVRAM servant à
stocker les variables EFI et notamment les entrées d'amorçage manipulées
par efibootmgr.
Dans la sortie d'efibootmgr, on peut voir que l'entrée "debian" avait
disparu. Il se peut que sa re-création ait échoué par manque d'espace.
C'est une erreur assez courante.
update-grub

Inutile.
grub-install -v --target=x86_64-efi --recheck /dev/sda

Le paramètre /dev/sda est ignoré en mode EFI.
Note que puisque tu n'as pas de multi-boot, il existe un moyen simple de
se protéger contre la suppression de l'entrée d'amorçage EFI : installer
GRUB EFI dans le chemin de support amovible avec l'option --removable.
Avec dans la configuration du paquet grub-efi-amd64 modifiable avec
dpkg-reconfigure, il faut répondre oui à la question sur le chemin de
support amovible.
=?iso-8859-1?q?Ga=EBtan?= Perrier
Le #26496005
--=-l8hy5ij7ciHLAxBcOss0
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Le mercredi 07 novembre 2018 à 07:53 +0100, Pascal Hambourg a écr it :
Le 07/11/2018 à 00:49, Gaëtan Perrier a écrit :
> Suite à la mise à jour grub sur testing mon PC ne boote plu s du tout.
> Pour démarrer je suis obligé de booter avec une clé rE FInd pour pouvoir
> lancer
> debian.
J'ai résolu le problème en suivant les instructions de la pre mière réponse
de
cette page:
https://unix.stackexchange.com/questions/379774/grub-installation-faile d
----------------------------------------------
Fixed that by deleting dump files :
# rm /sys/firmware/efi/efivars/dump-*

L'as-tu fait spontanément ou après avoir constaté que grub -install
échouait avec une erreur relative à la création de l'entr ée d'amorçage EFI ?

Après que grub-install m'ait renvoyé une erreur.
[...]
update-grub

Inutile.

Oui mais comme j'avais fait pas mal de manip je me suis dit que ça ne coûtait
rien de le faire.
grub-install -v --target=x86_64-efi --recheck /dev/sda

Le paramètre /dev/sda est ignoré en mode EFI.

Ah bon? Pourtant on le voit sur tous les tutos que j'ai pu consulter.
Note que puisque tu n'as pas de multi-boot, il existe un moyen simple de
se protéger contre la suppression de l'entrée d'amorçage E FI : installer
GRUB EFI dans le chemin de support amovible avec l'option --removable.
Avec dans la configuration du paquet grub-efi-amd64 modifiable avec
dpkg-reconfigure, il faut répondre oui à la question sur le che min de
support amovible.

J'ai fait la manip, merci.
A+
Gaëtan
--=-l8hy5ij7ciHLAxBcOss0
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: This is a digitally signed message part
Content-Transfer-Encoding: 7bit
-----BEGIN PGP SIGNATURE-----
iQEzBAABCgAdFiEEd7zcTjS9jiJYzB4MTEjQapSg6ZkFAlvjYvwACgkQTEjQapSg
6ZnleQf+O6ngkbX/dTuqpYIb2PsusG5O4Ta4EeHllKRXW3TUBrg31wonpw7WgVDV
AspPz0n4reBhb2IfI6i/jG8wvDgcfOwX1WBiIwROmWRS+lhWVNhSnXFJ1Rd9MP9j
WrXj54SOHdsBllMhrMwhPv9Gm4hX1I5IXMk7t4udoG+hqFkn/xW7kYjA1acLtN7m
EZTXubnXr8pM4neCYaHXpM6zfuOPxCr0p2dKSS7RmFrimAT9pL2ftTEMaSQfiY4P
zi3GSF2LyyumDsNC1y09+iALA/BhMJL6PaFyiHioTqKcccvk4P4Wi9IcaVfBf2Ex
6ZzBSDaUvXFOLSsPM+YqdGr0s+GpCg= =NKgw
-----END PGP SIGNATURE-----
--=-l8hy5ij7ciHLAxBcOss0--
Pascal Hambourg
Le #26496009
Le 07/11/2018 à 23:11, Gaëtan Perrier a écrit :
Le mercredi 07 novembre 2018 à 07:53 +0100, Pascal Hambourg a écrit :
Le 07/11/2018 à 00:49, Gaëtan Perrier a écrit :
grub-install -v --target=x86_64-efi --recheck /dev/sda

Le paramètre /dev/sda est ignoré en mode EFI.

Ah bon? Pourtant on le voit sur tous les tutos que j'ai pu consulter.

Pour GRUB EFI, vraiment ? Cela renforce le peu de crédit que j'accorde
aux tutoriels en général.
Ce paramètre n'a de sens que pour GRUB BIOS, où il sert à indiquer
l'emplacement du secteur d'amorce (boot image). Il n'y a pas de secteur
d'amorce en UEFI.
Publicité
Poster une réponse
Anonyme