testing+xorg 7.0+fglrx

Le
Jean Baptiste BALLEYGUIER
=_Part_3547_677986.1149509577142
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour tous,

je viens de faire une mise jour de ma debian testing, et je constate qu=
e
xorg est updat vers 7.0. Pendant la mise jour il me vire les driver
proprio de ma carte ATI (normal ils ont t gnrs sur xorg 6.9 =
me dis je.
Lorsque la mise jour est finie, je redmmare X. Il me fait une ou deu=
x
erreurs dues mon Xorg.conf mais rien de mchant.
Je reprend le fichier d'ati pour gnrer les driver 8.25. Il me dtec=
te bien
on xorg 7.0. Parfait. Je fais un

#dpkg -i fglrx*.deb, mais il me renvoit cette erreur :

"(Lecture de la base de donnes 170606 fichiers et rpertoires dj=

installs.)
Prparation du remplacement de fglrx-control 8.25.18-1 (en utilisant
fglrx-control_8.25.18-1_i386.deb)
Dpaquetage de la mise jour de fglrx-control
Prparation du remplacement de fglrx-driver 8.25.18-1 (en utilisant
fglrx-driver_8.25.18-1_i386.deb)
Dpaquetage de la mise jour de fglrx-driver
Prparation du remplacement de fglrx-driver-dev 8.25.18-1 (en utilisant
fglrx-driver-dev_8.25.18-1_i386.deb)
Dpaquetage de la mise jour de fglrx-driver-dev
Prparation du remplacement de fglrx-kernel-src 8.25.18-1 (en utilisant
fglrx-kernel-src_8.25.18-1_i386.deb)
Dpaquetage de la mise jour de fglrx-kernel-src
Prparation du remplacement de fglrx-sources 8.25.18-1 (en utilisant
fglrx-sources_8.25.18-1_i386.deb)
Dpaquetage de la mise jour de fglrx-sources
Paramtrage de fglrx-control (8.25.18-1)
dpkg : des problmes de dpendances empchent la configuration de
fglrx-driver :
fglrx-driver dpend de xserver-xorg (<< 7.0.99) ; cependant :
La version de xserver-xorg sur le systme est 1:7.0.20.
dpkg : erreur de traitement de fglrx-driver (--install) :
problmes de dpendances - laiss non configur
dpkg : des problmes de dpendances empchent la configuration de
fglrx-driver-dev :
fglrx-driver-dev dpend de fglrx-driver ; cependant :
Le paquet fglrx-driver n'est pas encore configur.
dpkg : erreur de traitement de fglrx-driver-dev (--install) :
problmes de dpendances - laiss non configur
Paramtrage de fglrx-kernel-src (8.25.18-1)
Paramtrage de fglrx-sources (8.25.18-1)
Des erreurs ont t rencontres pendant l'excution :
fglrx-driver
fglrx-driver-dev"

Je sais que les 8.25 ne supporte pas xorg 7.1 (ce qui expliquerait la
dpendance des version infrieures 7.0.99). Mais visiblement, il y =
a un
problme de nom pour la version debian de xorg 7.0 puisque c'est 1:7.0.20

Est-ce que quelqu'un a t confront ce problme ?

Merci d'avance !

Jean Baptiste

=_Part_3547_677986.1149509577142
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Bonjour tous,<br><br>je viens de faire une mise jour de ma debian t=
esting, et je constate que xorg est updat vers 7.0. Pendant la mise =
jour il me vire les driver proprio de ma carte ATI (normal ils ont t =
gnrs sur xorg
6.9 me dis je.<br>Lorsque la mise jour est finie, je redmmare X. Il =
me fait une ou deux erreurs dues mon Xorg.conf mais rien de mchant.<=
br>Je reprend le fichier d'ati pour gnrer les driver 8.25. Il me d=
tecte bien on xorg
7.0. Parfait. Je fais un<br><br>#dpkg -i fglrx*.deb, mais il me renvoit cet=
te erreur&nbsp; :<br><br>&quot;(Lecture de la base de donnes 170606 f=
ichiers et rpertoires dj installs.)<br>Prparation du remplac=
ement de fglrx-control
8.25.18-1 (en utilisant fglrx-control_8.25.18-1_i386.deb) <br>Dpaquet=
age de la mise jour de fglrx-control <br>Prparation du remplaceme=
nt de fglrx-driver 8.25.18-1 (en utilisant fglrx-driver_8.25.18-1_i386.deb)=

<br>Dpaquetage de la mise jour de fglrx-driver <br>Prparation =
du remplacement de fglrx-driver-dev 8.25.18-1 (en utilisant fglrx-driver-de=
v_8.25.18-1_i386.deb) <br>Dpaquetage de la mise jour de fglrx-dri=
ver-dev
<br>Prparation du remplacement de fglrx-kernel-src 8.25.18-1 (en utilisa=
nt fglrx-kernel-src_8.25.18-1_i386.deb) <br>Dpaquetage de la mise =
jour de fglrx-kernel-src <br>Prparation du remplacement de fglrx-sou=
rces
8.25.18-1 (en utilisant fglrx-sources_8.25.18-1_i386.deb) <br>Dpaquet=
age de la mise jour de fglrx-sources <br>Paramtrage de fglrx-cont=
rol (8.25.18-1) <br>dpkg&nbsp;: des problmes de dpendances empc=
hent la configuration de fglrx-driver&nbsp;:
<br>&nbsp;fglrx-driver dpend de xserver-xorg (&lt;&lt; 7.0.99)&nbsp;; ce=
pendant&nbsp;:<br>&nbsp; La version de xserver-xorg sur le systme est 1:=
7.0.20.<br>dpkg&nbsp;: erreur de traitement de fglrx-driver (--install)&nbs=
p;:<br>&nbsp;problmes de dpendances - laiss non configur
<br>dpkg&nbsp;: des problmes de dpendances empchent la configurati=
on de fglrx-driver-dev&nbsp;:<br>&nbsp;fglrx-driver-dev dpend de fglrx-d=
river&nbsp;; cependant&nbsp;:<br>&nbsp;Le paquet fglrx-driver n'est pas enc=
ore configur.<br>dpkg&nbsp;: erreur de traitement de fglrx-driver-dev (-=
-install)&nbsp;:
<br>&nbsp;problmes de dpendances - laiss non configur<br>Param=
trage de fglrx-kernel-src (8.25.18-1) <br>Paramtrage de fglrx-sour=
ces (8.25.18-1) <br>Des erreurs ont t rencontres pendant l'ex=
cution&nbsp;:<br>&nbsp;fglrx-driver
<br>&nbsp;fglrx-driver-dev&quot;<br><br>Je sais que les 8.25 ne supporte pa=
s xorg 7.1 (ce qui expliquerait la dpendance des version infrieures =
7.0.99). Mais visiblement, il y a un problme de nom pour la version =
debian de xorg
7.0 puisque c'est 1:7.0.20<br><br>Est-ce que quelqu'un a t confront=
ce problme ?<br><br>Merci d'avance !<br><br>Jean Baptiste<br>

=_Part_3547_677986.1149509577142--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Damien Ulrich
Le #9171041
Le Lundi 05 Juin 2006 14:12, Jean Baptiste BALLEYGUIER a écrit :
Bonjour à tous,


Hallo,
Il me semble qu'il te faut simplement recompiler tes drivers.deb, avec xorg
7.0, non ?
Perso, j'aurai certainement le même pb !
Je cherche déjà à installer correctement le xorg ...
retour d'xp à l'issu...

je viens de faire une mise à jour de ma debian testing, et je constate que
xorg est updaté vers 7.0. Pendant la mise à jour il me vire les driver
proprio de ma carte ATI (normal ils ont été générés sur xorg 6. 9 me dis je.
Lorsque la mise à jour est finie, je redémmare X. Il me fait une ou d eux
erreurs dues à mon Xorg.conf mais rien de méchant.
Je reprend le fichier d'ati pour générer les driver 8.25. Il me dét ecte
bien on xorg 7.0. Parfait. Je fais un

#dpkg -i fglrx*.deb, mais il me renvoit cette erreur :

"(Lecture de la base de données... 170606 fichiers et répertoires d éjà
installés.)
Préparation du remplacement de fglrx-control 8.25.18-1 (en utilisant
fglrx-control_8.25.18-1_i386.deb) ...
Dépaquetage de la mise à jour de fglrx-control ...
Préparation du remplacement de fglrx-driver 8.25.18-1 (en utilisant
fglrx-driver_8.25.18-1_i386.deb) ...
Dépaquetage de la mise à jour de fglrx-driver ...
Préparation du remplacement de fglrx-driver-dev 8.25.18-1 (en utilisant
fglrx-driver-dev_8.25.18-1_i386.deb) ...
Dépaquetage de la mise à jour de fglrx-driver-dev ...
Préparation du remplacement de fglrx-kernel-src 8.25.18-1 (en utilisant
fglrx-kernel-src_8.25.18-1_i386.deb) ...
Dépaquetage de la mise à jour de fglrx-kernel-src ...
Préparation du remplacement de fglrx-sources 8.25.18-1 (en utilisant
fglrx-sources_8.25.18-1_i386.deb) ...
Dépaquetage de la mise à jour de fglrx-sources ...
Paramétrage de fglrx-control (8.25.18-1) ...
dpkg : des problèmes de dépendances empêchent la configuration de
fglrx-driver :
fglrx-driver dépend de xserver-xorg (<< 7.0.99) ; cependant :
La version de xserver-xorg sur le système est 1:7.0.20.
dpkg : erreur de traitement de fglrx-driver (--install) :
problèmes de dépendances - laissé non configuré
dpkg : des problèmes de dépendances empêchent la configuration de
fglrx-driver-dev :
fglrx-driver-dev dépend de fglrx-driver ; cependant :
Le paquet fglrx-driver n'est pas encore configuré.
dpkg : erreur de traitement de fglrx-driver-dev (--install) :
problèmes de dépendances - laissé non configuré
Paramétrage de fglrx-kernel-src (8.25.18-1) ...
Paramétrage de fglrx-sources (8.25.18-1) ...
Des erreurs ont été rencontrées pendant l'exécution :
fglrx-driver
fglrx-driver-dev"

Je sais que les 8.25 ne supporte pas xorg 7.1 (ce qui expliquerait la
dépendance des version inférieures à 7.0.99). Mais visiblement, il y a un
problème de nom pour la version debian de xorg 7.0 puisque c'est 1:7.0. 20

Est-ce que quelqu'un a été confronté à ce problème ?

Merci d'avance !

Jean Baptiste



--
La magie de l'art naît de la souffrance, car l'humain de révèle dans
l'écorchure
Damien Ulrich
Damien Ulrich
Le #9170201
Bon...
retour d'xp :
J'ai d'abord du retirer tous les paquets dépendants de xbase-clients
à la mano, avec dpkg --remove ...
long ! très long... y'avait peut-être mieux... :P
Au final, j'ai pu correctement faire l'upgrade de x11-common
et l'install correcte de xserver-xorg

Pour le paquet fglrx-driver,
puisque qu'on les prépare en local, je l'ai tout simplement arrangé,
en extrayant sont contenu dans
fglrx-driver/
mv fglrx-driver/CONTENTS/* fglrx-driver
rmdir fglrx-driver/CONTENTS
-il me prenait pas les fichiers déclarés dans 'DEBIAN/conffiles' !?-
j'en ai profité pour corriger ses erreurs d'emplacement :
mkdir -p fglrx-driver/usr/lib/xorg
mv fglrx-driver/usr/X11R6/* fglrx-driver/usr/lib/xorg
rmdir fglrx-driver/usr/X11R6

correction de fglrx-driver/DEBIAN/control
en changeant :
xserver-xorg (>= 7.0.1), xserver-xorg (<< 7.0.99)
en
xserver-xorg (>= 1:7.0.1), xserver-xorg (<< 1:7.0.99)

dpkg-deb --build fglrx-driver
mv fglrx-driver{,_8.25.18-1_amd64}.deb
et ouala...
Si ça peut aider ...
Damien Ulrich
Le #9170121
Le Vendredi 09 Juin 2006 00:41, Damien Ulrich a écrit :
Bon...
retour d'xp :
J'ai d'abord du retirer tous les paquets dépendants de xbase-clients
à la mano, avec dpkg --remove ...
long ! très long... y'avait peut-être mieux... :P
Au final, j'ai pu correctement faire l'upgrade de x11-common
et l'install correcte de xserver-xorg

Pour le paquet fglrx-driver,
puisque qu'on les prépare en local, je l'ai tout simplement arrangé,
en extrayant sont contenu dans
fglrx-driver/
mv fglrx-driver/CONTENTS/* fglrx-driver
rmdir fglrx-driver/CONTENTS
-il me prenait pas les fichiers déclarés dans 'DEBIAN/conffiles' !?-
j'en ai profité pour corriger ses erreurs d'emplacement :


Ouaip beh c'est moi l'erreur :
mkdir -p fglrx-driver/usr/lib/xorg
mv fglrx-driver/usr/X11R6/* fglrx-driver/usr/lib/xorg
rmdir fglrx-driver/usr/X11R6


Ce changement bugge le driver DRI,
un lien ne suffit pas non plus...
A éviter ! :P

correction de fglrx-driver/DEBIAN/control
en changeant :
xserver-xorg (>= 7.0.1), xserver-xorg (<< 7.0.99)
en
xserver-xorg (>= 1:7.0.1), xserver-xorg (<< 1:7.0.99)

dpkg-deb --build fglrx-driver
mv fglrx-driver{,_8.25.18-1_amd64}.deb
et ouala...
Si ça peut aider ...



--
La sinusoïde est à l'échantillonnage, ce que l'Humain est au Systèm e.
Jean Baptiste BALLEYGUIER
Le #9168991
------=_Part_1729_13660456.1150088432086
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Une question stupide : comment on fais pour "extraire les driver" ... on
fait ça à parti du .run d'ati ?

Jean Baptiste

2006/6/10, S4mdf0o1

Le Samedi 10 Juin 2006 19:57, vous avez écrit:
> Ok,
>
> merci d'expérimenter... et donc j'évite là solution...mais je te suis en
> marchant sur des oeufs :D
Ca marche très bien en laissant les drivers à leur emplacement d'orig ine :
pas dans fglrx-driver/CONTENTS/usr/X11R6,
mais fglrx-driver/usr/X11R6
la 3D, double écran, tout nickel ! ;)
>
> Jean Baptiste
>
> 2006/6/9, Damien Ulrich > > Le Vendredi 09 Juin 2006 00:41, Damien Ulrich a écrit:
> > > Bon...
> > > retour d'xp :
> > > J'ai d'abord du retirer tous les paquets dépendants de xbase-clie nts
> > > à la mano, avec dpkg --remove ...
> > > long ! très long... y'avait peut-être mieux... :P
> > > Au final, j'ai pu correctement faire l'upgrade de x11-common
> > > et l'install correcte de xserver-xorg
> > >
> > > Pour le paquet fglrx-driver,
> > > puisque qu'on les prépare en local, je l'ai tout simplement arran gé,
> > > en extrayant sont contenu dans
> > > fglrx-driver/
> > > mv fglrx-driver/CONTENTS/* fglrx-driver
> > > rmdir fglrx-driver/CONTENTS
> > > -il me prenait pas les fichiers déclarés dans 'DEBIAN/conffiles ' !?-
> > > j'en ai profité pour corriger ses erreurs d'emplacement :
> >
> > Ouaip beh c'est moi l'erreur :
> > > mkdir -p fglrx-driver/usr/lib/xorg
> > > mv fglrx-driver/usr/X11R6/* fglrx-driver/usr/lib/xorg
> > > rmdir fglrx-driver/usr/X11R6
> >
> > Ce changement bugge le driver DRI,
> > un lien ne suffit pas non plus...
> > A éviter ! :P
> >
> > > correction de fglrx-driver/DEBIAN/control
> > > en changeant :
> > > xserver-xorg (>= 7.0.1), xserver-xorg (<< 7.0.99)
> > > en
> > > xserver-xorg (>= 1:7.0.1), xserver-xorg (<< 1:7.0.99)
> > >
> > > dpkg-deb --build fglrx-driver
> > > mv fglrx-driver{,_8.25.18-1_amd64}.deb
> > > et ouala...
> > > Si ça peut aider ...
> >
> > --
> > La sinusoïde est à l'échantillonnage, ce que l'Humain est au Sy stème.

--
"En politique, rien n'arrive par hasard. Chaque fois qu'un évènement
survient,
on peut être certain qu'il avait été prévu pour se dérouler ain si."
Franklin D. Roosevelt
Président des Etats Unis de 1932 à 1945




------=_Part_1729_13660456.1150088432086
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Une question stupide : comment on fais pour &quot;extraire les driver&quot; ... on fait ça à parti du .run d'ati ? &gt; <br>&gt; &gt; &gt; Au final, j'ai pu correctement faire l'upgrade de x11-co mmon<br>&gt; &gt; &gt; et l'install correcte de xserver-xorg<br>&gt; &gt; & gt;<br>&gt; &gt; &gt; Pour le paquet fglrx-driver,<br>&gt; &gt; &gt; puisqu e qu'on les prépare en local, je l'ai tout simplement arrangé,
<br>&gt; &gt; &gt; en extrayant sont contenu dans<br>&gt; &gt; &gt; fglrx-d river/<br>&gt; &gt; &gt; mv fglrx-driver/CONTENTS/*&nbsp;&nbsp;fglrx-driver <br>&gt; &gt; &gt; rmdir fglrx-driver/CONTENTS<br>&gt; &gt; &gt; -il me pre nait pas les fichiers déclarés dans 'DEBIAN/conffiles' !?-
<br>&gt; &gt; &gt; j'en ai profité pour corriger ses erreurs d'emplacemen t :<br>&gt; &gt;<br>&gt; &gt; Ouaip beh c'est moi l'erreur :<br>&gt; &gt; & gt; mkdir -p fglrx-driver/usr/lib/xorg<br>&gt; &gt; &gt; mv fglrx-driver/us r/X11R6/*&nbsp;&nbsp;fglrx-driver/usr/lib/xorg
<br></blockquote></div><br>

------=_Part_1729_13660456.1150088432086--


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Poster une réponse
Anonyme