Thunderbird et noyau 4.15

Le
David BERCOT
Bonjour,

Je viens de passer sur un noyau 4.15 (cool, le test pour Meltdown et
Spectre est négatif ;-)) et j'ai un problème bizarre avec Thunderbird :
"Thunderbird is already running, but is not responding. To open a new
window, you must first close the existing Thunderbird process, or
restart your system."

Or, Thunderbird n'est pas lancé !!! Un ps -ef | grep thunder me le
confirme

D'autre part, j'ai bien sûr vérifié les lock et autres joyeusetés du
même genre.

Bizarrement, si je reboot sur un noyau 4.12 (et ce, plusieurs fois de
suite sur ces 2 noyaux), tout marche parfaitement.

J'ai également testé un "safe mode" sans succès

Auriez-vous une idée ?

Merci d'avance.

David.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Legrand
Le #26465746
apparmor ???
--
Pascal
Pascal Legrand
Le #26465751
apparmor est installé ?
--
Pascal
David BERCOT
Le #26465756
Bonjour,
En effet, AppArmor est installé.
J'avoue ne pas connaître ce produit et son impact potentiel sur mon problème...
Des infos complémentaires peut-être (même si je vais chercher de mon côté ;-)) ?
Merci.
David.
Le 26/02/2018 à 09:23, Pascal Legrand a écrit :
apparmor est installé ?
Pascal Legrand
Le #26465755
En fait j'ai découvert ça par hasard.
Mon profil Thunderbird n'est pas à l'endroit habituel et une fois
apparmor installé celui-ci ne fonctionnait plus.
Cela peut se voir avec journalctl -n 1 -f
Perso j'ai viré apparmor sans chercher beaucoup plus.
Du coup si tu as plus d'infos je suis aussi preneur ;-)
Le 26/02/2018 à 10:16, David BERCOT a écrit :
Bonjour,
En effet, AppArmor est installé.
J'avoue ne pas connaître ce produit et son impact potentiel sur mon problème...
Des infos complémentaires peut-être (même si je vais chercher de mon côté ;-)) ?
Merci.
David.
Le 26/02/2018 à 09:23, Pascal Legrand a écrit :
apparmor est installé ?



--
Pascal
David BERCOT
Le #26465918
Bonjour,
J'ai en effet créé un lien du fichier usr.bin.thunderbird dans
/etc/apparmor.d/disable/ et ça semble OK.
Bon, j'ai à nouveau mon problème bluetooth mais j'espère réussir à le
résoudre ;-)
Merci.
David.
Le 26/02/2018 à 11:35, Pierre Malard a écrit :
Salut,
« AppArmor » est un outil libre de sécurisation des applications
déployées sur un système. Il restreint les fichiers et répertoires que
l’application qui le supporte peuvent accéder. C’est un peut le portage
du « SandBox » d’Apple sur ses OS et c’est installé par défaut avec
Firefox et Thunderbird.
Cela peut effectivement expliquer tes problèmes. Par exemple, j’avais
rencontré ça parce que j’avais modifié la racine des répertoires des
utilisateurs locaux en « /homeL » car « /home » était référencé pour les
utilisateurs LDAP. Du coup, les utilisateurs locaux ne pouvaient plus
utiliser les produits « Mozilla ».
On peut voir et modifier cette configuration dans le répertoire
« /etc/apparmor.d ». Jette un œil sur la documentation Ubuntu
(https://doc.ubuntu-fr.org/apparmor).
Cordialement
Le 26 févr. 2018 à 10:16, David BERCOT
Bonjour,
En effet, AppArmor est installé.
J'avoue ne pas connaître ce produit et son impact potentiel sur mon
problème...
Des infos complémentaires peut-être (même si je vais chercher de mon
côté ;-)) ?
Merci.
David.
Le 26/02/2018 à 09:23, Pascal Legrand a écrit :
apparmor est installé ?


-- 
Pierre Malard
   « /Tous les Français ambitionnent pour la France un grand rôle/
/   dans le monde. Ce n'est point par des aventures guerrières qu'elle/
/   le trouvera, c'est en donnant aux peuples l'exemple et le signal/
/   de justice. /»
                                            Jean Jaures - "L'idéal de
justice" - 1889
   |      _,,,---,,_
   /,`.-'`'    -.  ;-;;,_
  |,4-  ) )-,_. , (  `'-'
 '---''(_/--'  `-'_)   πr
perl -e '$_=q#: 3| 5_,3-3,2_: 3/,`.'"'"'`'"'"' 5-.  ;-;;,_:  |,A-  )
)-,_. , (  `'"'"'-'"'"': '"'"'-3'"'"'2(_/--'"'"'  `-'"'"'_):
24πr::#;y#:#n#;s#(D)(d+)#$1x$2#ge;print'
- --> Ce message n’engage que son auteur <--
Publicité
Poster une réponse
Anonyme