Toshiba = Bruit

Le
stac
Bonjour,

J'ai un Toshiba Satellite A30, Pentium 4M 2.8 GHz, ATI RADEON 9000,
etc. Le gros problème de ce portable est le bruit que générent les deux
ventilateurs. Sous windows, à l'aide de SpeedSwitch je suis arrivé à
faire en sorte que ces ventilateurs ne fonctionne souvent mais moins que
normalement (avec les utilitaires toshiba).
Le problème est sous Linux. J'ai installé une Mandrake 10.0 Communitity
qui fonctionne trés bien. J'ai recompilé le noyau pour qu'il prenne en
compte toutes les spécificité des Pentium 4M (SpeedStep, Toshiba
Utils). Le PC fonctionne. Seul gros défaut, les deux ventilateurs
fonctionnent sans discontinuité, non-stop. Alors je me suis dis, et bien
c'est le processeur qui fonctionne à fond comme un gros bourrin. Et
donc, à l'aide des commandes du type :

echo 5 > /proc/acpi/processor/CPU0/throtling
ou
echo "400000:1000000:powersave" > /proc/cpufreq

Là, outre le fait que le PC rame, les ventilos se lancent toutes les 5
secondes pendant 30 secondes. Peu convainquant donc
Ensuite, j'ai essayé des utilitaires du genre powernowd, cpufreqd
Mais le resultat n'est guère mieux.
Il y a néanmoins quelquechose qui m'interpèle. Je ne comprend pas
pourquoi /proc/acpi/fan et /proc/acpi/thermal_zone sont vide. N'ai je
pas d'accés à ces propriétés de mon ordi ? Et pourquoi n'ai je pas
/proc/toshiba comme c'est sensé être quand on a un toshiba avec un noyau
pour lequel on a mis Toshiba Utils ?

Merci d'avance,

Stac

PS : j'ai aussi un problème de son. J'en ai pas. J'ai voulu mettre les
derniers pilotes ALSA mais en fait je ne sais pas quelle carte son j'ai.
Sous Win, y a marqué Realtek AC97. Et un lspci sous linux semble me dire
que tout ce que j'ai est de l'ATI. Alors je ne sais pas quoi mettre.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ducrot Bruno
Le #1055759
On Wed, 28 Apr 2004 09:30:14 +0200, stac
Bonjour,

J'ai un Toshiba Satellite A30, Pentium 4M 2.8 GHz, ATI RADEON 9000,
etc. Le gros problème de ce portable est le bruit que générent les deux
ventilateurs. Sous windows, à l'aide de SpeedSwitch je suis arrivé à
faire en sorte que ces ventilateurs ne fonctionne souvent mais moins que
normalement (avec les utilitaires toshiba).
Le problème est sous Linux. J'ai installé une Mandrake 10.0 Communitity
qui fonctionne trés bien. J'ai recompilé le noyau pour qu'il prenne en
compte toutes les spécificité des Pentium 4M (SpeedStep, Toshiba
Utils...). Le PC fonctionne. Seul gros défaut, les deux ventilateurs
fonctionnent sans discontinuité, non-stop. Alors je me suis dis, et bien
c'est le processeur qui fonctionne à fond comme un gros bourrin. Et
donc, à l'aide des commandes du type :

echo 5 > /proc/acpi/processor/CPU0/throtling
ou
echo "400000:1000000:powersave" > /proc/cpufreq


Il faudrait que vous verifiez si vous avez quelque chose comme ca:
:~$ cat /proc/acpi/processor/*/info
processor id: 0
acpi id: 1
bus mastering control: yes
power management: yes
...

Le « power management » permet de placer le processeur dans un etat
moins gourmand en energie durant l'idle loop.
Ensuite, regardez les differents etats dans lesquels le processeur peut
etre place via /proc/acpi/processor/*/power

C1 correspond a 'hlt' (et donc n'est pas si interressant puisque vous
aurez la meme chose sans ACPI), les autres sont bien plus interressants
en terme de gain de consommation.
Si cela ne fonctionne pas, je vous conseille vivement d'ecrire a la
mailing list de developpement d'APCI pour linux (voir liens dans

Là, outre le fait que le PC rame, les ventilos se lancent toutes les 5
secondes pendant 30 secondes. Peu convainquant donc ...
Ensuite, j'ai essayé des utilitaires du genre powernowd, cpufreqd...
Mais le resultat n'est guère mieux.
Il y a néanmoins quelquechose qui m'interpèle. Je ne comprend pas
pourquoi /proc/acpi/fan et /proc/acpi/thermal_zone sont vide. N'ai je
pas d'accés à ces propriétés de mon ordi ? Et pourquoi n'ai je pas
/proc/toshiba comme c'est sensé être quand on a un toshiba avec un noyau
pour lequel on a mis Toshiba Utils ?


Tout simplement parce que :
-> ce modele n'a pas un bios proprietaire Toshiba. A la place, il y a
un bios pheonix classique. Par contre, ce modele a ete concu, en fait,
par Compal (le 'l' n'est pas une erreur, hein).

-> Il se trouve que certaines personnes ont developpes quelques
petites choses pour les Compals. Je vous renvoi sur
alors notamment le support de tout ce qui touche au monitoring au
de la temperature du processeur, activation du ventilo, et autres
goodies.). Bien que cela ait ete prevu pour les HP Omnibooks a
l'origine, ca marche tres bien avec les Toshiba Satellites en general.

PS : j'ai aussi un problème de son. J'en ai pas. J'ai voulu mettre les
derniers pilotes ALSA mais en fait je ne sais pas quelle carte son j'ai.
Sous Win, y a marqué Realtek AC97. Et un lspci sous linux semble me dire
que tout ce que j'ai est de l'ATI. Alors je ne sais pas quoi mettre.


Alors la, je n'en sais rien. Desole.

--
Bruno Ducrot.

-- Which is worse: ignorance or apathy?
-- Don't know. Don't care.

stac
Le #1059820
Merci beaucoup pour ces informations. Néanmoins je n'ai pas trouvé les
utilitaires compal.


On Wed, 28 Apr 2004 09:30:14 +0200, stac
Bonjour,

J'ai un Toshiba Satellite A30, Pentium 4M 2.8 GHz, ATI RADEON 9000,
etc. Le gros problème de ce portable est le bruit que générent les deux
ventilateurs. Sous windows, à l'aide de SpeedSwitch je suis arrivé à
faire en sorte que ces ventilateurs ne fonctionne souvent mais moins que
normalement (avec les utilitaires toshiba).
Le problème est sous Linux. J'ai installé une Mandrake 10.0 Communitity
qui fonctionne trés bien. J'ai recompilé le noyau pour qu'il prenne en
compte toutes les spécificité des Pentium 4M (SpeedStep, Toshiba
Utils...). Le PC fonctionne. Seul gros défaut, les deux ventilateurs
fonctionnent sans discontinuité, non-stop. Alors je me suis dis, et bien
c'est le processeur qui fonctionne à fond comme un gros bourrin. Et
donc, à l'aide des commandes du type :

echo 5 > /proc/acpi/processor/CPU0/throtling
ou
echo "400000:1000000:powersave" > /proc/cpufreq



Il faudrait que vous verifiez si vous avez quelque chose comme ca:
:~$ cat /proc/acpi/processor/*/info
processor id: 0
acpi id: 1
bus mastering control: yes
power management: yes
...

Le « power management » permet de placer le processeur dans un etat
moins gourmand en energie durant l'idle loop.
Ensuite, regardez les differents etats dans lesquels le processeur peut
etre place via /proc/acpi/processor/*/power

C1 correspond a 'hlt' (et donc n'est pas si interressant puisque vous
aurez la meme chose sans ACPI), les autres sont bien plus interressants
en terme de gain de consommation.
Si cela ne fonctionne pas, je vous conseille vivement d'ecrire a la
mailing list de developpement d'APCI pour linux (voir liens dans


Là, outre le fait que le PC rame, les ventilos se lancent toutes les 5
secondes pendant 30 secondes. Peu convainquant donc ...
Ensuite, j'ai essayé des utilitaires du genre powernowd, cpufreqd...
Mais le resultat n'est guère mieux.
Il y a néanmoins quelquechose qui m'interpèle. Je ne comprend pas
pourquoi /proc/acpi/fan et /proc/acpi/thermal_zone sont vide. N'ai je
pas d'accés à ces propriétés de mon ordi ? Et pourquoi n'ai je pas
/proc/toshiba comme c'est sensé être quand on a un toshiba avec un noyau
pour lequel on a mis Toshiba Utils ?



Tout simplement parce que :
-> ce modele n'a pas un bios proprietaire Toshiba. A la place, il y a
un bios pheonix classique. Par contre, ce modele a ete concu, en fait,
par Compal (le 'l' n'est pas une erreur, hein).

-> Il se trouve que certaines personnes ont developpes quelques
petites choses pour les Compals. Je vous renvoi sur
alors notamment le support de tout ce qui touche au monitoring au
de la temperature du processeur, activation du ventilo, et autres
goodies.). Bien que cela ait ete prevu pour les HP Omnibooks a
l'origine, ca marche tres bien avec les Toshiba Satellites en general.


PS : j'ai aussi un problème de son. J'en ai pas. J'ai voulu mettre les
derniers pilotes ALSA mais en fait je ne sais pas quelle carte son j'ai.
Sous Win, y a marqué Realtek AC97. Et un lspci sous linux semble me dire
que tout ce que j'ai est de l'ATI. Alors je ne sais pas quoi mettre.



Alors la, je n'en sais rien. Desole.




françois
Le #1059618
stac wrote:

PS : j'ai aussi un problème de son. J'en ai pas. J'ai voulu mettre les
derniers pilotes ALSA mais en fait je ne sais pas quelle carte son j'ai.
Sous Win, y a marqué Realtek AC97. Et un lspci sous linux semble me dire
que tout ce que j'ai est de l'ATI. Alors je ne sais pas quoi mettre.


Salut ,

as-tu fait des recherches ??

en tapant "satellite A30" le premier site renvoyer dans google/linux :

http://www.triptico.com/software/linux-ts-a30-303.html

On y trouve entre autres ça :

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio
Controller (rev 03)

puis la liste des modules pour un fonctionnement optimal de la machine
,et en particulier:

i810_audio 25272 0
ac97_codec 13768 0 [i810_audio]
soundcore 3780 2 [i810_audio]

il est précisé que alsa n'est pas utilisé mais oss l'est,
à toi de voir si alsa peut prendre en charge ce matos ,
(même démarche.... également pour l'histoire de ventilo)

@+

stac
Le #1520334
Bonsoir,

Pour la carte son je l'avoue c'était une question en passant. Néanmoins
pour l'histoire des ventilateurs la je crois que j'ai écumé une bonne
partie des sites répertoriés par google. D'ailleurs, j'ai un peu avancé
de ce coté. Il parait que l'on peut avoir plein d'informations sur sa
bécanne comme sur les fan ou autre, en insérant le module omnibook. Je
le compile et l'installe mais là, Ô surprise, "invalid module format".
Je ne comprend pas, j'ai une mandrake noyau 2.6.3, le fichier
omnibook.ko a bien été construit et je n'arrive pas à insérer ce module
avec un modprobe omnibook.

Stac

stac wrote:

PS : j'ai aussi un problème de son. J'en ai pas. J'ai voulu mettre les
derniers pilotes ALSA mais en fait je ne sais pas quelle carte son
j'ai. Sous Win, y a marqué Realtek AC97. Et un lspci sous linux semble
me dire que tout ce que j'ai est de l'ATI. Alors je ne sais pas quoi
mettre.



Salut ,

as-tu fait des recherches ??

en tapant "satellite A30" le premier site renvoyer dans google/linux :

http://www.triptico.com/software/linux-ts-a30-303.html

On y trouve entre autres ça :

00:1f.5 Multimedia audio controller: Intel Corp. 82801DB AC'97 Audio
Controller (rev 03)

puis la liste des modules pour un fonctionnement optimal de la machine
,et en particulier:

i810_audio 25272 0
ac97_codec 13768 0 [i810_audio]
soundcore 3780 2 [i810_audio]

il est précisé que alsa n'est pas utilisé mais oss l'est,
à toi de voir si alsa peut prendre en charge ce matos ,
(même démarche.... également pour l'histoire de ventilo)

@+



françois
Le #1518286
stac wrote:
Bonsoir,

Pour la carte son je l'avoue c'était une question en passant.
Néanmoins pour l'histoire des ventilateurs la je crois que j'ai écumé
une bonne partie des sites répertoriés par google. D'ailleurs, j'ai un
peu avancé de ce coté. Il parait que l'on peut avoir plein
d'informations sur sa bécanne comme sur les fan ou autre, en insérant le
module omnibook. Je le compile et l'installe mais là, Ô surprise,
"invalid module format". Je ne comprend pas, j'ai une mandrake noyau
2.6.3, le fichier omnibook.ko a bien été construit et je n'arrive pas à
insérer ce module avec un modprobe omnibook.



Bonjour ,

Voilà ce que l'on trouve sur google/linux (sourceforge) concernant le
module omnibook :

apparemment il a du mal avec un noyau 2.6 ,il cause des oups lors du
chargement mais c'est en cours de "réparation" cependant il y a
un moyen de le faire fonctionner :

tout est indiqué dans le README-2.6 des sources (prendre la derniere
version )

Voilà :

vi omnibook-2004-01-20/doc/README-2.6

Additional notes using omnibook module on kernel 2.6
----------------------------------------------------

1. General support
------------------

Finally a working kernel 2.6 support solution was added to Makefile
(thanks to Mark Chappell install and load the omnibook module. Unfortunately the module unloading
code is incompatible with kernel 2.6 and causes kernel Oops. So if you
load omnibook module you have to reboot after installing a new one to
load it. The scenario:

1. Download the new verion.
2. Build it (make).
3. Install it (make install).
4. Reboot.
5. Load omnibook module (insmod omnibook).

I'm investigate the reason of the kernel Oops. Please be patient.

2. OneTouch buttons
-------------------

OneTouch buttons are enabled by kernel series 2.5/2.6 at startup without
this module, and someone asked me: Why have you need it yet? Sometimes it
is useful to disable them e.g. if you travel with your laptop on train or
plane, and want to prevent accidental pressing buttons on front/side of
your laptop.

carex
Le #1516021
Bonsoir,

I have installed Woody 3.rev1 on this Toshiba A30 (very noisy indeed !!)

My actual problem is I can't get the USB working. (kernel-2.4.19 usb-uhci)

00:1d.0 USB Controller: Intel Corp. unknow device 24C2 ???

It seems the USB controller 82801DB is not recognised !

Any idea ??

Thanks.
Carex.


stac
Bonjour,

J'ai un Toshiba Satellite A30, Pentium 4M 2.8 GHz, ATI RADEON 9000,
etc. Le gros problème de ce portable est le bruit que générent les deux
ventilateurs. Sous windows, à l'aide de SpeedSwitch je suis arrivé à
faire en sorte que ces ventilateurs ne fonctionne souvent mais moins que
normalement (avec les utilitaires toshiba).
Le problème est sous Linux. J'ai installé une Mandrake 10.0 Communitity
qui fonctionne trés bien. J'ai recompilé le noyau pour qu'il prenne en
compte toutes les spécificité des Pentium 4M (SpeedStep, Toshiba
Utils...). Le PC fonctionne. Seul gros défaut, les deux ventilateurs
fonctionnent sans discontinuité, non-stop. Alors je me suis dis, et bien
c'est le processeur qui fonctionne à fond comme un gros bourrin. Et
donc, à l'aide des commandes du type :

echo 5 > /proc/acpi/processor/CPU0/throtling
ou
echo "400000:1000000:powersave" > /proc/cpufreq

Là, outre le fait que le PC rame, les ventilos se lancent toutes les 5
secondes pendant 30 secondes. Peu convainquant donc ...
Ensuite, j'ai essayé des utilitaires du genre powernowd, cpufreqd...
Mais le resultat n'est guère mieux.
Il y a néanmoins quelquechose qui m'interpèle. Je ne comprend pas
pourquoi /proc/acpi/fan et /proc/acpi/thermal_zone sont vide. N'ai je
pas d'accés à ces propriétés de mon ordi ? Et pourquoi n'ai je pas
/proc/toshiba comme c'est sensé être quand on a un toshiba avec un noyau
pour lequel on a mis Toshiba Utils ?

Merci d'avance,

Stac

PS : j'ai aussi un problème de son. J'en ai pas. J'ai voulu mettre les
derniers pilotes ALSA mais en fait je ne sais pas quelle carte son j'ai.
Sous Win, y a marqué Realtek AC97. Et un lspci sous linux semble me dire
que tout ce que j'ai est de l'ATI. Alors je ne sais pas quoi mettre.


Publicité
Poster une réponse
Anonyme