truc bizarre : localhost:3333 marche sans server ?

Le
Une Bévue
J'ai une page web en cours de dev.
Normalement, pour la visualiser je fais un :
$ npm run start

qui démarre un server en localhost:3333, là, je n'ai pas démarré le
serveur, est pourtant ma page est complétement fonctionnelle.

j'ai vérifié si quelqu'un "causait" sur 3333 que dalle :
$ netstat -an | grep 3333

ne donne rien du tout.

bon par ailleurs j'ai apache2 mais sur le port 80

comment expliquer cela ?
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Francois Lafont
Le #26420099
Bonsoir,
On 12/10/2016 04:51 PM, Une Bévue wrote:
J'ai une page web en cours de dev.
Normalement, pour la visualiser je fais un :
$ npm run start
qui démarre un server en localhost:3333, là, je n'ai pas démarré le serveur, est pourtant ma page est complétement fonctionnelle.
j'ai vérifié si quelqu'un "causait" sur 3333 que dalle :
$ netstat -an | grep 3333
ne donne rien du tout.
bon par ailleurs j'ai apache2 mais sur le port 80
comment expliquer cela ?

Et un « curl http://localhost:3333 » ça donne quoi ? Faut se méfier des navigateurs et de leur cache.
Et dans /etc/hosts, y'a quoi ?
--
François Lafont
yamo'
Le #26420100
Une Bévue a écrit le 10/12/2016 à 16:51 :
J'ai une page web en cours de dev.
Normalement, pour la visualiser je fais un :
$ npm run start
qui démarre un server en localhost:3333, là, je n'ai pas démarré le
serveur, est pourtant ma page est complétement fonctionnelle.
j'ai vérifié si quelqu'un "causait" sur 3333 que dalle :
$ netstat -an | grep 3333
ne donne rien du tout.
bon par ailleurs j'ai apache2 mais sur le port 80
comment expliquer cela ?


Utilises tu tor?
Une fois sur une ubuntu où tor tournait, je ne pouvais pas aller sur
cups en localhost.
Je suis aussi d'avis que /etc/hosts peut aider à trouver le bug.
C'est une VM? J'ai déjà eu une machine qui ne résolvait plus localhost à
cause d'une version incompatible de vmware-tools.

--
Stéphane
Une Bévue
Le #26420147
Le 10/12/2016 à 17:38, Francois Lafont a écrit :
Et un « curl http://localhost:3333 » ça donne quoi ? Faut se méfier des navigateurs et de leur cache.

bonne pioche, merci beaucoup :
$ curl http://localhost:3333
curl: (7) Failed to connect to localhost port 3333: Connexion refusée
Et dans /etc/hosts, y'a quoi ?

$ cat /etc/hosts
127.0.0.1 localhost
127.0.1.1 d620.local d620
# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
192.168.0.15 vostro.local
192.168.0.41 mbp.local
www.xxx.yyy.zzz souslamousse
rrr.sss.ttt.uuu j-kiosk.com
c'est le cache du navigateur qui me joue des tours...
Une Bévue
Le #26420149
Le 10/12/2016 à 17:55, yamo' a écrit :
Utilises tu tor?
Une fois sur une ubuntu où tor tournait, je ne pouvais pas aller sur
cups en localhost.
Je suis aussi d'avis que /etc/hosts peut aider à trouver le bug.
C'est une VM? J'ai déjà eu une machine qui ne résolvait plus localhost à
cause d'une version incompatible de vmware-tools.

je n'utilise ni tor ni VM.
c'est sans doute un pb de cache du navigateur.
le cache me semble être performant car, dans cette page il y a un appel
à un websocket pour charger des items.
quand je regarde la console du navigateur, j'ai qqc comme "connection
failed" avec ce websocket MAIS les données sont chargées !!!
(le websocket sert à lire une base de données MongoDB)
je dois dire que ce pb n'existe qu'avec firefox, opera me donne :
Ce site est inaccessible
localhost n'autorise pas la connexion.
pour que ça marche correctement, je dois faire :
┬─[:~]─[16-12-11 12:02:21]
╰─>$ cd Brunch/Villes
┬─[:~/Brunch/Villes]─[16-12-11 12:02:27]
╰─>$ npm run start
start /home/yt/Brunch/Villes
brunch watch --server

11 Dec 12:02:35 - info: application started on http://localhost:3333/
11 Dec 12:02:37 - info: compiling
11 Dec 12:02:41 - info: compiling.
11 Dec 12:02:41 - info: compiled 165 files into 3 files, copied 20 in
8.8 sec
Yliur
Le #26420226
Le Sun, 11 Dec 2016 11:54:38 +0100
Une Bévue
c'est le cache du navigateur qui me joue des tours...

Ctrl + F5 dans Firefox pour mettre à jour la page complètement me
semble-t-il.
Une Bévue
Le #26420281
Le 11/12/2016 à 20:27, Yliur a écrit :
Ctrl + F5 dans Firefox pour mettre à jour la page complètement me
semble-t-il.

ok merci !
Publicité
Poster une réponse
Anonyme