UEFI Bios : Disque système ne boot plus

Le
Alain Vaugham
Bonjour la liste,


Il s'agit d'un serveur principalement pour Samba et Postgresql sur
Wheezy.
Voulant passer en stable j'ai remplacé le disque sur lequel tournait
Wheesy par un disque vierge.
L'installation de Buster sur le nouveau disque s'est faite sans
problème particulier sauf que de Wheezy à Buster certains paquets
n'existent plus, d'autres ont vu leur configuration modifiées.
Dans le temps imparti (remise en service lundi matin), n'ayant pas pu
configurer Samba sur la Buster, j'ai remis à plus tard cette refonte du
serveur.

J'ai donc déconnecté le disque Buster et remis le disque Wheezy.
Seulement maintenant, ce disque Wheezy ne boot plus. Je n'ai rien
changé dans le BIOS-UEFI.

Sur une autre machine sous Buster, je peux monter ce disque: Les trois
partitions de Wheezy sont :
1 System EFI ext4
2 swap
3 System EFI vfat
Je retrouve tous les répertoires sous /

Cette mésaventure m'était déjà arrivée. Je n'avais=
pas insisté
davantage.

Je me pose donc aujourd'hui la question si c'est normal qu'un disque
sous Debian ne soit plus accepté par un BIOS-UEFI après qu'il ait=
été
simplement démonté/remonté.

Merci par avance pour toutes infos qui me permettront de faire rebooter
ce disque.


--
Alain Vaugham
Clef GPG : 0xDB77E054673ECFD2
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Alain Vaugham
Le #26547986
Le Sun, 31 May 2020 17:45:07 +0200,
Alain Vaugham
Je me pose donc aujourd'hui la question si c'est normal qu'un disque
sous Debian ne soit plus accepté par un BIOS-UEFI après qu'il a it été
simplement démonté/remonté.

Je me réponds à moi-même.
Le BIOS-UEFI AMD 2.16.1240 sur la carte ASUS que j'utilise est
probablement buggé comme c'est suggéré sur :
https://wiki.debian.org/UEFI#Force_grub-efi_installation_to_the_removable_m edia_path
Ce que qui m'a dépanné c'est que pour qu'un disque Debian puisse
rebooter sur ce BIOS-UEFI après multiples
démontages/remontages/permutations de disques UEFI Debian/MS Windows, la
seule configuration qui a fonctionné c'est que la Debian soit install ée
avec l'option BIOS-UEFI: Démarrage/Compatibilité Support Module =[Auto].
Avec une telle configuration, Netinst ne propose plus l'installation
UEFI mais BIOS.
--
Alain Vaugham
Clef GPG : 0xDB77E054673ECFD2
Poster une réponse
Anonyme