UML starting problem

Le
romain.daumont
Re,

Je me suis trompé de salon :-p

Donc, je vous poste mon inittab (meme configuration entre l'hote et le
filesystem virtuel) :

# /etc/init.d executes the S and K scripts upon change
# of runlevel.
#
# Runlevel 0 is halt.
# Runlevel 1 is single-user.
# Runlevels 2-5 are multi-user.
# Runlevel 6 is reboot.

l0:0:wait:/etc/init.d/rc 0
l1:1:wait:/etc/init.d/rc 1
l2:2:wait:/etc/init.d/rc 2
l3:3:wait:/etc/init.d/rc 3
l4:4:wait:/etc/init.d/rc 4
l5:5:wait:/etc/init.d/rc 5
l6:6:wait:/etc/init.d/rc 6
# Normally not reached, but fallthrough in case of emergency.
z6:6:respawn:/sbin/sulogin

# What to do when CTRL-ALT-DEL is pressed.
ca:12345:ctrlaltdel:/sbin/shutdown -t1 -a -r now

# Action on special keypress (ALT-UpArrow).
#kb::kbrequest:/bin/echo "Keyboard Request--edit /etc/inittab to let
this work."

# What to do when the power fails/returns.
pf::powerwait:/etc/init.d/powerfail start
pn::powerfailnow:/etc/init.d/powerfail now
po::powerokwait:/etc/init.d/powerfail stop

# /sbin/getty invocations for the runlevels.
#
# The "id" field MUST be the same as the last
# characters of the device (after "tty").
#
# Format:
# <id>:<runlevels>:<action>:<process>
#
# Note that on most Debian systems tty7 is used by the X Window
System,
# so if you want to add more getty's go ahead but skip tty7 if you run
X.
#
1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

# Example how to put a getty on a serial line (for a terminal)
#
#T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100
#T1:23:respawn:/sbin/getty -L ttyS1 9600 vt100

# Example how to put a getty on a modem line.
#
#T3:23:respawn:/sbin/mgetty -x0 -s 57600 ttyS
-

Aussi, j'ai egalement des messages de ce style (selon le kernel et
l'image) :
-
VFS: Cannot open root device "ub0" or unknown-block(0,0)
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on unknown-block(0,0)
--

Là, franchement ça commence un peu à me prendre la tête!

merci pour vos post
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Ronald
Le #1308148
Le Wed, 19 Jan 2005 03:13:17 -0800, MaXX a écrit :

Re,

----------------------------------------------

Aussi, j'ai egalement des messages de ce style (selon le kernel et
l'image) :
------------------------------------------------------- VFS: Cannot open
root device "ub0" or unknown-block(0,0) Please append a correct "root="
boot option Kernel panic: VFS: Unable to mount root fs on
unknown-block(0,0)
--------------------------------------------------------------



Ca fait bien longtemps que je n'ai pas jouer avec uml, mais j'ai retrouvé
une image pour uml (une slack 8.0.0) et voilà ce qui me semble différent:

le fstab:

/dev/ubd0 / ext2 defaults 1 1
none /dev/pts devpts gid=5,modeb0 0 0
none /proc proc defaults 0 0

Les devices spécifiques (dans /dev, ne tient pas compte de /mnt/loop):

brw-r--r-- 1 root root 98, 0 May 9 2003 /mnt/loop/dev/ubd0
brw-r--r-- 1 root root 98, 1 May 9 2003 /mnt/loop/dev/ubd1
brw-r--r-- 1 root root 98, 2 May 9 2003 /mnt/loop/dev/ubd2
brw-r--r-- 1 root root 98, 3 May 9 2003 /mnt/loop/dev/ubd3
brw-r--r-- 1 root root 98, 4 May 9 2003 /mnt/loop/dev/ubd4
brw-r--r-- 1 root root 98, 5 May 9 2003 /mnt/loop/dev/ubd5
brw-r--r-- 1 root root 98, 5 May 9 2003 /mnt/loop/dev/ubd5
brw-r--r-- 1 root root 98, 6 May 9 2003 /mnt/loop/dev/ubd6
brw-r--r-- 1 root root 98, 6 May 9 2003 /mnt/loop/dev/ubd6
brw-r--r-- 1 root root 98, 7 May 9 2003 /mnt/loop/dev/ubd7
brw-r--r-- 1 root root 98, 7 May 9 2003 /mnt/loop/dev/ubd7

inittab n'est pas modifié, enfin pas spécialement.

Là, franchement ça commence un peu à me prendre la tête!

merci pour vos post


Publicité
Poster une réponse
Anonyme