USB / laptop /kernel 2.4.25

Le
bricem13
Salut

j'ai un pbm avec l'usb sur mon portable: seul un port est détecté sur
3!!

sortie de dmesg:
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 07:52:37 Mar 2 2004
usb-uhci.c: High bandwidth mode enabled
PCI: Found IRQ 9 for device 00:10.0
PCI: Setting latency timer of device 00:10.0 to 64
usb-uhci.c: USB UHCI at I/O 0x1020, IRQ 9
usb-uhci.c: Detected 2 ports
usb.c: new USB bus registered, assigned bus number 1
hub.c: USB hub found
hub.c: 2 ports detected
PCI: No IRQ known for interrupt pin B of device 00:10.1.
usb-uhci.c: found UHCI device with no IRQ assigned. check BIOS
settings!
PCI: No IRQ known for interrupt pin C of device 00:10.2.
usb-uhci.c: found UHCI device with no IRQ assigned. check BIOS
settings!
usb-uhci.c: v1.275:USB Universal Host Controller Interface driver
usbdevfs: remount parameter error
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,6), internal journal
Adding Swap: 506008k swap-space (priority -1)
hub.c: new USB device 00:10.0-1, assigned address 2
usb.c: USB device 2 (vend/prod 0x4fc/0x3) is not claimed by any active
driver.
SCSI subsystem driver Revision: 1.00
hdc: attached ide-scsi driver.
scsi0 : SCSI host adapter emulation for IDE ATAPI devices
Vendor: QSI Model: CDRW/DVD SBW-241 Rev: VS04
Type: CD-ROM ANSI SCSI revision: 02
kjournald starting. Commit interval 5 seconds
EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,8), internal journal
EXT3-fs: mounted filesystem with ordered data mode.
MSDOS FS: IO charset iso8859-1
MSDOS FS: Using codepage 850
usb.c: registered new driver hiddev
usb.c: registered new driver hid
usb-uhci.c: interrupt, status 3, frame# 713
input: USB HID v1.00 Mouse [04fc:0003] on usb1:2.0
hid-core.c: v1.8.1 Andreas Gal, Vojtech Pavlik <vojtech@suse.cz>
hid-core.c: USB HID support drivers
mice: PS/2 mouse device common for all mice
usb.c: registered new driver usbmouse
usbmouse.c: v1.6:USB HID Boot Protocol mouse driver


sortie de lspci:
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo
KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo
KT266/A/333 AGP]
00:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
00:0e.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev aa)
00:0e.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev aa)
00:0e.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C552 IEEE 1394 Controller
(rev 02)
00:10.0 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. USB (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT8233/A/C/VT8235 PIPC Bus Master IDE (rev
06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc.
VT8233/A/8235 AC97 Audio Controller (rev 50)
00:11.6 Communication controller: VIA Technologies, Inc. Intel 537
[AC97 Modem] (rev 80)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4
420 Go] (rev a3)


l'option pci=biosirq est passée au noyau au boot!

dmesg me dit de vérifier le bios mais je ne peux rien faire du
tout!!!! c'est un portable SONY (à la con je crois!!) avec un bios
Phoenix mais pas moyen de changer la config du bios

PLEASE HELP

Brice
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Guy Decarpentrie
Le #1522214
Brice wrote:
Salut

j'ai un pbm avec l'usb sur mon portable: seul un port est détecté sur
3!!

dmesg me dit de vérifier le bios mais je ne peux rien faire du
tout!!!! c'est un portable SONY (à la con je crois!!) avec un bios
Phoenix mais pas moyen de changer la config du bios

PLEASE HELP

Brice


Bonsoir,

http://www.linux-on-laptops.com/sony.html

++

no_spam
Le #1522202
On Tue, 27 Apr 2004 10:11:21 -0700, Brice wrote:

Salut

j'ai un pbm avec l'usb sur mon portable: seul un port est détecté sur
3!!

sortie de dmesg:
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 07:52:37 Mar 2 2004
usb-uhci.c: High bandwidth mode enabled
PCI: Found IRQ 9 for device 00:10.0
PCI: Setting latency timer of device 00:10.0 to 64
usb-uhci.c: USB UHCI at I/O 0x1020, IRQ 9
usb-uhci.c: Detected 2 ports
^^^^^^^^^^^^^^^^

Regardes plus fort: 2 ports détectés...
Sinon, en passant, l'USB, c'est plutôt dans /proc/bus/usb/devices
qu'il y a des infos...

bricem13
Le #1522153
Je regarde plus forts et je pense que cela veut dire que le controller
USB 2.0 a aussi été détecté!

en étant bête et méchant, seul un port marche !!!!! (essai avec ma
souris USB)

Quant à /proc/bus/usb/devices, la sortie doit être la même que usbview
qui donne un seul USB: usb-uhci root hub ou qqch comme ça (ça doit
pas être dans le bon ordre je pense)

Brice


no_spam
On Tue, 27 Apr 2004 10:11:21 -0700, Brice wrote:

Salut

j'ai un pbm avec l'usb sur mon portable: seul un port est détecté sur
3!!

sortie de dmesg:
usb.c: registered new driver usbdevfs
usb.c: registered new driver hub
usb-uhci.c: $Revision: 1.275 $ time 07:52:37 Mar 2 2004
usb-uhci.c: High bandwidth mode enabled
PCI: Found IRQ 9 for device 00:10.0
PCI: Setting latency timer of device 00:10.0 to 64
usb-uhci.c: USB UHCI at I/O 0x1020, IRQ 9
usb-uhci.c: Detected 2 ports
^^^^^^^^^^^^^^^^

Regardes plus fort: 2 ports détectés...
Sinon, en passant, l'USB, c'est plutôt dans /proc/bus/usb/devices
qu'il y a des infos...



Publicité
Poster une réponse
Anonyme