USF & MultiPage & Boutons

Le
JohnFuss
Bonjour à tous,

voici mon soucis, j'ai créé une userform conteant quelques boutons
(commandButton) avec des Captions de ce type "[Mois]", "[Année]", etc., je
créé depuis VBA un multipage que j'alimente en fonction de données issues de
la base de registre.

Avant de mettre ce multipage dynamique il était statique et tout marchait
bien, depuis qu'il est dynamique les libellé des boutons ne s'affichent pas
systématiquement et je n'arrive pas à trouver où ça coince. Puis-je
rafraichir les boutons (leur libellé au moins) après avoir chargé mon
multiPage ? si oui comment :-)

Merci d'avance.

John

  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
michdenis
Le #3228571
Bonjour John,

Il y a une commande qui "oblige" le formulaire à se mettre à jour graphiquement :

Me.Repaint


Salutations!



"JohnFuss" Bonjour à tous,

voici mon soucis, j'ai créé une userform conteant quelques boutons
(commandButton) avec des Captions de ce type "[Mois]", "[Année]", etc., je
créé depuis VBA un multipage que j'alimente en fonction de données issues de
la base de registre.

Avant de mettre ce multipage dynamique il était statique et tout marchait
bien, depuis qu'il est dynamique les libellé des boutons ne s'affichent pas
systématiquement et je n'arrive pas à trouver où ça coince. Puis-je
rafraichir les boutons (leur libellé au moins) après avoir chargé mon
multiPage ? si oui comment :-)

Merci d'avance.

John
JohnFuss
Le #3228481
Je l'ai ajouté à mon code, sans nouvelle de ma part dans ce post c'est que
jue n'ai plus eu le soucis.

Merci bien tu es mon sauveur de ce jour ;)

John

"michdenis" news:
Bonjour John,

Il y a une commande qui "oblige" le formulaire à se mettre à jour
graphiquement :


Me.Repaint


Salutations!



"JohnFuss" djl1pu$oov$

Bonjour à tous,

voici mon soucis, j'ai créé une userform conteant quelques boutons
(commandButton) avec des Captions de ce type "[Mois]", "[Année]", etc., je
créé depuis VBA un multipage que j'alimente en fonction de données issues
de

la base de registre.

Avant de mettre ce multipage dynamique il était statique et tout marchait
bien, depuis qu'il est dynamique les libellé des boutons ne s'affichent
pas

systématiquement et je n'arrive pas à trouver où ça coince. Puis-je
rafraichir les boutons (leur libellé au moins) après avoir chargé mon
multiPage ? si oui comment :-)

Merci d'avance.

John





JohnFuss
Le #3228401
Pour aller plus loin, les fameux boutons anmésiques passait à .Visible False et revenait à .Visible = True
et c'est come ça qu'ils perdent leur Caption, j'ai donc du remettre leur
propriété Caption en dur avant ton Me.Repaint et là c'est bon.

Merci encore.

John


"michdenis" news:
Bonjour John,

Il y a une commande qui "oblige" le formulaire à se mettre à jour
graphiquement :


Me.Repaint


Salutations!



"JohnFuss" djl1pu$oov$

Bonjour à tous,

voici mon soucis, j'ai créé une userform conteant quelques boutons
(commandButton) avec des Captions de ce type "[Mois]", "[Année]", etc., je
créé depuis VBA un multipage que j'alimente en fonction de données issues
de

la base de registre.

Avant de mettre ce multipage dynamique il était statique et tout marchait
bien, depuis qu'il est dynamique les libellé des boutons ne s'affichent
pas

systématiquement et je n'arrive pas à trouver où ça coince. Puis-je
rafraichir les boutons (leur libellé au moins) après avoir chargé mon
multiPage ? si oui comment :-)

Merci d'avance.

John





Poster une réponse
Anonyme