w3wp.exe est a 100%

Le
zoltix
Hello,
On vient de mettre place une application Web et Web service. Mais de
temps en temps notre serveur bloque et l’instance instance w3wp.exe est
a 100% . Et lorsqu’on le redémarre le service. Tout redémarre très
bien.
Comment puis je identifier si c’est le site ou le web service qui pose
problème car ces deux systèmes sont étroitement liés ?
Aurait-il un bug ?


ASPX net.2 et IIS 6 sur Windows 2003 serveur
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
jbongran
Le #11357441
zoltix wrote:
Hello,
On vient de mettre place une application Web et Web service. Mais de
temps en temps notre serveur bloque et l’instance instance w3wp.exe
est a 100% . Et lorsqu’on le redémarre le service. Tout redémarre
très bien.
Comment puis je identifier si c’est le site ou le web service qui pose
problème car ces deux systèmes sont étroitement liés ?
Aurait-il un bug ?


ASPX net.2 et IIS 6 sur Windows 2003 serveur



Un seul site web sur le serveur ?
Un seul pool d'application sur le serveur ?
La "santé" (ping du process ouvrier, redemarrage du pool en cas de
defaillance, consommation cpu, etc) du pool d'application concerné est-elle
activée ?

Utiliser un debogueur tel que celui de MS
http://support.microsoft.com/?id‰3657, la plus grosse difficulté (en
dehors du deboggage lui-même) est de savoir a quelle instance de w3wp.exe il
faut l'attacher, mais il y a de la matière d'écrite pour ça, sur cette page,
tu trouvera un script en vbs, un outil MS, un script en powershell
http://pluralsight.com/blogs/mike/archive/2006/08/16/33041.aspx:
Publicité
Poster une réponse
Anonyme