[WD8] largeur de colonne dans une table

Le
Pascal F
Bonjour,
Depuis le passage en version 7.5 et 8, j'ai un problème sur la largeur
des colonnes des tables.
J'ai une table comportant les colonnes COL1, COL2 COL3 COL4 COL5 COL6
par programmation je fixe la largeur des colonnes et la visibilité.
je rends la colonne COL6 invisible et je fixe les COL2 et COL5 à une
largeur 0.
La colonne COL5 a bien la largeur 0, mais la COL2 a une largeur de
quelques pixels, ce qui donne un aspect déplorable à l'affichage. Si je
déplace la COL2 en 4èeme position (soit après la dernière colonne de
largeur non nulle) miracle, la colonne COL2 a bien une largeur de 0
pixels. :/
Je précise que pour des besoins de traitement, je ne veux pas rendre
ces colonnes invisibles.
Quelqu'un a t il constaté ce phénomène ou bien ai-je un paramètre de ma
table incorrect. Ce code ne me posais aucun problème en 5.5
Merci d'avance.

--
Pascal Ferracci
efpé

efpe@efpe.biz
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
STASZEWSKI André
Le #13284001
Bonjour,

Pascal F wrote:
Bonjour,
Depuis le passage en version 7.5 et 8, j'ai un problème sur la largeur
des colonnes des tables.
J'ai une table comportant les colonnes COL1, COL2 COL3 COL4 COL5 COL6
par programmation je fixe la largeur des colonnes et la visibilité.
je rends la colonne COL6 invisible et je fixe les COL2 et COL5 à une
largeur 0.
La colonne COL5 a bien la largeur 0, mais la COL2 a une largeur de
quelques pixels, ce qui donne un aspect déplorable à l'affichage. Si
je déplace la COL2 en 4èeme position (soit après la dernière colonne
de largeur non nulle) miracle, la colonne COL2 a bien une largeur de 0
pixels. :/
Je précise que pour des besoins de traitement, je ne veux pas rendre
ces colonnes invisibles.
Quelqu'un a t il constaté ce phénomène ou bien ai-je un paramètre de
ma table incorrect. Ce code ne me posais aucun problème en 5.5
Merci d'avance.



Vérifie dans la description de la table que aucune colonne n'est encrée et
que le taux délargissement et bien à zéro partout (pour chaque colonne)
--
Cordialement,
André STASZEWSKI
Nouvelle version 3.0 de Photo Visu sur www.PlaneteDev.fr.st
Pascal F
Le #13139641
Le 25/06/2004, STASZEWSKI André a supposé :
Bonjour,

Pascal F wrote:
Bonjour,
je déplace la COL2 en 4èeme position (soit après la dernière colonne
de largeur non nulle) miracle, la colonne COL2 a bien une largeur de 0
pixels. :/
Quelqu'un a t il constaté ce phénomène ou bien ai-je un paramètre de
ma table incorrect. Ce code ne me posais aucun problème en 5.5
Merci d'avance.



Vérifie dans la description de la table que aucune colonne n'est encrée et
que le taux délargissement et bien à zéro partout (pour chaque colonne)


Merci

--
Pascal Ferracci
efpé


Poster une réponse
Anonyme