webcam logitech quickcam express avec kernel 2.6.11-6

Le
Johnny
salut à tous
j'ai acheté une webcam logitech quickcam express et je n'arrive pa du tt à
la configurer. Je suis sous mandriva LE2005 et je croi avoir essayé tout ce
que j'ai pu trouver sur le net. Avez-vous des astuces qui pourraient m'aider
svp ?

merci d'avoir pris connaissance de mon pb
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Christophe PEREZ
Le #1366170
Le Wed, 11 May 2005 18:25:10 +0200, Johnny a écrit:

salut à tous


Salut à toi

j'ai acheté une webcam logitech quickcam express et je n'arrive pa du tt à
la configurer.


Alors, allons y gaiement.
Déjà, qu'appelles-tu configurer une webcam ?
Le module se charge t'il ?
Que disent les logs à son chargement ?
Avec quelle application tentes-tu de "configurer" la webcam ?

Je suis sous mandriva LE2005 et je croi avoir essayé tout ce
que j'ai pu trouver sur le net.


Ça serait bien étonnant, que tu aies tout essayé, et qu'en l'ayant fait
tu n'obtiennes pas le résultat souhaité.
Qu'as-tu donc essayé ?

Avez-vous des astuces qui pourraient m'aider svp ?


- Vérifier que les bons modules sont compilés avec le noyau courant (à
priori, oui)
- Charger les modules
- voir si le périphérique /dev/video ou /dev/video0 ou /dev/video1...
est créé
- sinon, voir du côté des hotplug, coldplug etc...
- consulter les logs

--
Christophe PEREZ
Écrivez moi sans _faute !

Johnny
Le #1366167
oh la la moi je débute en linux je comprends pas tout ce que tu m'as dit.
Ce que je peux dire c'est que ma webcam est reconnue par le système en tant
que camera mais il doit manquer des pilotes pour qu'elle soit utilisable.
J'ai installé tout ce que j'ai pu trouver ayant rapport avec ma webcam sans
succès. Je te tiens au courant de la suite des événements.
Merci

Johnny
gadget
Le #1366166
Bonsoir,

va voir sur http://lea-linux.org/hardware/hard_image/webcam.html

et plus généralement tout le site www.lea-linux.org est un bon point de
départ pour les débutant

--
Gadget
(5710)

12:24 12:20 Midnight Commander n'a jamais ete tres stable (je l'utilise
depuis 3 ans). Mais qu'est-ce qu'il est pratique !
12:31 12:24 Windows n'a jamais été très stable (je l'utilise depuis 3
heures), mais qu'est-ce qu'il est pratique! Le seul pb, c'est
quand le clavier se blo
Christophe PEREZ
Le #1366161
Le Wed, 11 May 2005 22:41:00 +0200, Johnny a écrit:

oh la la moi je débute en linux je comprends pas tout ce que tu m'as dit.
Ce que je peux dire c'est que ma webcam est reconnue par le système en tant
que camera mais il doit manquer des pilotes pour qu'elle soit utilisable.
J'ai installé tout ce que j'ai pu trouver ayant rapport avec ma webcam sans
succès. Je te tiens au courant de la suite des événements.


Oui ben quand tu me réponds tout ça, ça ne m'avance à rien.

Si tu ne fais pas l'effort de répondre au moins aux questions basiques du
genre :
« Avec quelle application tentes-tu de "configurer" la webcam ? »
je ne pourrai strictement rien pour toi.
Désolé.

Merci


Je t'en prie, mais sincèrement, si tu t'attaques à Linux, un minimum de
lecture te sera utile.
Au moins pour avoir un vocabulaire pour comprendre les questions, et y
répondre, si tu veux avoir de l'aide. Sans ça, tu es bien mal barré.

--
Christophe PEREZ
Écrivez moi sans _faute !

Johnny
Le #1366157
je reviens avec mon problème en apportant quelques précisions qui sont
indispensables.
Donc ce que je voudrais c'est pouvoir utiliser ma webcam en
'visioconférence'. Pour cela j'ai télécharger certains pilotes qui étaient
sensés m'aider ( qce-ga-0.40d, qc-usb-0.6.3 et spca532-04012005 )
A chaque fois que je tente un 'make' ça se termine par une 'erreur1'.
Alors ce matin je suis aller voir, dev/video/ ne semble pas exister.
Cependant, si je vais voir dans la liste de matériel 'HardDrake' ma webcam
est listée dans le matériel inconnu.
Voilà le point auquel je suis ce matin.
Merci à tous.
Johnny
Le #1366156
Merci pour le lien mais sur cette page il y a des liens morts.
Je vais essayer de m'en sortir.
Je mettrai un message sur ce forum dès que j'aurais réussi (si j'y
arrive :-D)
Marc Dejardin
Le #1366150
Johnny wrote:
je reviens avec mon problème en apportant quelques précisions qui sont
indispensables.
Donc ce que je voudrais c'est pouvoir utiliser ma webcam en
'visioconférence'. Pour cela j'ai télécharger certains pilotes qui étaient
sensés m'aider ( qce-ga-0.40d, qc-usb-0.6.3 et spca532-04012005 )
A chaque fois que je tente un 'make' ça se termine par une 'erreur1'.
Peut etre que les outils de developpement ne sont pas installes ?

gcc, headers divers etc.
Il faudrait un peu plus de details sur les messages d'erreur.

En verifiant, la compilation du de qce-ga se termine aussi chez moi par
une erreur 1 apres 2 pages d'injures. Il semblerait que de driver n'ai
pas ete mis a jour pour les noyaux 2.6. Ceci dit, c'est un vieux
developpement qui ne doit pas etre le plus approprie pour les nouvelle
quickcam express.
Je pense de qc-usb est mieux approprie. En tout cas la version 0.6.3
compile chez moi et j'obtiens quickcam.ko

Alors ce matin je suis aller voir, dev/video/ ne semble pas exister.
Ca doit apparaitre quand on charge le driver :

insmod quickcam.ko
donne dans dmesg :
quickcam: QuickCam USB camera found (driver version QuickCam USB 0.6.3
$Date: 2005/04/15 19:32:49 $)
quickcam: Kernel:2.6.9n bus:3 class:FF subclass:FF vendor:046D product:0840
quickcam: Sensor HDCS-1000/1100 detected
quickcam: Registered device: /dev/video0
usbcore: registered new driver quickcam

Cependant, si je vais voir dans la liste de matériel 'HardDrake' ma webcam
est listée dans le matériel inconnu.
Voilà le point auquel je suis ce matin.
Merci à tous.
J'espere que ca aide..

MD

Johnny
Le #1366146
je n'arrive à rien pour compiler qc-usb j'obtiens
which: no depmod in
(/usr/bin:/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin/:/usr/games:/usr/lib/jre-1.4.2_07/bin:/usr/share/apps/superkaramba/scripts:/home/johnny/bin:/usr/share/apps/superkaramba/scripts)
awk: cmd. ligne:1: Fatal: ne peut ouvrir le fichier
« /lib/modules/2.6.11-6mdk/build/include/linux/version.h » en lecture (No
such file or directory)
/bin/sh: line 0: [: -ge: unary operator expected
/bin/sh: line 0: [: -ge: unary operator expected
-=- Logitech QuickCam USB camera driver -=-

Makefile target examples:
make all - Compile driver and utilities against current running kernel
make all USER_OPT=-DDEBUG - Compile with debugging code and messages
make all LINUX_DIR=/usr/src/linux - Compile against specified kernel source
make install - Copy driver and utilities into standard locations (needs
root)
make install PREFIX=/usr - Copy utilities to /usr/bin instead
of /usr/local/bin
make install MODULE_DIR=/lib/modules/2.4.0 - Copy module
to /lib/modules/2.4.0/misc
make clean - Remove object files from the source directory

Current configuration:
Driver source directory (PWD): /home/johnny/webcam/qc-usb-0.6.3
Kernel source directory (LINUX_DIR): /lib/modules/2.6.11-6mdk/build
Module install directory (MODULE_DIR): /lib/modules/2.6.11-6mdk
Utility install directory (PREFIX): /usr/local
User options (USER_OPT):
Driver file name (use with insmod): quickcam.o
Kernel version code:

et je ne parle même pas du make all qui m'écrit 2 tonnes de pages.

avez-vous une solution ? Je pense avoir installer beaucoup de trucs de
développement je ne vois pas ce qu'il me manque...
Publicité
Poster une réponse
Anonyme