Wireless Netgear MA401 Fedora Core 2 - Module orinoco_cs

Le
Toto
Bonjour,

Ma config :
Laptop Sony Vaio PCG-FR105
Carte wifi Netgear MA401

Lorsque je lance le service pcmcia :
[root@chezmoi /usr/src/linux-2.6.6-1.435.2.3]# /etc/init.d/pcmcia start
Starting PCMCIA services: cardmgr[3211]: no sockets found!
done.

Lorsque je modprobe les modules orinoco, orinoco_cs, hermes, ds, pas de
message d'erreur (pas de message du tout)
Pourtant, à chaque fois que je veux monter la carte :
[root@chezmoi /usr/src/linux-2.6.6-1.435.2.3]# ifup eth1
Le périphérique orinoco_cs n'étant pas présent, l'initialisation de eth1
sera retardée.

Pourtant un lsmod me donne :
orinoco_cs 6152 0
ds 12292 1 orinoco_cs
pcmcia_core 47176 2 orinoco_cs,ds
orinoco 31500 1 orinoco_cs
hermes 6528 2 orinoco_cs,orinoco

Les modules sont bien chargés
--
Update
--
Apres avoir fait quelques tests, quand je décharge les modules
orinoco_cs et ds, je relance pcmcia (/etc/init.d/pcmcia start), le
module orinoco_cs se charge bien et le socket pcmcia est reconnu ainsi
que la carte qui y est connectée. Il semblerait que le module ds fout un
peu la panique la dedans.
Comment empécher ds de se charger avant orinoco_cs au démarrage ?
J'ai essayé de le virer, mais le service pcmcia le réclame

J'avoue que je ne comprends plus
Si quelqu'un a une idée

Merci
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Toto
Le #1116642
Bonjour,

Ma config :
Laptop Sony Vaio PCG-FR105
Carte wifi Netgear MA401

Lorsque je lance le service pcmcia :
[ /usr/src/linux-2.6.6-1.435.2.3]# /etc/init.d/pcmcia start
Starting PCMCIA services: cardmgr[3211]: no sockets found!
done.

Lorsque je modprobe les modules orinoco, orinoco_cs, hermes, ds, pas de
message d'erreur (pas de message du tout)
Pourtant, à chaque fois que je veux monter la carte :
[ /usr/src/linux-2.6.6-1.435.2.3]# ifup eth1
Le périphérique orinoco_cs n'étant pas présent, l'initialisation de eth1
sera retardée.

Pourtant un lsmod me donne :
orinoco_cs 6152 0
ds 12292 1 orinoco_cs
pcmcia_core 47176 2 orinoco_cs,ds
orinoco 31500 1 orinoco_cs
hermes 6528 2 orinoco_cs,orinoco

Les modules sont bien chargés
--------
Update
--------
Apres avoir fait quelques tests, quand je décharge les modules
orinoco_cs et ds, je relance pcmcia (/etc/init.d/pcmcia start), le
module orinoco_cs se charge bien et le socket pcmcia est reconnu ainsi
que la carte qui y est connectée. Il semblerait que le module ds fout un
peu la panique la dedans.
Comment empécher ds de se charger avant orinoco_cs au démarrage ?
J'ai essayé de le virer, mais le service pcmcia le réclame

J'avoue que je ne comprends plus
Si quelqu'un a une idée

Merci


Par hasard, j'ai viré l'alias "eth1 orinoco_cs" dans /etc/modprobe.conf
et ça marche...
aucune idée du pourquoi.
Je continue avec un autre probleme
Comment, lorsque j'utilise le wifi, basculer d'une carte à l'autre, et
surtout, définir correctement le gateway.
Ma passerelle internet est un routeur netgear IP 192.168.0.1
ma carte eth0 IP 192.168.0.101 et la carte wifi 192.168.0.102
quand je déconnecte l'eth0 pour passer sur l'eth1 en wifi, je fais :

ifup eth1
route add default gw 192.168.0.1 eth1
ifdown eth0

et quand je repasse sur l'eth0, je fais l'inverse :

ifup eth0
route add default gw 192.168.0.1 eth0
ifdown eth1

ça marche sur l'eth0 mais pas sur l'eth1
et je ne comprends pas ou j'ai commis l'erreur.
je précise que la wifi utilise une encryptation wep, mais qu'elle est
correctement configurée à ce niveau, car le netgear me l'indique comme
un périphérique connecté. C'est donc au niveau du routage que je merde.
Un ping sur une ip locale me donne un From
192.168.0.102 icmp_seq=0 Destination Host Unreachable
Un ping sur une IP extérieure cherche un moment sans rien trouver
(;; connection timed out; no servers could be reached)
je ne parle donc pas d'un ping sur un nom
Le dns et la passerelle semble n'etre pas accessibles depuis cette carte.
C'est ou que je merde??

MErci

Publicité
Poster une réponse
Anonyme