[WSS2003] Sécurité des composants WebPart

Le
sda
Bonjour,

J'ai un pb de sécurité avec certains composants WebParts.
Lorsque le niveau de sécurité est positionné à Full (dans le Web.config de
C:Inetpubwwwroot), tous fonctionnent. Cependant pour pouvoir rendre
l'application plus sûre j'ai mis en place un niveau de sécurité personnalisé
(fichier spécifique WSS_CustomTrust.config issu de WSS_MediumTrust.config).
J'essaye de régler correctement en fonction des éventuels codes non
managés. Or lorsque j'essaye d'ajouter à la page mes WebParts, l'erreur
"Impossible d'afficher un composant WebPart ou ce contrôle de formulaire Web
sur cette page de composants WebPart, car il n'est pas inscrit sur ce site
comme fiable" est systématique.

Ma question: Sachant que le message d'erreur est peu précis, comment savoir
quel appel pose pb et trouver ainsi l'instruction manquante ?

Merci

Cdt,

SDA

  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
EROL MVP SPS
Le #16875081
Bonjour,

Je viens de lire un article sur MS2D" pas mal,
http://www.msd2d.com/webparts_view_03.aspx?section=sharepoint
chercher web part

http://www.mysps.info/members/doc_sps/Forms/AllItems.aspx?RootFolder=%2fmembers%2fdoc%5fsps%2fArticlesUS&SortField=LinkFilename&SortDir=Asc&View=%7bC7F66365%2d93C3%2d4D26%2d84E8%2dC9E17A86136D%7d
voir notre site mysps c'est un abon. gratuit pour les membres.

http://www.mysps.info/WebPart/Forms/AllItems.aspx

Voyez aussi :
http://support.microsoft.com/?ID‰4092
+
http://www.sharepoint-france.com/dotNet/Tutorials/2004-05-06/Default.aspx
--
EROL MVP SharePoint. www.mysps.info
http://aspnet2.com/mvp.ashx?ErolGiraudy

"sda"
Bonjour,

J'ai un pb de sécurité avec certains composants WebParts.
Lorsque le niveau de sécurité est positionné à Full (dans le Web.config de
C:Inetpubwwwroot), tous fonctionnent. Cependant pour pouvoir rendre
l'application plus sûre j'ai mis en place un niveau de sécurité
personnalisé (fichier spécifique WSS_CustomTrust.config issu de
WSS_MediumTrust.config). J'essaye de régler correctement en fonction des
éventuels codes non managés.... Or lorsque j'essaye d'ajouter à la page
mes WebParts, l'erreur "Impossible d'afficher un composant WebPart ou ce
contrôle de formulaire Web sur cette page de composants WebPart, car il
n'est pas inscrit sur ce site comme fiable" est systématique.

Ma question: Sachant que le message d'erreur est peu précis, comment
savoir quel appel pose pb et trouver ainsi l'instruction manquante ?

Merci

Cdt,

SDA



Publicité
Poster une réponse
Anonyme