WSL 2 : l'accélération matérielle du GPU en préversion sur Windows 10

Le par  |  4 commentaire(s)
Windows-Linux

L'accélération matérielle du GPU dans Windows Subsystem for Linux 2 sur Windows 10 fait son apparition en préversion. Pour permettre à des binaires Linux d'exploiter le GPU dans WSL et avec des calculs de machine learning.

Le Windows Subsystem for Linux (WSL) permet aux utilisateurs sur Windows 10 d'exécuter nativement des outils Linux. WSL fonctionne actuellement sur plus de 3,5 millions d'appareils actifs par mois, selon Microsoft qui a rarement divulgué ce type de chiffre.

Avec la version 2004 de Windows 10, WSL 2 s'appuie sur un noyau Linux complet qui est exécuté dans une machine virtuelle basée sur Hyper-V, alors qu'auparavant il s'agissait d'une émulation d'API du noyau Linux sur le noyau NT.

Dans le cadre de la build 20150 de Windows 10 pour les Windows Insiders, WSL 2 débute en préversion le support du calcul sur GPU. Cette accélération matérielle du GPU dans WSL 2 était l'une des annonces de Microsoft en mai dernier.

Il est question de la prise en charge pour l'accélération des calculs de machine learning directement dans WSL. En l'occurrence, avec le support de la technologie CUDA de Nvidia et le support de la technologie DirectML de Microsoft pour les GPU AMD et Intel.

Microsoft écrit que l'API DirectML permet d'accélérer l'inférence pour des modèles de machine learning sur les GPU compatibles DirectX 12. Le groupe souligne le travail d'AMD, Intel et Nvidia qui publient des pilotes idoines. Une documentation a été mise en ligne.

Tout cela s'accompagne d'autres nouveautés, comme l'installation de Windows Subsystem for Linux avec une seule ligne de commande : wsl.exe --install.

Complément d'information

Vos commentaires

Trier par : date / pertinence
Le #2101929
le gros gros souci c'est que WSL2 se base sur HyperV. et HyperV actif = pas de virtualbox
Le #2101930
(en fait virtualbox peut marcher mais comme une merde)
Le #2101934
J'avais le même problème que toi avant graveen, sauf que j'utilisais VMware au lieu de Virtualbox.

Ca m'a "forcé" à tester un peu plus Hyper-V et je ne ferais plus machine arrière maintenant, sur un laptop récent avec SSD NVME les perfs des IO sont dingues, beaucoup plus violentes que VMware Workstation Pro.
Du coup toutes mes VMs sont sous Hyper-V maintenant et ça me va très bien
Le #2101947
Nerthazrim a écrit :

J'avais le même problème que toi avant graveen, sauf que j'utilisais VMware au lieu de Virtualbox.

Ca m'a "forcé" à tester un peu plus Hyper-V et je ne ferais plus machine arrière maintenant, sur un laptop récent avec SSD NVME les perfs des IO sont dingues, beaucoup plus violentes que VMware Workstation Pro.
Du coup toutes mes VMs sont sous Hyper-V maintenant et ça me va très bien


Merci pour l'info !

Tu confirmes que les dernières versions de VMware posent problème avec HyperV d'installé ? (dernière version également).
Suivre les commentaires
Poster un commentaire
Anonyme
Anonyme