Extensions Fx4 : un t-shirt pour motiver les développeurs

Le par  |  2 commentaire(s)
Firefox-addon

Avec la proche arrivée de Firefox 4 début 2011, Mozilla tente de motiver les développeurs d'extensions afin d'en assurer la compatibilité.

Firefox-addonPour les utilisateurs finaux de Firefox qui ont recours aux extensions, le passage à une nouvelle version majeure du navigateur est souvent rendu assez pénible pour cause d'absence de compatibilité. Un problème qui au fil du temps n'en sera plus un lorsque ces extensions seront passées sous la houlette de Jetpack.

Cette technologie Jetpack fait partie intégrante de Firefox 4 et un kit de développement a récemment été publié ( Add-on SDK 1.0 en bêta ). Reste que la transition vers des extensions en HTML, CSS et JavaScript ne se fera pas tout de suite, et Mozilla pense aussi aux extensions conçues " à l'ancienne " pour lesquelles il va aussi falloir assurer la compatibilité avec Fx4.

Mozilla sonne ainsi le rappel pour les développeurs en leur précisant qu'il n'y aura plus de changements dans Firefox 4 bêta susceptibles de casser une compatibilité. Les extensions peuvent donc être mises à niveau pour Fx4, sans risque de mauvaises surprises ultérieures.

Une manière originale de motiver les troupes, un t-shirt Firefox 4 sera offert aux développeurs qui réussiront à mettre à jour leurs extensions d'ici le 7 janvier prochain.

Complément d'information
  • Firefox 4 : ultime bêta à télécharger
    La phase de bêta touche à sa fin pour Firefox 4 avec la publication d'une douzième version du genre qui apporte des améliorations de performances notamment pour la consultation de contenus Flash.
  • Firefox 4 : la bêta 11 dispo avec DNT
    Mozilla propose une onzième version bêta de Firefox 4. Apparition de Do Not Track et retour du support WebGL sous Linux.

Vos commentaires

Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
patheticcockroach Hors ligne VIP 7663 points
Le #731111
"Une manière originale de motiver les troupes"
=>oui, enfin pas si originale que ça puisque c'est ce qu'ils font depuis la v2...
Le #731651
Une chose à ne pas oublier Mr Firefox et les développeurs :

Les utilisteurs de WindowXP :

IE9 ne sera pas pour les utilisateurs et utilisatrices de Windows XP

Faut faire honneur à Firefox pas à Microsoft. C'est le but espéront-le!!!!
Suivre les commentaires
Poster un commentaire
Anonyme
:) ;) :D ^^ 8) :| :lol: :p :-/ :o :w00t: :roll: :( :cry: :facepalm:
:andy: :annoyed: :bandit: :alien: :ninja: :agent: :doh: :@ :sick: :kiss: :love: :sleep: :whistle: =]