doublon colonnes

Le
pierre
Bonjour

J'utilise mfc avec la formule NB.SI($A$3:$D$90;A3)>1 pour détecter les
doublons
j'aimerais avoir un résultat positif uniquement si la valeur est presente
dans les 4 colonnes
J'ai augmenté >3 mais cela ne garantit pas sa présence dans toutes les
colonnes
merci pour votre aide

Pierre
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #23495271
Bonjour,

A défaut de plus court, ceci peut-être

=(NB.SI($A$3:$A$90;A3)>0)+(NB.SI($B$3:$B$90;A3)>0)+(NB.SI($C$3:$C$90;A3)>0)+(NB.SI($D$3:$D$90;A3)>0)=4

--
Salutations
JJ


"pierre"
Bonjour

J'utilise mfc avec la formule NB.SI($A$3:$D$90;A3)>1 pour détecter les doublons
j'aimerais avoir un résultat positif uniquement si la valeur est presente dans les 4 colonnes
J'ai augmenté >3 mais cela ne garantit pas sa présence dans toutes les colonnes
merci pour votre aide

Pierre


DanielCo
Le #23495831
Bonjour,
Sélectionne la plage A3:D90 et utilise :
=ET(NB.SI($A3:$D3;A3)>3;A3<>"")
Daniel


Bonjour

J'utilise mfc avec la formule NB.SI($A$3:$D$90;A3)>1 pour détecter les
doublons
j'aimerais avoir un résultat positif uniquement si la valeur est presente
dans les 4 colonnes
J'ai augmenté >3 mais cela ne garantit pas sa présence dans toutes les
colonnes
merci pour votre aide

Pierre
DanielCo
Le #23497401
Oups, c'est valable si les doublons sont sur la même ligne.
Daniel


Bonjour,
Sélectionne la plage A3:D90 et utilise :
=ET(NB.SI($A3:$D3;A3)>3;A3<>"")
Daniel


Bonjour

J'utilise mfc avec la formule NB.SI($A$3:$D$90;A3)>1 pour détecter les
doublons
j'aimerais avoir un résultat positif uniquement si la valeur est presente
dans les 4 colonnes
J'ai augmenté >3 mais cela ne garantit pas sa présence dans toutes les
colonnes
merci pour votre aide

Pierre
pierre
Le #23503251
Merci à vous deux et à Jacky, sa formule est parfaite

Pierre


"DanielCo" iu2n4q$cc9$
Oups, c'est valable si les doublons sont sur la même ligne.
Daniel


Bonjour,
Sélectionne la plage A3:D90 et utilise :
=ET(NB.SI($A3:$D3;A3)>3;A3<>"")
Daniel


Bonjour

J'utilise mfc avec la formule NB.SI($A$3:$D$90;A3)>1 pour détecter les
doublons
j'aimerais avoir un résultat positif uniquement si la valeur est
presente dans les 4 colonnes
J'ai augmenté >3 mais cela ne garantit pas sa présence dans toutes les
colonnes
merci pour votre aide

Pierre






MichD
Le #23505771
Bonjour Jacky,

| A défaut de plus court, ceci peut-être

|=(NB.SI($A$3:$A$90;A3)>0)+(NB.SI($B$3:$B$90;A3)>0)+(NB.SI($C$3:$C$90;A3)>0)+(NB.SI($D$3:$D$90;A3)>0)=4

Ceci peut -être :

=SOMME(SI(($A$3:$A$90=$A$2)*($B$3:$B$90=$A$2)*($C$3:$C$90=$A$2)*($D$3:$D$90=$A$2)=1;1))>0
et sa soeur jumelle
=SOMME(SI(($A$1:$A$10=$A$2)+($B$1:$B$10=$A$2)+($C$1:$C$10=$A$2)+($D$1:$D$10=$A$2)=4;1))>0

Lorsque cette formule est saisie dans une cellule, elle requiert une validation matricielle : Maj + Ctrl + enté,
mais non pour la formule de la mise en forme conditionnelle.


MichD
--------------------------------------------
MichD
Le #23505931
Et pour les amateurs de Sommeprod, on pourrait ajouter celle-ci qui est un tantinet
plus courte...
=SOMMEPROD(($A$1:$A$10=$A$2)*($B$1:$B$10=$A$2)*($C$1:$C$10=$A$2)*($D$1:$D$10=$A$2))>0


MichD
--------------------------------------------
Jacky
Le #23506271
Bonjour Denis

Désolé...mais
Avec aucune de tes propositions je n'obtiens le même résultat qu'avec la mienne.

--
Salutations
JJ


"MichD"
Et pour les amateurs de Sommeprod, on pourrait ajouter celle-ci qui est un tantinet
plus courte...
=SOMMEPROD(($A$1:$A$10=$A$2)*($B$1:$B$10=$A$2)*($C$1:$C$10=$A$2)*($D$1:$D$10=$A$2))>0


MichD
--------------------------------------------

Jacquouille
Le #23506511
..... et aussi moins de risque car un seul doigt suffit pour valider -))

Jacquouille

" Le vin est au repas ce que le parfum est à la femme."
"MichD" a écrit dans le message de groupe de discussion :
iu9t0r$bu9$

Et pour les amateurs de Sommeprod, on pourrait ajouter celle-ci qui est un
tantinet
plus courte...
=SOMMEPROD(($A$1:$A$10=$A$2)*($B$1:$B$10=$A$2)*($C$1:$C$10=$A$2)*($D$1:$D$10=$A$2))>0


MichD
--------------------------------------------
MichD
Le #23506731
| je n'obtiens le même résultat qu'avec la mienne

Cela confirme que le réveil du lundi matin fut difficile ! ;-))
Effectivement, j'avais mal lu la question!

Je t'en propose une autre, j'espère que tu seras plus indulgent. ;-)
=SOMME(SI(NB.SI(DECALER(A1;0;LIGNE(INDIRECT("1:4"))-1;NBVAL(A:A);1);100)>0;1))=4
Avec validation matricielle dans une cellule, mais non dans une mise en forme conditionnelle.

Avoue que c'est un bon effort...
;-))

Et pour Jacquouille, une forme dans une mise en forme conditionnelle ne requiert pas
une validation matricielle.


MichD
--------------------------------------------
Jacky
Le #23506891
... j'espère que tu seras plus indulgent. ;-)


Ben.....non !
Avoue que c'est un bon effort...


L'effort est bien là, mais pas le résultat ;o)
Allez encore un petit effort (café) ;o)
A moi que....
http://www.cijoint.fr/cjlink.php?file=cj201106/cijPu6lI7y.xls
Mais il y a aussi plusieurs interprétations possible à la question.


--
Salutations
JJ


"MichD"
| je n'obtiens le même résultat qu'avec la mienne

Cela confirme que le réveil du lundi matin fut difficile ! ;-))
Effectivement, j'avais mal lu la question!

Je t'en propose une autre, j'espère que tu seras plus indulgent. ;-)
=SOMME(SI(NB.SI(DECALER(A1;0;LIGNE(INDIRECT("1:4"))-1;NBVAL(A:A);1);100)>0;1))=4
Avec validation matricielle dans une cellule, mais non dans une mise en forme conditionnelle.

Avoue que c'est un bon effort...
;-))

Et pour Jacquouille, une forme dans une mise en forme conditionnelle ne requiert pas
une validation matricielle.


MichD
--------------------------------------------

Publicité
Poster une réponse
Anonyme