Finder qui freeze toutes les 24H

Le
jpnepl.schuck
Bonjour

Depuis quelque temps (à vrai dire, j'ai l'impression que ça date de la
mise à jour en 10.4.9), j'ai remarqué que mon Mac MMini PPC se bloquait
très fréquemment alors qu'auparavant il pouvait tourner des jours et des
jours sans problème.

Après 2 semaines d'observation, voici ce que j'ai pu constater : le
Finder se bloque (roue colorée, horloge gelée), mais toutes les
autres applications semblent fonctionner correctement (par exemple,
ffmpegX termine les encodages en cours). Ce blocage semble survenir à
peu près 24H exactement après chaque démarrage de la machine (démarrage,
pas ouverture de session).

J'ai essayé un certain nombre de remèdes courants :
- vérification des autorisations
- vérification du disque
- un gros coup de maintenance avec Onyx (nettoyage des caches, lancement
de tous les scripts)
- une réinstallation complète de la mise à jour à l'aide de la combo
10.4.9

-> Ca n'a rien changé.

J'ai aussi jeté un oeil dans la Console, mais les logs sont
désespérément (bizarrement ?) vides dans les moments précédant le
blocage.

Est-ce que quelqu'un à déjà constaté un problème similaire et
connaitraît une solution ?


--
Jean-Philippe Schuck
BloodBowl à Strasbourg :
http://jpschuck.free.fr/blood/
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 4
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
blanc
Le #2202881
Jean-Philippe Schuck
Après 2 semaines d'observation, voici ce que j'ai pu constater : le
Finder se bloque (roue colorée, horloge gelée...), mais toutes les
autres applications semblent fonctionner correctement (par exemple,
ffmpegX termine les encodages en cours).


Que donne le moniteur d'activité, aussi bien dans sa fenêtre principale
pour le processus "Finder" ou un autre, que dans sa fenêtre flottante
d'activité CPU (pomme-option 4 ou 5) ?

As-tu attendu suffisamment longtemps qu'il se débloque de lui-même
(combien de temps en fait) ou bien l'as-tu forcé à relancer au bout
d'une ou deux minutes, ce qui est le seuil d'impatience de beaucoup
d'utilisateurs ?

Ce blocage semble survenir à
peu près 24H exactement après chaque démarrage de la machine (démarrage,
pas ouverture de session).


Bizarre en effet. Un processus qui se lance à heure régulière à l'insu
de ton plein gré ?

J'ai essayé un certain nombre de remèdes courants :
- vérification des autorisations


Aucune raison que ça intervienne dans ce cas (amha).

- vérification du disque


idem

- un gros coup de maintenance avec Onyx (nettoyage des caches, lancement
de tous les scripts)


Onyx ? bah...

JPaul.

--
/==/==\- Jean-Paul BLANC
/ /--/--//\ quelque-part (somewhere)
|/| L |\ en (in)
/|| = |||\ FRANCE

jpnepl.schuck
Le #2202821
Le Moustique
Est-ce que quelqu'un à déjà constaté un problème similaire et
connaitraît une solution ?


Pas sur un Mac, mais sur un modem-routeur : la résolution de noms DNS
qui partait en vrille.
Vérifie ton paramétrage réseau, c'est p'têt là la cause...


Je vérifie quoi exactement ?
Je suis connecté via Airport à une FreeboxHD en mode routeur, j'utilise
le DHCP avec une adresse manuelle et je n'ai rien de configuré pour les
serveurs DNS (jamais rien rentré dans cette case).

--
Jean-Philippe Schuck
BloodBowl à Strasbourg :
http://jpschuck.free.fr/blood/


jpnepl.schuck
Le #2202841
JPaul

Que donne le moniteur d'activité, aussi bien dans sa fenêtre principale
pour le processus "Finder" ou un autre, que dans sa fenêtre flottante
d'activité CPU (pomme-option 4 ou 5) ?


J'ai oublié de préciser qu'une fois l'ordinateur figé, il était
impossible de lancer de nouvelles applications : l'icône bondit quelques
fois dans le dock puis... rien.
Je vais essayer de le lancer demain avant le prochain plantage (vers
23h20).


As-tu attendu suffisamment longtemps qu'il se débloque de lui-même
(combien de temps en fait) ou bien l'as-tu forcé à relancer au bout
d'une ou deux minutes, ce qui est le seuil d'impatience de beaucoup
d'utilisateurs ?


Longtemps, oui. Il est déjà arrivé qu'il se bloque la nuit : je
découvrais vers 9H une horloge figée à 3 H du matin. J'ai également
patienté une fois une bonne demi-heure en direct, histoire de voir si ça
allait repartir -> rien.


Bizarre en effet. Un processus qui se lance à heure régulière à l'insu
de ton plein gré ?


Oui mais lequel ? Il y a un des logs où je peux voir ça ?


Aucune raison que ça intervienne dans ce cas (amha).


Au début, avant d'avoir détecté la régularité de la chose, je me suis
dit que le Finder essayait peut-être d'accéder à quelque chose dont lil
n'aurait plus eu les droits en lecture/exécution.


Onyx ? bah...


A vrai dire, je pense la même chose, mais comme je n''avais pas d'autre
idée, je l'ai téléchargé pour voir...


--
Jean-Philippe Schuck
BloodBowl à Strasbourg :
http://jpschuck.free.fr/blood/

Nina Popravka
Le #2202801
On Fri, 13 Apr 2007 00:01:09 +0200, Le Moustique

Pas sur un Mac, mais sur un modem-routeur : la résolution de noms DNS
qui partait en vrille.


Pas de relation, IMHO; Quand ça arrive sur des routeurs soho, c'est le
cache du dns proxy qui est dedans qui part en vrille. Relativement
classique sur d'anciens modèles.
--
Nina

blanc
Le #2214661
Jean-Philippe Schuck
J'ai oublié de préciser qu'une fois l'ordinateur figé, il était
impossible de lancer de nouvelles applications : l'icône bondit quelques
fois dans le dock puis... rien.


Alors c'est peut-être le Dock qui plante. Tu n'aurais pas installé un
Dashboard exotique ?

Je vais essayer de le lancer demain avant le prochain plantage (vers
23h20).


Une autre solution (c'est perso ce que je fais) :

le laisser ouvert (le Moniteur d'Activité) en permanence avec juste sa
fenêtre flottante CPU (pomme-option-4). Pas vraiment pénalisant. Et
tellement pratique :-)
Et si besoin tu cliques dessus et tu ouvres sa fenêtre principale
(pomme-option-1) pour voir qui est le processus gourmand qui prends tout
le CPU ou qui se bloque.
(N'oublie pas de choisir "Toutes les opérations")

Ensuite tu refermes la dite fenêtre principale sans quitter l'appli.


Bizarre en effet. Un processus qui se lance à heure régulière à l'insu
de ton plein gré ?


Oui mais lequel ? Il y a un des logs où je peux voir ça ?


Le MA suffit normalement (voir ci-dessus).


JPaul.
--
/==/==\- Jean-Paul BLANC
/ /--/--//\ quelque-part (somewhere)
|/| L |\ en (in)
/|| = |||\ FRANCE


daniel patin
Le #2214541
Jean-Philippe Schuck wrote:
Le Moustique
Est-ce que quelqu'un à déjà constaté un problème similaire et
connaitraît une solution ?
Pas sur un Mac, mais sur un modem-routeur : la résolution de noms DNS

qui partait en vrille.
Vérifie ton paramétrage réseau, c'est p'têt là la cause...


Je vérifie quoi exactement ?
Je suis connecté via Airport à une FreeboxHD en mode routeur, j'utilise
le DHCP avec une adresse manuelle et je n'ai rien de configuré pour les
serveurs DNS (jamais rien rentré dans cette case).

tu as donc une ip fixe? (la freebox, pas le mac)


est ce que ça ne serait pas le nettoyage du systeme qui plante. jeter
les prefs du finder?

--
daniel.patin (et non pas marcel.dugenou)
http://leinad-fr.net le blog
http://www.daniel-patin.net sur mon mac
http://daniel.patin.adsl.free.fr/ quelques photos



junk
Le #2214521
Jean-Philippe Schuck
Est-ce que quelqu'un à déjà constaté un problème similaire


Est-ce que tu as des volumes Samba qui sont montés et qui ne répondent
plus ?

--
Nicolas Seriot

jpnepl.schuck
Le #2214491
Nicolas Seriot

Est-ce que tu as des volumes Samba qui sont montés et qui ne répondent
plus ?


Non, pas de volumes distants montés.

--
Jean-Philippe Schuck
BloodBowl à Strasbourg :
http://jpschuck.free.fr/blood/

jpnepl.schuck
Le #2214471
daniel patin
tu as donc une ip fixe? (la freebox, pas le mac)


Oui IP fixe pour la freebox.


est ce que ça ne serait pas le nettoyage du systeme qui plante. jeter
les prefs du finder?


Je vais essayer ça.

--
Jean-Philippe Schuck
BloodBowl à Strasbourg :
http://jpschuck.free.fr/blood/

jpnepl.schuck
Le #2214481
Pierre Guyot

symptomes:

- PowerMac G4 256 Mo et plusieurs disques utilisé en poste de travail et
en seveur(=> jamais en veille), mis à jour 10.4.9
la machine fige de temps en temps (pas de relation apparente avec la
date de reboot)
rien de suspect dans les logs...

Dernière observation:
écran figé, horloge marquant le jour et l'heure d'environ 24 heures plus
tôt, secondes figées, ballon de plage tournant
Depuis la date figée de l'horloge, la machine avait son écran éteint
mais les fonctions serveur étaient normales (smtp, pop, http/https,
named, ssh, partage disques...), et quelques enregistrement programmés
par MPlayer ont bien fonctionné, ce qui suppose le lancement
d'application sur l'interface graphique locale.
.


Oui c'est à peu près ça. En apparence tout à l'air bloqué, mais la
plupart des éléments continuent de tourner.
Une idée ?


--
Jean-Philippe Schuck
BloodBowl à Strasbourg :
http://jpschuck.free.fr/blood/

Publicité
Poster une réponse
Anonyme