Récapitulatif de plusieurs feuilles

Le
Eric C
Bonjour à tous,

Je cale devant un problème simple.
J'ai un fichier qui a 4 onglets : 1) recap, 2) role auteur avec la liste
des personnes qui ont ce role, 3)role reviewer avec la liste des
personnes qui ont ce role,4) role reviewer avec la liste des personnes
qui ont ce role.
Sur la feuille 1) recap, je voudrais avoir la liste de toutes les
personnes (une ligne par personne, là est mon problème) avec chaque role
détenu sur lamême ligne.

Voir fichier exemple

http://cjoint.com/?0JArahQHmT0

Merci de vos propositions

Eric
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacky
Le #23906901
Bonsoir,

Avec quelques plages nommées
en B2

=SI(ESTNUM(EQUIV($A2;'role auteur'!A:A;0));INDEX(auteur;EQUIV($A2;'role auteur'!A:A;0));"")
Le fichier modifié ici
http://www.cijoint.fr/cjlink.php?file=cj201110/cijX49Yz2G.xls
--
Salutations
JJ


"Eric C"
Bonjour à tous,

Je cale devant un problème simple.
J'ai un fichier qui a 4 onglets : 1) recap, 2) role auteur avec la liste des personnes qui ont ce role,
3)role reviewer avec la liste des personnes qui ont ce role,4) role reviewer avec la liste des personnes qui
ont ce role.
Sur la feuille 1) recap, je voudrais avoir la liste de toutes les personnes (une ligne par personne, là est
mon problème) avec chaque role détenu sur lamême ligne.

Voir fichier exemple

http://cjoint.com/?0JArahQHmT0

Merci de vos propositions

Eric
LSteph
Le #23906891
Bonjour,

Si tes titres se présentent toujours ainsi selon le nom de feuille

Sélectionne b2:D13, entre ceci:

=SI(NB.SI(INDIRECT("'"&B$1&"'!$A$1:$A$100");A2)>0;STXT(B$1;6;999);"")



Cordialement.

--
LSteph

On Oct 26, 5:06 pm, Eric C
Bonjour à tous,

Je cale devant un problème simple.
J'ai un fichier qui a 4 onglets : 1) recap, 2) role auteur avec la liste
des personnes qui ont ce role, 3)role reviewer avec la liste des
personnes qui ont ce role,4) role reviewer avec la liste des personnes
qui ont ce role.
Sur la feuille 1) recap, je voudrais avoir la liste de toutes les
personnes (une ligne par personne, là est mon problème) avec chaque r ole
détenu sur lamême ligne.

Voir fichier exemple

http://cjoint.com/?0JArahQHmT0

Merci de vos propositions

Eric
LSteph
Le #23906951
..oupsss petite rectif

=SI(NB.SI(INDIRECT("'"&B$1&"'!$A$1:$A$100");$A2)>0;STXT(B$1;6;999);"")

On Oct 26, 6:46 pm, LSteph
Bonjour,

Si  tes titres se présentent  toujours ainsi selon le nom de feuill e

Sélectionne b2:D13, entre ceci:

=SI(NB.SI(INDIRECT("'"&B$1&"'!$A$1:$A$100");A2)>0;STXT(B$1;6;999);"")

Cordialement.

--
LSteph

On Oct 26, 5:06 pm, Eric C






> Bonjour à tous,

> Je cale devant un problème simple.
> J'ai un fichier qui a 4 onglets : 1) recap, 2) role auteur avec la list e
> des personnes qui ont ce role, 3)role reviewer avec la liste des
> personnes qui ont ce role,4) role reviewer avec la liste des personnes
> qui ont ce role.
> Sur la feuille 1) recap, je voudrais avoir la liste de toutes les
> personnes (une ligne par personne, là est mon problème) avec chaque role
> détenu sur lamême ligne.

> Voir fichier exemple

>http://cjoint.com/?0JArahQHmT0

> Merci de vos propositions

> Eric
MichD
Le #23907181
Bonjour,

Ton fichier avec la macro à l'intérieur : http://cjoint.com/?AJAtQyVg8We



MichD
------------------------------------------
"Eric C" a écrit dans le message de groupe de discussion : 4ea821f1$0$5047$

Bonjour à tous,

Je cale devant un problème simple.
J'ai un fichier qui a 4 onglets : 1) recap, 2) role auteur avec la liste
des personnes qui ont ce role, 3)role reviewer avec la liste des
personnes qui ont ce role,4) role reviewer avec la liste des personnes
qui ont ce role.
Sur la feuille 1) recap, je voudrais avoir la liste de toutes les
personnes (une ligne par personne, là est mon problème) avec chaque role
détenu sur lamême ligne.

Voir fichier exemple

http://cjoint.com/?0JArahQHmT0

Merci de vos propositions

Eric
MichD
Le #23907171
OUPS, dans la macro, tu dois modifier ceci :
dans le code suivant, il est écrit : .Sort Key1:=1 <<<===
Cela devrait plutôt être comme ceci :

With .Range("A2:A" & DerLig)
.Sort Key1:=.Item(1, 1), Order1:=xlAscending, Header:=xlNo
End With



MichD
------------------------------------------
"MichD" a écrit dans le message de groupe de discussion : j89grb$9td$

Bonjour,

Ton fichier avec la macro à l'intérieur : http://cjoint.com/?AJAtQyVg8We



MichD
------------------------------------------
"Eric C" a écrit dans le message de groupe de discussion : 4ea821f1$0$5047$

Bonjour à tous,

Je cale devant un problème simple.
J'ai un fichier qui a 4 onglets : 1) recap, 2) role auteur avec la liste
des personnes qui ont ce role, 3)role reviewer avec la liste des
personnes qui ont ce role,4) role reviewer avec la liste des personnes
qui ont ce role.
Sur la feuille 1) recap, je voudrais avoir la liste de toutes les
personnes (une ligne par personne, là est mon problème) avec chaque role
détenu sur lamême ligne.

Voir fichier exemple

http://cjoint.com/?0JArahQHmT0

Merci de vos propositions

Eric
MichD
Le #23907271
Le fichier correctif : http://cjoint.com/?AJAubd7e6sz



MichD
------------------------------------------
Eric C
Le #23907761
Merci, je vais tester !
Eric

Le 26/10/2011 18:45, Jacky a écrit :
Bonsoir,

Avec quelques plages nommées
en B2

=SI(ESTNUM(EQUIV($A2;'role auteur'!A:A;0));INDEX(auteur;EQUIV($A2;'role auteur'!A:A;0));"")
Le fichier modifié ici
http://www.cijoint.fr/cjlink.php?file=cj201110/cijX49Yz2G.xls
Eric C
Le #23907751
Merci, je vais tester !
Eric

Le 26/10/2011 18:49, LSteph a écrit :
..oupsss petite rectif

=SI(NB.SI(INDIRECT("'"&B$1&"'!$A$1:$A$100");$A2)>0;STXT(B$1;6;999);"")

On Oct 26, 6:46 pm, LSteph
Bonjour,

Si tes titres se présentent toujours ainsi selon le nom de feuille

Sélectionne b2:D13, entre ceci:

=SI(NB.SI(INDIRECT("'"&B$1&"'!$A$1:$A$100");A2)>0;STXT(B$1;6;999);"")

Cordialement.

--
LSteph

On Oct 26, 5:06 pm, Eric C






Bonjour à tous,



Je cale devant un problème simple.
J'ai un fichier qui a 4 onglets : 1) recap, 2) role auteur avec la liste
des personnes qui ont ce role, 3)role reviewer avec la liste des
personnes qui ont ce role,4) role reviewer avec la liste des personnes
qui ont ce role.
Sur la feuille 1) recap, je voudrais avoir la liste de toutes les
personnes (une ligne par personne, là est mon problème) avec chaque role
détenu sur lamême ligne.



Voir fichier exemple



http://cjoint.com/?0JArahQHmT0



Merci de vos propositions



Eric





Eric C
Le #23907741
Merci MichD,

Je ne comprends pas à quoi sert la ligne en fin de code
.Range("B2:D" & DerLig).Value = .Range("B2:D" & DerLig).Value

Si j'ajoute une feuille, j'édite le code pour
.Range("E2").Formula = .... (çà, ca marche)
dois-je aussi changer la ligne
.Range("B2:D" & DerLig).Value = .Range("B2:D" & DerLig).Value
en
.Range("B2:E" & DerLig).Value = .Range("B2:E" & DerLig).Value

(Je ne l'ai pas fait et je ne vois pas ce que ca change, j'aime bien
comprendre...)

Eric

Le 26/10/2011 20:01, MichD a écrit :
Le fichier correctif : http://cjoint.com/?AJAubd7e6sz



MichD
------------------------------------------

MichD
Le #23908041
| Je ne comprends pas à quoi sert la ligne en fin de code
| .Range("B2:D" & DerLig).Value = .Range("B2:D" & DerLig).Value

Cela transforme les formules de la plage en valeur en dur dans la plage de cellules.
Si tu préfères conserver les formules, c'est ton choix.

| dois-je aussi changer la ligne
| .Range("B2:D" & DerLig).Value = .Range("B2:D" & DerLig).Value
| en
| .Range("B2:E" & DerLig).Value = .Range("B2:E" & DerLig).Value

Maintenant que tu sais pourquoi la ligne existe, selon que tu veux conserver les
formules ou non, tu devras adapter la ligne ou la supprimer.



MichD
------------------------------------------
"Eric C" a écrit dans le message de groupe de discussion : 4ea8712a$0$5038$

Merci MichD,

Je ne comprends pas à quoi sert la ligne en fin de code
.Range("B2:D" & DerLig).Value = .Range("B2:D" & DerLig).Value

Si j'ajoute une feuille, j'édite le code pour
.Range("E2").Formula = .... (çà, ca marche)
dois-je aussi changer la ligne
.Range("B2:D" & DerLig).Value = .Range("B2:D" & DerLig).Value
en
.Range("B2:E" & DerLig).Value = .Range("B2:E" & DerLig).Value

(Je ne l'ai pas fait et je ne vois pas ce que ca change, j'aime bien
comprendre...)

Eric

Le 26/10/2011 20:01, MichD a écrit :
Le fichier correctif : http://cjoint.com/?AJAubd7e6sz



MichD
------------------------------------------

Publicité
Poster une réponse
Anonyme