Reconfigurer un clavier anglais en français en environnement graphique.

Le
kaliderus
Bonjour,
Situation : Lenny fraichement installée, AMD_64.
En console : Clavier et environnement français, tout va bien.
En mode graphique, que ce soit blackbox ou kde ou autre j'ai un
clavier anglais pour toutes les applications.
Sous kde le contournement a été de rajouter le clavier français avec
les outils d'administration mais sous les autres environnement
graphique la situation ne me convient pas, et ce n'est pas propre au
final comme solution.
Ou est ce que je dois chercher pour avoir un clavier français quelque
soit l'environnement ?
J'ai reconfiguré xorg, la console, et la locale me semble correctement
configurée, là je sèche
Merci d'avance pour vos tuyaux.


Rester libre ou disparaître
www.debian.org

Mon blog est par ici
kaliderus.blogspot.com


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Adrien Bellanger
Le #19921501
Bonjour,

J'ai pas le temps de chercher mais il me semble déjà avoir eu un truc
similaire et la solution était à chercher du côté de hal.
Courage...

Le jeudi 13 août 2009 à 10:32 +0200, kaliderus a écrit :
Bonjour,
Situation : Lenny fraichement installée, AMD_64.
En console : Clavier et environnement français, tout va bien.
En mode graphique, que ce soit blackbox ou kde ou autre ... j'ai un
clavier anglais pour toutes les applications.
Sous kde le contournement a été de rajouter le clavier français avec
les outils d'administration mais sous les autres environnement
graphique la situation ne me convient pas, et ce n'est pas propre au
final comme solution.
Ou est ce que je dois chercher pour avoir un clavier français quelque
soit l'environnement ?
J'ai reconfiguré xorg, la console, et la locale me semble correctement
configurée, là je sèche ...
Merci d'avance pour vos tuyaux.

---------------------------------------------------
Rester libre ou disparaître
www.debian.org
---------------------------------------------------
Mon blog est par ici
kaliderus.blogspot.com
---------------------------------------------------




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Julien Valroff
Le #19921491
Le jeudi 13 août 2009 à 10:32 +0200, kaliderus a écrit :
Bonjour,
Situation : Lenny fraichement installée, AMD_64.
En console : Clavier et environnement français, tout va bien.
En mode graphique, que ce soit blackbox ou kde ou autre ... j'ai un
clavier anglais pour toutes les applications.
Sous kde le contournement a été de rajouter le clavier français avec
les outils d'administration mais sous les autres environnement
graphique la situation ne me convient pas, et ce n'est pas propre au
final comme solution.
Ou est ce que je dois chercher pour avoir un clavier français quelque
soit l'environnement ?
J'ai reconfiguré xorg,



Es-tu certain ?
Les choses ont bien changé récemment, avec l'arrivée de
l'autoconfiguration de Xorg avec hal (je n'ai même plus de xorg.conf sur
mes systèmes)

Essaye dpkg-reconfigure console-setup, ou édite
directement /etc/default/console-setup pour y ajouter :
XKBLAYOUT="fr"
XKBVARIANT=""

Julien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Grégory Bulot
Le #19921481
kaliderus +0200
Bonjour,
Situation : Lenny fraichement installée, AMD_64.
En console : Clavier et environnement français, tout va bien.
En mode graphique, que ce soit blackbox ou kde ou autre ... j'ai un
clavier anglais pour toutes les applications.



la solution que j'ai utilisé (qui n'est certainement pas la meilleure)

dans /etc/X11/xorg.conf :
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Pierre Meurisse
Le #19921691
Bonjour,

On Thu, Aug 13, 2009 at 10:42:55AM +0200, Adrien Bellanger wrote:

Bonjour,

J'ai pas le temps de chercher mais il me semble déjà avoir eu un truc
similaire et la solution était à chercher du côté de hal.
Courage...



...

C'est bien ça.
Je viens de pas mal chercher, pour finalement trouver une solution.

- installer les paquets xserver-xorg-input-synaptics (pour touchpad),
xserver-xorg-input-evdev, hal, hal-info

- dans /etc/hal/fdi/policy, copier 3 fichiers :

10-keymap.fdi :

<device>
</match>


<!-- If we're using Linux, we use evdev by default (falling back to
keyboard otherwise). -->
<match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
string="Linux">
merge key="input.xkb.model" type="string">evdev</merge>
</match>

</match>
</device>
</deviceinfo>


10-x11-input.fdi :

<device>
</match>
</match>
</device>
</deviceinfo>


11-x11-synaptics.fdi

<device>
<!-- Arbitrary options can be passed to the driver using
the input.x11_options property since xorg-server-1.5. -->
<!-- EXAMPLES:
Switch on shared memory, enables the driver to be configured at runtime

Maximum movement of the finger for detecting a tap

Enable vertical scrolling when dragging along the right edge

Enable vertical scrolling when dragging with two fingers anywhere on the touchpad

Enable horizontal scrolling when dragging with two fingers anywhere on the touchpad

If on, circular scrolling is used

For other possible options, check CONFIGURATION DETAILS in synaptics man page
-->
</match>
</device>
</deviceinfo>


- supprimer /etc/X11/xorg.conf, ou le renommer
- relancer hal
- on peut vérifier avec:
$ hal-device|grep input.x11
$ hal-device|grep xkb

- déconnecter et relancer se serveur graphique.


J'ai utilisé notamment :
http://bgoglin.livejournal.com/16734.html
http://who-t.blogspot.com/2008/07/input-configuration-in-nutshell.html

Hope this helps

--
Pierre Meurisse

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Julien Valroff
Le #19921881
Le jeudi 13 août 2009 à 11:03 +0200, Pierre Meurisse a écrit :
Bonjour,

On Thu, Aug 13, 2009 at 10:42:55AM +0200, Adrien Bellanger wrote:
>
> Bonjour,
>
> J'ai pas le temps de chercher mais il me semble déjà avoir eu un truc
> similaire et la solution était à chercher du côté de hal.
> Courage...

....

C'est bien ça.
Je viens de pas mal chercher, pour finalement trouver une solution.



[...]

J'ai utilisé notamment :
http://bgoglin.livejournal.com/16734.html
http://who-t.blogspot.com/2008/07/input-configuration-in-nutshell.html




Voir directement à la source, il y a bien plus simple :
http://wiki.debian.org/XStrikeForce/InputHotplugGuide

Julien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Guy Roussin
Le #19922091
Bonjour,
Es-tu certain ?
Les choses ont bien changé récemment, avec l'arrivée de
l'autoconfiguration de Xorg avec hal (je n'ai même plus de xorg.co nf sur
mes systèmes)

Essaye dpkg-reconfigure console-setup, ou édite
directement /etc/default/console-setup pour y ajouter :
XKBLAYOUT="fr"
XKBVARIANT=""




Pour moi ça suffit pas :
/etc/default/console-setup est correct :
XKBLAYOUT="fr"


et pourtant lorsque je fais
lshal | grep xkb
j'ai :
input.xkb.layout='us'

NB: J'ai bien redémarré /etc/init.d/console-setup et /etc/init. d/hal
Pour moi y a un truc pas clair avec la 5.0.2 ...

Certes, la solution de corriger /etc/X11/xorg.conf fonctionne
mais elle ne me parait pas satisfaisante.

Guy


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Julien Valroff
Le #19922131
Le jeudi 13 août 2009 à 12:12 +0200, Guy Roussin a écrit :
Bonjour,
> Es-tu certain ?
> Les choses ont bien changé récemment, avec l'arrivée de
> l'autoconfiguration de Xorg avec hal (je n'ai même plus de xorg.conf sur
> mes systèmes)
>
> Essaye dpkg-reconfigure console-setup, ou édite
> directement /etc/default/console-setup pour y ajouter :
> XKBLAYOUT="fr"
> XKBVARIANT=""
>
>
Pour moi ça suffit pas :
/etc/default/console-setup est correct :
XKBLAYOUT="fr"


et pourtant lorsque je fais
lshal | grep xkb
j'ai :
input.xkb.layout='us'

NB: J'ai bien redémarré /etc/init.d/console-setup et /etc/init.d/hal
Pour moi y a un truc pas clair avec la 5.0.2 ...



Tu es en stable ?
Dans ce cas, ce n'est pas hal qui gère tout ça, cela reste valable pour
sid (et testing maintenant je présume)


Certes, la solution de corriger /etc/X11/xorg.conf fonctionne
mais elle ne me parait pas satisfaisante.



Si, c'est bel et bien la bonne solution (à moins que tu utilises des
backports ?)

Julien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Guy Roussin
Le #19922201
>> Certes, la solution de corriger /etc/X11/xorg.conf fonctionne
mais elle ne me parait pas satisfaisante.




Si, c'est bel et bien la bonne solution (à moins que tu utilises d es
backports ?)



Donc, pour répondre correctement à 'kaliderus' (et à moi a ussi) faut lire
la réponse de Grégory et créer à la main un /etc/X11/ xorg

ça me parait donc une régression majeure introduite par la 5.0. 2 de
debian et qui
nécessite d'urgence une mise à jour 5.0.3. Les versions pré cédentes
(5.0.0 et 5.0.1)
créaient bien un /etc/X11/xorg avec les bon paramètres linguist iques.

Guy

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Pierre Meurisse
Le #19922191
On Thu, Aug 13, 2009 at 12:30:54PM +0200, Julien Valroff wrote:
...
Tu es en stable ?
Dans ce cas, ce n'est pas hal qui gère tout ça, cela reste valable pour
sid (et testing maintenant je présume)


> Certes, la solution de corriger /etc/X11/xorg.conf fonctionne
> mais elle ne me parait pas satisfaisante.

Si, c'est bel et bien la bonne solution (à moins que tu utilises des
backports ?)



Mon fils vient d'installer une stable sans backports. Il a utilisé la
méthode que j'ai décrite plus haut. Cela fonctionne en ce qui concerne
le clavier. Il n'a pas de touchpad.

--
Pierre Meurisse

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Julien Valroff
Le #19922411
Le jeudi 13 août 2009 à 12:48 +0200, Pierre Meurisse a écrit :
On Thu, Aug 13, 2009 at 12:30:54PM +0200, Julien Valroff wrote:
....
> Tu es en stable ?
> Dans ce cas, ce n'est pas hal qui gère tout ça, cela reste valable pour
> sid (et testing maintenant je présume)
>
>
> > Certes, la solution de corriger /etc/X11/xorg.conf fonctionne
> > mais elle ne me parait pas satisfaisante.
>
> Si, c'est bel et bien la bonne solution (à moins que tu utilises des
> backports ?)

Mon fils vient d'installer une stable sans backports. Il a utilisé la
méthode que j'ai décrite plus haut. Cela fonctionne en ce qui concerne
le clavier. Il n'a pas de touchpad.



Tiens, étrange, peut-être que le hotplug-input était déjà possible, mais
pas utilisé par défaut ?

Dans tous les cas, je pense que la méthode xorg.conf reste la plus
simple pour stable et console-setup (+ reste de la méthode via hal) pour
testing+sid.

Après, chacun fait ce qu'il lui plait ;)

Julien

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists Vous pouvez aussi ajouter le mot
``spam'' dans vos champs "From" et "Reply-To:"

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Publicité
Poster une réponse
Anonyme