Référence à plusieurs onglet

Le
Tschuß
Bonjour à tout le forum,

Un problème qui me parait simple me bloque depuis qques heures.
Chaque pays à le détail de ses données dans un onglet par pays. Je
dois faire un tableau de synthèse pour tous ces pays dans une seule
feuille (nommée DE, AT, SU, )
Bref, on va dire qu'un colonne A, j'ai le nom des pays DE, AT, SU, ES,
UK, .
En colonne B, je fais une formule =SOMME.SI([Extraction_Pays.xls]
DE!
Vu que le libellé en colonne A est identique au nom de mes onglets, je
me dis qu'il doit y avoir moyen de récupérer ce libellé pour l'inclur=
e
dans ma formule pour éviter de revoir changer manuellement le pays.

J'ai été voir la fonction INDIRECT mais j'ai pas réussit à m'en ser=
vir
pour faire ce que je voulais.

Une idée ???

Merci à tous
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
JB
Le #18915961
Bonjour,

Post un fichier exemple.

JB
http://boisgontierjacques.free.fr

On 16 mar, 17:57, Tschuß
Bonjour à tout le forum,

Un problème qui me parait simple me bloque depuis qques heures.
Chaque pays à le détail de ses données dans un onglet par pays. Je
dois faire un tableau de synthèse pour tous ces pays dans une seule
feuille (nommée DE, AT, SU, ...)
Bref, on va dire qu'un colonne A, j'ai le nom des pays DE, AT, SU, ES,
UK, ....
En colonne B, je fais une formule =SOMME.SI([Extraction_Pays.xls]
DE!..................
Vu que le libellé en colonne A est identique au nom de mes onglets, je
me dis qu'il doit y avoir moyen de récupérer ce libellé pour l'incl ure
dans ma formule pour éviter de revoir changer manuellement le pays.

J'ai été voir la fonction INDIRECT mais j'ai pas réussit à m'en s ervir
pour faire ce que je voulais.

Une idée ???

Merci à tous


MichDenis
Le #18915941
IMPORTANT : avec la fonction Indirect(), le fichier doit être ouvert
En A1 le nom du Classeur : Denis.xls
Sur A2 le nom de l'onglet : Diane
=INDIRECT("'["&A1&".xls]"&A2&"'!RefCase")

Pour un classeur fermé, il faut installer "MoreFunc" disponible
sur le site de Laurent Longre. http://xcell05.free.fr/
Une exemple de syntaxe après l'installation :

Voici un exemple de syntaxe :
A1 = Classeur1.xls
A2 = Feuil1

Cette formule renvoie le nombre fois que "toto" est inscrit en A1:A10
où l'on retrouve dans la colonne "B1:B10" la valeur "x".
(ce n'est qu'une formule sur une même ligne)
=SOMMEPROD(((INDIRECT.EXT("'C:["&A1&"]"&A2&"'!A1:A10")="toto")*((INDIRECT.EXT("'C:["&A1&"]"&A2&"'!B1:B10")="x"))))

=SOMMEPROD((INDIRECT.EXT("'C:["&A1&"]Feuil1'!A1:A10")="toto")*1)



"Tschuß"
Bonjour à tout le forum,

Un problème qui me parait simple me bloque depuis qques heures.
Chaque pays à le détail de ses données dans un onglet par pays. Je
dois faire un tableau de synthèse pour tous ces pays dans une seule
feuille (nommée DE, AT, SU, ...)
Bref, on va dire qu'un colonne A, j'ai le nom des pays DE, AT, SU, ES,
UK, ....
En colonne B, je fais une formule =SOMME.SI([Extraction_Pays.xls]
DE!..................
Vu que le libellé en colonne A est identique au nom de mes onglets, je
me dis qu'il doit y avoir moyen de récupérer ce libellé pour l'inclure
dans ma formule pour éviter de revoir changer manuellement le pays.

J'ai été voir la fonction INDIRECT mais j'ai pas réussit à m'en servir
pour faire ce que je voulais.

Une idée ???

Merci à tous
isabelle
Le #18915931
bonjour,

le fichier Extraction_Pays.xls doit être ouvert si tu veut utiliser la
fonction INDIRECT,

est ce le cas ?

isabelle


Tschuß a écrit :
Bonjour à tout le forum,

Un problème qui me parait simple me bloque depuis qques heures.
Chaque pays à le détail de ses données dans un onglet par pays. Je
dois faire un tableau de synthèse pour tous ces pays dans une seule
feuille (nommée DE, AT, SU, ...)
Bref, on va dire qu'un colonne A, j'ai le nom des pays DE, AT, SU, ES,
UK, ....
En colonne B, je fais une formule =SOMME.SI([Extraction_Pays.xls]
DE!..................
Vu que le libellé en colonne A est identique au nom de mes onglets, je
me dis qu'il doit y avoir moyen de récupérer ce libellé pour l'inclure
dans ma formule pour éviter de revoir changer manuellement le pays.

J'ai été voir la fonction INDIRECT mais j'ai pas réussit à m'en servir
pour faire ce que je voulais.

Une idée ???

Merci à tous



Tschuß
Le #18915901
On 16 mar, 18:28, isabelle wrote:
bonjour,

le fichier Extraction_Pays.xls doit être ouvert si tu veut utiliser la
fonction INDIRECT,

est ce le cas ?

isabelle

Tschuß a écrit :



> Bonjour à tout le forum,

> Un problème qui me parait simple me bloque depuis qques heures.
> Chaque pays à le détail de ses données dans un onglet par pays. J e
> dois faire un tableau de synthèse pour tous ces pays dans une seule
> feuille (nommée DE, AT, SU, ...)
> Bref, on va dire qu'un colonne A, j'ai le nom des pays DE, AT, SU, ES,
> UK, ....
> En colonne B, je fais une formule =SOMME.SI([Extraction_Pays.xls]
> DE!..................
> Vu que le libellé en colonne A est identique au nom de mes onglets, j e
> me dis qu'il doit y avoir moyen de récupérer ce libellé pour l'in clure
> dans ma formule pour éviter de revoir changer manuellement le pays.

> J'ai été voir la fonction INDIRECT mais j'ai pas réussit à m'en servir
> pour faire ce que je voulais.

> Une idée ???

> Merci à tous- Masquer le texte des messages précédents -

- Afficher le texte des messages précédents -



Ok, je vais vous envoyé un fichier exemple dans 1 petite heure
Et pour Isa, non le fichier n'est pas ouvert (mais même en l'ouvrant,
j'arrive pas à le faire)

A+
LSteph
Le #18916931
bonsoir,

tu vois que tu peux quand même donner des conseils...
faudra plus complexer à l'avenir.

--
lSteph


JB a écrit :
Bonjour,

Post un fichier exemple.

JB
http://boisgontierjacques.free.fr

On 16 mar, 17:57, Tschuß
Bonjour à tout le forum,

Un problème qui me parait simple me bloque depuis qques heures.
Chaque pays à le détail de ses données dans un onglet par pays. Je
dois faire un tableau de synthèse pour tous ces pays dans une seule
feuille (nommée DE, AT, SU, ...)
Bref, on va dire qu'un colonne A, j'ai le nom des pays DE, AT, SU, ES,
UK, ....
En colonne B, je fais une formule =SOMME.SI([Extraction_Pays.xls]
DE!..................
Vu que le libellé en colonne A est identique au nom de mes onglets, je
me dis qu'il doit y avoir moyen de récupérer ce libellé pour l'inclure
dans ma formule pour éviter de revoir changer manuellement le pays.

J'ai été voir la fonction INDIRECT mais j'ai pas réussit à m'en servir
pour faire ce que je voulais.

Une idée ???

Merci à tous





LSteph
Le #18917141
Bonsoir,

Un truc du genre devrait passer pour une somme simple

La feuille doit être à part des autres
supposons que la 1ère soit DE et la dernière UK
=Somme('DE:UK'!B2)
fera la somme B2 de toutes les feuilles situées entre DE et UK

par suite donne nous tes conditions pour un sommeprod (ou somme.si)

en même temps que l'exemple.

--
lSteph

Tschuß a écrit :
Bonjour à tout le forum,

Un problème qui me parait simple me bloque depuis qques heures.
Chaque pays à le détail de ses données dans un onglet par pays. Je
dois faire un tableau de synthèse pour tous ces pays dans une seule
feuille (nommée DE, AT, SU, ...)
Bref, on va dire qu'un colonne A, j'ai le nom des pays DE, AT, SU, ES,
UK, ....
En colonne B, je fais une formule =SOMME.SI([Extraction_Pays.xls]
DE!..................
Vu que le libellé en colonne A est identique au nom de mes onglets, je
me dis qu'il doit y avoir moyen de récupérer ce libellé pour l'inclure
dans ma formule pour éviter de revoir changer manuellement le pays.

J'ai été voir la fonction INDIRECT mais j'ai pas réussit à m'en servir
pour faire ce que je voulais.

Une idée ???

Merci à tous


Tschuß
Le #18917251
On 16 mar, 20:32, LSteph
Bonsoir,

Un truc du genre devrait passer pour une somme simple

La feuille doit être à part des autres
supposons que la 1ère soit DE et la dernière UK
=Somme('DE:UK'!B2)
fera la somme B2 de toutes les feuilles situées entre DE et UK

par suite donne nous tes conditions pour un sommeprod (ou somme.si)

en même temps que l'exemple.

--
lSteph

Tschuß a écrit :

> Bonjour à tout le forum,

> Un problème qui me parait simple me bloque depuis qques heures.
> Chaque pays à le détail de ses données dans un onglet par pays. J e
> dois faire un tableau de synthèse pour tous ces pays dans une seule
> feuille (nommée DE, AT, SU, ...)
> Bref, on va dire qu'un colonne A, j'ai le nom des pays DE, AT, SU, ES,
> UK, ....
> En colonne B, je fais une formule =SOMME.SI([Extraction_Pays.xls]
> DE!..................
> Vu que le libellé en colonne A est identique au nom de mes onglets, j e
> me dis qu'il doit y avoir moyen de récupérer ce libellé pour l'in clure
> dans ma formule pour éviter de revoir changer manuellement le pays.

> J'ai été voir la fonction INDIRECT mais j'ai pas réussit à m'en servir
> pour faire ce que je voulais.

> Une idée ???

> Merci à tous



Merci à tous déjà pour ces réponses (pas eu le temps de tester je
l'avoue)
Je vous laisse un exemple à l'adresse suivante pour comprendre ce que
je souhaite faire
Dans la feuille Synthèse, mon objectif c'est de remplacer AT!
par ....; c'est bien ça mon pb pour ne pas avoir à changer à chaque
fois le nom de la feuille
http://www.megaupload.com/?d=SBDTZBR4
LSteph
Le #18917531
=SOMMEPROD((INDIRECT($A2&"!$B$1:$B$6")*(INDIRECT($A2&"!$a$1:$a$6")=B$1)))

--
lSteph



Tschuß a écrit :
On 16 mar, 20:32, LSteph
Bonsoir,

Un truc du genre devrait passer pour une somme simple

La feuille doit être à part des autres
supposons que la 1ère soit DE et la dernière UK
=Somme('DE:UK'!B2)
fera la somme B2 de toutes les feuilles situées entre DE et UK

par suite donne nous tes conditions pour un sommeprod (ou somme.si)

en même temps que l'exemple.

--
lSteph

Tschuß a écrit :

Bonjour à tout le forum,
Un problème qui me parait simple me bloque depuis qques heures.
Chaque pays à le détail de ses données dans un onglet par pays. Je
dois faire un tableau de synthèse pour tous ces pays dans une seule
feuille (nommée DE, AT, SU, ...)
Bref, on va dire qu'un colonne A, j'ai le nom des pays DE, AT, SU, ES,
UK, ....
En colonne B, je fais une formule =SOMME.SI([Extraction_Pays.xls]
DE!..................
Vu que le libellé en colonne A est identique au nom de mes onglets, je
me dis qu'il doit y avoir moyen de récupérer ce libellé pour l'inclure
dans ma formule pour éviter de revoir changer manuellement le pays.
J'ai été voir la fonction INDIRECT mais j'ai pas réussit à m'en servir
pour faire ce que je voulais.
Une idée ???
Merci à tous





Merci à tous déjà pour ces réponses (pas eu le temps de tester je
l'avoue)
Je vous laisse un exemple à l'adresse suivante pour comprendre ce que
je souhaite faire
Dans la feuille Synthèse, mon objectif c'est de remplacer AT!
par ....; c'est bien ça mon pb pour ne pas avoir à changer à chaque
fois le nom de la feuille
http://www.megaupload.com/?d=SBDTZBR4


Tschuß
Le #18917701
On 16 mar, 21:18, LSteph
=SOMMEPROD((INDIRECT($A2&"!$B$1:$B$6")*(INDIRECT($A2&"!$a$1:$a$6")=B$ 1)))

--
lSteph

Tschuß a écrit :

> On 16 mar, 20:32, LSteph >> Bonsoir,

>> Un truc du genre devrait passer pour une somme simple

>> La feuille doit être à part des autres
>> supposons que la 1ère soit DE et la dernière UK
>> =Somme('DE:UK'!B2)
>> fera la somme B2 de toutes les feuilles situées entre DE et UK

>> par suite donne nous tes conditions pour un sommeprod (ou somme.si)

>> en même temps que l'exemple.

>> --
>> lSteph

>> Tschuß a écrit :

>>> Bonjour à tout le forum,
>>> Un problème qui me parait simple me bloque depuis qques heures.
>>> Chaque pays à le détail de ses données dans un onglet par pays. Je
>>> dois faire un tableau de synthèse pour tous ces pays dans une seule
>>> feuille (nommée DE, AT, SU, ...)
>>> Bref, on va dire qu'un colonne A, j'ai le nom des pays DE, AT, SU, ES ,
>>> UK, ....
>>> En colonne B, je fais une formule =SOMME.SI([Extraction_Pays.xls]
>>> DE!..................
>>> Vu que le libellé en colonne A est identique au nom de mes onglets, je
>>> me dis qu'il doit y avoir moyen de récupérer ce libellé pour l' inclure
>>> dans ma formule pour éviter de revoir changer manuellement le pays.
>>> J'ai été voir la fonction INDIRECT mais j'ai pas réussit à m' en servir
>>> pour faire ce que je voulais.
>>> Une idée ???
>>> Merci à tous

> Merci à tous déjà pour ces réponses (pas eu le temps de tester je
> l'avoue)
> Je vous laisse un exemple à l'adresse suivante pour comprendre ce que
> je souhaite faire
> Dans la feuille Synthèse, mon objectif c'est de remplacer AT!
> par ....; c'est bien ça mon pb pour ne pas avoir à changer à chaq ue
> fois le nom de la feuille
>http://www.megaupload.com/?d=SBDTZBR4



Top ! La fonction retourne le résultat mais ... (et oui, il y a un
mais) comment adapter la fonction INDIRECT si les onglets AT, BE, ...
sont dans un autre classeur ?
LSteph
Le #18918081
..télécharge morefun.dll
et utilise indirect.ext



Tschuß a écrit :
On 16 mar, 21:18, LSteph
=SOMMEPROD((INDIRECT($A2&"!$B$1:$B$6")*(INDIRECT($A2&"!$a$1:$a$6")=B$1)))

--
lSteph

Tschuß a écrit :





Top ! La fonction retourne le résultat mais ... (et oui, il y a un
mais) comment adapter la fonction INDIRECT si les onglets AT, BE, ...
sont dans un autre classeur ?


Publicité
Poster une réponse
Anonyme