[SATA] optimisation d'un disque

Le
Zelos
Bonjour,

Je possède un disque SATA pour mon pc familial et mon portable est en IDE.

J'ai suivi ce tuto : http://www.pc-boost.com/optimisation_linux.php

pour optimiser mon portable :

neptune:/home/jp# hdparm -i /dev/hda

/dev/hda:

Model=ST94019A, FwRev=3.05, SerialNo=3KW3RVYJ
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs RotSpdTol>.5% }
RawCHS383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
BuffType=unknown, BuffSize 48kB, MaxMultSect, MultSect=off
CurCHS383/16/63, CurSects514064, LBA=yes, LBAsectsx140160
IORDY=on/off, tPIO={min:240,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
AdvancedPM=yes: unknown setting WriteCache=enabled
Drive conforms to: ATA/ATAPI-6 T13 1410D revision 2: ATA/ATAPI-1,2,3,4,5,6

* signifies the current active mode



neptune:/home/jp# hdparm -X69 -d1 -u1 -m16 -c3 -W1 /dev/hda



Par contre, sur mon pc familial, c'est la cata :

root@sedna:/home/jp# hdparm -i /dev/sda

/dev/sda:

Model=Maxtor 6V160E0 , FwRev=VA111630,
SerialNo=V3095B9G
Config={ Fixed }
RawCHS383/16/63, TrkSize=0, SectSize=0, ECCbytes=4
BuffType=DualPortCache, BuffSize92kB, MaxMultSect, MultSect=?16?
CurCHS383/16/63, CurSects514064, LBA=yes, LBAsects&8435455
IORDY=on/off, tPIO={min:120,w/IORDY:120}, tDMA={min:120,rec:120}
PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 udma5
AdvancedPM=yes: disabled (255) WriteCache=enabled
Drive conforms to: ATA/ATAPI-7 T13 1532D revision 0:
ATA/ATAPI-1,2,3,4,5,6,7

* signifies the current active mode

Apparement, aucun mode n'est actif. Etrange, non ?

root@sedna:/home/jp# hdparm -X69 -d1 -u1 -m16 -c3 -W1 /dev/sda

/dev/sda:
setting 32-bit IO_support flag to 3
HDIO_SET_32BIT failed: Invalid argument
setting multcount to 16
HDIO_SET_MULTCOUNT failed: Inappropriate ioctl for device
setting unmaskirq to 1 (on)
HDIO_SET_UNMASKINTR failed: Inappropriate ioctl for device
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Inappropriate ioctl for device
setting xfermode to 69 (UltraDMA mode5)
SG_IO: bad/missing ATA_16 sense data:: 70 00 05 00 00 00 00 0a 00 00 00
00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
HDIO_DRIVE_CMD(setxfermode) failed: Input/output error
setting drive write-caching to 1 (on)
HDIO_GET_MULTCOUNT failed: Inappropriate ioctl for device
IO_support = 0 (default 16-bit)
write-caching = 1 (on)





Bref, j'ai essayé pas mal de trucs mais sans succès


Auriez-vous une idée ?

Merci.
Zelos


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Questions / Réponses high-tech
Vidéos High-Tech et Jeu Vidéo
Téléchargements
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean-Yves F. Barbier
Le #9725411
Zelos a écrit :
..........
/dev/sda:
setting 32-bit IO_support flag to 3
HDIO_SET_32BIT failed: Invalid argument
setting multcount to 16
HDIO_SET_MULTCOUNT failed: Inappropriate ioctl for device
setting unmaskirq to 1 (on)
HDIO_SET_UNMASKINTR failed: Inappropriate ioctl for device
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Inappropriate ioctl for device
setting xfermode to 69 (UltraDMA mode5)
SG_IO: bad/missing ATA_16 sense data:: 70 00 05 00 00 00 00 0a 00 00 00
00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
HDIO_DRIVE_CMD(setxfermode) failed: Input/output error
setting drive write-caching to 1 (on)
HDIO_GET_MULTCOUNT failed: Inappropriate ioctl for device
IO_support = 0 (default 16-bit)
write-caching = 1 (on)



les périfs reconnus comme SCSI ne prennent pas certains parms de hdparm
limite-toi à -X69

par ailleurs que dit: hdparm -t /dev/sda (+sieurs fois de suite)?

--
Life is a POPULARITY CONTEST! I'm REFRESHINGLY CANDID!!


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Zelos
Le #9725401
Jean-Yves F. Barbier wrote:
Zelos a écrit :
..........
/dev/sda:
setting 32-bit IO_support flag to 3
HDIO_SET_32BIT failed: Invalid argument
setting multcount to 16
HDIO_SET_MULTCOUNT failed: Inappropriate ioctl for device
setting unmaskirq to 1 (on)
HDIO_SET_UNMASKINTR failed: Inappropriate ioctl for device
setting using_dma to 1 (on)
HDIO_SET_DMA failed: Inappropriate ioctl for device
setting xfermode to 69 (UltraDMA mode5)
SG_IO: bad/missing ATA_16 sense data:: 70 00 05 00 00 00 00 0a 00 00 00
00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
HDIO_DRIVE_CMD(setxfermode) failed: Input/output error
setting drive write-caching to 1 (on)
HDIO_GET_MULTCOUNT failed: Inappropriate ioctl for device
IO_support = 0 (default 16-bit)
write-caching = 1 (on)



les périfs reconnus comme SCSI ne prennent pas certains parms de hdparm
limite-toi à -X69

par ailleurs que dit: hdparm -t /dev/sda (+sieurs fois de suite)?



J'ai essayé plusieurs fois et toujours le même message:

/dev/sda:
setting xfermode to 69 (UltraDMA mode5)
SG_IO: bad/missing ATA_16 sense data:: 70 00 05 00 00 00 00 0a 00 00 00
00 24 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
HDIO_DRIVE_CMD(setxfermode) failed: Input/output error


Une piste ?


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #9725391
Zelos, samedi 2 février 2008, 20:00:41 CET

Bonjour,



’soir,

Je possède un disque SATA pour mon pc familial et mon portable
est en IDE.

J'ai suivi ce tuto :
http://www.pc-boost.com/optimisation_linux.php

pour optimiser mon portable :

neptune:/home/jp# hdparm -i /dev/hda

/dev/hda:

Model=ST94019A, FwRev=3.05, SerialNo=3KW3RVYJ
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs
RotSpdTol>.5% } RawCHS383/16/63, TrkSize=0, SectSize=0,
RotSpdTol>ECCbytes=4
BuffType=unknown, BuffSize 48kB, MaxMultSect,
MultSect=off CurCHS383/16/63, CurSects514064, LBA=yes,
LBAsectsx140160 IORDY=on/off, tPIO={min:240,w/IORDY:120},
tDMA={min:120,rec:120} PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
AdvancedPM=yes: unknown setting WriteCache=enabled
Drive conforms to: ATA/ATAPI-6 T13 1410D revision 2:
ATA/ATAPI-1,2,3,4,5,6

* signifies the current active mode



neptune:/home/jp# hdparm -X69 -d1 -u1 -m16 -c3 -W1 /dev/hda



Questions idiotes :
— pourquoi -X69 quand le mode est déjà udma5 ?
— pourquoi -d1 puisque le disque est déjà en DMA ?
— pourquoi -W1 puisque le WriteCache est déjà «  enabled » ?
— pourquoi -c3, ton disque est sur un contrôleur PCI ?
— pourquoi -m16 ? Tu veux du/es en DMA, pas en PIO.

Par contre, sur mon pc familial, c'est la cata :

:/home/jp# hdparm -i /dev/sda
[…]



hdparm ne sait pas (encore ?) bien gérer les disques SATA.

De toute façon, les disques modernes se mettent en général
tout seuls dans le meilleur mode.
As-tu vraiment des problèmes de vitesse ou est-ce juste «  pour
bricoler » ?

--
Sylvain Sauvage
Zelos
Le #9725381
Sylvain Sauvage wrote:
Zelos, samedi 2 février 2008, 20:00:41 CET

Bonjour,




’soir,


Je possède un disque SATA pour mon pc familial et mon portable
est en IDE.

J'ai suivi ce tuto :
http://www.pc-boost.com/optimisation_linux.php

pour optimiser mon portable :

neptune:/home/jp# hdparm -i /dev/hda

/dev/hda:

Model=ST94019A, FwRev=3.05, SerialNo=3KW3RVYJ
Config={ HardSect NotMFM HdSw>15uSec Fixed DTR>10Mbs
RotSpdTol>.5% } RawCHS383/16/63, TrkSize=0, SectSize=0,
RotSpdTol>ECCbytes=4
BuffType=unknown, BuffSize 48kB, MaxMultSect,
MultSect=off CurCHS383/16/63, CurSects514064, LBA=yes,
LBAsectsx140160 IORDY=on/off, tPIO={min:240,w/IORDY:120},
tDMA={min:120,rec:120} PIO modes: pio0 pio1 pio2 pio3 pio4
DMA modes: mdma0 mdma1 mdma2
UDMA modes: udma0 udma1 udma2 udma3 udma4 *udma5
AdvancedPM=yes: unknown setting WriteCache=enabled
Drive conforms to: ATA/ATAPI-6 T13 1410D revision 2:
ATA/ATAPI-1,2,3,4,5,6

* signifies the current active mode



neptune:/home/jp# hdparm -X69 -d1 -u1 -m16 -c3 -W1 /dev/hda




Questions idiotes :
— pourquoi -X69 quand le mode est déjà udma5 ?
— pourquoi -d1 puisque le disque est déjà en DMA ?
— pourquoi -W1 puisque le WriteCache est déjà « enabled » ?
— pourquoi -c3, ton disque est sur un contrôleur PCI ?
— pourquoi -m16 ? Tu veux du/es en DMA, pas en PIO.




Bonne remarque. C'est pour tester la ligne de commandes que je place
ensuite dans /etc/hdparm.conf pour mon portable.
Par contre, sur mon pc familial, c'est la cata :

:/home/jp# hdparm -i /dev/sda
[…]




hdparm ne sait pas (encore ?) bien gérer les disques SATA.

De toute façon, les disques modernes se mettent en général
tout seuls dans le meilleur mode.
As-tu vraiment des problèmes de vitesse ou est-ce juste « pour
bricoler » ?




J'ignorais jusqu'alors que les disques modernes géraient déjà le
meilleur mode disponible. Mais je trouvais que le débit du disque
n'était pas terrible en fait:

:~# hdparm -Tt /dev/sda

/dev/sda:
Timing cached reads: 1082 MB in 2.00 seconds = 541.03 MB/sec
Timing buffered disk reads: 156 MB in 3.00 seconds = 51.96 MB/sec


et sur mon portable:

neptune:/home/jp# hdparm -Tt /dev/hda

/dev/hda:
Timing cached reads: 1382 MB in 2.00 seconds = 690.81 MB/sec
Timing buffered disk reads: 74 MB in 3.02 seconds = 24.48 MB/sec

Qu'en penses-tu ?


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Yves F. Barbier
Le #9725371
Zelos a écrit :
..........
J'ignorais jusqu'alors que les disques modernes géraient déjà le
meilleur mode disponible. Mais je trouvais que le débit du disque
n'était pas terrible en fait:

:~# hdparm -Tt /dev/sda

/dev/sda:
Timing cached reads: 1082 MB in 2.00 seconds = 541.03 MB/sec
Timing buffered disk reads: 156 MB in 3.00 seconds = 51.96 MB/sec



Nooon, il est carrément pourri à 52 MB/sec ;-)

Ne pas oublier que ATA-133 (133 pour 133MHz) ne correspond qu'à un débit
théorique de l'interface (et qui plus est, en burst), pas au débit du HD.

et sur mon portable:

neptune:/home/jp# hdparm -Tt /dev/hda

/dev/hda:
Timing cached reads: 1382 MB in 2.00 seconds = 690.81 MB/sec
Timing buffered disk reads: 74 MB in 3.02 seconds = 24.48 MB/sec



c'est plus qu'honorable pour un HD possiblement en 5400 RPM

Même avec des HD SCSI Ultra-640 ça ne cracherait pas plus vite,
c'est l'interface qui est capable de débiter 640 MB/sec, répartis
entre plusieurs HDz; pas chaque HD.

--
The man-hating woman, like the cold woman, is largely imaginary. She
is simply a woman who has done her best to snare a man and has failed.
-- Norton


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
gaetan.perrier
Le #9725341
Selon "Jean-Yves F. Barbier"
> et sur mon portable:
>
> neptune:/home/jp# hdparm -Tt /dev/hda
>
> /dev/hda:
> Timing cached reads: 1382 MB in 2.00 seconds = 690.81 MB/sec
> Timing buffered disk reads: 74 MB in 3.02 seconds = 24.48 MB/sec

c'est plus qu'honorable pour un HD possiblement en 5400 RPM



J'ai la même chose sur mon portable avec un disque 5400tr/min, environ 24/25
Mo/s


Même avec des HD SCSI Ultra-640 ça ne cracherait pas plus vite,
c'est l'interface qui est capable de débiter 640 MB/sec, répartis
entre plusieurs HDz; pas chaque HD.



Euh sur mon fixe avec un controleur SCSI 160, j'obtiens aux tests hdparm -t des
débit > 80Mo/s

Gaëtan


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Yves F. Barbier
Le #9725331
a écrit :
......
Euh sur mon fixe avec un controleur SCSI 160, j'obtiens aux tests hdparm -t des
débit > 80Mo/s



il serait étonnant que ce soit en 5600 RPM...

--
Q: How can you tell when a Burroughs salesman is lying?
A: When his lips move.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
gaetan.perrier
Le #9725181
Selon "Jean-Yves F. Barbier"
a écrit :
......
> Euh sur mon fixe avec un controleur SCSI 160, j'obtiens aux tests hdparm -t
des
> débit > 80Mo/s

il serait étonnant que ce soit en 5600 RPM...




Je n'ai pas dit ça non plus! Ce sont des 15000tr/min.

Gaëtan


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Pascal Hambourg
Le #9725031
Sylvain Sauvage a écrit :
Zelos, samedi 2 février 2008, 20:00:41 CET

Je possède un disque SATA pour mon pc familial et mon portable
est en IDE.

neptune:/home/jp# hdparm -X69 -d1 -u1 -m16 -c3 -W1 /dev/hda



Questions idiotes :
- pourquoi -X69 quand le mode est déjà udma5 ?



Et *surtout* pourquoi chercher à régler un mode de transfert UDMA qui ne
s'applique qu'au transport ATA parallèle (PATA) et non au transport
série (SATA) ?

- pourquoi -c3, ton disque est sur un contrôleur PCI ?



En général, oui. ;-) Ou un bus système de largeur supérieure à 16 bits
en émulation PCI. Cependant ce réglage n'améliore les performances que
pour les modes PIO, qui sont a éviter absolument car ça rame
abominablement (débit maxi 16 Mo/s).

- pourquoi -m16 ? Tu veux du/es en DMA, pas en PIO.



Ce réglage s'applique aussi bien en DMA qu'en PIO, non ?

De toute façon, les disques modernes se mettent en général
tout seuls dans le meilleur mode.



En effet.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Pascal Hambourg
Le #9725021
Jean-Yves F. Barbier a écrit :
Zelos a écrit :

Mais je trouvais que le débit du disque
n'était pas terrible en fait:

:~# hdparm -Tt /dev/sda

/dev/sda:
Timing cached reads: 1082 MB in 2.00 seconds = 541.03 MB/sec
Timing buffered disk reads: 156 MB in 3.00 seconds = 51.96 MB/sec



Nooon, il est carrément pourri à 52 MB/sec ;-)



Ça dépend quel âge il a. C'est sûr qu'il y a mieux, sans aller chercher
dans le haut de gamme.

Ne pas oublier que ATA-133 (133 pour 133MHz) ne correspond qu'à un débit
théorique de l'interface (et qui plus est, en burst), pas au débit du HD.



Non, il n'y a pas de 133 MHz en UDMA mode 6 (vulgairement UDMA 133). La
fréquence d'horloge est à 33 MHz. 133 Mo/s n'est pas un débit théorique,
c'est le débit de signalisation physique sur la nappe.

et sur mon portable:

neptune:/home/jp# hdparm -Tt /dev/hda

/dev/hda:
Timing cached reads: 1382 MB in 2.00 seconds = 690.81 MB/sec
Timing buffered disk reads: 74 MB in 3.02 seconds = 24.48 MB/sec



c'est plus qu'honorable pour un HD possiblement en 5400 RPM



J'ai vu nettement mieux : dans les 40 Mo/s sur un Maxtor 5400 tours/mn
20 Go qui n'est pas de première jeunesse. Mais c'est un 3,5", pas un
2,5" de portable.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme