Firefox 4.0 : troisième bêta à télécharger

Le par  |  7 commentaire(s)
Firefox-4-beta-3

Mozilla livre une troisième version bêta de Firefox 4.0 avec support de la technologie multitouch de Windows 7 et des améliorations JavaScript.

Firefox-4-beta-3Le développement de Firefox 4.0 se poursuit et Mozilla propose désormais de tester une troisième version bêta. Cette dernière arrive avec la compatibilité multitouch native sous Windows 7. Une apparition qui s'adresse tout particulièrement aux développeurs Web qui sont invités à tirer parti des API idoines pour la gestion d'évènements tactiles sur certaines machines Windows 7.

L'autre nouveauté de cette bêta 3 de Firefox 4.0 est une amélioration JavaScript devenue quasi constante. En l'occurrence, une nouvelle façon de représenter les valeurs en JavaScript ( entier, chaîne de caractères... ) a été mise en œuvre. Selon Mozilla, elle permet de traiter plus efficacement du code numérique lourd exploité pour des graphiques et des animations.

Avec la version bêta de Firefox 4.0, Mozilla a mis en place un bouton Réagir situé à droite de la barre d'adresse afin d'obtenir les retours des utilisateurs. Selon Mozilla, le demi-million de testeurs de Fx 4.0 a opéré par ce biais près de 3 500 retours quotidiens !

La bêta 3 de Firefox 4.0 peut être téléchargée depuis cette page pour le système d'exploitation et la langue de son choix.

Nos actualités sur les précédentes versions bêta de Firefox 4.0 :

Complément d'information
  • Le nouveau Firefox à télécharger
    C'est désormais officiel. La version 29 du navigateur Firefox est disponible. Nouvelle interface utilisateur et service de synchronisation amélioré.
  • Firefox à télécharger en version 27
    Mozilla livre la version 27 de son navigateur Firefox. Plusieurs médias sociaux à la fois, TLS 1.2 et diverses attentions pour les développeurs.

Vos commentaires

Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Le #676331
Première impression : pas une seule extension compatible, ça commence bien
Pas compatible avec le site Orange (très marqué IE il est vrai)
Déjà la version 4 beta2 je ne l'ai pas gardée longtemps, trop de problèmes
Le #676341
"Première impression : pas une seule extension compatible, ça commence bien"

C'est vrai que c'est le travail de la fondation mozilla de s'occuper des extensions...

"Pas compatible avec le site Orange (très marqué IE il est vrai)"

RAS avec une version pré4.0b4... Dommage pour toi

"Déjà la version 4 beta2 je ne l'ai pas gardée longtemps, trop de problèmes"

Quel mot ne comprends-tu pas dans "version béta" ?
Le #676361
J'ai installé la beta 2 mais il est vrai que la non compatibilité des extensions la rend inutilisable pour le surf quotidien.
Je sais que ce n'est pas le but d'une beta mais j'espère que la version finale ne tardera pas trop.

Sympa la prise en charge du multitouch
Le #676381
Salut,
@Jérome :

"Cette dernière arrive avec la compatibilité multitouch native sous Windows 7. Une apparition qui s'adresse tout particulièrement aux développeurs Web qui sont invités à tirer parti des API idoines pour la gestion d'évènements tactiles sur certaines machines Windows 7."


Depuis quand on invite des développeurs Web à utiliser des technologies non standards afin de cibler une plate-forme spécifique ? Pour faire comme Microsoft avec ses ActiveX ?

@Fred :
"C'est vrai que c'est le travail de la fondation mozilla de s'occuper des extensions..."
Oui, en partie puisqu'elle doit au moins s'assurer qu'elle ne distribue pas de cochonneries dans sa boutique à modules complémentaire et aussi documenter, à l'intention des développeurs d'extensions, toutes les subtilités qui peuvent casser tel ou tel type d'addon de version en version...
Tu avoueras j'espère aussi que si tu ne pouvais te passer de quelques dizaines d'extensions hétéroclites, tu aurais un peu plus de mal à tester chaque nightly de ton navigateur préféré.

@+
--
Pierre
Le #676401
@JolinFire
Moi aussi je t'aime

Et vive Chromium 6 qui gère parfaitement tous les sites (lui) y compris celui d'Orange, et ses extensions toujours fonctionnelles au fur et à mesure des nouvelles versions (au moins une par jour)
Le #676601
La beta 2 ne m'a causé aucun problème, et je reste pour l'instant sur celle-ci.

En effet, pas une seule extension compatible avec la beta 3 ! On se demande combien d'entre elles le seront lorsque la version finale va sortir...
Anonyme
Le #676611
Je suis sur la version nightly depuis le début de la 4.0 (qui était la version 3.7).
Jamais eu de soucis. Pour les extensions, si elles étaient compatibles avec la précédente bêta, il ne devrait pas y avoir de gros changements, il est donc possible de forcer l'installation via une petite manipulation d'un fichier.
Suivre les commentaires
Poster un commentaire
Anonyme
:) ;) :D ^^ 8) :| :lol: :p :-/ :o :w00t: :roll: :( :cry: :facepalm:
:andy: :annoyed: :bandit: :alien: :ninja: :agent: :doh: :@ :sick: :kiss: :love: :sleep: :whistle: =]