Alsa me brouille l'

Le
Jo Engo
Bonjour,

Bon ben voilu, je n'ai toujours pas de son.
J'ai trouvé le remplaçant de alsaconf : 'alsactl init' mais patatras :

$ sudo alsactl init
[sudo] Mot de passe de abdallah : 
alsactl: init:1757: No soundcards found
$

Pourtant quand je fais lspci -v j'ai bien quelque chose qui ressemble
fort à une carte-son (un chip du moins) que le noyau connaît :
$ sudo lspci -v
../..
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
Subsystem: Lenovo Sunrise Point-LP HD Audio
Flags: fast devsel, IRQ 16
Memory at d1220000 (64-bit, non-prefetchable) [sizeK]
Memory at d1210000 (64-bit, non-prefetchable) [sizedK]
Capabilities: [50] Power Management version 3
Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
Kernel modules: snd_hda_intel, snd_soc_skl

../..

Bon, qu'est-ce que j'ai manqué ? Que puis-je encore faire ?
Je compte sur vos lumières

--
REMUGLES

P : C'est pas vrai ! Il a encore bouché les chiottes ! MAURICE !! Qu'est-
ce que t'as foutu là-dedans pour que ça déborde !?
M : Hein ?
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #26455344
Jo Engo , dans le message
Bon, qu'est-ce que j'ai manqué ? Que puis-je encore faire ?

dmesg
Jo Engo
Le #26455433
Le Sun, 10 Dec 2017 15:05:50 +0000, Nicolas George a écrit :
dmesg

dmesg|grep Audio
# rien
dmesg|grep 00:1f.3
[ 0.176010] pci 0000:00:1f.3: [8086:9d70] type 00 class 0x040300
[ 0.176041] pci 0000:00:1f.3: reg 0x10: [mem 0xd1220000-0xd1223fff
64bit]
[ 0.176076] pci 0000:00:1f.3: reg 0x20: [mem 0xd1210000-0xd121ffff
64bit]
[ 0.176132] pci 0000:00:1f.3: PME# supported from D3hot D3cold
dmesg|grep snd_hda_intel
# rien
dmesg|grep snd_soc_skl
# là il y a du monde
[ 11.776902] Modules linked in: snd_soc_skl(+) snd_soc_skl_ipc
snd_soc_sst_ipc iwlmvm(+) wmi_bmof mac80211 ghash_clmulni_intel
snd_soc_sst_dsp bluetooth intel_cstate iwlwifi evdev snd_hda_ext_core
drbg ideapad_laptop joydev intel_uncore snd_soc_sst_match cfg80211
sparse_keymap serio_raw ansi_cprng intel_rapl_perf snd_soc_core pcspkr
snd_compress snd_hda_core iTCO_wdt snd_pcm wmi iTCO_vendor_support
ecdh_generic i915 rfkill snd_timer sg shpchp snd ac acpi_pad battery
video intel_lpss_acpi intel_lpss tpm_crb intel_pch_thermal button mei_me
mei soundcore i2c_algo_bit cuse fuse drm_kms_helper drm parport_pc ppdev
lp parport ip_tables x_tables autofs4 ext4 crc16 mbcache jbd2 fscrypto
ecb raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor
async_tx xor rtsx_usb_sdmmc mmc_core rtsx_usb mfd_core
[ 11.777050] skl_nhlt_init+0x87/0xc0 [snd_soc_skl]
Rien qui ressemble à un warning ou une erreur, si ?
J'accuse alsa de ne pas reconnaître la carte-son. Que dire pour sa
défense ? Quelle peine est efficace ? Passer à OSS ?
--
L'univers m'embarrasse, et je ne puis songer
Que cette horloge existe et n'ait pas d'horloger.
-+- Voltaire, Poésies -+-
Fran=c3=a7ois Patte
Le #26455436
Le 10/12/2017 à 15:47, Jo Engo a écrit :
Bonjour,
Bon ben voilu, je n'ai toujours pas de son.
J'ai trouvé le remplaçant de alsaconf : 'alsactl init' mais patatras :
$ sudo alsactl init
[sudo] Mot de passe de abdallah : 
alsactl: init:1757: No soundcards found...
$
Pourtant quand je fais lspci -v j'ai bien quelque chose qui ressemble
fort à une carte-son (un chip du moins) que le noyau connaît :
$ sudo lspci -v
../..
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
Subsystem: Lenovo Sunrise Point-LP HD Audio
Flags: fast devsel, IRQ 16
Memory at d1220000 (64-bit, non-prefetchable) [sizeK]
Memory at d1210000 (64-bit, non-prefetchable) [sizedK]
Capabilities: [50] Power Management version 3
Capabilities: [60] MSI: Enable- Count=1/1 Maskable- 64bit+
Kernel modules: snd_hda_intel, snd_soc_skl
../..
Bon, qu'est-ce que j'ai manqué ? Que puis-je encore faire ?

pulseaudio?
--
François Patte
Université Paris Descartes
Jo Engo
Le #26455435
dmesg
Bonus :
sudo dmesg|grep rro
[ 0.116112] ACPI Error: [_PPC] Namespace lookup failure,
AE_ALREADY_EXISTS (20170728/dswload-378)
[ 8.478720] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
en passant c'est quoi cette erreur ?
--
Suez, Edmond, nom de Zeus !
-- Schmitter, Frédéric
Jo Engo
Le #26455445
Le Mon, 11 Dec 2017 11:08:56 +0100, François Patte a écrit :
pulseaudio?


PulseAudio dépend d'alsa
--
Ce n'est pas en continuant de faire ce que l'on connaît
que l'on pourra faire ce que l'on ne connaît pas
Nicolas George
Le #26455484
Jo Engo , dans le message
|grep Audio
|grep 00:1f.3
|grep snd_hda_intel
|grep snd_soc_skl

Arrête avec ces greps !
docanski
Le #26455483
Nicolas George a écrit le 11/12/17 à 15:36 :
Jo Engo , dans le message
|grep Audio

|grep 00:1f.3

|grep snd_hda_intel

|grep snd_soc_skl

Arrête avec ces greps !


C'est la chandeleur ? :-)
(bon, je sors ...)
--
docanski
Portail et annuaire du nord-Bretagne : http://armorance.free.fr/
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Hugolino
Le #26455513
Le 11-12-2017, Jo Engo
dmesg
Bonus :
sudo dmesg|grep rro
[ 0.116112] ACPI Error: [_PPC] Namespace lookup failure,
AE_ALREADY_EXISTS (20170728/dswload-378)
[ 8.478720] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
en passant c'est quoi cette erreur ?

sda5 a été remounté en read only à cause d'erreurs. (On me corrigera si
j'ai mal interprété).
Un fsck sur cette partition devrait (peut-être) résoudre le problème.
--
Une sensation que Windows ne pourra jamais procurer à ses utilisateurs,
c'est celle de sentir qu'on a réussi grâce sa connaissance profonde du
système et non pas à cause d'un clic de souris chanceux.
Hugo (né il y a 1 692 407 515 secondes)
Jo Engo
Le #26455524
Le Mon, 11 Dec 2017 19:26:41 +0100, Hugolino a écrit :
en passant c'est quoi cette erreur ?

sda5 a été remounté en read only à cause d'erreurs. (On me corrigera si
j'ai mal interprété).

Merci mais non, en fait l'autre :
0.116112] ACPI Error: [_PPC] Namespace lookup failure, AE_ALREADY_EXISTS
(20170728/dswload-378)
(pour l'«erreur» sur sda5, j'ai véérifié il est bien en rw, vu que
c'est / ça m'aurait interpellé avant. En cas d'erreur il SERA remonté en
ro.
--
Mais en cette vie mortelle rien n'est béat de toute part.
-+- François Rabelais (1494?-1553), Quart livre (chap. 44) -+-
Jo Engo
Le #26455523
Le Mon, 11 Dec 2017 14:36:31 +0000, Nicolas George a écrit :
Arrête avec ces greps !

Que me conseilles-tu ?
En attendant j'en ai fait un autre que j'avais«oublié» :
[ 0.116112] ACPI Error: [_PPC] Namespace lookup failure,
AE_ALREADY_EXISTS (20170728/dswload-378)
[ 0.201483] platform MSFT0101:00: failed to claim resource 1: [mem
0xfed40000-0xfed40fff]
[ 0.201550] acpi MSFT0101:00: platform device creation failed: -16
[ 11.851203] thermal thermal_zone3: failed to read out thermal zone
(-61)
[193618.526424] wlp2s0: failed to remove key (1, ff:ff:ff:ff:ff:ff) from
hardware (-22)
[193618.526574] wlp2s0: failed to remove key (2, ff:ff:ff:ff:ff:ff) from
hardware (-22)
[193636.636223] wlp2s0: failed to remove key (2, ff:ff:ff:ff:ff:ff) from
hardware (-22)
Ce sont des félure donc c'est grave (avant de taper, je signale que je
rigole) mais ça ne me parle pas (mais ça n'a pas l'air d'avoir grand
chose à voir avec le son)
--
17:39 ou peut-on trouver des fortunes en francais ???
17:40 17:39 La banque de france ?
Publicité
Poster une réponse
Anonyme