apt-get upgrade et paquets non mis =c3=a0 jour.

Le
Dominique
Bonsoir,

Je fais :

sudo apt-get upgrade
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Calcul de la mise à jour Fait
Les paquets suivants ont été conservés :
gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0
libjavascriptcoregtk-4.0-18 libwebkit2gtk-4.0-37 linux-generic
linux-headers-generic linux-image-generic
0 mis à jour, 0 nouvellement installés, 0 à enlever et 7 non mis à jour.

Synaptic trouve ces 7 paquets non mis à jour et y procède.

Je fais à nouveau :
sudo apt-get upgrade
Lecture des listes de paquets Fait
Construction de l'arbre des dépendances
Lecture des informations d'état Fait
Calcul de la mise à jour Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

et les 7 paquets sont mis à jour. Pourquoi m'est-il impossible de le
faire avec apt-get ?

Merci à tous,

--
Dominique
Courriel : dominique point sextant ate orange en France
Esto quod es
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Marc SCHAEFER
Le #26473900
Dominique
et les 7 paquets sont mis à jour. Pourquoi m'est-il impossible de le
faire avec apt-get ?

Je ne sais pas si c'est la raison, mais j'utilise toujours
apt-get -u dist-upgrade (*)
et non pas un simple apt-get upgrade.
La différence est, d'après la manpage de apt-get, une gestion plus
intelligente des dépendances et des conflits.
J'utilise juste aptitude en plus, pour voir les Obsolete and locally installed
après un changement de version d'OS, pour les supprimer (car ils ne sont plus
gérés en sécurité).
apt-get --purge autoremove
et
apt-get --purge $(deborphan)
sont aussi utiles pour nettoyer un peu.
(*) seule exception, quand je mets à jour entre deux versions, d'après les
Release Notes ils suggèrent d'abord un apt-get upgrade, voire parfois
même l'installation manuelle de 2-3 trucs avant le dist-upgrade.
Dominique
Le #26473916
Le 04/05/2018 à 19:28, Marc SCHAEFER a écrit :
Je te remercie pour ce retour que je me mets de côté, pour la fois où
j'en aurai besoin.
Passe une bonne journée,
--
Dominique
Courriel : dominique point sextant ate orange en France
Esto quod es
Je ne sais pas si c'est la raison, mais j'utilise toujours
apt-get -u dist-upgrade (*)
et non pas un simple apt-get upgrade.
La différence est, d'après la manpage de apt-get, une gestion plus
intelligente des dépendances et des conflits.
J'utilise juste aptitude en plus, pour voir les Obsolete and locally installed
après un changement de version d'OS, pour les supprimer (car ils ne sont plus
gérés en sécurité).
apt-get --purge autoremove
et
apt-get --purge $(deborphan)
sont aussi utiles pour nettoyer un peu.
(*) seule exception, quand je mets à jour entre deux versions, d'après les
Release Notes ils suggèrent d'abord un apt-get upgrade, voire parfois
même l'installation manuelle de 2-3 trucs avant le dist-upgrade.
Pascal Hambourg
Le #26473922
Le 04/05/2018 à 19:28, Marc SCHAEFER a écrit :
Dominique
et les 7 paquets sont mis à jour. Pourquoi m'est-il impossible de le
faire avec apt-get ?

Je ne sais pas si c'est la raison, mais j'utilise toujours
apt-get -u dist-upgrade (*)
et non pas un simple apt-get upgrade.

Pas moi, avec une version stable. Je n'utilise dist-upgrade que lorsque
upgrade me dit que des paquets ont été conservés. Cela m'informe des
changements de dépendances lors des mises à jour.
La différence est, d'après la manpage de apt-get, une gestion plus
intelligente des dépendances et des conflits.

Plus concrètement, apt-get upgrade ne peut pas installer de nouveaux
paquets ni supprimer des paquets installés. Donc lorsque la nouvelle
version d'un paquet à mettre à jour a de nouvelles dépendances
impliquant l'installation ou la suppression de paquets, il faut utiliser
apt-get dist-upgrade.
dadou
Le #26473997
Le 04/05/2018 à 19:28, Marc SCHAEFER a écrit :
apt-get --purge $(deborphan)

$(deborphan) ? Qu'est-ce ??
Jo Engo
Le #26474012
Le Sat, 05 May 2018 22:58:03 +0200, dadou a écrit :
$(deborphan) ? Qu'est-ce ??


# $() renvoie le résultat de la commande (entre parenthèses) à la ligne
de commande
# deborphan liste les paquets orphelins (c à d dont aucun paquet ne
dépend)
man deborphan devrait t'en dire plus.
--
Autant en emporte le vent.
-+- François Villon (1431-1463?), Ballade en vieux
langage français -+-
Jo Engo
Le #26474013
Le Sat, 05 May 2018 22:58:03 +0200, dadou a écrit :
$(deborphan) ? Qu'est-ce ??


# $() renvoie le résultat de la commande (entre parenthèses) à la ligne de
commande # deborphan liste les paquets orphelins (c à d dont aucun paquet
ne dépend)
man deborphan devrait t'en dire plus.
(supersedes) à condition bien sûr d'avoir installé deborphan sinon la
commande renvoie (quand on a installé command_not_found) :
The program 'deborphan' is currently not installed. To run 'deborphan'
please ask your administrator to install the package 'deborphan'
--
Autant en emporte le vent.
-+- François Villon (1431-1463?), Ballade en vieux
langage français -+-

--
En arithmétique, un et un font deux.
En amour un et un devraient faire un,
et ça fait deux tout de même.
-+- Guy de Maupassant, Yvette -+-
Francois Lafont
Le #26474021
Bonjour,
On 05/05/2018 10:29 AM, Pascal Hambourg wrote:
Je ne sais pas si c'est la raison, mais j'utilise toujours
    apt-get -u dist-upgrade (*)
et non pas un simple apt-get upgrade.

Pas moi, avec une version stable. Je n'utilise dist-upgrade que lorsque upgrade me dit que des paquets ont été conservés. Cela m'informe des changements de dépendances lors des mises à jour.

J'avoue que personnellement j'utilise systématiquement
(y compris sur des serveurs) :
apt-get dist-upgrade --no-remove
que j'ai défini sous la forme d'un alias. Du coup, s'il
n'y a pas de suppression de paquets, ça provoque la mise à
jour « complète » de l'OS. Quand il y a suppression de
paquets (ce qui est assez rare, je n'ai pas souvenir que ça
me soit arrivé d'ailleurs - je suis toujours en stable),
la commande plante et me force à regarder de plus près
la situation.
--
François Lafont
Jo Engo
Le #26474027
Le Sun, 06 May 2018 11:06:19 +0200, Francois Lafont a écrit :
apt-get dist-upgrade --no-remove

C'est à dire l'équivalent de :
aptitude safe-upgrade
non ?
NB depuis quelques temps existe la commande apt (tout court) qui a la
même syntaxe qu'apt-get (vérfier en faisant man apt)
--
Prédire n'est pas expliquer.
-+- Réne Thom -+-
Jo Engo
Le #26474026
(supersedes au temps pour moi)
Le Sun, 06 May 2018 11:06:19 +0200, Francois Lafont a écrit :
apt-get dist-upgrade --no-remove

C'est à dire l'équivalent de :
aptitude safe-upgrade
non ?
NB depuis quelques temps existe la commande apt (tout court) qui n'a pas
la même syntaxe qu'apt-get (vérfier en faisant man apt)
--
Prédire n'est pas expliquer.
-+- Réne Thom -+-
--
Avant donc que d'écrire, apprenez à penser.
-+- Nicolas Boileau, Art poétique -+-
yamo'
Le #26474114
Salut,
Francois Lafont a écrit le 06/05/2018 à 11:06 :
On 05/05/2018 10:29 AM, Pascal Hambourg wrote:
Je ne sais pas si c'est la raison, mais j'utilise toujours
    apt-get -u dist-upgrade (*)
et non pas un simple apt-get upgrade.

Pas moi, avec une version stable. Je n'utilise dist-upgrade que lorsque upgrade me dit que des paquets ont été conservés. Cela m'informe des changements de dépendances lors des mises à jour.

J'avoue que personnellement j'utilise systématiquement
(y compris sur des serveurs) :
apt-get dist-upgrade --no-remove

Je fais comme Pascal, mais c'est une très bonne idée ce no-remove.
dist-upgrade m'a déjà proposé de supprimer apt!
--
Stéphane
Publicité
Poster une réponse
Anonyme