C'est pas la foule ...

Le
docanski
et j'ai besoin d'un petit coup de main.

Bonjour,

En revoyant une petite réalisation à usage privé comportant son et
video, je constate que ni l'un ni l'autre ne fonctionne plus. :-( Il est
vrai que cette réalisation date de 2001, que les navigateurs sont
désormais plus "sérieux" et qu'HTML 5 est passé par là.
J'ai beau m'escrimer avec le code mais rien ne fonctionne :-(
Pour le son, par exemple, je tente sans succès le code qui suit :

[code 1]
<audio controls hidden="true" autostart="true" volume="60" autoplay>
<source src="/valwave/introdoc.wav" type="audio/wav">
</audio>
[/code]

[code 2]
<object type="audio/wave" data="walwave/introdoc.wav" height="0" width="0">
<param name="filename" value="walwave/introdoc.wav" />
<param name="autostart" value="true" />
<param name="loop" value="true" />
</object>
[/code]

Un petit coup de main serait le bienvenu.

Cordialement,
--
docanski

Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Forum boursier : http://docanski.free.fr/boursomania/
  • Partager ce contenu :
Vos réponses Page 1 / 2
Trier par : date / pertinence
Olivier Miakinen
Le #26535765
Bonjour,
Le 14/01/2020 10:43, docanski a écrit :
... et j'ai besoin d'un petit coup de main.

Tout d'abord, ce serait bien de mettre un titre plus informatif sur ton
besoin que « C'est pas la foule », et de ne pas considérer que le corps
d'un article est la « suite » du titre (donc de ne pas couper une phrase
entre titre et corps).
Cela étant dit, je ne sais pas comment on met du son dans une page web,
mais voici quelques pistes à tout hasard.

1) Le répertoire valwave est à la fois à la racine de ton site (écriture avec
slash) et au même endroit que le fichier HTML (écriture sans slash) ? Est-ce
que tu peux essayer avec un chemin complet (http://le_site/le_chemin) ?
2) Tu as essayé les types audio/wav et audio/wave. As-tu essayé audio/x-wav ?
--
Olivier Miakinen
DV
Le #26535768
docanski a écrit ceci :
En revoyant une petite réalisation à usage privé comportant son et
video, je constate que ni l'un ni l'autre ne fonctionne plus. :-( Il est
vrai que cette réalisation date de 2001, que les navigateurs sont
désormais plus "sérieux" et qu'HTML 5 est passé par là.
J'ai beau m'escrimer avec le code mais rien ne fonctionne ... :-(
Pour le son, par exemple, je tente sans succès le code qui suit :
[code 1]
<audio controls hidden="true" autostart="true" volume="60" autoplay>
</audio>
[/code]

J'ai testé ceci :
<audio autoplay>
<source src="[chemin du fichier WAV]" type="audio/wav">
</audio>
Et cela fonctionne comme tu le souhaites (le son est joué à
l'ouverture de la page et les contrôles ne s'affichent pas)... mais
uniquement dans le navigateur Microsoft Edge sous Windows. Rien à
faire dans Firefox, Vivaldi ou Chrome.
La raison probable, c'est que l'autoplay est prohibé dans ces
navigateurs (je sais que c'est officiel dans le cas de Chrome), et la
raison certaine de cette raison probable, c'est que le démarrage
automatique de sons sur les pages web est considéré comme une nuisance.
Autres précisions :
- Les contrôles ne s'affichent pas si l'attribut "controls" est
absent (mais si "autoplay" est inopérant, ça ne sert à rien).
- À ma connaissance, la balise <audio> n'accepte pas l'attribut
"volume".
--
Denis
docanski
Le #26535780
Olivier Miakinen a écrit le 14/01/20 à 11:22 :
Bonjour,

Salut Olivier,
Le 14/01/2020 10:43, docanski a écrit :
... et j'ai besoin d'un petit coup de main.

Tout d'abord, ce serait bien de mettre un titre plus informatif sur ton
besoin ...

Vu la désuétude de ce groupe, foin des usages, cela ne vaut pas le coup
: il sera de toute façon lu par celui ou ceux qui passeront par là.
Normal : ils viennent pour lire. ;-)
Cela étant dit, je ne sais pas comment on met du son dans une page web,
mais voici quelques pistes à tout hasard.


Toutes essayées mais sans succès. A croire que l'extension .wav est
devenue obsolète.
1) Le répertoire valwave est à la fois à la racine de ton site (écriture avec
slash) et au même endroit que le fichier HTML (écriture sans slash) ? Est-ce
que tu peux essayer avec un chemin complet (http://le_site/le_chemin) ?

Là, tu me vexes ;-) ! Il y a près de 25 ans que je hante ce groupe
(depuis sa naissance, en fait) et l'essentiel de mes interventions, à la
belle époque, étaient destinées à prêter main forte aux
apprentis-webmestres.
2) Tu as essayé les types audio/wav et audio/wave. As-tu essayé audio/x-wav ?

Tiens ! je ne connaissais pas ... Mais ça ne va pas mieux pour autant.
--
docanski
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Forum boursier : http://docanski.free.fr/boursomania/
docanski
Le #26535779
DV a écrit le 14/01/20 à 12:13 :
J'ai testé ceci :
<audio autoplay>
<source src="[chemin du fichier WAV]" type="audio/wav">
</audio>
Et cela fonctionne comme tu le souhaites (le son est joué à
l'ouverture de la page et les contrôles ne s'affichent pas)... mais
uniquement dans le navigateur Microsoft Edge sous Windows. Rien à
faire dans Firefox, Vivaldi ou Chrome.

Alors c'est foutu car MicroMachin n'est pas le seul navigateur de la
planète. Et comme le but est de faire du code propre et universel ...
La raison probable, c'est que l'autoplay est prohibé dans ces
navigateurs (je sais que c'est officiel dans le cas de Chrome), et la
raison certaine de cette raison probable, c'est que le démarrage
automatique de sons sur les pages web est considéré comme une nuisance.

Nuisance qui était possible (et d'ailleurs souvent constatée) dans le
passé. Mais alors on utilisait la balise "embed", aussi un machin
inventé par Micro$oft pour son Internet Exploser. Aujourd'hui éjecté,
bien entendu.
Merci quand même ! ;-)
--
docanski
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Forum boursier : http://docanski.free.fr/boursomania/
DV
Le #26535782
docanski a écrit ceci :
Alors c'est foutu car MicroMachin n'est pas le seul navigateur de la
planète. Et comme le but est de faire du code propre et universel ...

Cela dit, je sais qu'il est possible de contourner le blocage avec du
javascript, mais je serais incapable de te dire comment. J'ai sur mon
Mac une application qui sait le faire, mais le code qu'elle produit
est particulièrement touffu...
Nuisance qui était possible (et d'ailleurs souvent constatée) dans le
passé.

Il faut croire que beaucoup de gens s'en sont plaints, pour que la
plupart des éditeurs de navigateurs bloquent ce fameux "autoplay".
À mon avis, balancer du son à l'ouverture d'une page n'est pas gênant
si le visiteur sait que le site est sonorisé, soit parce qu'il en a
été averti sur la page d'accueil, soit parce qu'il a déjà eu
l'occasion d'entendre des sons en cliquant sur tel ou tel élément.
Tout est question de contexte, mais je pense que le faire sur la page
d'accueil et/ou sans le moindre avertissement préalable a le don de
faire fuir les visiteurs (moi le premier).
--
Denis
DV
Le #26535784
docanski a écrit ceci :
Toutes essayées mais sans succès. A croire que l'extension .wav est
devenue obsolète.

WAV fait bien partie des formats compatibles avec la balise <audio> :
--
Denis
docanski
Le #26535831
DV a écrit le 14/01/20 à 19:18 :
À mon avis, balancer du son à l'ouverture d'une page n'est pas gênant
si le visiteur sait que le site est sonorisé, soit parce qu'il en a
été averti sur la page d'accueil, soit parce qu'il a déjà eu
l'occasion d'entendre des sons en cliquant sur tel ou tel élément.
Tout est question de contexte, mais je pense que le faire sur la page
d'accueil et/ou sans le moindre avertissement préalable a le don de
faire fuir les visiteurs (moi le premier).

Comme écrit en préambule, il s'agit d'une réalisation à usage privé.
Elle n'est donc pas publiée telle quelle sur Internet.
A l'origine, elle comportait audio et video mais ni l'une ni l'autre ne
sont plus accessibles : les navigateurs ont évolué, les normes ont changé.
--
docanski
Guide des champignons d'Europe : http://mycorance.free.fr/
La vallée de la Rance maritime : http://valderance.free.fr/
Les côtes du nord de la Bretagne : http://docarmor.free.fr/
Forum boursier : http://docanski.free.fr/boursomania/
DV
Le #26535836
docanski a écrit ceci :
Comme écrit en préambule, il s'agit d'une réalisation à usage privé.
Elle n'est donc pas publiée telle quelle sur Internet.

Désolé, j'avais zappé cette précision.
--
Denis
Gerald
Le #26535859
Le 14 janvier 2020 à 18:41, docanski a écrit :
Toutes essayées mais sans succès. A croire que l'extension .wav est
devenue obsolète.

Qu'elle le soit ou pas, pourquoi ne pas convertir en MP4 ou ogg qui
me semblent plus "universels" ?
--
Gerald
DV
Le #26535863
Gerald a écrit ceci :
Le 14 janvier 2020 à 18:41, docanski a écrit :
Toutes essayées mais sans succès. A croire que l'extension .wav est
devenue obsolète.

Qu'elle le soit ou pas, pourquoi ne pas convertir en MP4 ou ogg qui
me semblent plus "universels" ?

C'est MP3 et non MP4 qui convient pour la balise <audio>, mais à part
ce détail je rejoins ton avis. On peut même inclure deux versions du
même son en intégrant deux <sources> à la balise <audio> : MP3 + OGG,
et laisser le navigateur choisir celle qui lui convient le mieux.
Reste que la fonction "autoplay" ne fonctionnera pas davantage avec
ces formats.
--
Denis
Poster une réponse
Anonyme