carte nvidia jessie =?iso-8859-15?q?n=27appr=E9cie_pas_les?= upgrade

Le
andre_debian
Bonjour,

Depuis que j'ai upgrad Jessie dernire version,
(pas vers stretch),
ma carte nvidia geforce 200 (2xx), ne se lance plus.

J'ai essay :
1] avec le driver debian nvidia,
2] avec le driver de nvidia tlcharg sur leur site,
chaque fois avec dsinstallation de l'ancienne config,
aucun message d'erreur sur les deux mthodes d'installation.

Nvidia fonctionne parfaitement sur une Jessie non upgrade,
avec le driver nvidia de debian.

Au boot, je tombe sur un cran noir et blocage.
CTRL-ALT-F1 et CTRL-C pour revenir la console.

Merci d'une aide, une ide

Andr
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
maderios
Le #26440072
On 07/26/2017 05:15 PM, wrote:
Bonjour,
Depuis que j'ai upgradé Jessie dernière version,
(pas vers stretch),
ma carte nvidia geforce 200 (2xx), ne se lance plus.
J'ai essayé :
1] avec le driver debian nvidia,
2] avec le driver de nvidia téléchargé sur leur site,
à chaque fois avec désinstallation de l'ancienne config,
aucun message d'erreur sur les deux méthodes d'installation.
Nvidia fonctionne parfaitement sur une Jessie non upgradée,
avec le driver nvidia de debian.
Au boot, je tombe sur un écran noir et blocage.
CTRL-ALT-F1 et CTRL-C pour revenir à la console.

Supprimer le xorg.conf s'il existe.
Désinstaller / supprimer / purger tout ce qui concerne nvidia
Installer les paquets nvidia de jessie + dépendances +
xserver-xorg-video-nvidia + dkms
Ensuite, tout est 'automagique', dkms fera le boulot lors de chaque mise
à jour...
--
Maderios
bernard.schoenacker
Le #26440076
----- Mail original -----
De: "andre debian" À:
Envoyé: Mercredi 26 Juillet 2017 17:15:52
Objet: carte nvidia jessie n'apprécie pas les upgrade
Bonjour,
Depuis que j'ai upgradé Jessie dernière version,
(pas vers stretch),
ma carte nvidia geforce 200 (2xx), ne se lance plus.
J'ai essayé :
1] avec le driver debian nvidia,
2] avec le driver de nvidia téléchargé sur leur site,
à chaque fois avec désinstallation de l'ancienne config,
aucun message d'erreur sur les deux méthodes d'installation.
Nvidia fonctionne parfaitement sur une Jessie non upgradée,
avec le driver nvidia de debian.
Au boot, je tombe sur un écran noir et blocage.
CTRL-ALT-F1 et CTRL-C pour revenir à la console.
Merci d'une aide, une idée...
André


bonjour,
voici un début de piste à la menthe :
https://community.linuxmint.com/tutorial/view/176
slt
bernard
andre_debian
Le #26440094
On Wednesday 26 July 2017 17:27:28 maderios wrote:
On 07/26/2017 05:15 PM, wrote:
Depuis que j'ai upgradé Jessie dernière version,
(pas vers stretch),
ma carte nvidia geforce 200 (2xx), ne se lance plus.
J'ai essayé :
1] avec le driver debian nvidia,
2] avec le driver de nvidia téléchargé sur leur site,
à chaque fois avec désinstallation de l'ancienne config,
aucun message d'erreur sur les deux méthodes d'installation.
Nvidia fonctionne parfaitement sur une Jessie non upgradée,
avec le driver nvidia de debian.
Au boot, je tombe sur un écran noir et blocage.
CTRL-ALT-F1 et CTRL-C pour revenir à la console.

Supprimer le xorg.conf s'il existe.
Désinstaller / supprimer / purger tout ce qui concerne nvidia
Installer les paquets nvidia de jessie + dépendances +
xserver-xorg-video-nvidia + dkms
Ensuite, tout est 'automagique', dkms fera le boulot lors de chaque mise
à jour...

Merci de ton aide.
J'ai bien fait ce que tu a écrit.
Échec, pareil, écran noir, pas de connexion graphique.
Je n'ai pas de fichier xorg dans /usr/share/X11/xorg.conf.d
À la fin de l'installation des paquets nvidia, une fenêtre
m'a dit de créer un fichier "xorg.conf".
Ok, mais comment ?
J'ai trouvé un exemple de ce fichier que j'ai mis
dans /etc/X11, mais rien à faire...
Je me demande si ma carte nvidia accepte les dernières
versions de Debian car les 2 méthodes, driver proprio et libre
ne marchent pas.
André
=c3
Le #26440096
On 07/26/2017 07:19 PM, wrote:
On Wednesday 26 July 2017 17:27:28 maderios wrote:
On 07/26/2017 05:15 PM, wrote:
Depuis que j'ai upgradé Jessie dernière version,
(pas vers stretch),
ma carte nvidia geforce 200 (2xx), ne se lance plus.
J'ai essayé :
1] avec le driver debian nvidia,
2] avec le driver de nvidia téléchargé sur leur site,
à chaque fois avec désinstallation de l'ancienne config,
aucun message d'erreur sur les deux méthodes d'installation.
Nvidia fonctionne parfaitement sur une Jessie non upgradée,
avec le driver nvidia de debian.
Au boot, je tombe sur un écran noir et blocage.
CTRL-ALT-F1 et CTRL-C pour revenir à la console.


Supprimer le xorg.conf s'il existe.
Désinstaller / supprimer / purger tout ce qui concerne nvidia
Installer les paquets nvidia de jessie + dépendances +
xserver-xorg-video-nvidia + dkms
Ensuite, tout est 'automagique', dkms fera le boulot lors de chaque mise
à jour...

Merci de ton aide.
J'ai bien fait ce que tu a écrit.
Échec, pareil, écran noir, pas de connexion graphique.
Je n'ai pas de fichier xorg dans /usr/share/X11/xorg.conf.d
À la fin de l'installation des paquets nvidia, une fenêtre
m'a dit de créer un fichier "xorg.conf".
Ok, mais comment ?
J'ai trouvé un exemple de ce fichier que j'ai mis
dans /etc/X11, mais rien à faire...
Je me demande si ma carte nvidia accepte les dernières
versions de Debian car les 2 méthodes, driver proprio et libre
ne marchent pas.
André


Bonjour André,
Vous devriez avoir accès à la commande `nvidia-xconfig` avec le
pilote propriétaire (c'est dispo à part dans un paquet éponyme).
Elle devrait vous engendrer un fichier /etc/X11/xorg.conf qui
soit opérationnel pour votre carte graphique.
À plus,
--
Étienne Mollier
maderios
Le #26440105
On 07/26/2017 07:50 PM, Étienne Mollier wrote:
Vous devriez avoir accès à la commande `nvidia-xconfig` avec le
pilote propriétaire (c'est dispo à part dans un paquet éponyme).
Elle devrait vous engendrer un fichier /etc/X11/xorg.conf qui
soit opérationnel pour votre carte graphique.


Cela fait un bail que le serveur X n'a plus besoin de xorg.conf
--
Maderios
=c3
Le #26440112
On 07/26/2017 08:44 PM, maderios wrote:
On 07/26/2017 07:50 PM, Étienne Mollier wrote:
Vous devriez avoir accès à la commande `nvidia-xconfig` avec le
pilote propriétaire (c'est dispo à part dans un paquet éponyme).
Elle devrait vous engendrer un fichier /etc/X11/xorg.conf qui
soit opérationnel pour votre carte graphique.

Cela fait un bail que le serveur X n'a plus besoin de xorg.conf


Bonjour Maderios,
C'est vrai pour le serveur X en lui-même, ainsi que le principaux
pilotes libres qui vont avec.
Pour ce qui est d'un serveur X animé d'un pilote NVidia propriétaire,
c'est un peu moins vrai, le 340 proposé dans jessie non-free (sans
backports certes...) en avait encore besoin je crois.
Il me semble effectivement que les pilotes NVidia très récents ne sont
plus censé avoir besoin de ce fichier, mais dans le doute, je tenterais
tout de même l'opération avec `nvidia-xconfig`, juste pour voir...
Bien Cordialement,
--
Étienne Mollier
=c3
Le #26440115
On 07/26/2017 09:05 PM, Étienne Mollier wrote:
On 07/26/2017 08:44 PM, maderios wrote:
On 07/26/2017 07:50 PM, Étienne Mollier wrote:
Vous devriez avoir accès à la commande `nvidia-xconfig` avec le
pilote propriétaire (c'est dispo à part dans un paquet éponyme).
Elle devrait vous engendrer un fichier /etc/X11/xorg.conf qui
soit opérationnel pour votre carte graphique.

Cela fait un bail que le serveur X n'a plus besoin de xorg.conf


Bonjour Maderios,
C'est vrai pour le serveur X en lui-même, ainsi que le principaux
pilotes libres qui vont avec.
Pour ce qui est d'un serveur X animé d'un pilote NVidia propriétaire,
c'est un peu moins vrai, le 340 proposé dans jessie non-free (sans
backports certes...) en avait encore besoin je crois.
Il me semble effectivement que les pilotes NVidia très récents ne sont
plus censé avoir besoin de ce fichier, mais dans le doute, je tenterais
tout de même l'opération avec `nvidia-xconfig`, juste pour voir...
Bien Cordialement,


Mea culpa, après lecture du Fabuleux manuel, le `nvidia-xconfig` n'est
effectivement plus nécessaire depuis Debian 9 avec le pilote 375 :
https://wiki.debian.org/NvidiaGraphicsDrivers#Debian_9_.22Stretch.22
On 07/26/2017 05:15 PM, wrote:
nvidia geforce 200 (2xx)

Apparemment, sur le site de NVidia, la série de cartes GeForce 200
n'est plus supportée après les pilotes 340, je crois qu'on tient le
détail qui pêche. Si on recherche la carte en fonction du pilote sur
leur site (nécessite JS actif sur nvidia.fr et nvidia.com) :
http://www.nvidia.fr/Download/index.aspx?lang=fr
alors il nous propose un pilote 342 à la page suivante (j'ai
sélectionné une GTX 295 en espérant taper large) :
http://www.nvidia.fr/download/driverResults.aspx/112665/fr
La solution serait d'installer le pilote legacy nvidia 340 pour
rétablir le bon fonctionnement du serveur X.
À plus,
--
Étienne Mollier
andre_debian
Le #26440114
On Wednesday 26 July 2017 19:40:54 you wrote:
On 07/26/2017 07:19 PM, wrote:
On Wednesday 26 July 2017 17:27:28 maderios wrote:
On 07/26/2017 05:15 PM, wrote:
Depuis que j'ai upgradé Jessie dernière version,
(pas vers stretch),
ma carte nvidia geforce 200 (2xx), ne se lance plus.
J'ai essayé :
1] avec le driver debian nvidia,
2] avec le driver de nvidia téléchargé sur leur site,
à chaque fois avec désinstallation de l'ancienne config,
aucun message d'erreur sur les deux méthodes d'installation.
Nvidia fonctionne parfaitement sur une Jessie non upgradée,
avec le driver nvidia de debian.
Au boot, je tombe sur un écran noir et blocage.
CTRL-ALT-F1 et CTRL-C pour revenir à la console.





Bonjour André,
Vous devriez avoir accès à la commande `nvidia-xconfig` avec le
pilote propriétaire (c'est dispo à part dans un paquet épo nyme).
Elle devrait vous engendrer un fichier /etc/X11/xorg.conf qui
soit opérationnel pour votre carte graphique.

Merci du conseil,
J'ai installé nvidia-xconfig , nvidia-detect (qui détecte bien ma carte),
réinstallé nvidia-driver, nvidia-fglx... rebooté,
et rien n'y fait, toujours un écran noir.
Avec Jessie non upgradée à la dernière version, X fonctionne très bien,
avec les paquets libres de Debian.
J'y passe des heures et ça devient franchement pénible.
André
maderios
Le #26440121
On 07/26/2017 09:05 PM, Étienne Mollier wrote:
On 07/26/2017 08:44 PM, maderios wrote:
On 07/26/2017 07:50 PM, Étienne Mollier wrote:
Vous devriez avoir accès à la commande `nvidia-xconfig` avec le
pilote propriétaire (c'est dispo à part dans un paquet éponyme).
Elle devrait vous engendrer un fichier /etc/X11/xorg.conf qui
soit opérationnel pour votre carte graphique.

Cela fait un bail que le serveur X n'a plus besoin de xorg.conf


Bonjour Maderios,
C'est vrai pour le serveur X en lui-même, ainsi que le principaux
pilotes libres qui vont avec.
Pour ce qui est d'un serveur X animé d'un pilote NVidia propriétaire,
c'est un peu moins vrai, le 340 proposé dans jessie non-free (sans
backports certes...) en avait encore besoin je crois.
Il me semble effectivement que les pilotes NVidia très récents ne sont
plus censé avoir besoin de ce fichier, mais dans le doute, je tenterais
tout de même l'opération avec `nvidia-xconfig`, juste pour voir...

J'utilise une carte nvidia ancienne (quadro 600)sans fichier xorg.conf
Je le faisais également avec les drivers 340.xx
xorg.conf est nécessaire pour des configurations plus pointues, qui
concernent les tablettes graphiques, par exemple.
--
Maderios
=c3
Le #26440125
On 07/26/2017 09:57 PM, maderios wrote:
On 07/26/2017 09:05 PM, Étienne Mollier wrote:
On 07/26/2017 08:44 PM, maderios wrote:
On 07/26/2017 07:50 PM, Étienne Mollier wrote:
Vous devriez avoir accès à la commande `nvidia-xconfig` avec le
pilote propriétaire (c'est dispo à part dans un paquet éponyme).
Elle devrait vous engendrer un fichier /etc/X11/xorg.conf qui
soit opérationnel pour votre carte graphique.

Cela fait un bail que le serveur X n'a plus besoin de xorg.conf


Bonjour Maderios,
C'est vrai pour le serveur X en lui-même, ainsi que le principaux
pilotes libres qui vont avec.
Pour ce qui est d'un serveur X animé d'un pilote NVidia propriétaire,
c'est un peu moins vrai, le 340 proposé dans jessie non-free (sans
backports certes...) en avait encore besoin je crois.
Il me semble effectivement que les pilotes NVidia très récents ne sont
plus censé avoir besoin de ce fichier, mais dans le doute, je tenterais
tout de même l'opération avec `nvidia-xconfig`, juste pour voir...

J'utilise une carte nvidia ancienne (quadro 600)sans fichier xorg.conf
Je le faisais également avec les drivers 340.xx
xorg.conf est nécessaire pour des configurations plus pointues, qui concernent les tablettes graphiques, par exemple.


Ok, si de fait cette configuration marche, au temps pour moi. :)
--
Étienne Mollier
Publicité
Poster une réponse
Anonyme