Clavier fou (mais j'y crois moyen...)

Le
michele
J'ai ici un MacBook Pro 15' core i7 2,66 Ghz (arrandale) Mid 2010 avec
une panne qui ne m'inspire pas confiance.

Apparemment, le clavier semble responsable, mais c'est plus compliqué
que ça :

Dès qu'on se sert du clavier, il fait des wwwwwwwww tout seul pendant
des kilomètres (sur textedit, word ou dans un champs de mot de passe,
etc.).
A priori, quand on tape sur les autres lignes que celle du w, ça tape
les lettres/chiffres tout en faisant de temps en temps des wwwwwwww
entre les deux.
Les lettres de la ligne du w/x/c/v/b/n/,/:/= ne sont plus accessibles,
ça produit du wwwwww au kilomètre.
Le pointeur peut avoir un comportement bizarre, être inutilisable
momentanément, revenir, repartir, etc.

Je me suis dit que la batterie avait gonflé et qu'elle pressait sur le
bas du clavier et du pad.
Ou bien qu'une particule métallique foutait le dawa dans le clavier ou
le pad.

Sauf que
Ça fait pareil avec un clavier externe qui fonctionne très bien par
ailleurs

Note importante :
- Ce n'est pas le système qui en a un coup car j'ai échangé les SSD
internes de 2 MBP afin que mon copain ait une macine pour bosser. le
problème est le même quel que soit le disque interne.
- J'ai fait les tests sans la batterie interne. Pareil la même chose.

Une idée avant que je ne démonte tout.
(j'espère que ce n'est pas le processeur qui en a un air)
Vos réponses Page 3 / 4
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
gilbert.olivier
Le #26325172
michele
> Gilbert :
> Pour t'en convaincre avant de démonter, branche ton clavier externe et
> fait une saisie, quelques lettres sur "l'interne" quelques lettres sur
> l'externe pour bien voir que les deux peuvent envoyer des données.


Oui, ça, je sais. Mais que le clavier interne malade du w provoque une
maladie du w sur le clavier externe qui est sur un autre bus usb, c'est
ça que je ne m'explique pas.



Pour faire simple:

Oui mais les deux bus USB vont sur le même écran non?
Alors comment peux-tu dire qui envoie les wwwww?

--
Gilbert
Le Moustique
Le #26325186
Le 25/11/2014 20:37, Gilbert OLIVIER a écrit :
Pour faire simple:

Oui mais les deux bus USB vont sur le même écran non?
Alors comment peux-tu dire qui envoie les wwwww?



Pour faire simple, les deux bus USB utilisent le même régulateur de
tension... et je ne serais pas étonné que ce soit lui qui déconne.
Ce qui pour Michèle n'est pas bon du tout...

--
/)
-:oo= Guillaume
)
Je nettoyais mon clavier, et le coup est parti tout seul.
michele
Le #26325212
Sébastien : la membrane du clavier fonctionne comme une grille,
avec un fil pour toute une ligne de touches, des fils pour les
colonnes et les touches établissent des connexions aux croisements.




J'ai démonté la bestiole pour nettoyer à l'alcool à 90.

Je n'ai enlevé et nettoyé que le cache noir qui a une petite nappe qui
sert à allumer les loupiotes du rétroéclairage du clavier + le cache
transparent avec quelques sérigraphies blanches dessus.

La nappe du pad est indépendante.

Il y a en tout 4 nappes : loupiotes / clavier / pad + la mini-nappe qui
va au tient le bouton de boot à l'emplacement qui va bien.

J'ai décroché/raccroché les diverses nappes + croisé les tests avec
souris externe seule / clavier externe seul / souris + clavier externes.
Le resultat est qu'effectivement le clavier fout le dawa.

Il rend marteau le pad indépendant + le bouton de boot (5/6 redémarrages
tout seul en boucle) et les périphs externes alors qu'ils ne sont pas
sur la même nappe...

Je ne peux pas déconnecter le clavier + fonctionner avec des periphs
externes en attendant d'avoir une soluce car sinon... gn'a plus de
bouton de boot...

Note : le boot est très lent. La loupiote extérieure s'allume après 2 à
4 secondes après que j'ai appuyé sur le bouton. Elle clignotte au bout
de 8 secondes. Et le bruit d'éjection du lecteur optique qui annonce le
boot du disque se fait au bout de 11 à 12 secondes. Normalement, la
séquence appui/loupiotte/éjection dvd/lancement disque est pliée en 2
secondes (je ne parle pas du boot complet pour arriver au bureau).

Bref. Je vais peut-être redémonter pour nettoyer au micro-millimètre la
ligne w, x, c,... mais je ne suis pas sûre que ça arrange grand chose.

A priori, tous les claviers d'unibody A1286 (du Late 2008 au mid 2012
NON retina) sont identiques.
iFixit ne vend pas le clavier seul, c'est upper case complet à un prix
prohibitif, mais sur leboncoin et ebay, y'a de quoi faire.

Je crois que je vais jsute faire des tests croisés avec un unibody Late
2008 pour confirmer puis acheter d'occase.

Mouala.

Merci à tous... même si je ne pige toujours pas comment un truc usb sur
son bus perso et sa nappe perso peut foutre un merdier pareil (je sais
pas pourquoi, pour moi, c'est étanche, ces machins usb-là).
michele
Le #26325213
Le Moustique : les deux bus USB utilisent le même régulateur
de tension... et je ne serais pas étonné que ce soit lui qui
déconne. Ce qui pour Michèle n'est pas bon du tout...



Put**n, dis pas ça, Guillauuuuuuuuuume.
C'est un truc dans le genre que je crains.
Un truc irrémédiable, tu vois... F*******************ck.

Et ce qui me fait chier, c'est que c'est le MBP que j'avais trouvé pour
le gosse de JM (et qui a fonctionné parfaitement nickel tout le temps
que le gosse l'a utilisé. C'est à dire tous les jours pendant 6 mois, si
je me souviens bien).
Et le MBP a été racheté par Philippe, si tu vois ce que je veux dire.
Le MBP a déconné moins d'1 mois après l'achat, juste au moment où
Philippe en avait le plus besoin.
Et le gosse s'en est servi passablement pour du jeu en tapant à
répétition sur le clavier...
JM sait plus où se foutre (il vient pas sur fcsm, donc je peux en
parler).
Si c'est une tuile de clavier, y'en aura pour 65 euros max en achat
garanti chez note x ou moins sur LBCoin.
Si c'est autre chose, je te dis pas la merde.
Philippe sait plus quoi faire (enfin, je lui ai remis une bécane pour
ici, sauf qu'elle devait partir à son bureau. Il est donc à cheval sur
une bécane d'un collègue au bureau) + JM lâche regarde ses godasses
+ moi, je siffle aux alouettes l'air de pas y être.

En attendant :

Réponse de Seb sur Ordinosaure : la membrane du clavier
fonctionne comme une grille, avec un fil pour toute une ligne
de touches, des fils pour les colonnes et les touches
établissent des connexions aux croisements.
Si ça se trouve, c'est bien la cause du problème



Ma réponse à Seb :

J'ai démonté la bestiole pour nettoyer à l'alcool à 90.

Je n'ai enlevé et nettoyé que le cache noir qui a une petite nappe qui
sert à allumer les loupiotes du rétroéclairage du clavier + le cache
transparent avec quelques sérigraphies blanches dessus.

La nappe du pad est indépendante.

Il y a en tout 4 nappes : loupiotes / clavier / pad + la mini-nappe qui
va au tient le bouton de boot à l'emplacement qui va bien.

J'ai décroché/raccroché les diverses nappes + croisé les tests avec
souris externe seule / clavier externe seul / souris + clavier externes.
Le resultat est qu'effectivement le clavier fout le dawa.

Il rend marteau le pad indépendant + le bouton de boot (5/6 redémarrages
tout seul en boucle) et les périphs externes alors qu'ils ne sont pas
sur la même nappe...

Je ne peux pas déconnecter le clavier + fonctionner avec des periphs
externes en attendant d'avoir une soluce car sinon... gn'a plus de
bouton de boot...

Note : le boot est très lent. La loupiote extérieure s'allume après 2 à
4 secondes après que j'ai appuyé sur le bouton. Elle clignotte au bout
de 8 secondes. Et le bruit d'éjection du lecteur optique qui annonce le
boot du disque se fait au bout de 11 à 12 secondes. Normalement, la
séquence appui/loupiotte/éjection dvd/lancement disque est pliée en 2
secondes (je ne parle pas du boot complet pour arriver au bureau).

Bref. Je vais peut-être redémonter pour nettoyer au micro-millimètre la
ligne w, x, c,... mais je ne suis pas sûre que ça arrange grand chose.

A priori, tous les claviers d'unibody A1286 (du Late 2008 au mid 2012
NON retina) sont identiques.
iFixit ne vend pas le clavier seul, c'est upper case complet à un prix
prohibitif, mais sur leboncoin et ebay, y'a de quoi faire.

Je crois que je vais jsute faire des tests croisés avec un unibody Late
2008 pour confirmer puis acheter d'occase.

Mouala.

Je ne pige toujours pas comment un truc usb sur son bus perso et sa
nappe perso peut foutre un merdier pareil (je sais pas pourquoi, pour
moi, c'est étanche, ces machins usb-là).

2h30, rannnnnnnnnnnnnnnnnnnn.
Bon, une tisane et au lit, demain j'ai edf.
J.P
Le #26325219
In article (michele) wrote:

> Le Moustique : les deux bus USB utilisent le même régulateur
> de tension... et je ne serais pas étonné que ce soit lui qui
> déconne. Ce qui pour Michèle n'est pas bon du tout...

Put**n, dis pas ça, Guillauuuuuuuuuume.
C'est un truc dans le genre que je crains.
Un truc irrémédiable, tu vois... F*******************ck.



In article (michele) wrote:

> Le Moustique : les deux bus USB utilisent le même régulateur
> de tension... et je ne serais pas étonné que ce soit lui qui
> déconne. Ce qui pour Michèle n'est pas bon du tout...

Put**n, dis pas ça, Guillauuuuuuuuuume.
C'est un truc dans le genre que je crains.
Un truc irrémédiable, tu vois... F*******************ck.



Bonjour Michèle,

j'ai lu ton problème en diagnale et ne sais si ça te servira.
Ici j'ai plusieurs touches en haut à gauche du clavier filaire de mon
iMac alu mid2007 qui sont mortes.
Avec KeyRemap4MacBook je le ai "remappées" en haut du clavier numérique
sur les touches qui ne me servent pas.
Cela marche impecable depuis des mois.
Mon OS es 10.6.8
KeyReMapMacBook 8.4.0


Vu le tas de Vierges ici, je devrais bien trouver celle des clavier et
lui offir un cierge ... :-)
JPK, n'est pas invité à collaborer à l'exposé de la chose ... :-)

--
Jean-Pierre
DuboisP
Le #26325221
Le 26/11/2014 02:08, michele a écrit :


Merci à tous... même si je ne pige toujours pas comment un truc usb sur
son bus perso et sa nappe perso peut foutre un merdier pareil (je sais
pas pourquoi, pour moi, c'est étanche, ces machins usb-là).



parce qu'il n'a pas son contrôleur perso ?

des claviers de PC, j'en ai qui défaillent, de temps en temps
à 10€ pièce, on ne prend pas la peine de démonter, c'est trop cher :-)
michele
Le #26325224
C'est un clavier de portable.
michele
Le #26325225
J'ai un truc dans le même genre pur remapper, c'est fonctionflip.
Mais là, le clavier provoque un problème qui affecte tout le bus usb.
Je n'ai même pas à me servir du clavier pour qu'il foute le dawa sur le
pad (qui a sa nappe indépendante), le bouton de boot et les périphs usb
externes...
Mais merci d'avoir essayé de m'aider ;o)

Ça va sur le Machu Picchu ?
Pascal-J
Le #26325261
iFixit ne vend pas le clavier seul, c'est upper case complet à un prix


prohibitif, mais sur leboncoin et ebay, y'a de quoi faire.

Vu a 16$ sur amazon .....chinois pur jus ;>)
michele
Le #26325275
Pascal-J : Donc bien un probleme dans le cablage du clavier,
nappe a isolant abimé touchant au chassis par exemple.



Bon, c'est rassurant. S'il ne faut que changer le clavier...

Mais pourquoi le clavier aurai il un controlleur usb integré ?



J'en sais rien, je suis nulle à ce point de connaissance.
D'où mes questionnements.

A voir la nappe sur les petites photos qui trainenet sur le
net, cablage matriciel a 99% pour moi



Là, tu me parles chinois.

Merci pour l'aide.
Publicité
Poster une réponse
Anonyme