Clef wifi USB reconnue ne détecte pas de réseau

Le
Seb
Bonjour !


J'ai une clef USB wifi (TP-Link TL-WN727N) qui utilise un chipset Ralink:

~>lsusb | grep -i wireless
Bus 001 Device 016: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070
Wireless Adapter

Elle est reconnue par le système dès que je la branche:

~>ifconfig -a
[snip]
wlan0 Link encap:Ethernet HWaddr 54:e6:fc:92:72:00
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

~>iw wlan0 info
Interface wlan0
ifindex 13
type managed

~>lsmod | grep rt2
rt2870sta 326811 0
rt2800usb 24919 0
rt2x00usb 5713 1 rt2800usb
rt2x00lib 19101 2 rt2800usb,rt2x00usb
led_class 1757 1 rt2x00lib
mac80211 123570 2 rt2x00usb,rt2x00lib
cfg80211 87657 2 rt2x00lib,mac80211
crc_ccitt 1039 2 rt2870sta,rt2800usb
usbcore 98733 7 rt2870sta,rt2800usb,rt2x00usb,usbhid,ohci_hcd,ehci_hcd

Problème: je ne parviens pas à détecter de signal wifi. *Aucun* signal
wifi, ce n'est pas seulement celui de ma Freebox qui n'apparaît pas: ceux
des voisins n'apparaissent pas non plus.

~#iwlist wlan0 scan
wlan0 No scan results

~>nmcli dev wifi
SSID BSSID MODE
FREQ RATE SIGNAL SECURITY ACTIVE
~>

~#wicd-client -n
-> fenêtre et la mention "No wireless networks found."

Quand j'ai testé cette clef sous Windows, je n'avais pas ce problème: une
dizaine de signaux wifi étaient captés, dont celui de ma Freebox. Donc la
clef fonctionne.

Précisions importantes:

* Je suis en Debian stable.

* Je connais assez bien Linux, mais je n'ai /jamais/ utilisé de wifi
auparavant; il est donc très possible que j'aie raté un truc évident et
essentiel à ce sujet.

* Je n'utilise pas Gnome/KDE/etc., mais fvwm2, et je n'ai pas de clic-clic
bien enrobé pour lancer network-manager (quand je lance nm-applet en
ligne de commande, il ne se passe rien, sauf que le prompt est
mobilisé).

* Pour faire comme dit dans la doc de network-manager, j'ai commenté
toutes les lignes concernant wlan0 dans /etc/network/interfaces.

* Quand je mets les lignes suivantes dans /etc/network/interfaces:
auto wlan0
iface wlan0 inet dhcp
wpa-ssid <snip:nom-du-réseau>
wpa-psk <snip:mot-de-passe>
et que je lance /etc/init.d/networking restart, l'établissement d'une
connexion échoue:
Listening on LPF/wlan0/54:e6:fc:92:72:00
Sending on LPF/wlan0/54:e6:fc:92:72:00
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 5
[etc.]

* En suivant des tutos en ligne, j'ai fait pas mal de manips type enlever
tel driver par rmmod, le blacklist, etc. Rien n'a marché. J'ai tout
remis en l'état de départ. Mais après avoir débranché et rebranché la
clef, c'est tombé en marche: "iwlist wlan0 scan" me donnait une dizaine
de réseaux. J'étais hélas incapable de savoir ce qui avait produit cet
effet (qui ne s'est manifesté qu'après avoir débranché/rebranché la
clef). J'ai rebooté et patatras: mêmes symptômes que ci-dessus, plus de
réseau détecté, que je boote avec la clef branchée ou non. Je ne sais
vraiment pas ce qui a fait temporairement la différence et je n'ai pas
réussi à retomber dessus par hasard. Moralité quand même: ça *peut*
marcher, ça *a* marché, c'est juste un problème de config qui me
dépasse.

* Enfin, un ami qui a la même clef me dit que sur son Ubuntu 11.04, le
clic-clic de Gnome fait marcher la clef tandis que "iwlist wlan0 scan"
ne renvoie rien en ligne de commande. À l'évidence son clic-clic fait un
truc supplémentaire, mais quoi


J'aimerais beaucoup réussir à faire enfin marcher cette clef, vous avez
sans doute compris que j'y ai déjà passé pas mal de temps Tout conseil
sera le bienvenu, merci d'avance !


Seb.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/Pine.LNX.4.58.1105062001180.24267@ybpnyubfg.ybpnyqbznva
Vos réponses Page 2 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jean Baptiste Favre
Le #23346011
Bonjour,

Le 09/05/11 08:59, giggzounet a écrit :
Salut,

Le 06/05/2011 23:40, Seb a écrit :
Bonsoir,



[snip]

as tu regardé si ta clé a un "rfkill" ?
install le paquet du même nom. lire le man...

mais je ne pense pas que ça vienne de là. car si ton rfkill était à on,
tu n'aurais pas d'interface wlan0 visible.


Pas tout à fait exact: rfkill possède 2 type de kill switch: hard et soft.

Dans le premier cas, il s'agit en général de l'interrupteur hardware (si
présent).
Dans ce cas là effectivement, la carte n'est généralement pas reconnue.

Dans le second cas en revanche, il s'agit d'un switch logiciel (qui
suppose donc que la carte soit reconnue).

Exemple chez moi:
# rfkill list
0: sony-wifi: Wireless LAN
Soft blocked: yes
Hard blocked: no
1: sony-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no
2: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
3: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

# ifconfig -a
# ip link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast
state UP qlen 1000
link/ether 00:24:be:b8:e2:55 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN qlen 1000
link/ether 2c:81:58:e9:bf:b2 brd ff:ff:ff:ff:ff:ff


Donc oui, rfkill est définitivement une bonne piste ;)

Mes 2 cents,
JB
| # /etc/network/interfaces
| allow-hotplug wlan0
| auto wlan0
| iface wlan0 inet dhcp
| wireless-essid<SSID>
| wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

Je n'ai pas encore configuré wpa_supplicant, je me dis que cela vient en
aval de la détection de réseaux.



Ce que tu peux faire pour tester:
tu vires ces lignes du fichier interface:
wpa-ssid
wpa-psk

et tu fais un fichier de conf wpa_supplicant. Ensuite tu lances en mode
debug wpa_supplicant dessus. je sais c'est po très clair :D mais je suis
au boulot et j'ai pas trop de doc sous la main :D

pour les exemples de fichiers de conf:
/usr/share/doc/wpasupplicant/example

(attention dans certaines versions de wpa_supplicant, le monsieur est
capricieux: parfois il faut mettre des guillements autour des
password/passphrase, parfois non...lire le man et tester...)

pour lancer wpa_supplicant:
sudo wpa_supplicant -iMoninterfaceWifi -c Monfichierdeconf -d -K

Je n'ai jamais réussi à faire marcher du wifi direct en dur dans
/etc/network/interfaces. J'utilise le roaming de wpa_supplicant. lire la
doc de wpa_supplicant c'est bien expliqué et ça marche!

en espérant t'avoir donné des pistes.
GiGGz

[snip]




--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Seb
Le #23358401
Bonjour,


| > as tu regardé si ta clé a un "rfkill" ?

Merci pour le pointeur; j'ai testé; mais pas de problème de blocage.

Pour information, j'ai aussi pris contact avec les développeurs de
Network-Manager via IRC et ils ne voient pas bien pourquoi la clef est
reconnue et aisément utilisable sous Ubuntu+Gnome alors qu'elle ne détecte
aucun réseau par iwlist que ce soit sous Debian+fvwm ou Ubuntu+Gnome
(iwlist reste muet même quand la clef est en train de fonctionner grâce à
nm-applet). D'après eux, la détection de réseau par NM est un enrobage
autour de iwlist justement. Je suppose que l'enrobage est particulièrement
bien fait...

Autre info: pour lancer nm-applet depuis fvwm, il faut installer un
systray, par exemple stalonetray. À partir de là j'ai bien une icône pour
NM; elle ne détecte aucun réseau (alors qu'elle devrait en voir une
dizaine) mais si je lui indique le nom de mon réseau wifi (sur Freebox)
elle parvient à se connecter -- mais seulement en mode ad hoc,
c'est-à-dire en établissant une connexion point à point dont on ne peut
pas sortir.

La solution n'est pas encore là, mais il y a un peu de progrès...


Seb.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Raphaël RIGNIER
Le #23358391
Le 13/05/2011 18:15, Seb a écrit :
Bonjour,


|> as tu regardé si ta clé a un "rfkill" ?

Merci pour le pointeur; j'ai testé; mais pas de problème de blocage.

Pour information, j'ai aussi pris contact avec les développeurs de
Network-Manager via IRC et ils ne voient pas bien pourquoi la clef est
reconnue et aisément utilisable sous Ubuntu+Gnome alors qu'elle ne détecte
aucun réseau par iwlist que ce soit sous Debian+fvwm ou Ubuntu+Gnome
(iwlist reste muet même quand la clef est en train de fonctionner grâce à
nm-applet). D'après eux, la détection de réseau par NM est un enrobage
autour de iwlist justement. Je suppose que l'enrobage est particulièrement
bien fait...

Autre info: pour lancer nm-applet depuis fvwm, il faut installer un
systray, par exemple stalonetray. À partir de là j'ai bien une icône pour
NM; elle ne détecte aucun réseau (alors qu'elle devrait en voir une
dizaine) mais si je lui indique le nom de mon réseau wifi (sur Freebox)
elle parvient à se connecter -- mais seulement en mode ad hoc,
c'est-à-dire en établissant une connexion point à point dont on ne peut
pas sortir.

La solution n'est pas encore là, mais il y a un peu de progrès...


Seb.



Un idée comme ça :
Il arrive parfois que certains chipsets soient bridés à une certaine
plage de canaux en fonction de la zone choisie.
En principe les utilitaires sous windows permettent de choisir sa
région. Si on sors de la plage définie, point de détection.
Par exemple France = 11-13 et Europe=1-13.
Peut être un truc comme ça ?

Raphaël

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Seb
Le #23358381
Bonjour Raphaël,


| Il arrive parfois que certains chipsets soient bridés à une certaine
| plage de canaux en fonction de la zone choisie. En principe les
| utilitaires sous windows permettent de choisir sa région. Si on sors de
| la plage définie, point de détection. Par exemple France = 11-13 et
| Europe=1-13. Peut être un truc comme ça ?

Piste intéressante, mais qui ne colle pas bien avec le fait que la clef
marche parfaitement dans un environnement Ubuntu+Gnome (ou Windows),
désolé de ne pas avoir redonné cette info dans le mail précédent.
Je cherche plutôt une explication dans la direction d'Ubuntu ou de Gnome.


Seb.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
corbie
Le #23358741
Le vendredi 13 mai 2011, Seb a écrit :
Piste intéressante, mais qui ne colle pas bien avec le fait que la clef
marche parfaitement dans un environnement Ubuntu+Gnome (ou Windows),
désolé de ne pas avoir redonné cette info dans le mail précéden t.
Je cherche plutôt une explication dans la direction d'Ubuntu ou de Gn ome.



Et avec Debian Squeeze sous GNOME ? :
la clé USB WiFi fonctionne ?

Jamais réussi à connecter la wifi après une Lenny upgradée =>Sque eze
sous KDE ...
Par contre avec le bureau GNOME, aucun problème.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Seb
Le #23358791
Hello,


| Et avec Debian Squeeze sous GNOME ? :
| la clé USB WiFi fonctionne ?

Hélas je n'ai pas de moyen simple de le tester: le CD d'Ubuntu peut être
utilisé en Live, pas celui de Debian il me semble. (Mais ça fait bien
longtemps que je n'ai pas booté un CD de Debian: je migre de version en
version.) Je ne tiens pas vraiment à installer Gnome sur ma machine
d'usage.

| Jamais réussi à connecter la wifi après une Lenny upgradée =>Squeeze
| sous KDE ... Par contre avec le bureau GNOME, aucun problème.

Tiens, c'est bizarre et intéressant ! Parmi les pistes, ce serait donc
plutôt Gnome qui fait quelque chose de spécial, pas Ubuntu...


Seb.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
corbie
Le #23358981
Le vendredi 13 mai 2011, Seb a écrit :
| Et avec Debian Squeeze sous GNOME ? :
| la clé USB WiFi fonctionne ?

Hélas je n'ai pas de moyen simple de le tester: le CD d'Ubuntu peut ê tre
utilisé en Live, pas celui de Debian il me semble. (Mais ça fait bien
longtemps que je n'ai pas booté un CD de Debian: je migre de version en
version.) Je ne tiens pas vraiment à installer Gnome sur ma machine
d'usage :



Ici je pense :
http://www.debian.org/CD/live/

| Jamais réussi à connecter la wifi après une Lenny upgradée => Squeeze
| sous KDE ... Par contre avec le bureau GNOME, aucun problème.

Tiens, c'est bizarre et intéressant ! Parmi les pistes, ce serait donc
plutôt Gnome qui fait quelque chose de spécial, pas Ubuntu...
Seb.



Désolé, j'avais mal suivi le thread : tu es donc sous Ubuntu.
Essaye alors d'installer GNOME sous Ubuntu et vois si il connecte le WiFi.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Seb
Le #23359041
| http://www.debian.org/CD/live/

Merci pour le pointeur, je télécharge pour faire l'essai.

| Désolé, j'avais mal suivi le thread : tu es donc sous Ubuntu.

Non, je suis sous Debian Squeeze. Juste, le seul Gnome que j'avais sous la
main était sur un live CD d'Ubuntu.


Seb.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
corbie
Le #23359161
Le vendredi 13 mai 2011, Seb a écrit :
| http://www.debian.org/CD/live/
Merci pour le pointeur, je télécharge pour faire l'essai.



Je suis aussi intéressé car ce sera intéressant de voir si tu as eu l e
même problème que moi.
Déjà décrit sur la ML (WiFi) :
Squeeze + KDE : non,
Squeeze + GNOME : oui.

:-)

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
corbie
Le #23385381
Le vendredi 13 mai 2011, Seb a écrit :
Je cherche plutôt une explication dans la direction d'Ubuntu ou de Gn ome.
Seb.


---------------------

Je n'ai pas vu passer la suite et fin sur ce sujet.

Elle m'aurait intéressé :
sous Squeeze et KDE-4, je n'arrive pas à connecter ma Box via WiFi,
par contre sous Gnome = OUI.

Merci d'un petit retour si résolu ou pas.


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme