Connexion bureau ̓  distance et clavier fran̓§ais

Le
Olivier Miakinen
Bonjour,

J'ai un problème non systématique mais très fréquent, et particulièrement
pénible quand ça arrive, et j'aimerais comprendre pourquoi.

Je fais une 'Connexion bureau Í  distance' d'un Windows 10 vers un Windows
server 2008. Parfois tout se passe bien et je reste en clavier français.
Mais assez souvent je me retrouve avec un clavier anglais. Dans ce cas,
j'ai beau repasser en clavier français, le clavier repasse tout seul en
anglais, en particulier lorsque je lance un Windows powershell.

J'ai même essayé de virer carrément le clavier anglais de la configuration,
mais rien n'y fait, il arrive toujours Í  se réinstaller.

Je n'ose pas en venir aux séances d'exorcisme et de désenvoutement est-ce
que je pourrais espérer trouver une explication rationnelle ?

Cordialement,
--
Olivier Miakinen
  • Partager ce contenu :
Vos réponses Page 1 / 2
Trier par : date / pertinence
DuboisP
Le #26561619
Le 02/12/2020 Í  01:17, Olivier Miakinen a écrit :
Bonjour,
J'ai un problème non systématique mais très fréquent, et particulièrement
pénible quand ça arrive, et j'aimerais comprendre pourquoi.
Je fais une 'Connexion bureau Í  distance' d'un Windows 10 vers un Windows
server 2008. Parfois tout se passe bien et je reste en clavier français.
Mais assez souvent je me retrouve avec un clavier anglais. Dans ce cas,
j'ai beau repasser en clavier français, le clavier repasse tout seul en
anglais, en particulier lorsque je lance un Windows powershell.
J'ai même essayé de virer carrément le clavier anglais de la configuration,
mais rien n'y fait, il arrive toujours Í  se réinstaller.
Je n'ose pas en venir aux séances d'exorcisme et de désenvoutement... est-ce
que je pourrais espérer trouver une explication rationnelle ?
Cordialement,

ce n'est plus supporté, Windows Server 2008, il faut upgrader / changer.
les paramêtres de session sont ceux du Server, qui n'a probablement de
configuration clavier français, et c'est lui qui commande.
d'autant plus dans un Powershell.
peut-être changer la configuration systématiquement en entrée de
Powershell, mais il est possible que la version du Server soit ancienne
et ne le supporte pas.
https://akril.net/change-keyboard-layout-in-one-command/
pehache
Le #26561699
Le 02/12/2020 Í  01:17, Olivier Miakinen a écrit :
Bonjour,
J'ai un problème non systématique mais très fréquent, et particulièrement
pénible quand ça arrive, et j'aimerais comprendre pourquoi.
Je fais une 'Connexion bureau Í  distance' d'un Windows 10 vers un Windows
server 2008. Parfois tout se passe bien et je reste en clavier français.
Mais assez souvent je me retrouve avec un clavier anglais. Dans ce cas,
j'ai beau repasser en clavier français, le clavier repasse tout seul en
anglais, en particulier lorsque je lance un Windows powershell.
J'ai même essayé de virer carrément le clavier anglais de la configuration,
mais rien n'y fait, il arrive toujours Í  se réinstaller.
Je n'ose pas en venir aux séances d'exorcisme et de désenvoutement... est-ce
que je pourrais espérer trouver une explication rationnelle ?
Cordialement,


J'ai résolu mon problème de clavier en faisant du Remote Desktop depuis
un Mac vers un PC Win 10 (claviers différents, même en Azerty), le jour
o͹ dans l'appli "MS Remote Desktop" j'ai découvert le menu "Connections
--> Keyboard Mode --> Unicode".
Olivier Miakinen
Le #26561713
Bonjour,
Le 02/12/2020 08:44, DuboisP m'a répondu :
ce n'est plus supporté, Windows Server 2008, il faut upgrader / changer.

Ça, ce n'est pas de mon ressort. Je sais qu'il y a encore six mois c'était
un Windows encore plus ancien (2003, ça existe ? je crois que c'était un
truc comme ça) et le fait d'être passé en 2008 pose déjÍ  des problèmes.
Parce que cet ordinateur sert Í  faire des corrections sur de très vieux
programmes qui sont encore supportés pour quelques clients de l'entreprise
o͹ je suis employé.
les paramêtres de session sont ceux du Server, qui n'a probablement de
configuration clavier français, et c'est lui qui commande.
d'autant plus dans un Powershell.

Mais si, la configuration du clavier français existe, et tant que j'ai une
icone [FR] en bas Í  droite de l'écran mon clavier fonctionne sans problème.
Mais régulièrement cette icone change pour [EN] et mon clavier se comporte
alors comme un QWERTY jusqu'Í  ce que je sélectionne de nouveau [FR].
peut-être changer la configuration systématiquement en entrée de
Powershell, mais il est possible que la version du Server soit ancienne
et ne le supporte pas.
https://akril.net/change-keyboard-layout-in-one-command/

Merci, je vais essayer ça. Il y a un fichier de commande, du style du
/etc/profile ou ~/.profile Unix, qui pourrait se lancer automatiquement
au démarrage d'un PowerShell ?
--
Olivier Miakinen
Olivier Miakinen
Le #26561714
Le 02/12/2020 18:38, pehache a écrit :
J'ai résolu mon problème de clavier en faisant du Remote Desktop depuis
un Mac vers un PC Win 10 (claviers différents, même en Azerty), le jour
o͹ dans l'appli "MS Remote Desktop" j'ai découvert le menu "Connections
--> Keyboard Mode --> Unicode".

Je vais essayer de trouver l'équivalent sur Windows, mais je crois avoir
déjÍ  cherché sans résultat. Bon, je ne désespère pas.
Note quand même que le problème n'est pas seulement au lancement du
"remote desktop" (je suppose que c'est le nom anglais pour "bureau Í 
distance"), mais surtout que le clavier change plusieurs fois en cours
de session.
--
Olivier Miakinen
Olivier Miakinen
Le #26561717
Le 02/12/2020 19:57, je répondais Í  DuboisP :
peut-être changer la configuration systématiquement en entrée de
Powershell, mais il est possible que la version du Server soit ancienne
et ne le supporte pas.
https://akril.net/change-keyboard-layout-in-one-command/

Merci, je vais essayer ça.

Comme tu l'avais craint, les commandes proposées sur cette page ou sur
la page référencée depuis celle-ci ne sont pas supportées dans cette
version de PowerShell, qu'il s'agisse de 'Set-WinUserLanguageList' ou
de 'ipmo international'.
En attendant j'ai de nouveau supprimé la configuration [EN] (qui était
revenue magiquement quelques jours après que je l'avais supprimée la
première fois). Pour voir, j'ai ajouté une configuration [DE], et j'ai
remis un raccourci clavier 'Ctrl+1' pour forcer la configuration [FR],
raccourci qui avait disparu lui aussi.
Pour le moment ça tient. On verra pour combien de temps.
Cela dit, j'aurais quand même bien aimé comprendre pourquoi lancer un
PowerShell remettait systématiquement la config [EN] tant qu'elle
existait.
--
Olivier Miakinen
Olivier Miakinen
Le #26561716
Le 02/12/2020 20:02, je répondais Í  pehache :
J'ai résolu mon problème de clavier en faisant du Remote Desktop depuis
un Mac vers un PC Win 10 (claviers différents, même en Azerty), le jour
o͹ dans l'appli "MS Remote Desktop" j'ai découvert le menu "Connections
--> Keyboard Mode --> Unicode".

Je vais essayer de trouver l'équivalent sur Windows, mais je crois avoir
déjÍ  cherché sans résultat. Bon, je ne désespère pas.

Non, je ne trouve vraiment rien de la sorte. J'ajoute que je n'ai jamais
été Í  l'aise avec l'environnement de Windows, même si je suis obligé de
l'utiliser au boulot. J'ai toujours préféré Unix ou Linux.
--
Olivier Miakinen
pehache
Le #26561718
Le 02/12/2020 Í  20:43, Olivier Miakinen a écrit :
Le 02/12/2020 20:02, je répondais Í  pehache :
J'ai résolu mon problème de clavier en faisant du Remote Desktop depuis
un Mac vers un PC Win 10 (claviers différents, même en Azerty), le jour
o͹ dans l'appli "MS Remote Desktop" j'ai découvert le menu "Connections
--> Keyboard Mode --> Unicode".

Je vais essayer de trouver l'équivalent sur Windows, mais je crois avoir
déjÍ  cherché sans résultat. Bon, je ne désespère pas.

Non, je ne trouve vraiment rien de la sorte. J'ajoute que je n'ai jamais
été Í  l'aise avec l'environnement de Windows, même si je suis obligé de
l'utiliser au boulot. J'ai toujours préféré Unix ou Linux.

Le client RDP Windows a effectivement l'air assez différent du client
RDP macOS, et je ne saurais t'aider plus :-(
DuboisP
Le #26561742
Le 02/12/2020 Í  20:39, Olivier Miakinen a écrit :
Le 02/12/2020 19:57, je répondais Í  DuboisP :
peut-être changer la configuration systématiquement en entrée de
Powershell, mais il est possible que la version du Server soit ancienne
et ne le supporte pas.
https://akril.net/change-keyboard-layout-in-one-command/

Merci, je vais essayer ça.

Comme tu l'avais craint, les commandes proposées sur cette page ou sur
la page référencée depuis celle-ci ne sont pas supportées dans cette
version de PowerShell, qu'il s'agisse de 'Set-WinUserLanguageList' ou
de 'ipmo international'.
En attendant j'ai de nouveau supprimé la configuration [EN] (qui était
revenue magiquement quelques jours après que je l'avais supprimée la
première fois). Pour voir, j'ai ajouté une configuration [DE], et j'ai
remis un raccourci clavier 'Ctrl+1' pour forcer la configuration [FR],
raccourci qui avait disparu lui aussi.
Pour le moment ça tient. On verra pour combien de temps.
Cela dit, j'aurais quand même bien aimé comprendre pourquoi lancer un
PowerShell remettait systématiquement la config [EN] tant qu'elle
existait.

fonctionnalité Windows / Office
Í  une époque, et ça s'est calmé, Word passait en qwerty quand il
détectait du texte en anglais
Olivier Miakinen
Le #26561767
Le 03/12/2020 08:18, DuboisP m'a répondu :
Cela dit, j'aurais quand même bien aimé comprendre pourquoi lancer un
PowerShell remettait systématiquement la config [EN] tant qu'elle
existait.

fonctionnalité Windows / Office
Í  une époque, et ça s'est calmé, Word passait en qwerty quand il
détectait du texte en anglais

En l'occurrence Word n'est même pas installé sur cette machine. Cela dit c'est
peut-être le même bug dans les deux programmes : quand on lance PowerShell il
affiche les deux lignes « Windows PowerShell » et « Copyright (C) 2016 Microsoft
Corporation. All rights reserved. », je ne sais pas si ça lui suffit pour croire
qu'on est en anglais.
Sinon, j'ai deux infos supplémentaires.
La première, c'est que l'on peut avoir deux bureaux Í  distance ouverts en même
temps sur la même machine, l'un d'eux se mettant par défaut en français et y
restant (conformément Í  la config) alors que l'autre présente le bug d'être
par défaut en anglais et d'y revenir régulièrement.
La deuxième info, c'est que maintenant que j'ai viré le clavier anglais pour y
mettre le clavier allemand, le bureau Í  distance qui a le bug passe quand même
en anglais, bien que cette configuration de clavier ait été supprimée ! Sur
la session sans bug j'ai les icones [FR] et [DE] comme choix de langue, alors
que sur la session avec bug j'ai [FR] et [EN]. Et sur la session avec bug mon
raccourci Ctrl+1 pour repasser en français a été supprimé alors qu'il est
toujours présent sur la session sans bug.
--
Olivier Miakinen
DuboisP
Le #26561769
Le 03/12/2020 Í  10:44, Olivier Miakinen a écrit :
Le 03/12/2020 08:18, DuboisP m'a répondu :
Cela dit, j'aurais quand même bien aimé comprendre pourquoi lancer un
PowerShell remettait systématiquement la config [EN] tant qu'elle
existait.

fonctionnalité Windows / Office
Í  une époque, et ça s'est calmé, Word passait en qwerty quand il
détectait du texte en anglais

En l'occurrence Word n'est même pas installé sur cette machine. Cela dit c'est
peut-être le même bug dans les deux programmes : quand on lance PowerShell il
affiche les deux lignes « Windows PowerShell » et « Copyright (C) 2016 Microsoft
Corporation. All rights reserved. », je ne sais pas si ça lui suffit pour croire
qu'on est en anglais.
Sinon, j'ai deux infos supplémentaires.
La première, c'est que l'on peut avoir deux bureaux Í  distance ouverts en même
temps sur la même machine, l'un d'eux se mettant par défaut en français et y
restant (conformément Í  la config) alors que l'autre présente le bug d'être
par défaut en anglais et d'y revenir régulièrement.
La deuxième info, c'est que maintenant que j'ai viré le clavier anglais pour y
mettre le clavier allemand, le bureau Í  distance qui a le bug passe quand même
en anglais, bien que cette configuration de clavier ait été supprimée ! Sur
la session sans bug j'ai les icones [FR] et [DE] comme choix de langue, alors
que sur la session avec bug j'ai [FR] et [EN]. Et sur la session avec bug mon
raccourci Ctrl+1 pour repasser en français a été supprimé alors qu'il est
toujours présent sur la session sans bug.


tu as supprimé les claviers sur ton PC ou sur le serveur ?
sur le serveur, quand tu supprimes un clavier, tu le fais dans la
session, et sauf erreur, après fermeture-réouverture, tu retrouves
normalement les paramêtres serveur.
bon, je ne peux plus tester beaucoup, je n'ai plus accès Í  un serveur
depuis que j'ai pris ma retraite, et je n'en ai pas en VM
Poster une réponse
Anonyme