DD Maxtor dans un boitier externe

Le
Xavier Maillard
Salut la liste,

Je viens de me payer un disque dur de marque Maxtor (250 Go) que j'ai placé
dans un boitier externe lui-même branché sur le port USB (2.0) de ma machine.
Le tout est alimenté complètement par une alimentation externe (ce n'est pas
le port USB qui fournit le courant).

Lorsque j'allume le tout et que je regarde dans les logs, j'obtiens des
messages que je vous copie ici:

Dec 29 23:47:28 localhost kernel: usb 4-2: new high speed USB device using ehci_hcd and address 6
Dec 29 23:47:28 localhost kernel: scsi2 : SCSI emulation for USB Mass Storage devices
Dec 29 23:47:28 localhost kernel: usb-storage: device found at 6
Dec 29 23:47:28 localhost kernel: usb-storage: waiting for device to settle before scanning
Dec 29 23:47:39 localhost kernel: usb 4-2: reset high speed USB device using ehci_hcd and address 6
Dec 29 23:48:04 localhost last message repeated 3 times
Dec 29 23:48:05 localhost kernel: scsi: Device offlined - not ready after error recovery: host 2 channel 0 id 0 lun 0
Dec 29 23:48:05 localhost kernel: usb-storage: device scan complete

Bref, il n'apparait pas, aucun périphérique n'est créé malgré la présence de
tous les modules nécessaires dans le noyau.

Sur un forum, on dit qu'il faudrait que j'essaie de partitionner le disque dur
en utilisant un ordinateur équipé de Microsoft Windows. C'est pas que je ne
veux pas le faire mais disons que, heu, je n'ai pas ce genre d'animal ici et
je ne connais personne dans mon entourage qui aurait ça sous la main.

Alors je m'en remets à vous. Y-a-t-il ne serait-ce que une chance que je
puisse me servir de ce beau disque dur tout neuf ? (C'est que j'ai tout mes
cédés à encoder moi ;)).

Ah oui j'allais oublier, j'essaie de faire ça sur une Debian SID et un noyau
sauce Debian pur souche (2.6.14).

Voilà, merci à tous et bon réveillon.

Xavier


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Patrice Karatchentzeff
Le #8451991
Xavier Maillard writes:

[...]

> Bref, il n'apparait pas, aucun périphérique n'est créé malgré la présence de
> tous les modules nécessaires dans le noyau.
>
> Sur un forum, on dit qu'il faudrait que j'essaie de partitionner le
> disque dur en utilisant un ordinateur équipé de Microsoft
> Windows. C'est pas que je ne veux pas le faire mais disons que,
> heu, je n'ai pas ce genre d'animal ici et je ne connais personne
> dans mon entourage qui aurait ça sous la main.
>
> Alors je m'en remets à vous. Y-a-t-il ne serait-ce que une chance que je
> puisse me servir de ce beau disque dur tout neuf ? (C'est que j'ai tout mes
> cédés à encoder moi ;)).


1) est-ce que ton disque a un système de fichier dessus ?
2) ce que j'essaierai :

2.1) récupérer le numéro sur la chaîne SCSI (enfin, vers où il
pointe)
2.2) cfdisk sur le périphérique
2.3) mk.ext3 dessus (ou ext2, si c'est juste pour y mettre des iso)

Tu peux essayer le 2.3 directement...

Bonne chance,

PK

PS : essaie aussi de booter une Ubuntu dessus, des fois, cela fait des
miracles :)

--
      |      _,,,---,,_       Patrice KARATCHENTZEFF
ZZZzz /,`.-'`'    -.  ;-;;,_   mailto:
     |,4-  ) )-,_. , (  `'-'  http://p.karatchentzeff.free.fr
    '---''(_/--'  `-'_)       


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Sylvain Sauvage
Le #8451981
Samedi 31 décembre 2005, 19:55:55 CET, Patrice Karatchentzeff a écrit :

Xavier Maillard writes:

[...]

> Bref, il n'apparait pas, aucun périphérique n'est créé malgr é la
> présence de tous les modules nécessaires dans le noyau.



Es-tu sûr que sd_mod est présent ?
J'ai remarqué qu'en ce moment, il n'était pas toujours chargé
automatiquement avec certains périphériques USB.

[...]
Bonne chance,



Itou

--
Sylvain Sauvage
Xavier Maillard
Le #8451971
Cc:
From: Patrice Karatchentzeff
Xavier Maillard writes:

[...]

> Bref, il n'apparait pas, aucun périphérique n'est créé malgré la présence de
> tous les modules nécessaires dans le noyau.
>
> Sur un forum, on dit qu'il faudrait que j'essaie de partitionner le
> disque dur en utilisant un ordinateur équipé de Microsoft
> Windows. C'est pas que je ne veux pas le faire mais disons que,
> heu, je n'ai pas ce genre d'animal ici et je ne connais personne
> dans mon entourage qui aurait ça sous la main.
>
> Alors je m'en remets à vous. Y-a-t-il ne serait-ce que une chance que je
> puisse me servir de ce beau disque dur tout neuf ? (C'est que j'ai tout mes
> cédés à encoder moi ;)).


1) est-ce que ton disque a un système de fichier dessus ?

Rien, nada.

2.3) mk.ext3 dessus (ou ext2, si c'est juste pour y mettre des iso)

Je veux bien mais comment faire si aucune entrée n'est créée dans /dev ?

Xavier


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Luc Coulon (f5ibh)
Le #8451961
--=-8z/C1p7ltPmKgY/fLin5
Content-Type: text/plain; charset=iso-8859-15; DelSp=Yes; Format=Flowed
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Le 31.12.2005 20:04:41, Sylvain Sauvage a écrit :
Samedi 31 décembre 2005, 19:55:55 CET, Patrice Karatchentzeff a écrit
:
>
> Xavier Maillard writes:
>
> [...]
>
> > Bref, il n'apparait pas, aucun périphérique n'est créé malgr é la
> > présence de tous les modules nécessaires dans le noyau.

Es-tu sûr que sd_mod est présent ?
J'ai remarqué qu'en ce moment, il n'était pas toujours chargé
automatiquement avec certains périphériques USB.

>[...]
> Bonne chance,

Itou



Mon BIOS "voit" le lecteur de carte USB avant de booter. Il le voit
comme un drive. Peut-être est-il vu aussi ?

Bonne réveillon, bonne année

Jean-Luc

--=-8z/C1p7ltPmKgY/fLin5
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQBDttt4UdGGXzzGnNARAuDoAKCXU3sgl9oenWo9hEP/gN8786gqsACgpJBe
BYglS/RmcKWLlMbQbRAiP5Y =WtPu
-----END PGP SIGNATURE-----

--=-8z/C1p7ltPmKgY/fLin5--


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Patrice Karatchentzeff
Le #8451941
Xavier Maillard writes:

[...]

> Je veux bien mais comment faire si aucune entrée n'est créée dans /dev ?

Est-ce que tu en sûr ? Fût un temps, je passais à « cat » tous les
périphériques SCSI susceptibles d'être concernés pour déterminer quel
était le bon...

PK

--
      |      _,,,---,,_       Patrice KARATCHENTZEFF
ZZZzz /,`.-'`'    -.  ;-;;,_   mailto:
     |,4-  ) )-,_. , (  `'-'  http://p.karatchentzeff.free.fr
    '---''(_/--'  `-'_)       


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Xavier Maillard
Le #8451931
From: "Jean-Luc Coulon (f5ibh)"
Le 31.12.2005 20:04:41, Sylvain Sauvage a écrit :
> Samedi 31 décembre 2005, 19:55:55 CET, Patrice Karatchentzeff a écrit
> :
> >
> > Xavier Maillard writes:
> >
> > [...]
> >
> > > Bref, il n'apparait pas, aucun périphérique n'est créé malgré la
> > > présence de tous les modules nécessaires dans le noyau.
>
> Es-tu sûr que sd_mod est présent ?
> J'ai remarqué qu'en ce moment, il n'était pas toujours chargé
> automatiquement avec certains périphériques USB.
>
> >[...]
> > Bonne chance,
>
> Itou

Mon BIOS "voit" le lecteur de carte USB avant de booter. Il le voit
comme un drive. Peut-être est-il vu aussi ?

Je ne comprends pas. Si je laisse la bestiole allumée lorssque je redémarre le
PC, ça prend trois plombes pour tout. Il n'y a que lorsque je décide de couper
le boitier que tout rentre dans l'ordre.

Bonne réveillon, bonne année

Bonne année à tous.


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Jean-Luc Coulon (f5ibh)
Le #8451921
--=-lviXIFt7sysov61PIXB/
Content-Type: text/plain; charset=iso-8859-1; DelSp=Yes; Format=Flowed
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

Le 01.01.2006 10:52:45, Xavier Maillard a écrit :
From: "Jean-Luc Coulon (f5ibh)"



Que dit lsusb une fois le PC démarré ?

Sur le laptop, voici ce que ça donne:

totoz:/home/zedek# lsusb
Bus 004 Device 007: ID 04b4:6830 Cypress Semiconductor Corp. USB-2.0
IDE Adapter



et ls -l /proc/bus/uab/004 ?
Quels sont les droits associés à ce périphérique ?

Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 002: ID 046d:c00f Logitech, Inc.
Bus 002 Device 001: ID 0000:0000


Que dit cat /proc/bus/usb/devices (ne donner que la partie
concernant
le disque)

totoz:/home/zedek# cat /proc/bus/usb/devices




....


T: Bus Lev Prnt Port Cnt Dev#= 7 SpdH0 M xCh= 0


...
C:* #Ifs= 1 Cfg#= 1 Atr MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 2 Cls(stor.) Sub ProtP
Driver=usb-storage



Là, c'est bon.



Voilà.

Merci à tous.

Xavier





Merci (prière de) ne pas me mettre en copie perso : je suis abonné à la
liste.

--=-lviXIFt7sysov61PIXB/
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQBDt6moXit3lz9m7V4RAjwoAJ0SChp9GYoxX4DeEATM9QN7P2PPigCeO62G
w+JDPXCt/+QbOSFZ7xNU9dk =1jo1
-----END PGP SIGNATURE-----

--=-lviXIFt7sysov61PIXB/--


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Xavier Maillard
Le #8451911
> > Bref, il n'apparait pas, aucun périphérique n'est créé malgré la


> > présence de tous les modules nécessaires dans le noyau.

Es-tu sûr que sd_mod est présent ?

Ce module manquait à l'appel mais le charger n'a rien donné de mieux.

Les mêmes messages remontent dans le journal.

Xavier


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Xavier Maillard
Le #8451891
From: "Jean-Luc Coulon (f5ibh)"
Le 01.01.2006 10:27:53, Xavier Maillard a écrit :
> From: "Jean-Luc Coulon (f5ibh)"
...

> Je ne comprends pas. Si je laisse la bestiole allumée lorssque je
> redémarre le
> PC, ça prend trois plombes pour tout. Il n'y a que lorsque je décide
> de couper
> le boitier que tout rentre dans l'ordre.

Là, c'est votre boîtier USB qui sème la grouille sur le bus USB.

Vérifiez si votre PC est configuré en USB2 HighSpeed pour le port USB
considéré.

Je ne sais pas du tout comment corriger cela sur ce PC. Rien dans le BIOS ne
me parle de ce genre de configuration pour l'USB.

Que dit lsusb une fois le PC démarré ?

Sur le laptop, voici ce que ça donne:

totoz:/home/zedek# lsusb
Bus 004 Device 007: ID 04b4:6830 Cypress Semiconductor Corp. USB-2.0 IDE Adapter
Bus 004 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 002 Device 002: ID 046d:c00f Logitech, Inc.
Bus 002 Device 001: ID 0000:0000


Que dit cat /proc/bus/usb/devices (ne donner que la partie concernant
le disque)

totoz:/home/zedek# cat /proc/bus/usb/devices

T: Bus Lev Prnt Port Cnt Dev#= 1 SpdH0 MxCh= 6
B: Alloc= 0/800 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 2.00 Cls (hub ) Sub Prot MxPS= 8 #Cfgs= 1
P: Vendor00 ProdID00 Rev= 2.06
S: Manufacturer=Linux 2.6.14-2-686 ehci_hcd
S: Product=EHCI Host Controller
S: SerialNumber00:00:1d.7
C:* #Ifs= 1 Cfg#= 1 Atrà MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls (hub ) Sub Prot Driver=hub
E: Ad(I) Atr(Int.) MxPS= 2 Ivl%6ms

T: Bus Lev Prnt Port Cnt Dev#= 7 SpdH0 MxCh= 0
D: Ver= 2.00 Cls(>ifc ) Sub Prot MxPSd #Cfgs= 1
P: Vendorb4 ProdIDh30 Rev= 0.01
S: Manufacturer=Cypress Semiconductor
S: Product=USB2.0 Storage Device
S: SerialNumber=6RO000067985
C:* #Ifs= 1 Cfg#= 1 AtrÀ MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 2 Cls(stor.) Sub ProtP Driver=usb-storage
E: Ad(O) Atr(Bulk) MxPS= 512 Ivl=0ms
E: Adˆ(I) Atr(Bulk) MxPS= 512 Ivl=0ms


Voilà.

Merci à tous.

Xavier


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Xavier Maillard
Le #8451871
Cc:
From: Patrice Karatchentzeff
Xavier Maillard writes:

[...]

> Je veux bien mais comment faire si aucune entrée n'est créée dans /dev ?

Est-ce que tu en sûr ? Fût un temps, je passais à « cat » tous les
périphériques SCSI susceptibles d'être concernés pour déterminer quel
était le bon...

J'en suis quasi sûr. Je viens de vérifier encore un fois et je n'ai rien.


Xavier


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme