donnes sur les jours fériés

Le
L-A
Bonjour et bonne année Excelliene !!

Voici mon premier souci de l'année

Sur un tableau avec tous les jours du mois considéré, je cherche =
à récupérer des données uniquement sur les jours f=
riés

J'ai une feuille ayant tous les jours fériés de l'année

voici la formule que j'ai pour les samedis et dimanches

mais cela ne marche pas pour les fériés car ca peut etre un jour =
différents du samedi et dimanche

=SOMMEPROD(($L5:$EE5=$B$51)*(JOURSEM(JRS)=7)) pour le samedi

=SOMMEPROD(($L5:$EE5=$B$51)*(JOURSEM(JRS)=1)) pour le dimanche

=(($L5:$EE5=$B$51) correspond aux cellules (fusionnées par 4) cont=
enant mes dates

merci de votre aide
Vos réponses Page 1 / 3
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #26458214
Bonsoir,
Excel n'aime pas les cellules fusionnées (et moi non plus). Cela amène
souvent des problèmes....
Pour les jours fériés, tu peux faire un tableau avec une recherche dedans
via ...RECHERCHE.
Mais, la meilleure solution, c'est d'attendre celle que Denis va
oposer. -))
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"L-A" a écrit dans le message de groupe de discussion :

Bonjour et bonne année Excelliene !!
Voici mon premier souci de l'année
Sur un tableau avec tous les jours du mois considéré, je cherche à récupérer
des données uniquement sur les jours fériés
J'ai une feuille ayant tous les jours fériés de l'année
voici la formule que j'ai pour les samedis et dimanches
mais cela ne marche pas pour les fériés car ca peut etre un jour différents
du samedi et dimanche
=SOMMEPROD(($L5:$EE5=$B$51)*(JOURSEM(JRS)=7)) pour le samedi
=SOMMEPROD(($L5:$EE5=$B$51)*(JOURSEM(JRS)=1)) pour le dimanche
=(($L5:$EE5=$B$51) correspond aux cellules (fusionnées par 4) contenant mes
dates
merci de votre aide
Jacquouille
Le #26458217
Lire bien évidemment " que Denis va proposer ..."
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Jacquouille" a écrit dans le message de groupe de discussion :
p2r912$qkg$
Bonsoir,
Excel n'aime pas les cellules fusionnées (et moi non plus). Cela amène
souvent des problèmes....
Pour les jours fériés, tu peux faire un tableau avec une recherche dedans
via ...RECHERCHE.
Mais, la meilleure solution, c'est d'attendre celle que Denis va
oposer. -))
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"L-A" a écrit dans le message de groupe de discussion :

Bonjour et bonne année Excelliene !!
Voici mon premier souci de l'année
Sur un tableau avec tous les jours du mois considéré, je cherche à récupérer
des données uniquement sur les jours fériés
J'ai une feuille ayant tous les jours fériés de l'année
voici la formule que j'ai pour les samedis et dimanches
mais cela ne marche pas pour les fériés car ca peut etre un jour différents
du samedi et dimanche
=SOMMEPROD(($L5:$EE5=$B$51)*(JOURSEM(JRS)=7)) pour le samedi
=SOMMEPROD(($L5:$EE5=$B$51)*(JOURSEM(JRS)=1)) pour le dimanche
=(($L5:$EE5=$B$51) correspond aux cellules (fusionnées par 4) contenant mes
dates
merci de votre aide
L-A
Le #26458218
merci jacquouille
pour illustrer mes propos, voici un petit modele
https://www.cjoint.com/c/HAguqQowuvF
Jacquouille
Le #26458223
Re
malheureusement pour toi, il semblerait que tu utilises une version plus
récente que la mienne.
Avec mon 2003, je n'ai pas accès à toutes tes cel.
cependant, si je comprends bien, tu désires comptabiliser le nombre de
présences les WE et jours fériés.
Avec cette formule =NB.JOURS.OUVRES(date_début;date_fin;jours_fériés) ,
tu devrais pouvoir combiner un sommeprod ....
jours_fériés peut être une plage (a2:a10)
Bonne chance
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"L-A" a écrit dans le message de groupe de discussion :

merci jacquouille
pour illustrer mes propos, voici un petit modele
https://www.cjoint.com/c/HAguqQowuvF
L-A
Le #26458241
en utilisant cette formule
=NB.JOURS.OUVRES(C3;AG3;Feriés)
j'obtiens 21 soit 21 jours excluant les samedi dimanche et jours féri és
Jacquouille
Le #26458251
RE
21, ce qui est bien le nombre de jours ouvrés, ouvrables, travaillés (?) du
mois de mai, en tenant compte des jours fériés repris dans la plage
"fériés".
yapluka combiner un SOMMEPROD (je pense) avec pour déterminer le nombre de
jours fériés qui ont été travaillés par Monsieur X.
Mais cela, il faut attendre la formule que Denis va proposer car je bute...
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"L-A" a écrit dans le message de groupe de discussion :

en utilisant cette formule
=NB.JOURS.OUVRES(C3;AG3;Feriés)
j'obtiens 21 soit 21 jours excluant les samedi dimanche et jours fériés
L-A
Le #26458254
Oui c’est bien ça.
23 jours ouvres
21 jours ouvres en déduisant les 2 fériés
Mais moi aussi je bute sur le sommeprod
Dénis. A l’aide !!
Michd
Le #26458265
En fait comme l’illustre mon fichier je voudrais savoir le nombre de matin M
soir S ou nuit N travailles uniquement sur les jours fériés déterminés dans
l’onglet données.
**** Une simple formule du type : =Nb.Si(Plage_Cellules;"M") pour trouver le
nombre de "M", le même type de formule s'applique pour "S" et "N"
**** Si tu veux avoir le nombre total de M, N, S dans la plage de cellules
=SOMME(NB.SI(Plage_Cellules;{"M"."N"."S"}))
MichD
L-A
Le #26458264
Merci pour cette avancée.
Mais comment déterminer la plage de cellule de la formule.
Dois je prendre celle qui est dans l’onglet données ?
Michd
Le #26458269
| Mais comment déterminer la plage de cellule de la formule.
Dans ton fichier, sur la feuille "Mai", tu as défini les jours du mois de
mai de la colonne C à AG. Le premier candidat "Durant" à la plage de
cellules "C4:AG4" dans la formule de la cellule C13. Après avoir inséré
cette formule, tu recopies la formule en utilisant le "point" dans le coin
inférieur droit de la cellule lorsque le curseur passe à l'intersection des
4 cellules jusqu'au dernier candidat dans la liste. Voilà!
MichD
Publicité
Poster une réponse
Anonyme