Format perso

Le
Jacquouille
Bonjour
Afin de peaufiner ma réponse à Pierre Fonds, j'aimerais introduire le numéro
du mois de la date qui est en B15
Ce serait pour remplacer mon 01 du format perso "A.01."##.## par le num du
mois.
J'ai testé "A."mois($b$15).##.## mais ça va pas.
Merci et bonne fin de WE

Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
MichD
Le #26515914
Bonjour,
À la place de "Formule", fais un copier-coller de ta formule sans le
symbole "=" et remplace l'expression "Formule".
Ta formule doit retourner une valeur entre 1 et 12 inclusivement.
Mon format date lorsque j'inscris une date dans une cellule est :
Jour/mois/année. Si ton format est différent, adapte!
=TEXTE("01/"&Formule&"/2019";"MMMM")
Michd
MichD
Le #26515916
Le 04/05/19 à 13:48, MichD a écrit :
Bonjour,
À la place de "Formule", fais un copier-coller de ta formule sans le
symbole "=" et remplace l'expression "Formule".
Ta formule doit retourner une valeur entre 1 et 12 inclusivement.
Mon format date lorsque j'inscris une date dans une cellule est :
Jour/mois/année. Si ton format est différent, adapte!
=TEXTE("01/"&Formule&"/2019";"MMMM")
Michd


Si tu veux le nom du mois court:
=TEXTE("01/"&Formule&"/2019";"MMM")
MichD
Jacquouille
Le #26515921
Bonsoir Denis
Je reprends ma question:
J'applique un format perso sur une cellule, à savoir : "A.01."##.##
Cela me donne A.01."12.34 si j'encode 1234.
Dans ce format perso, j'aimerai y remplacer le 01 écrit en dur par le n° du
mois.
Donc, j'ai essayé "A.mois($B$15)."##.## mais cela ne fonctionne pas.
B15 étant une date.
Encore merci
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"MichD" a écrit dans le message de groupe de discussion :
qakjc8$1g5$
Le 04/05/19 à 13:48, MichD a écrit :
Bonjour,
À la place de "Formule", fais un copier-coller de ta formule sans le
symbole "=" et remplace l'expression "Formule".
Ta formule doit retourner une valeur entre 1 et 12 inclusivement.
Mon format date lorsque j'inscris une date dans une cellule est :
Jour/mois/année. Si ton format est différent, adapte!
=TEXTE("01/"&Formule&"/2019";"MMMM")
Michd


Si tu veux le nom du mois court:
=TEXTE("01/"&Formule&"/2019";"MMM")
MichD
MichD
Le #26515926
Je ne suis pas sûr d'avoir compris...
"A.mois($B$15)."##.##
Si en B15 tu as une valeur entre 1 et 12
="A." & Texte($B$15;"MMM")&"."
Si c'est une formule que tu as en B15, au lieu de prendre 2 cellules
pour afficher ton résultat, tu peux tout mettre dans la même cellule
="A." & Texte(LaFormuleSans=;"MMM")&"."
MichD
Jacquouille
Le #26515935
Re bonsoir
Je suis désolé, mais je ne sais rien dire d'autre.
En B15, j'ai une date : 24/01/2019
En A1:A10, j'applique le format perso : "A.01."##.##
qui me donne : A.01.12.34 , si j'encode 1234.
J'aimerais pouvoir remplacer le 01 par un truc (formule?) qui donnerait la
valeur du mois. Dans mon cas, 01 pour janvier qui est en B15
Ta proposition de : "A.mois($B$15)."##.## me donne : A.mois($B$15).12.34
lorsque j'encode 1234.
Je suis désolé de ne pas pouvoir mieux expliquer.
Déjà merci
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"MichD" a écrit dans le message de groupe de discussion :
qakmm8$gqc$
Je ne suis pas sûr d'avoir compris...
"A.mois($B$15)."##.##
Si en B15 tu as une valeur entre 1 et 12
="A." & Texte($B$15;"MMM")&"."
Si c'est une formule que tu as en B15, au lieu de prendre 2 cellules
pour afficher ton résultat, tu peux tout mettre dans la même cellule
="A." & Texte(LaFormuleSans=;"MMM")&"."
MichD
MichD
Le #26515939
Donne-moi le contenu de la cellule B15 (la formule)
MichD
Jacquouille
Le #26515943
Bonsoir Denis,
C'est pas une formule, mais une date en dur, entrée à la main. ex:
24/01/2019

Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"MichD" a écrit dans le message de groupe de discussion :
qal1v2$3rk$

Donne-moi le contenu de la cellule B15 (la formule)
MichD
MichD
Le #26515942
Le 04/05/19 à 17:59, MichD a écrit :
Donne-moi le contenu de la cellule B15 (la formule)
MichD

Ceci : "A.mois($B$15)."##.## C'est un format de cellule.
Pourquoi ne pas inscrire tout ce que tu veux directement dans la
cellule. Si l'usager veut traiter le contenu de la cellule, il ne peut
accéder aux éléments affichés par le format.
MichD
MichD
Le #26515941
Le 04/05/19 à 18:07, Jacquouille a écrit :
Bonsoir Denis,
C'est pas une formule, mais une date en dur, entrée à la main.  ex:
24/01/2019

Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"MichD"  a écrit dans le message de groupe de discussion :
qal1v2$3rk$

Donne-moi le contenu de la cellule B15 (la formule)
MichD

Il n'y a pas une solution à ce que tu veux, si tu veux faire cela dans
un format de cellule. Moi je parle d'insérer ma formule dans une cellule.
MichD
Jacquouille
Le #26515966
Bonjour Denis
J'ai torturé ce format et je n'arrive pas à le faire fonctionner.
J'en déduis que c'est pas possible (du moins pour moi).
J'ai donc suggéré à Pierre de changer le format perso chaque mois.
merci pour ta patience
Bonne fin de WE
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"MichD" a écrit dans le message de groupe de discussion :
qal2lh$7vj$
Le 04/05/19 à 17:59, MichD a écrit :
Donne-moi le contenu de la cellule B15 (la formule)
MichD

Ceci : "A.mois($B$15)."##.## C'est un format de cellule.
Pourquoi ne pas inscrire tout ce que tu veux directement dans la
cellule. Si l'usager veut traiter le contenu de la cellule, il ne peut
accéder aux éléments affichés par le format.
MichD
Publicité
Poster une réponse
Anonyme