Lynx, pour les anglais ?

Le
Sergio
[Follow-up surt fr.comp.infosystemes.www.navigateurs]

N'ayant peur de rien, et m'étant installé un petit Linux, je me dis, je
vais voir ce que ça donne la vie avec Lynx, le browser de l'élite

Catastrophe ! Tous les caractères accentués sont remplacés par de
magnifiques "?".

Je précise que les pages ont bien le
<meta http-equiv="content-type" content="text/html;
charset=iso-8859-1">
réglementaire. J'avais fait auparavant des essais avec Konqueror, et
effectivement il est plus tâtillon que Mozilla ou IE là-dessus.

Y'a pas une astuce (que les auteurs américains de la distrib ont oublié
d'activer, bien entendu).

Précision : c'est une distrib en Français (Redhat 9), où même Lynx
affiche des accents dans ses menus (mais pas sur les pages).

--
Serge http://leserged.online.fr/
Tout sur Windows : http://www.bellamyjc.org/ et http://www.ntfaqfr.com/
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Daniel Glazman
Le #11093381
Sergio wrote:

[Follow-up surt fr.comp.infosystemes.www.navigateurs]

N'ayant peur de rien, et m'étant installé un petit Linux, je me dis, je
vais voir ce que ça donne la vie avec Lynx, le browser de l'élite...

Catastrophe ! Tous les caractères accentués sont remplacés par de
magnifiques "?".

Je précise que les pages ont bien le
<meta http-equiv="content-type" content="text/html; charset=iso-8859-1">
réglementaire. J'avais fait auparavant des essais avec Konqueror, et
effectivement il est plus tâtillon que Mozilla ou IE là-dessus.

Y'a pas une astuce (que les auteurs américains de la distrib ont oublié
d'activer, bien entendu).

Précision : c'est une distrib en Français (Redhat 9), où même Lynx
affiche des accents dans ses menus (mais pas sur les pages...).



stty pass8 ?

</Daniel>
Gg
Le #11093371
Sergio wrote:

N'ayant peur de rien, et m'étant installé un petit Linux, je me dis, je
vais voir ce que ça donne la vie avec Lynx, le browser de l'élite...

Catastrophe ! Tous les caractères accentués sont remplacés par de
magnifiques "?".

Je précise que les pages ont bien le
<meta http-equiv="content-type" content="text/html;
charset=iso-8859-1">
réglementaire. J'avais fait auparavant des essais avec Konqueror, et
effectivement il est plus tâtillon que Mozilla ou IE là-dessus.



Euh, ca sera pas charset=iso-8859-15 ?


--
GéraLd : http://gerald.fauvelle.free.fr
| Photos : http://www.gg.free.fr
| myStats : Système de statistiques
| Version 1.0.8 - http://emcity.nexenservices.com/mystats
william
Le #11093321
On Mon, 19 Apr 2004 17:16:10 +0200, Sergio wrote:

N'ayant peur de rien, et m'étant installé un petit Linux, je me dis, je
vais voir ce que ça donne la vie avec Lynx, le browser de l'élite...



euh ...

Catastrophe ! Tous les caractères accentués sont remplacés par de
magnifiques "?".



ça peut être plusieurs choses :

1° tu n'as pas les bonne locales soit tu es en unicode
dans ce cas un
export LANG=C voire meme export LANG_ALL=C doit suffire

2° tu as un terminal qui ne supporte pas iso-8859-1 (mais ca serait
étonnant)

3° la page est mal faite

--
William.
Fabrice Bonny
Le #11093301
Sergio wrote:

N'ayant peur de rien, et m'étant installé un petit Linux, je me dis, je
vais voir ce que ça donne la vie avec Lynx, le browser de l'élite...

Catastrophe ! Tous les caractères accentués sont remplacés par de
magnifiques "?".



Dans les options, choisis "7bit approximations" pour le charset.

--
Fabrice Bonny
Hervé
Le #11093281
Sergio a écrit :
Précision : c'est une distrib en Français (Redhat 9), où même Lynx
affiche des accents dans ses menus (mais pas sur les pages...).



Problème d'UTF-8 (Redhat l'utilise par défaut) ?

--
Hervé
Jean-Marc Desperrier
Le #11093271
william wrote:
1° tu n'as pas les bonne locales soit tu es en unicode
dans ce cas un
export LANG=C voire meme export LANG_ALL=C doit suffire



La locale en C peut en théorie donner des problème.

export LANG=en_US
ou bien
export LANG=fr_FR
devraient être mieux

2° tu as un terminal qui ne supporte pas iso-8859-1 (mais ca serait
étonnant)



Ou bien qui est réglé en UTF-8 sans que Lynx le gère bien comme suggéré
ailleurs.
Changer LANG changera aussi le jeu de caractère utilisé.
Vincent Lefevre
Le #11093221
Dans l'article william
ça peut être plusieurs choses :



1° tu n'as pas les bonne locales soit tu es en unicode
dans ce cas un
export LANG=C voire meme export LANG_ALL=C doit suffire



2° tu as un terminal qui ne supporte pas iso-8859-1 (mais ca serait
étonnant)



3° la page est mal faite



Vu qu'il a bien les accents dans les menus, ça devrait éliminer 1 et 2.
C'est 3, ou alors un bug quelque part.

--
Vincent Lefèvre 100% validated (X)HTML - Acorn / RISC OS / ARM, free software, YP17,
Championnat International des Jeux Mathématiques et Logiques, etc.
Work: CR INRIA - computer arithmetic / SPACES project at LORIA
Sergio
Le #11093191
Vincent Lefevre a formulé ce mardi :

ça peut être plusieurs choses :



1° tu n'as pas les bonne locales soit tu es en unicode
dans ce cas un
export LANG=C voire meme export LANG_ALL=C doit suffire



2° tu as un terminal qui ne supporte pas iso-8859-1 (mais ca serait
étonnant)



3° la page est mal faite



Vu qu'il a bien les accents dans les menus, ça devrait éliminer 1 et 2.
C'est 3, ou alors un bug quelque part.



La page est "bien" faite (c'est moi qui l'ai faite) :
- Il y a un bien un charset iso-8859-1 dans les headers.
- Les caractères accentués sont insérés normalement (pas de caractère
exotique à la Windows comme Euro).

Il semble que Lynx ait toujours eu un problème avec les accents : Les
différentes versions de Lynx pour Windows, que j'ai testées dans le
passé, avaient *toutes* un problème avec les accents (accents en ISO
alors que le charset de la console Windows est un DOS).

Je pensais naïvement que sous Linux, tout allait aller pour le mieux,
ben...

--
Serge http://leserged.online.fr/
Tout sur Windows : http://www.bellamyjc.org/ et http://www.ntfaqfr.com/
Pascal Blondé
Le #11093171
Sergio a écrit :
Je pensais naïvement que sous Linux, tout allait aller pour le mieux,
ben...




Bonjour,

J'ai le même problème avec ma seule machine encore sous RH9 même en
changeant la variable LANG. J'ai fait des essais en utilisant les
consoles ou sous X11 (gnome-terminal ou xterm).

Par contre, tout fonctionne bien avec mes machines sous Fedora Core 1.

Pascal
Vincent Lefevre
Le #11093071
Dans l'article Sergio
Il semble que Lynx ait toujours eu un problème avec les accents : Les
différentes versions de Lynx pour Windows, que j'ai testées dans le
passé, avaient *toutes* un problème avec les accents (accents en ISO
alors que le charset de la console Windows est un DOS).



Oui, tu as raison, lynx bugge... Enfin, je n'ai aucun problème dans
une xterm avec des locales en ISO-8859-1 (avec un fichier de config
vide). Mais dans un xterm avec des locales en UTF-8, lynx semble
sortir toujours du ISO-8859-1. Résultat: ça donne n'importe quoi
(rectangles en pointillés, typiques de séquences incorrectes en
UTF-8).

--
Vincent Lefèvre 100% validated (X)HTML - Acorn / RISC OS / ARM, free software, YP17,
Championnat International des Jeux Mathématiques et Logiques, etc.
Work: CR INRIA - computer arithmetic / SPACES project at LORIA
Publicité
Poster une réponse
Anonyme