[Q] Premier lancement d'une appli trééééés long....

Le
karim
J'ai une image que je descend sur un disque (iMacG5).

Dans le dossier Applications de cette image, il y un soft qui prend
+sieurs secondes avant de se lancer.

On a même le sentiment que la machine est "gelée" ce qui n'est pas du
tout le cas : une fenêtre demandant si "on veut bien lancer cette
application pour la première fois apparaît".

Il suffit de valider, et tout fonctionne. Les lancemants suivants se
passent sans pb (rapide, fluide)

Pourquoi ca ?

une histoire de "(pre)binding" avec qq chose ?

On peut rémédier à ça ?

j'aimerai comprendre le mécanisme

Gracias.
  • Partager ce contenu :
Vos réponses Page 1 / 2
Trier par : date / pertinence
Bruno Lixi
Le #1392338
In article (Karim) wrote:

J'ai une image que je descend sur un disque (iMacG5).

Dans le dossier Applications de cette image, il y un soft qui prend
+sieurs secondes avant de se lancer.

On a même le sentiment que la machine est "gelée" ce qui n'est pas du
tout le cas : une fenêtre demandant si "on veut bien lancer cette
application pour la première fois apparaît".

Il suffit de valider, et tout fonctionne. Les lancemants suivants se
passent sans pb (rapide, fluide...)

Pourquoi ca ?

une histoire de "(pre)binding" avec qq chose ?

On peut rémédier à ça ?

j'aimerai comprendre le mécanisme...

Gracias.


le soft attend peut-être des infos du web (nouvelle version ...) qui
tardent à venir ?

Eric Lévénez
Le #1392103
Le 26/01/05 12:47, dans « Karim »
J'ai une image que je descend sur un disque (iMacG5).

Dans le dossier Applications de cette image, il y un soft qui prend
+sieurs secondes avant de se lancer.


Quel soft ? On n'est pas devin.

On a même le sentiment que la machine est "gelée" ce qui n'est pas du


La souris ne bouge plus ? Le disque ne tourne plus ?

tout le cas : une fenêtre demandant si "on veut bien lancer cette
application pour la première fois apparaît".


C'est "normal".

Il suffit de valider, et tout fonctionne. Les lancemants suivants se
passent sans pb (rapide, fluide...)

Pourquoi ca ?


Quoi "ça" ? Le message ? C'est pour éviter les virus belges (des
applications lancées à la main).

une histoire de "(pre)binding" avec qq chose ?


On est toujours supposé être devin ?

Certains softs profitent de leur premier lancement pour scanner des
répertoires pour s'initialiser (recherche des fonts, des plugins...), c'est
pas exemple le cas avec Adobe Reader 7. Certains softs sont aussi plus lent
au premier lancement du jour ou de la semaine si par exemple ils vérifient
si des mises à jours sont dispos. D'autres softs sont lents au démarrage car
ils vérifient si un autre soft avec le même numéro de série n'est pas
présent sur le sous-réseau internet... Il y a plein de cas possibles.

On peut rémédier à ça ?


Oui.

j'aimerai comprendre le mécanisme...


On aimerait connaître le nom et la version du soft qui te pose des
problèmes. On n'est pas... allez, dis le avec nous : d e v i n ! :-)

--
Éric Lévénez -- Unix is not only an OS, it's a way of life.

gilbert.olivier
Le #1392093
Karim
J'ai une image que je descend sur un disque (iMacG5).

Dans le dossier Applications de cette image, il y un soft qui prend
+sieurs secondes avant de se lancer.


Si c'est depuis une image disque montée que tu lances cette appli, que
cette image est un "peu volumineuse", que tu n'aies pas trop de mémoire
(enfin pas une très très grosse quantité - le max que permet l'iMac G5)
c'est peut être une peu normal car il faut qu'il cherche dans l'image,
fasse pas mal de manip mémoire et d'accès disque pour accéder au code et
ensuite le charge avec d'éventuelles écritures en fichier(s) de swap....

Enfin j'ai peut-être mal compris le contexte ;-)

--
Gilbert

mv
Le #1416556
Eric Lévénez
allez, dis le avec nous : d e v i n !


J'en prendrais bien un petit verre, moi, tiens... ;-)
--
Les PL sont ici : http://michel.vauquois.free.fr
via Shippagan : http://nicole.jacquet2.free.fr/Quebec2002/
via la Côte Nord : http://nicole.jacquet2.free.fr/Quebec2000/

karim
Le #1414336
Gilbert OLIVIER
Enfin j'ai peut-être mal compris le contexte ;-)


Oui ; la description correspond à une machine botée sur son DD
interne,sur lequel j'ai descendu une image qq minutes avant.

j'ai pas été très clair a en juger les commentaires "vignèsques" (devin)
des contributeurs du fil ;-)

karim
Le #1414337
J'ai une image que je descend sur un disque (iMacG5).

Dans le dossier Applications de cette image, il y un soft qui prend
+sieurs secondes avant de se lancer.


Quel soft ? On n'est pas devin.
Un client CITRIX



On a même le sentiment que la machine est "gelée" ce qui n'est pas du


La souris ne bouge plus ? Le disque ne tourne plus ?
Le curseur se transforme en roue multicolore...



tout le cas : une fenêtre demandant si "on veut bien lancer cette
application pour la première fois apparaît".


C'est "normal".
Ben non : les autres softs installés ne le font pas. j'aimerai savoir

pourquoi certains déclenchent cette alerte et pas d'autres.


une histoire de "(pre)binding" avec qq chose ?


On est toujours supposé être devin ?
ca va, ca va :-)


Certains softs profitent de leur premier lancement pour scanner des
répertoires pour s'initialiser (recherche des fonts, des plugins...), c'est
pas exemple le cas avec Adobe Reader 7. Certains softs sont aussi plus lent
au premier lancement du jour ou de la semaine si par exemple ils vérifient
si des mises à jours sont dispos. D'autres softs sont lents au démarrage car
ils vérifient si un autre soft avec le même numéro de série n'est pas
présent sur le sous-réseau internet... Il y a plein de cas possibles.
Début de réponse à ma question.

Merci (il fallait peut-être commencer par là ;-)

On peut rémédier à ça ?


Oui.

j'aimerai comprendre le mécanisme...


On aimerait connaître le nom et la version du soft qui te pose des
problèmes. On n'est pas... allez, dis le avec nous : d e v i n ! :-)
vous n'êtes pas d e v i n !


j'ai bon là ? :-)


Eric Lévénez
Le #1392784
Le 27/01/05 10:58, dans « Karim »
J'ai une image que je descend sur un disque (iMacG5).

Dans le dossier Applications de cette image, il y un soft qui prend
+sieurs secondes avant de se lancer.


Quel soft ? On n'est pas devin.
Un client CITRIX



Là je ne connais pas, il faudrait voir si quelqu'un connaît ce soft.

On a même le sentiment que la machine est "gelée" ce qui n'est pas du


La souris ne bouge plus ? Le disque ne tourne plus ?
Le curseur se transforme en roue multicolore...



Cela indique que le programme boucle et ne répond plus à des ordres
graphiques. L'interface de Mac OS X détecte cela au bout de 2 secondes et
affiche cette roue. Dès que le programme se remet à parler à l'interface
graphique, la roue fait place à la flèche.

tout le cas : une fenêtre demandant si "on veut bien lancer cette
application pour la première fois apparaît".


C'est "normal".
Ben non : les autres softs installés ne le font pas. j'aimerai savoir

pourquoi certains déclenchent cette alerte et pas d'autres.


Quand on clic sur un fichier qui lance une appli pour la première fois, on a
ce message. Mais on ne l'a plus les fois suivantes. Si on lance directement
un programme, même la première fois, on n'a pas ce message.


--
Éric Lévénez -- Unix is not only an OS, it's a way of life.



Michael
Le #1392782
Un client CITRIX



Là je ne connais pas, il faudrait voir si quelqu'un connaît ce soft.


Client de connexion à un métaframe je suppose


laurent.pertois
Le #1392780
Karim
Oui ; la description correspond à une machine botée sur son DD
interne,sur lequel j'ai descendu une image qq minutes avant.


Le problème ici c'est qu'on ne sait pas ce que fait l'application citrix
la première fois qu'on la lance. Si elle apprécie le fait dêtre
masterisée ainsi à partir d'une image, etc...

--
Politically Correct Unix - UTILITIES
The "touch" command has been removed from the standard distribution due
to its inappropriate use by high-level managers.

karim
Le #1392495
Michael
Client de connexion à un métaframe je suppose
oui.


Poster une réponse
Anonyme