Twitter iPhone pliant OnePlus 11 PS5 Disney+ Orange Livebox Windows 11

Questions sur Exim4 avec un SMTP Orange

21 réponses
Avatar
Olivier
--089e0160b7d481457705161f91b7
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,

J'ai un syst=C3=A8me (sous Squeeze) qui =C3=A9met quelques courriels.
Il utilise exim4 et un compte GMail pour ses envois et l'ensemble
fonctionne sans histoire.

Depuis peu, j'ai une nouvelle exigence: je dois =C3=A9mettre certains mails=
avec
une adresse d'=C3=A9misssion pr=C3=A9cise (exemple: contact@exemple.fr et n=
on plus
foobar@gmail.com).

Gr=C3=A2ce =C3=A0 cette liste, j'ai pu trouver le moyen pour configurer l'a=
dresse
d'=C3=A9mission: le pb est que mon compte GMail n'accepte pas une autre adr=
esse
d'=C3=A9mission que la sienne.

Pour contourner cette limitation, j'envisage d'utiliser les param=C3=A8tres=
SMTP
fournis avec le lien ADSL Orange du site d'installation de mon syst=C3=A8me=
.

Je rencontre des difficult=C3=A9s pour =C3=A9mettre avec ces param=C3=A8tre=
s SMTP Orange
et j'appr=C3=A9cierai beaucoup une aide sur le sujet.

Voici comment j'ai proc=C3=A9d=C3=A9:

1. J'ai test=C3=A9 unitairement les param=C3=A8tres SMTP en suivant la proc=
=C3=A9dure
d=C3=A9crite ici [1].
Je me suis connect=C3=A9 avec:
telnet smtp.orange.fr 587
Apr=C3=A8s la commande AUTH LOGIN et l'envoi du login et du mot de passe en
base64, j'ai la r=C3=A9ponse suivante du serveur:
235 2.7.0 ... authentication succeeded
J'en d=C3=A9duis que mes param=C3=A8tres d'authentification sont corrects m=
ais j'ai
un doute sur les param=C3=A8tres de connexion car je lis ici ou l=C3=A0 des
r=C3=A9f=C3=A9rences aux ports 25 ou 465.
Quels param=C3=A8tres de connexion doit-on privil=C3=A9gier ?

2. Je poursuis pour ensuite arriver =C3=A0 =C3=A9mettre mais il n'y a pas d=
'=C3=A9metteur
dans le mail re=C3=A7u malgr=C3=A9 la commande
MAIL FROM: <bar@foo.com>
250 2.1.0 <bar@foo.com> sender ok
Avez-vous une suggestion pour valoriser en telnet avec le SMTP d'Orange
l'adresse d'=C3=A9mission ?

3. Je reviens maintenant =C3=A0 mailx et exim4.
Je configure ceux-ci du mieux possible et je lance un envoi avec mailx et
l'option -v.
J'observe alors =C3=A0 l'=C3=A9cran:
SMTP<< 550 5.1.0 Authentification requise. Authentication Required.
OFR102_402 [402]

Avant cette ligne, j'observe que mailx/exim4 n'=C3=A9met aucune commande AU=
TH
LOGIN pr=C3=A9alable, analogue =C3=A0 celle que j'envoie avec telnet.
Ma question est: comment dois-je sp=C3=A9cifier =C3=A0 exim4/mailx d'envoye=
r un AUTH
LOGIN ?

J'ai ceci dans /etc/exim4/pass.client:
smtp.orange.fr:moncompte@orange.fr:monmotdpasse

Dans update-exim4.conf.conf, j'ai:
dc_smarthost=3D'smtp.orange.fr::587'


Slts



[1] http://www.linuxjournal.com/content/troubleshooting-telnet

--089e0160b7d481457705161f91b7
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr"><div><div><div><div><div><div><div><div><div><div><div><di=
v><div><div><div><div><div><div><div>Bonjour,<br><br></div>J&#39;ai un syst=
=C3=A8me (sous Squeeze) qui =C3=A9met quelques courriels.<br></div>Il utili=
se exim4 et un compte GMail pour ses envois et l&#39;ensemble fonctionne sa=
ns histoire.<br><br></div>Depuis peu, j&#39;ai une nouvelle exigence: je do=
is =C3=A9mettre certains mails avec une adresse d&#39;=C3=A9misssion pr=C3=
=A9cise (exemple: <a href=3D"mailto:contact@exemple.fr">contact@exemple.fr<=
/a> et non plus <a href=3D"mailto:foobar@gmail.com">foobar@gmail.com</a>).<=
br><br></div>Gr=C3=A2ce =C3=A0 cette liste, j&#39;ai pu trouver le moyen po=
ur configurer l&#39;adresse d&#39;=C3=A9mission: le pb est que mon compte G=
Mail n&#39;accepte pas une autre adresse d&#39;=C3=A9mission que la sienne.=
<br><br></div>Pour contourner cette limitation, j&#39;envisage d&#39;utilis=
er les param=C3=A8tres SMTP fournis avec le lien ADSL Orange du site d&#39;=
installation de mon syst=C3=A8me.<br><br></div>Je rencontre des difficult=
=C3=A9s pour =C3=A9mettre avec ces param=C3=A8tres SMTP Orange et j&#39;app=
r=C3=A9cierai beaucoup une aide sur le sujet.<br><br></div>Voici comment j&=
#39;ai proc=C3=A9d=C3=A9:<br><br></div>1. J&#39;ai test=C3=A9 unitairement =
les param=C3=A8tres SMTP en suivant la proc=C3=A9dure d=C3=A9crite ici [1].=
<br></div><div>Je me suis connect=C3=A9 avec:<br></div><div>telnet <a href=
=3D"http://smtp.orange.fr">smtp.orange.fr</a> 587<br></div><div>Apr=C3=A8s =
la commande AUTH LOGIN et l&#39;envoi du login et du mot de passe en base64=
, j&#39;ai la r=C3=A9ponse suivante du serveur:<br>235 2.7.0 ... authentica=
tion succeeded<br></div><div>J&#39;en d=C3=A9duis que mes param=C3=A8tres d=
&#39;authentification sont corrects mais j&#39;ai un doute sur les param=C3=
=A8tres de connexion car je lis ici ou l=C3=A0 des r=C3=A9f=C3=A9rences aux=
ports 25 ou 465.<br></div><div>Quels param=C3=A8tres de connexion doit-on =
privil=C3=A9gier ?<br></div><div><br></div><div>2. Je poursuis pour ensuite=
arriver =C3=A0 =C3=A9mettre mais il n&#39;y a pas d&#39;=C3=A9metteur dans=
le mail re=C3=A7u malgr=C3=A9 la commande <br></div></div>MAIL FROM: &lt;<=
a href=3D"mailto:bar@foo.com">bar@foo.com</a>&gt;=C2=A0=C2=A0=C2=A0=C2=A0=
=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0=C2=A0 <br>250 =
2.1.0 &lt;<a href=3D"mailto:bar@foo.com">bar@foo.com</a>&gt; sender ok<br><=
/div>Avez-vous une suggestion pour valoriser en telnet avec le SMTP d&#39;O=
range l&#39;adresse d&#39;=C3=A9mission ?<br><br></div>3. Je reviens mainte=
nant =C3=A0 mailx et exim4.<br></div>Je configure ceux-ci du mieux possible=
et je lance un envoi avec mailx et l&#39;option -v.<br></div>J&#39;observe=
alors =C3=A0 l&#39;=C3=A9cran:<br>=C2=A0 SMTP&lt;&lt; 550 5.1.0 Authentifi=
cation requise. Authentication Required. OFR102_402 [402]<br><br></div>Avan=
t cette ligne, j&#39;observe que mailx/exim4 n&#39;=C3=A9met aucune command=
e AUTH LOGIN pr=C3=A9alable, analogue =C3=A0 celle que j&#39;envoie avec te=
lnet.<br></div>Ma question est: comment dois-je sp=C3=A9cifier =C3=A0 exim4=
/mailx d&#39;envoyer un AUTH LOGIN ?<br><br></div>J&#39;ai ceci dans /etc/e=
xim4/pass.client:<br>smtp.orange.fr:moncompte@orange.fr:monmotdpasse<br><br=
></div>Dans update-exim4.conf.conf, j&#39;ai:<br>dc_smarthost=3D&#39;smtp.o=
range.fr::587&#39;<br><br><br></div>Slts<br><div><br><div><br><div><div><di=
v><div><div><div><div><div><div><br>[1] <a href=3D"http://www.linuxjournal.=
com/content/troubleshooting-telnet">http://www.linuxjournal.com/content/tro=
ubleshooting-telnet</a> <br></div></div></div></div></div></div></div></div=
></div></div></div></div>

--089e0160b7d481457705161f91b7--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: https://lists.debian.org/CAPeT9jhsJ=HafqVEgJyxoPH-6W7d_eay+5W3Ly7z1aAMFtvdWg@mail.gmail.com

10 réponses

1 2 3
Avatar
Olivier
--089e01177485542473051620388e
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Le 15 mai 2015 16:42, Guillaume a écrit :

Bonjour,

Désolé je ne peux pas t'aider à propos d'Exim4,

mais il me sembe qu'Orange utilise la même protection.




Tu veux dire qu'on ne peux qu'émettre avec l'adresse d'émission f ournie par
Orange ?




Le 15/05/2015 16:22, Olivier a écrit :

Bonjour,

J'ai un système (sous Squeeze) qui émet quelques courriels.
Il utilise exim4 et un compte GMail pour ses envois et l'ensemble
fonctionne sans histoire.

Depuis peu, j'ai une nouvelle exigence: je dois émettre certains ma ils
avec une adresse d'émisssion précise (exemple: fr et non
plus ).

Grâce à cette liste, j'ai pu trouver le moyen pour configurer l'adresse
d'émission: le pb est que mon compte GMail n'accepte pas une autre a dresse
d'émission que la sienne.

Pour contourner cette limitation, j'envisage d'utiliser les paramèt res
SMTP fournis avec le lien ADSL Orange du site d'installation de mon syst ème.

Je rencontre des difficultés pour émettre avec ces paramè tres SMTP Orange
et j'apprécierai beaucoup une aide sur le sujet.

Voici comment j'ai procédé:

1. J'ai testé unitairement les paramètres SMTP en suivant la p rocédure
décrite ici [1].
Je me suis connecté avec:
telnet smtp.orange.fr 587
Après la commande AUTH LOGIN et l'envoi du login et du mot de passe en
base64, j'ai la réponse suivante du serveur:
235 2.7.0 ... authentication succeeded
J'en déduis que mes paramètres d'authentification sont correct s mais
j'ai un doute sur les paramètres de connexion car je lis ici ou là   des
références aux ports 25 ou 465.
Quels paramètres de connexion doit-on privilégier ?

2. Je poursuis pour ensuite arriver à émettre mais il n'y a pa s
d'émetteur dans le mail reçu malgré la commande
MAIL FROM:
250 2.1.0 sender ok
Avez-vous une suggestion pour valoriser en telnet avec le SMTP d'Orange
l'adresse d'émission ?

3. Je reviens maintenant à mailx et exim4.
Je configure ceux-ci du mieux possible et je lance un envoi avec mailx e t
l'option -v.
J'observe alors à l'écran:
SMTP<< 550 5.1.0 Authentification requise. Authentication Required.
OFR102_402 [402]

Avant cette ligne, j'observe que mailx/exim4 n'émet aucune commande AUTH
LOGIN préalable, analogue à celle que j'envoie avec telnet.
Ma question est: comment dois-je spécifier à exim4/mailx d'env oyer un
AUTH LOGIN ?

J'ai ceci dans /etc/exim4/pass.client:
smtp.orange.fr::monmotdpasse

Dans update-exim4.conf.conf, j'ai:
dc_smarthost='smtp.orange.fr::587'


Slts



[1] http://www.linuxjournal.com/co" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.linuxjournal.com/content/troubleshooting-telnet" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.linuxjournal.com/co" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.linuxjournal.com/content/troubleshooting-telnet



--
Guillaume





--089e01177485542473051620388e
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quo te">Le 15 mai 2015 16:42, Guillaume <span dir="ltr">&lt;<a href="mailto :" target="_blank"></a>&gt;</ span> a écrit :<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">



<div bgcolor="#FFFFFF" text="#000000">
Bonjour,<br>
<br>
Désolé je ne peux pas t&#39;aider à propos d&#39;Exim4,< br>
<br>
mais il me sembe qu&#39;Orange utilise la même protection.</div></ blockquote><div><br></div><div>Tu veux dire qu&#39;on ne peux qu&#39;é mettre avec l&#39;adresse d&#39;émission fournie par Orange ? <br></di v><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left: 1px #ccc solid;padding-left:1ex"><div bgcolor="#FFFFFF" text="#000000"> <div><div class="h5"><br>
<br>
<br>
<div>Le 15/05/2015 16:22, Olivier a écrit :<br>
</div>
<blockquote type="cite">
<div dir="ltr">
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>Bonjour,<br>
<br>
</div>
J&#39;ai un système (sous
Squeeze) qui émet quelques
courriels.<br>
</div>
Il utilise exim4 et un compte
GMail pour ses envois et
l&#39;ensemble fonctionne sans
histoire.<br>
<br>
</div>
Depuis peu, j&#39;ai une nouvelle
exigence: je dois émettre
certains mails avec une adresse
d&#39;émisssion précise ( exemple: <a href="mailto:" target="_blank"> emple.fr</a>
et non plus <a href="mailto:fooba " target="_blank"></a>).<br>
<br>
</div>
Grâce à cette liste, j&#39; ai pu
trouver le moyen pour configurer
l&#39;adresse d&#39;émission: le pb est
que mon compte GMail n&#39;accepte pa s
une autre adresse d&#39;émission que
la sienne.<br>
<br>
</div>
Pour contourner cette limitation,
j&#39;envisage d&#39;utiliser les param ètres
SMTP fournis avec le lien ADSL
Orange du site d&#39;installation de mo n
système.<br>
<br>
</div>
Je rencontre des difficultés pour
émettre avec ces paramètres SMT P
Orange et j&#39;apprécierai beaucoup une
aide sur le sujet.<br>
<br>
</div>
Voici comment j&#39;ai procédé:<b r>
<br>
</div>
1. J&#39;ai testé unitairement les param ètres
SMTP en suivant la procédure décrit e ici
[1].<br>
</div>
<div>Je me suis connecté avec:<br>
</div>
<div>telnet <a href="http://smtp.orange.fr&quot; t arget="_blank">smtp.orange.fr</a>
587<br>
</div>
<div>Après la commande AUTH LOGIN et l&#39 ;envoi
du login et du mot de passe en base64,
j&#39;ai la réponse suivante du serveur: <br>
235 2.7.0 ... authentication succeeded<br>
</div>
<div>J&#39;en déduis que mes paramètr es
d&#39;authentification sont corrects mais j&# 39;ai
un doute sur les paramètres de connexion
car je lis ici ou là des référ ences aux
ports 25 ou 465.<br>
</div>
<div>Quels paramètres de connexion doit-on
privilégier ?<br>
</div>
<div><br>
</div>
<div>2. Je poursuis pour ensuite arriver à
émettre mais il n&#39;y a pas d&#39;à ©metteur dans
le mail reçu malgré la commande <br >
</div>
</div>
MAIL FROM: &lt;<a href="mailto:" tar get="_blank"></a>&gt;        Â Â Â Â Â Â Â Â 
<br>
250 2.1.0 &lt;<a href="mailto:" targ et="_blank"></a>&gt;
sender ok<br>
</div>
Avez-vous une suggestion pour valoriser en
telnet avec le SMTP d&#39;Orange l&#39;adresse
d&#39;émission ?<br>
<br>
</div>
3. Je reviens maintenant à mailx et exim4.<br>
</div>
Je configure ceux-ci du mieux possible et je lance
un envoi avec mailx et l&#39;option -v.<br>
</div>
J&#39;observe alors à l&#39;écran:<br>
  SMTP&lt;&lt; 550 5.1.0 Authentification requise.
Authentication Required. OFR102_402 [402]<br>
<br>
</div>
Avant cette ligne, j&#39;observe que mailx/exim4 n&#39;Ã ©met
aucune commande AUTH LOGIN préalable, analogue à celle
que j&#39;envoie avec telnet.<br>
</div>
Ma question est: comment dois-je spécifier à exim4/ mailx
d&#39;envoyer un AUTH LOGIN ?<br>
<br>
</div>
J&#39;ai ceci dans /etc/exim4/pass.client:<br>
<a href="mailto:smtp.orange.fr::monmotdpas se" target="_blank">smtp.orange.fr::monmotdpasse</a><b r>
<br>
</div>
Dans update-exim4.conf.conf, j&#39;ai:<br>
dc_smarthost=&#39;smtp.orange.fr::587&#39;<br>
<br>
<br>
</div>
Slts<br>
<div><br>
<div><br>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div><br>
[1] <a href="http://www.linuxjournal.com/co" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.linuxjournal.com/co ntent/troubleshooting-telnet" target="_blank">http://www.linuxjournal.com /content/troubleshooting-telnet</a>
<br>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</blockquote>
<br>
<br>
</div></div><span class="HOEnZb"><font color="#888888"><pre cols= "72">--
Guillaume</pre>
</font></span></div>

</blockquote></div><br></div></div>

--089e01177485542473051620388e--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Avatar
SD76
--047d7bdcaa0ee1b1fc051620ec72
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Bonjour,

Pourquoi ne pas laisser exim4 envoyé lui même l'email?
Il faut cependant ajouter l'IP publique que vous utilisez dans le champs
SPF du domaine concerné afin de ne pas passer en spam.

Le 15 mai 2015 17:25, Guillaume a écrit :

Oui c'est ça, a vérifier quand même.


Le 15/05/2015 17:08, Olivier a écrit :



Le 15 mai 2015 16:42, Guillaume a écrit :

Bonjour,

Désolé je ne peux pas t'aider à propos d'Exim4,

mais il me sembe qu'Orange utilise la même protection.




Tu veux dire qu'on ne peux qu'émettre avec l'adresse d'émissio n fournie
par Orange ?




Le 15/05/2015 16:22, Olivier a écrit :

Bonjour,

J'ai un système (sous Squeeze) qui émet quelques courriels.
Il utilise exim4 et un compte GMail pour ses envois et l'ensemble
fonctionne sans histoire.

Depuis peu, j'ai une nouvelle exigence: je dois émettre certains m ails
avec une adresse d'émisssion précise (exemple: .fr et non
plus ).

Grâce à cette liste, j'ai pu trouver le moyen pour configurer l'adresse
d'émission: le pb est que mon compte GMail n'accepte pas une autre adresse
d'émission que la sienne.

Pour contourner cette limitation, j'envisage d'utiliser les paramè tres
SMTP fournis avec le lien ADSL Orange du site d'installation de mon syst ème.

Je rencontre des difficultés pour émettre avec ces paramà ¨tres SMTP
Orange et j'apprécierai beaucoup une aide sur le sujet.

Voici comment j'ai procédé:

1. J'ai testé unitairement les paramètres SMTP en suivant la procédure
décrite ici [1].
Je me suis connecté avec:
telnet smtp.orange.fr 587
Après la commande AUTH LOGIN et l'envoi du login et du mot de pass e en
base64, j'ai la réponse suivante du serveur:
235 2.7.0 ... authentication succeeded
J'en déduis que mes paramètres d'authentification sont correc ts mais
j'ai un doute sur les paramètres de connexion car je lis ici ou l à des
références aux ports 25 ou 465.
Quels paramètres de connexion doit-on privilégier ?

2. Je poursuis pour ensuite arriver à émettre mais il n'y a p as
d'émetteur dans le mail reçu malgré la commande
MAIL FROM:
250 2.1.0 sender ok
Avez-vous une suggestion pour valoriser en telnet avec le SMTP d'Orange
l'adresse d'émission ?

3. Je reviens maintenant à mailx et exim4.
Je configure ceux-ci du mieux possible et je lance un envoi avec mailx
et l'option -v.
J'observe alors à l'écran:
SMTP<< 550 5.1.0 Authentification requise. Authentication Required.
OFR102_402 [402]

Avant cette ligne, j'observe que mailx/exim4 n'émet aucune command e AUTH
LOGIN préalable, analogue à celle que j'envoie avec telnet.
Ma question est: comment dois-je spécifier à exim4/mailx d'en voyer un
AUTH LOGIN ?

J'ai ceci dans /etc/exim4/pass.client:
smtp.orange.fr::monmotdpasse

Dans update-exim4.conf.conf, j'ai:
dc_smarthost='smtp.orange.fr::587'


Slts



[1] http://www.lin" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.linuxjournal.com/content/troubleshooting-telnet" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.lin" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.linuxjournal.com/content/troubleshooting-telnet



--
Guillaume






--
Guillaume





--047d7bdcaa0ee1b1fc051620ec72
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir="ltr"><div><div>Bonjour,<br><br></div>Pourquoi ne pas laisser ex im4 envoyé lui même l&#39;email?<br></div>Il faut cependant ajout er l&#39;IP publique que vous utilisez dans le champs SPF du domaine concer né afin de ne pas passer en spam.<br></div><div class="gmail_extra"> <br><div class="gmail_quote">Le 15 mai 2015 17:25, Guillaume <span dir= "ltr">&lt;<a href="mailto:" target="_blank">list- </a>&gt;</span> a écrit :<br><blockquote class="gma il_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-lef t:1ex">



<div bgcolor="#FFFFFF" text="#000000">
Oui c&#39;est ça, a vérifier quand même.<div><div class ="h5"><br>
<br>
<div>Le 15/05/2015 17:08, Olivier a écrit :<br>
</div>
<blockquote type="cite">
<div dir="ltr"><br>
<div class="gmail_extra"><br>
<div class="gmail_quote">Le 15 mai 2015 16:42, Guillaume <span dir="ltr">&lt;<a href="mailto:" target="_blank" ></a>&gt;</span>
a écrit :<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;bo rder-left:1px #ccc solid;padding-left:1ex">
<div bgcolor="#FFFFFF" text="#000000"> Bonjour,<br>
<br>
Désolé je ne peux pas t&#39;aider à propos d &#39;Exim4,<br>
<br>
mais il me sembe qu&#39;Orange utilise la même protect ion.</div>
</blockquote>
<div><br>
</div>
<div>Tu veux dire qu&#39;on ne peux qu&#39;émettre avec l& #39;adresse
d&#39;émission fournie par Orange ? <br>
</div>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;bo rder-left:1px #ccc solid;padding-left:1ex">
<div bgcolor="#FFFFFF" text="#000000">
<div>
<div><br>
<br>
<br>
<div>Le 15/05/2015 16:22, Olivier a écrit :<b r>
</div>
<blockquote type="cite">
<div dir="ltr">
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>Bonjour,<br>
<br>
</div>
J&#39;ai un
système (sou s
Squeeze) qui
émet quelque s
courriels.<br>
</div>
Il utilise
exim4 et un
compte GMail
pour ses
envois et
l&#39;ensemble
fonctionne
sans histoire.<br >
<br>
</div>
Depuis peu, j&#39;a i
une nouvelle
exigence: je
dois émettre
certains mails
avec une adresse
d&#39;émisssio n
précise
(exemple: <a href ="mailto:" target="_blank"></a>
et non plus <a href ="mailto:" target="_blank"></a>).<br>
<br>
</div>
Grâce à cet te
liste, j&#39;ai pu
trouver le moyen
pour configurer
l&#39;adresse
d&#39;émission: le pb
est que mon compte
GMail n&#39;accepte
pas une autre
adresse d&#39;ém ission
que la sienne.<br>
<br>
</div>
Pour contourner
cette limitation,
j&#39;envisage
d&#39;utiliser les
paramètres SMTP
fournis avec le lien
ADSL Orange du site
d&#39;installation de
mon système.<br>
<br>
</div>
Je rencontre des
difficultés pour
émettre avec ces
paramètres SMTP Oran ge
et j&#39;apprécierai
beaucoup une aide sur
le sujet.<br>
<br>
</div>
Voici comment j&#39;ai
procédé:<br>
<br>
</div>
1. J&#39;ai testé unitai rement
les paramètres SMTP en
suivant la procédure
décrite ici [1].<br>
</div>
<div>Je me suis connecté
avec:<br>
</div>
<div>telnet <a href="http://s mtp.orange.fr" target="_blank">smtp.orange.fr</a>
587<br>
</div>
<div>Après la commande AUT H
LOGIN et l&#39;envoi du login
et du mot de passe en
base64, j&#39;ai la répo nse
suivante du serveur:<br>
235 2.7.0 ...
authentication succeeded<br>
</div>
<div>J&#39;en déduis que m es
paramètres
d&#39;authentification sont
corrects mais j&#39;ai un
doute sur les paramètres
de connexion car je lis
ici ou là des réf érences
aux ports 25 ou 465.<br>
</div>
<div>Quels paramètres de
connexion doit-on
privilégier ?<br>
</div>
<div><br>
</div>
<div>2. Je poursuis pour
ensuite arriver à é mettre
mais il n&#39;y a pas
d&#39;émetteur dans le m ail
reçu malgré la comm ande <br>
</div>
</div>
MAIL FROM: &lt;<a href="mailto: " target="_blank"></a>&gt;                

<br>
250 2.1.0 &lt;<a href="mailto:b " target="_blank"></a>&gt;

sender ok<br>
</div>
Avez-vous une suggestion pour
valoriser en telnet avec le SMTP
d&#39;Orange l&#39;adresse d&#39; émission ?<br>
<br>
</div>
3. Je reviens maintenant à mailx
et exim4.<br>
</div>
Je configure ceux-ci du mieux
possible et je lance un envoi avec
mailx et l&#39;option -v.<br>
</div>
J&#39;observe alors à l&#39;écr an:<br>
  SMTP&lt;&lt; 550 5.1.0
Authentification requise.
Authentication Required. OFR102_402
[402]<br>
<br>
</div>
Avant cette ligne, j&#39;observe que
mailx/exim4 n&#39;émet aucune commande AUTH
LOGIN préalable, analogue à celle que
j&#39;envoie avec telnet.<br>
</div>
Ma question est: comment dois-je spécifi er
à exim4/mailx d&#39;envoyer un AUTH LOGI N ?<br>
<br>
</div>
J&#39;ai ceci dans /etc/exim4/pass.client:<br>
<a href="mailto:smtp.orange.fr: ge.fr:monmotdpasse" target="_blank">smtp.orange.fr::mo nmotdpasse</a><br>
<br>
</div>
Dans update-exim4.conf.conf, j&#39;ai:<br>
dc_smarthost=&#39;smtp.orange.fr::587&#39;<br>
<br>
<br>
</div>
Slts<br>
<div><br>
<div><br>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div><br>
[1] <a href="http://www.lin" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.lin uxjournal.com/content/troubleshooting-telnet" target="_blank">http://www. linuxjournal.com/content/troubleshooting-telnet</a>
<br>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</blockquote>
<br>
<br>
</div>
</div>
<span><font color="#888888">
<pre cols="72">--
Guillaume</pre>
</font></span></div>
</blockquote>
</div>
<br>
</div>
</div>
</blockquote>
<br>
<br>
</div></div><span class="HOEnZb"><font color="#888888"><pre cols= "72">--
Guillaume</pre>
</font></span></div>

</blockquote></div><br></div>

--047d7bdcaa0ee1b1fc051620ec72--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/CA+GqTg8AYVpU8xhMJ+
Avatar
Olivier
--001a11347920f185f30516212322
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

Le 15 mai 2015 17:59, SD76 a écrit :

Bonjour,

Pourquoi ne pas laisser exim4 envoyé lui même l'email?




Je ne suis pas sûr de comprendre la remarque.
Si tu fais référence à l'utilisation de telnet, il s'agit bi en sûr d'une
utilisation temporaire n'ayant pour but que de valider certains paramè tres.
En utilisation courante, les scripts utilisent mailx-heirloom qui s'appuie
sur exim.



Il faut cependant ajouter l'IP publique que vous utilisez dans le champs
SPF du domaine concerné afin de ne pas passer en spam.



Peux-tu préciser ?



Le 15 mai 2015 17:25, Guillaume a écrit :

Oui c'est ça, a vérifier quand même.


Le 15/05/2015 17:08, Olivier a écrit :



Le 15 mai 2015 16:42, Guillaume a écrit :

Bonjour,

Désolé je ne peux pas t'aider à propos d'Exim4,

mais il me sembe qu'Orange utilise la même protection.




Tu veux dire qu'on ne peux qu'émettre avec l'adresse d'émissi on fournie
par Orange ?




Le 15/05/2015 16:22, Olivier a écrit :

Bonjour,

J'ai un système (sous Squeeze) qui émet quelques courriels.
Il utilise exim4 et un compte GMail pour ses envois et l'ensemble
fonctionne sans histoire.

Depuis peu, j'ai une nouvelle exigence: je dois émettre certains mails
avec une adresse d'émisssion précise (exemple: e.fr et
non plus ).

Grâce à cette liste, j'ai pu trouver le moyen pour configure r l'adresse
d'émission: le pb est que mon compte GMail n'accepte pas une autre adresse
d'émission que la sienne.

Pour contourner cette limitation, j'envisage d'utiliser les paramà ¨tres
SMTP fournis avec le lien ADSL Orange du site d'installation de mon sys tème.

Je rencontre des difficultés pour émettre avec ces paramà ¨tres SMTP
Orange et j'apprécierai beaucoup une aide sur le sujet.

Voici comment j'ai procédé:

1. J'ai testé unitairement les paramètres SMTP en suivant la procédure
décrite ici [1].
Je me suis connecté avec:
telnet smtp.orange.fr 587
Après la commande AUTH LOGIN et l'envoi du login et du mot de pas se en
base64, j'ai la réponse suivante du serveur:
235 2.7.0 ... authentication succeeded
J'en déduis que mes paramètres d'authentification sont corre cts mais
j'ai un doute sur les paramètres de connexion car je lis ici ou l à des
références aux ports 25 ou 465.
Quels paramètres de connexion doit-on privilégier ?

2. Je poursuis pour ensuite arriver à émettre mais il n'y a pas
d'émetteur dans le mail reçu malgré la commande
MAIL FROM:
250 2.1.0 sender ok
Avez-vous une suggestion pour valoriser en telnet avec le SMTP d'Orang e
l'adresse d'émission ?

3. Je reviens maintenant à mailx et exim4.
Je configure ceux-ci du mieux possible et je lance un envoi avec mailx
et l'option -v.
J'observe alors à l'écran:
SMTP<< 550 5.1.0 Authentification requise. Authentication Required.
OFR102_402 [402]

Avant cette ligne, j'observe que mailx/exim4 n'émet aucune comman de
AUTH LOGIN préalable, analogue à celle que j'envoie avec teln et.
Ma question est: comment dois-je spécifier à exim4/mailx d'e nvoyer un
AUTH LOGIN ?

J'ai ceci dans /etc/exim4/pass.client:
smtp.orange.fr::monmotdpasse

Dans update-exim4.conf.conf, j'ai:
dc_smarthost='smtp.orange.fr::587'


Slts



[1] http://www.lin" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.linuxjournal.com/content/troubleshooting-telnet" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.lin" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.linuxjournal.com/content/troubleshooting-telnet



--
Guillaume






--
Guillaume








--001a11347920f185f30516212322
Content-Type: text/html; charset=UTF-8
Content-Transfer-Encoding: quoted-printable

<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quo te">Le 15 mai 2015 17:59, SD76 <span dir="ltr">&lt;<a href="mailto:sd76 " target="_blank"></a>&gt;</span> a écrit :<br><blockquote class="gmail_quote" style="margin:0 0 0 .8 ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div><div> Bonjour,<br><br></div>Pourquoi ne pas laisser exim4 envoyé lui mê me l&#39;email?<br></div></div></blockquote><div><br></div><div>Je ne suis pas sûr de comprendre la remarque.<br></div><div>Si tu fais réf érence à l&#39;utilisation de telnet, il s&#39;agit bien sûr d&#39;une utilisation temporaire n&#39;ayant pour but que de valider certa ins paramètres.<br></div><div>En utilisation courante, les scripts uti lisent mailx-heirloom qui s&#39;appuie sur exim. <br></div><div><br></div>< div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8e x;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div></div> Il faut cependant ajouter l&#39;IP publique que vous utilisez dans le champ s SPF du domaine concerné afin de ne pas passer en spam.<br></div></bl ockquote><div>Peux-tu préciser ?<br></div><div> </div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc soli d;padding-left:1ex"><div dir="ltr"></div><div class="HOEnZb"><div class ="h5"><div class="gmail_extra"><br><div class="gmail_quote">Le 15 mai 2015 17:25, Guillaume <span dir="ltr">&lt;<a href="mailto:list-debian@ gwilhom.fr" target="_blank"></a>&gt;</span> a à ©crit :<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;b order-left:1px #ccc solid;padding-left:1ex">



<div bgcolor="#FFFFFF" text="#000000">
Oui c&#39;est ça, a vérifier quand même.<div><div><br>
<br>
<div>Le 15/05/2015 17:08, Olivier a écrit :<br>
</div>
<blockquote type="cite">
<div dir="ltr"><br>
<div class="gmail_extra"><br>
<div class="gmail_quote">Le 15 mai 2015 16:42, Guillaume <span dir="ltr">&lt;<a href="mailto:" target="_blank" ></a>&gt;</span>
a écrit :<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;bo rder-left:1px #ccc solid;padding-left:1ex">
<div bgcolor="#FFFFFF" text="#000000"> Bonjour,<br>
<br>
Désolé je ne peux pas t&#39;aider à propos d &#39;Exim4,<br>
<br>
mais il me sembe qu&#39;Orange utilise la même protect ion.</div>
</blockquote>
<div><br>
</div>
<div>Tu veux dire qu&#39;on ne peux qu&#39;émettre avec l& #39;adresse
d&#39;émission fournie par Orange ? <br>
</div>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;bo rder-left:1px #ccc solid;padding-left:1ex">
<div bgcolor="#FFFFFF" text="#000000">
<div>
<div><br>
<br>
<br>
<div>Le 15/05/2015 16:22, Olivier a écrit :<b r>
</div>
<blockquote type="cite">
<div dir="ltr">
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>Bonjour,<br>
<br>
</div>
J&#39;ai un
système (sou s
Squeeze) qui
émet quelque s
courriels.<br>
</div>
Il utilise
exim4 et un
compte GMail
pour ses
envois et
l&#39;ensemble
fonctionne
sans histoire.<br >
<br>
</div>
Depuis peu, j&#39;a i
une nouvelle
exigence: je
dois émettre
certains mails
avec une adresse
d&#39;émisssio n
précise
(exemple: <a href ="mailto:" target="_blank"></a>
et non plus <a href ="mailto:" target="_blank"></a>).<br>
<br>
</div>
Grâce à cet te
liste, j&#39;ai pu
trouver le moyen
pour configurer
l&#39;adresse
d&#39;émission: le pb
est que mon compte
GMail n&#39;accepte
pas une autre
adresse d&#39;ém ission
que la sienne.<br>
<br>
</div>
Pour contourner
cette limitation,
j&#39;envisage
d&#39;utiliser les
paramètres SMTP
fournis avec le lien
ADSL Orange du site
d&#39;installation de
mon système.<br>
<br>
</div>
Je rencontre des
difficultés pour
émettre avec ces
paramètres SMTP Oran ge
et j&#39;apprécierai
beaucoup une aide sur
le sujet.<br>
<br>
</div>
Voici comment j&#39;ai
procédé:<br>
<br>
</div>
1. J&#39;ai testé unitai rement
les paramètres SMTP en
suivant la procédure
décrite ici [1].<br>
</div>
<div>Je me suis connecté
avec:<br>
</div>
<div>telnet <a href="http://s mtp.orange.fr" target="_blank">smtp.orange.fr</a>
587<br>
</div>
<div>Après la commande AUT H
LOGIN et l&#39;envoi du login
et du mot de passe en
base64, j&#39;ai la répo nse
suivante du serveur:<br>
235 2.7.0 ...
authentication succeeded<br>
</div>
<div>J&#39;en déduis que m es
paramètres
d&#39;authentification sont
corrects mais j&#39;ai un
doute sur les paramètres
de connexion car je lis
ici ou là des réf érences
aux ports 25 ou 465.<br>
</div>
<div>Quels paramètres de
connexion doit-on
privilégier ?<br>
</div>
<div><br>
</div>
<div>2. Je poursuis pour
ensuite arriver à é mettre
mais il n&#39;y a pas
d&#39;émetteur dans le m ail
reçu malgré la comm ande <br>
</div>
</div>
MAIL FROM: &lt;<a href="mailto: " target="_blank"></a>&gt;                

<br>
250 2.1.0 &lt;<a href="mailto:b " target="_blank"></a>&gt;

sender ok<br>
</div>
Avez-vous une suggestion pour
valoriser en telnet avec le SMTP
d&#39;Orange l&#39;adresse d&#39; émission ?<br>
<br>
</div>
3. Je reviens maintenant à mailx
et exim4.<br>
</div>
Je configure ceux-ci du mieux
possible et je lance un envoi avec
mailx et l&#39;option -v.<br>
</div>
J&#39;observe alors à l&#39;écr an:<br>
  SMTP&lt;&lt; 550 5.1.0
Authentification requise.
Authentication Required. OFR102_402
[402]<br>
<br>
</div>
Avant cette ligne, j&#39;observe que
mailx/exim4 n&#39;émet aucune commande AUTH
LOGIN préalable, analogue à celle que
j&#39;envoie avec telnet.<br>
</div>
Ma question est: comment dois-je spécifi er
à exim4/mailx d&#39;envoyer un AUTH LOGI N ?<br>
<br>
</div>
J&#39;ai ceci dans /etc/exim4/pass.client:<br>
<a href="mailto:smtp.orange.fr: ge.fr:monmotdpasse" target="_blank">smtp.orange.fr::mo nmotdpasse</a><br>
<br>
</div>
Dans update-exim4.conf.conf, j&#39;ai:<br>
dc_smarthost=&#39;smtp.orange.fr::587&#39;<br>
<br>
<br>
</div>
Slts<br>
<div><br>
<div><br>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div>
<div><br>
[1] <a href="http://www.lin" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://www.lin uxjournal.com/content/troubleshooting-telnet" target="_blank">http://www. linuxjournal.com/content/troubleshooting-telnet</a>
<br>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</blockquote>
<br>
<br>
</div>
</div>
<span><font color="#888888">
<pre cols="72">--
Guillaume</pre>
</font></span></div>
</blockquote>
</div>
<br>
</div>
</div>
</blockquote>
<br>
<br>
</div></div><span><font color="#888888"><pre cols="72">--
Guillaume</pre>
</font></span></div>

</blockquote></div><br></div>
</div></div></blockquote></div><br></div></div>

--001a11347920f185f30516212322--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/CAPeT9jgEn+
Avatar
Christophe
Hello,

Le 15/05/2015 17:25, Guillaume a écrit :
Oui c'est ça, a vérifier quand même.

Le 15/05/2015 17:08, Olivier a écrit :

Tu veux dire qu'on ne peux qu'émettre avec l'adresse d'émiss ion
fournie par Orange ?







Pour l'avoir fait chez un client il y a peu, il y a d'autres problèm es
(nombre d'envois simultanés par ex), mais il n'y a pas de restrictio n de
ce type. Il me semble par contre que l'authentification par compte/mot
de passe valide chez orange est obligatoire dans ce cas.

Par contre , je ne connais pas du tout exim ...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Avatar
nicolas.patrois
Le 15/05/2015 17:08:43, Olivier a écrit :

Tu veux dire qu'on ne peux qu'émettre avec l'adresse d'émission
fournie par Orange ?



Non, tu peux utiliser d’autres adresses (encore heureux pour moi).
Il faut entrer le nom d’utilisateur d’Orange et la phrase d e passe
donnés.

nicolas patrois : pts noir asocial
--
RÉALISME

M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des
humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Avatar
Christophe
Hello,

Le 15/05/2015 17:59, SD76 a écrit :
Bonjour,

Pourquoi ne pas laisser exim4 envoyé lui même l'email?
Il faut cependant ajouter l'IP publique que vous utilisez dans le champ s
SPF du domaine concerné afin de ne pas passer en spam.




A moins que ca ait changé, ce dont je doute, ce n'est pas possible c hez
Orange (Offres residentielles et pro) : port 25 bloqué en sortie (et
blocage non désactivable).

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Avatar
Pierre Meurisse
On Fri, May 15, 2015 at 04:22:04PM +0200, Olivier wrote:
Bonjour,

J'ai un système (sous Squeeze) qui émet quelques courriels.
Il utilise exim4 et un compte GMail pour ses envois et l'ensemble
fonctionne sans histoire.

Depuis peu, j'ai une nouvelle exigence: je dois émettre certains mails avec
une adresse d'émisssion précise (exemple: et non plus
).

Grâce à cette liste, j'ai pu trouver le moyen pour configurer l'adresse
d'émission: le pb est que mon compte GMail n'accepte pas une autre adresse
d'émission que la sienne.

Pour contourner cette limitation, j'envisage d'utiliser les paramètres SMTP
fournis avec le lien ADSL Orange du site d'installation de mon système.

Je rencontre des difficultés pour émettre avec ces paramètres SMTP Orange
et j'apprécierai beaucoup une aide sur le sujet.




J'ai le même problème avec free.
Si je comprends bien, tes utilisateurs doivent voir comme expéditeur
mais gmail doit voir

A la fin de REWRITE CONFIGURATION dans /etc/exim4.conf/exim4.conf.template :
*@machine.domaine F
rsf

éventuellement, pour un autre utilisateur :
rsf

et ensuite :
$ sudo update-exim4.conf

Pour vérifier :

$ sudo exim4 -brw toi




Hope this helps.





--
Pierre Meurisse

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Avatar
Alain Rpnpif
Le 15 mai 2015, a écrit :

Le 15/05/2015 17:08:43, Olivier a écrit :

> Tu veux dire qu'on ne peux qu'émettre avec l'adresse d'émissi on
> fournie par Orange ?

Non, tu peux utiliser d’autres adresses (encore heureux pour moi).
Il faut entrer le nom d’utilisateur d’Orange et la phrase de passe
donnés.



Bonjour,

Oui, il est parfaitement possible d'envoyer un message par Orange avec
un nom d'utilisateur différent de celui du compte Orange de connexion.

L'authentification chez Orange est à la fois une garantie anti
départ de spam et un flicage.

Le problème se situe à la fois chez l'expéditeur Orange et c hez certains
serveurs destinataires.

Chez Orange, on peut utiliser l'authentification dure qui met le nom du
compte de connexion dans les en-têtes des messages. Cela peut
être gênant quand on accueille des invités ou que l'on utili se des
adresses courriel "poubelles" afin d'éviter le spam par exemple.
Une façon de faire qui devrait être évitée dans les PME à mon avis.
Les réglages sont relativement faciles pour Postfix avec
smtpauth.orange.fr:587 en relais. Le mot de passe du compte Orange doit
être déclaré dans un fichier à part. Sans doute c'est a ussi possible
avec Exim.

On peut aussi utiliser une authentification plus "douce". Seule
l'adresse IP d'origine sera incluse dans les en-têtes des messages
avec smtp.orange.fr en relais.
Tout est expliqué dans l'assistance d'Orange.

Les problèmes de connexion peuvent aussi se confondre avec un refus du
serveur destinataire qui fait une vérification SPF
(http://fr.wikipedia.org/wiki/Sender_Policy_Framework). Ne trouvant
évidemment pas le destinataire par exemple chez
Orange, il refuse le message. Ce destinataire vérifie l'existence
réelle de l'expéditeur auprès du serveur expéditeur. C' est par exemple
le cas quand on utilise une adresse d'expéditeur chez laposte.net.
De plus certains de ces serveurs destinataires me semblent bogués ou
excessivement sévères. La solution se trouve au niveau de l'envel oppe
du message envoyé.

Par exemple sous claws-mail, on peut envoyer les messages au serveur
Postfix par la commande externe de Postfix
/usr/sbin/sendmail -t -i -f
Je n'ai pas essayé sous Exim.

En résumé, ce n'est pas si simple que ça mais faisable.

--
Alain Rpnpif

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
Avatar
Philippe Gras
--Apple-Mail=_4CC12709-2F8F-4A37-BD40-8CE4055A7790
Content-Transfer-Encoding: quoted-printable
Content-Type: text/plain;
charset=windows-1252


Le 17 mai 2015 à 10:50, Alain Rpnpif a écrit :

Le 15 mai 2015, a écrit :

Le 15/05/2015 17:08:43, Olivier a écrit :

Tu veux dire qu'on ne peux qu'émettre avec l'adresse d'émission
fournie par Orange ?



Non, tu peux utiliser d’autres adresses (encore heureux pour moi).
Il faut entrer le nom d’utilisateur d’Orange et la phrase de passe
donnés.



Bonjour,

Oui, il est parfaitement possible d'envoyer un message par Orange avec
un nom d'utilisateur différent de celui du compte Orange de connexion.



Oui, mais…

L'authentification chez Orange est à la fois une garantie anti
départ de spam et un flocage.



Pas sûr :-D

Le problème se situe à la fois chez l'expéditeur Orange et chez certains
serveurs destinataires.

Chez Orange, on peut utiliser l'authentification dure qui met le nom du
compte de connexion dans les en-têtes des messages. Cela peut
être gênant quand on accueille des invités ou que l'on utilise des
adresses courriel "poubelles" afin d'éviter le spam par exemple.
Une façon de faire qui devrait être évitée dans les PME à mon avis.
Les réglages sont relativement faciles pour Postfix avec
smtpauth.orange.fr:587 en relais. Le mot de passe du compte Orange doit
être déclaré dans un fichier à part. Sans doute c'est aussi possible
avec Exim.



Je crois que c’est ce que je fais, mais avec smtp.orange.fr et je l’utilise juste
pour faire partir mon courrier, que ce soit celui de ou
celui de mes domaines

Par contre, je n’ai jamais réussi à faire partir ces derniers courriers autrement
que par France Télécom depuis mon client mail.

Je n’ai jamais réussi à faire partir un mail d’un de ces domaines sur le serveur
mail de ce domaine.

On peut aussi utiliser une authentification plus "douce". Seule
l'adresse IP d'origine sera incluse dans les en-têtes des messages
avec smtp.orange.fr en relais.
Tout est expliqué dans l'assistance d'Orange.

Les problèmes de connexion peuvent aussi se confondre avec un refus du
serveur destinataire qui fait une vérification SPF
(http://fr.wikipedia.org/wiki/Sender_Policy_Framework). Ne trouvant
évidemment pas le destinataire par exemple chez
Orange, il refuse le message. Ce destinataire vérifie l'existence
réelle de l'expéditeur auprès du serveur expéditeur. C'est par exemple
le cas quand on utilise une adresse d'expéditeur chez laposte.net.
De plus certains de ces serveurs destinataires me semblent bogués ou
excessivement sévères. La solution se trouve au niveau de l'enveloppe
du message envoyé.



Je crois que SPF, ce n’est pas tout à fait ça. D’ailleurs orange n’a pas de champ
texte pour le SPF dans ses DNS.

L’authentification SPF si je m’en réfère à ma science toute neuve, c’est quand on
reçois un mail de , il est bien passé par chez le serveur du
propriétaire de free.fr ET/OU l’IP OU la plage IP de se(s) serveur(s) :

$ host -t TXT pole-emploi.fr
pole-emploi.fr descriptive text "v=spf1 include:spf-a.pole-emploi.fr include:spf-b.pole-emploi.fr ?all »
$ host -t TXT gmail.com
gmail.com descriptive text "v=spf1 redirect=_spf.google.com"
$ host -t TXT orange.fr
orange.fr descriptive text "google-site-verificationOfrczLMSJm4DyV_ROkN-H3IoVB-up0QI0FfErDj2Y"
$ host -t TXT free.fr
free.fr has no TXT record
$ host -t TXT debian.org
debian.org has no TXT record
$ host -t TXT lists.debian.org
lists.debian.org has no TXT record

Je voulais vous montrer comment c’est chez moi, j’ai l’impression d’avoir oublié 1 truc :-(

Là dans mes exemples, seuls pole-emploi.fr et gmail.com utilisent l’authentification SPF.


Par exemple sous claws-mail, on peut envoyer les messages au serveur
Postfix par la commande externe de Postfix
/usr/sbin/sendmail -t -i -f
Je n'ai pas essayé sous Exim.

En résumé, ce n'est pas si simple que ça mais faisable.

--
Alain Rpnpif

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">https://lists.debian.org/





--Apple-Mail=_4CC12709-2F8F-4A37-BD40-8CE4055A7790
Content-Transfer-Encoding: quoted-printable
Content-Type: text/html;
charset=windows-1252

<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;"><br><div><div>Le 17 mai 2015 à 10:50, Alain Rpnpif &lt;<a href="mailto:"></a>&gt; a écrit :</div><br class="Apple-interchange-newline"><blockquote type="cite">Le 15 mai 2015, <a href="mailto:"></a> a écrit :<br><br><blockquote type="cite">Le 15/05/2015 17:08:43, Olivier a écrit&nbsp;:<br><br><blockquote type="cite">Tu veux dire qu'on ne peux qu'émettre avec l'adresse d'émission<br>fournie par Orange ?<br></blockquote><br>Non, tu peux utiliser d’autres adresses (encore heureux pour moi).<br>Il faut entrer le nom d’utilisateur d’Orange et la phrase de passe <br>donnés.<br></blockquote><br>Bonjour,<br><br>Oui, il est parfaitement possible d'envoyer un message par Orange avec<br>un nom d'utilisateur différent de celui du compte Orange de connexion.<br></blockquote><div><br></div>Oui, mais…<br><blockquote type="cite"><br>L'authentification chez Orange est à la fois une garantie anti<br>départ de spam et un flocage.<br></blockquote><div><br></div>Pas sûr :-D<br><blockquote type="cite"><br>Le problème se situe à la fois chez l'expéditeur Orange et chez certains<br>serveurs destinataires.<br><br>Chez Orange, on peut utiliser l'authentification dure qui met le nom du<br>compte de connexion dans les en-têtes des messages. Cela peut<br>être gênant quand on accueille des invités ou que l'on utilise des<br>adresses courriel "poubelles" afin d'éviter le spam par exemple.<br>Une façon de faire qui devrait être évitée dans les PME à mon avis.<br>Les réglages sont relativement faciles pour Postfix avec<br><a href="http://smtpauth.orange.fr">smtpauth.orange.fr</a>:587 en relais. Le mot de passe du compte Orange doit<br>être déclaré dans un fichier à part. Sans doute c'est aussi possible<br>avec Exim.<br></blockquote><div><br></div>Je crois que c’est ce que je fais, mais avec <a href="http://smtp.orange.fr">smtp.orange.fr</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://smtp.orange.fr">smtp.orange.fr</a&gt; et je l’utilise juste</div><div>pour faire partir mon courrier, que ce soit celui de <a href="mailto:"></a> ou</div><div>celui de mes domaines <a href="mailto:"> eindenomsacoucherdehorsdifferents.tld</a></div><div><br></div><div>Par contre, je n’ai jamais réussi à faire partir ces derniers courriers autrement</div><div>que par France Télécom depuis mon client mail.</div><div><br></div><div>Je n’ai jamais réussi à faire partir un mail d’un de ces domaines sur le serveur</div><div>mail de ce domaine.<br><blockquote type="cite"><br>On peut aussi utiliser une authentification plus "douce". Seule<br>l'adresse IP d'origine sera incluse dans les en-têtes des messages<br>avec <a href="http://smtp.orange.fr">smtp.orange.fr</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://smtp.orange.fr">smtp.orange.fr</a&gt; en relais.<br>Tout est expliqué dans l'assistance d'Orange.<br><br>Les problèmes de connexion peuvent aussi se confondre avec un refus du<br>serveur destinataire qui fait une vérification SPF<br>(<a href="http://fr.wikipedia.org/wiki/Sender_Policy_Framework">http://fr.wi kipedia.org/wiki/Sender_Policy_Framework</a>). Ne trouvant<br>évidemment pas le destinataire <a href="mailto:"></a> par exemple chez<br>Orange, il refuse le message. Ce destinataire vérifie l'existence<br>réelle de l'expéditeur auprès du serveur expéditeur. C'est par exemple<br>le cas quand on utilise une adresse d'expéditeur chez <a href="http://laposte.net">laposte.net</a>.<br>De plus certains de ces serveurs destinataires me semblent bogués ou<br>excessivement sévères. La solution se trouve au niveau de l'enveloppe<br>du message envoyé.<br></blockquote><div><br></div>Je crois que SPF, ce n’est pas tout à fait ça. D’ailleurs orange n’a pas de champ</div><div>texte pour le SPF dans ses DNS.</div><div><br></div><div>L’authentification SPF si je m’en réfère à ma science toute neuve, c’est quand on</div><div>reçois un mail de <a href="mailto:"></a>, il est bien passé par chez le serveur du</div><div>propriétaire de <a href="http://free.fr">free.fr</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://free.fr">free.fr</a&gt; ET/OU l’IP OU la plage IP de se(s) serveur(s) :</div><div><br></div><div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">$ host -t TXT <a href="http://pole-emploi.fr">pole-emploi.fr</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://pole-emploi.fr">pole-emploi.fr</a&gt;</div><div" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://pole-emploi.fr">pole-emploi.fr</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://pole-emploi.fr">pole-emploi.fr</a&gt;</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;"><a href="http://pole-emploi.fr">pole-emploi.fr</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://pole-emploi.fr">pole-emploi.fr</a&gt; descriptive text "v=spf1 include:spf-<a href="http://a.pole-emploi.fr">a.pole-emploi.fr</a&gt; include:spf-<a href="http://b.pole-emploi.fr">b.pole-emploi.fr</a&gt; ?all&nbsp;»</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;"><div style="margin: 0px;">$ host -t TXT <a href="http://gmail.com">gmail.com</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://gmail.com">gmail.com</a&gt;</div><div" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://gmail.com">gmail.com</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://gmail.com">gmail.com</a&gt;</div><div style="margin: 0px;"><a href="http://gmail.com">gmail.com</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://gmail.com">gmail.com</a&gt; descriptive text "v=spf1 redirect=_<a href="http://spf.google.com">spf.google.com</a>"</div><div&gt;$ host -t TXT <a href="http://orange.fr">orange.fr</a&gt;</div></div><div><div" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://orange.fr">orange.fr</a&gt;</div></div><div><div style="margin: 0px; font-size: 11px; font-family: Menlo;"><a href="http://orange.fr">orange.fr</a&gt; descriptive text "google-site-verificationOfrczLMSJm4DyV_ROkN-H3IoVB-up0QI0FfErDj2Y"</ div></div><div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">$ host -t TXT <a href="http://free.fr">free.fr</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://free.fr">free.fr</a&gt;</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;"><a href="http://free.fr">free.fr</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://free.fr">free.fr</a&gt; has no TXT record</div></div><div style="margin: 0px; font-size: 11px; font-family: Menlo;"><div style="margin: 0px;">$ host -t TXT <a href="http://debian.org">debian.org</a&gt;</div><div" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://debian.org">debian.org</a&gt;</div><div style="margin: 0px;"><a href="http://debian.org">debian.org</a&gt; has no TXT record</div><div><div style="margin: 0px;">$ host -t TXT <a href="http://lists.debian.org">lists.debian.org</a&gt;</div><div" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://lists.debian.org">lists.debian.org</a&gt;</div><div style="margin: 0px;"><a href="http://lists.debian.org">lists.debian.org</a&gt; has no TXT record</div></div><div><br></div></div><div>Je voulais vous montrer comment c’est chez moi, j’ai l’impression d’avoir oublié 1 truc :-(</div><div><br></div><div>Là dans mes exemples, seuls <a href="http://pole-emploi.fr">pole-emploi.fr</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://pole-emploi.fr">pole-emploi.fr</a&gt; et <a href="http://gmail.com">gmail.com</a&gt" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://gmail.com">gmail.com</a&gt; utilisent l’authentification SPF.</div><div><br></div><blockquote type="cite"><br>Par exemple sous claws-mail, on peut envoyer les messages au serveur<br>Postfix par la commande externe de Postfix<br>/usr/sbin/sendmail -t -i -f <a href="mailto:">mon_adresse_de_connexio </a><br>Je n'ai pas essayé sous Exim.<br><br>En résumé, ce n'est pas si simple que ça mais faisable.<br><br>-- <br>Alain Rpnpif<br><br>--<br>Lisez la FAQ de la liste avant de poser une question :<br><a href="http://wiki.debian.org/fr/FrenchLists" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://wiki.debian.org/fr/FrenchLists">http://wiki.debian.org/fr/F renchLists</a><br><br>Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"<br>vers <br>En cas de soucis, contactez EN ANGLAIS <br>Archive: https://lists.debian.org/" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">https://lists.debian.org/<br><br></blo ckquote></div><br></body></html>
--Apple-Mail=_4CC12709-2F8F-4A37-BD40-8CE4055A7790--

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">https://lists.debian.org/
Avatar
Alain Rpnpif
Le 17 mai 2015, Philippe Gras a écrit :


Le 17 mai 2015 à 10:50, Alain Rpnpif a écrit :

> Le 15 mai 2015, a écrit :
>
>> Le 15/05/2015 17:08:43, Olivier a écrit :
>>
>>> Tu veux dire qu'on ne peux qu'émettre avec l'adresse d'émis sion
>>> fournie par Orange ?
>>
>> Non, tu peux utiliser d’autres adresses (encore heureux pour m oi).
>> Il faut entrer le nom d’utilisateur d’Orange et la phr ase de passe
>> donnés.
>
> Bonjour,
>
> Oui, il est parfaitement possible d'envoyer un message par Orange avec
> un nom d'utilisateur différent de celui du compte Orange de connex ion.

Oui, mais…
>
> L'authentification chez Orange est à la fois une garantie anti
> départ de spam et un flocage.

Pas sûr :-D



La soi-disant garantie anti-spam est pour Orange pas pour
l'utilisateur. Pas de flocage mais du flicage. :/

> Le problème se situe à la fois chez l'expéditeur Orange et chez certains
> serveurs destinataires.

Par contre, je n’ai jamais réussi à faire partir ces de rniers courriers autrement
que par France Télécom depuis mon client mail.


...
Je crois que SPF, ce n’est pas tout à fait ça. D†™ailleurs orange n’a pas de champ
texte pour le SPF dans ses DNS.

L’authentification SPF si je m’en réfère à ma science toute neuve, c’est quand on
reçois un mail de , il est bien passé par chez le serveur du
propriétaire de free.fr ET/OU l’IP OU la plage IP de se(s) s erveur(s) :

$ host -t TXT pole-emploi.fr
pole-emploi.fr descriptive text "v=spf1 include:spf-a.pole-emploi.fr in clude:spf-b.pole-emploi.fr ?all »
$ host -t TXT gmail.com
gmail.com descriptive text "v=spf1 redirect=_spf.google.com"
$ host -t TXT orange.fr
orange.fr descriptive text "google-site-verificationOfrczLMSJm4DyV_R OkN-H3IoVB-up0QI0FfErDj2Y"
$ host -t TXT free.fr
free.fr has no TXT record
$ host -t TXT debian.org
debian.org has no TXT record
$ host -t TXT lists.debian.org
lists.debian.org has no TXT record

Je voulais vous montrer comment c’est chez moi, j’ai lâ €™impression d’avoir oublié 1 truc :-(

Là dans mes exemples, seuls pole-emploi.fr et gmail.com utilisent l ’authentification SPF.



Comme je disais, tous les serveurs SMTP ne sont pas concernés.

D'Olivier :
J'observe alors à l'écran:
SMTP<< 550 5.1.0 Authentification requise. Authentication Required.
OFR102_402 [402]



Je confirme que le problème vient bien de SPF. La solution de changer
automatiquement ou manuellement l'adresse de l'enveloppe des messages
marche bien avec la méthode que j'ai indiquée. SPF est bien une
validation de l'expéditeur pas une demande de garantie que le message
est bien passé sur son serveur.

--
Alain Rpnpif

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: https://lists.debian.org/
1 2 3