Recherche valeurs

12 réponses
Avatar
turpitude
Bonjour ; dans un tableau un bloc de 6 colonnes T 12 Y 300 je recherche
dans les tirages lotos, un numéros ou une série de 5 numéros plus le
complémentaire tapés ligne T11 Í  Y 11.

Ma syntaxe de recherche en AB 12 est =NB.SI($T$12:X300;AA12) colonne
AA12 étant les nombres sortis de 1 Í  49 recherchés par tirage.

Si je modifie les recherches sur la ligne T 11 Í  Y 11 j'ai l'erreur
syntaxe suivante
=NB.SI(#REF!;AA12).

Je dois retaper la syntaxe complète =NB.SI($T$12:X300;AA12) pour Í 
nouveau obtenir les bons résultats.

Comment taper la bonne syntaxe de recherche AB 12, pour ne pas avoir Í 
retaper =NB.SI($T$12:X300;AA12) en AB12 Í  chaque modif de recherche T11
Í  Y 11
Merci pour votre aide je pense si simple pour vous!

10 réponses

1 2
Avatar
MichD
Le 2021-07-27 Í  04:22, turpitude a écrit :
Si je modifie les recherches sur la ligne  T 11 ͠ Y 11 j'ai l'erreur
syntaxe  suivante
=NB.SI(#REF!;AA12).

Bonjour,
Je n'ai pas vraiment saisi la donne de ton problème. À cette adresse, il
y a une explication de ce qu'est une erreur de type #REF! Les
explications données ne correspondent pas Í  ce que tu décris, comme
étant simplement une modification de données.
https://support.microsoft.com/fr-fr/office/correction-d-un-ref-erreur-822c8e46-e610-4d02-bf29-ec4b8c5ff4be
MichD
Avatar
Pierre Fonds
Le 2021-07-27 Í  04:22, turpitude a écrit :
Bonjour ; dans un tableau un bloc de 6 colonnes T 12 Y 300  je recherche
dans les tirages lotos, un numéros ou une série de 5 numéros plus le
complémentaire tapés  ligne T11 Í  Y 11.
Ma syntaxe de recherche en AB 12 est =NB.SI($T$12:X300;AA12) colonne
AA12 étant les nombres sortis de 1 Í  49 recherchés par tirage.
Si je modifie les recherches sur la ligne  T 11 ͠ Y 11 j'ai l'erreur
syntaxe  suivante
=NB.SI(#REF!;AA12).
Je dois retaper la syntaxe complète =NB.SI($T$12:X300;AA12) pour Í 
nouveau obtenir les bons résultats.
Comment taper la bonne syntaxe de recherche AB 12, pour ne pas avoir Í 
retaper =NB.SI($T$12:X300;AA12) en AB12 Í  chaque modif de recherche T11
Í  Y 11
Merci pour votre aide je pense si simple pour vous!

Je ne comprend pas bien ta demande mais vois si ceci ne pourrait pas
t'aider Í  résoudre ou reformuler ta demande.
J'inscris le résultat du tirage et chacune des sélections
https://www.cjoint.com/c/KGBnTrlwDed
Avatar
MichD
Le 27/07/21 Í  09:49, Pierre Fonds a écrit :
Le 2021-07-27 Í  04:22, turpitude a écrit :
Bonjour ; dans un tableau un bloc de 6 colonnes T 12 Y 300  je
recherche dans les tirages lotos, un numéros ou une série de 5 numéros
plus le complémentaire tapés  ligne T11 Í  Y 11.
Ma syntaxe de recherche en AB 12 est =NB.SI($T$12:X300;AA12) colonne
AA12 étant les nombres sortis de 1 Í  49 recherchés par tirage.
Si je modifie les recherches sur la ligne  T 11 ͠ Y 11 j'ai l'erreur
syntaxe  suivante
=NB.SI(#REF!;AA12).
Je dois retaper la syntaxe complète =NB.SI($T$12:X300;AA12) pour Í 
nouveau obtenir les bons résultats.
Comment taper la bonne syntaxe de recherche AB 12, pour ne pas avoir Í 
retaper =NB.SI($T$12:X300;AA12) en AB12 Í  chaque modif de recherche
T11 Í  Y 11
Merci pour votre aide je pense si simple pour vous!

Je ne comprend pas bien ta demande mais vois si ceci ne pourrait pas
t'aider Í  résoudre ou reformuler ta demande.
J'inscris le résultat du tirage et chacune des sélections
https://www.cjoint.com/c/KGBnTrlwDed

j'ai regardé rapidement ton fichier,
j'ai modifié les valeurs de la ligne D3:J3 et aucune formule n'affiche
#REF!
O͹ est située cette cellule qui retourne une valeur d'erreur?
Quelle manipulation as-tu faite pour provoquer cette erreur?
MichD
Avatar
Pierre Fonds
Le 2021-07-27 Í  11:06, MichD a écrit :
Le 27/07/21 Í  09:49, Pierre Fonds a écrit :
Le 2021-07-27 Í  04:22, turpitude a écrit :
Bonjour ; dans un tableau un bloc de 6 colonnes T 12 Y 300  je
recherche dans les tirages lotos, un numéros ou une série de 5
numéros plus le complémentaire tapés  ligne T11 Í  Y 11.
Ma syntaxe de recherche en AB 12 est =NB.SI($T$12:X300;AA12) colonne
AA12 étant les nombres sortis de 1 Í  49 recherchés par tirage.
Si je modifie les recherches sur la ligne  T 11 ͠ Y 11 j'ai l'erreur
syntaxe  suivante
=NB.SI(#REF!;AA12).
Je dois retaper la syntaxe complète =NB.SI($T$12:X300;AA12) pour Í 
nouveau obtenir les bons résultats.
Comment taper la bonne syntaxe de recherche AB 12, pour ne pas avoir
Í  retaper =NB.SI($T$12:X300;AA12) en AB12 Í  chaque modif de recherche
T11 Í  Y 11
Merci pour votre aide je pense si simple pour vous!

Je ne comprend pas bien ta demande mais vois si ceci ne pourrait pas
t'aider Í  résoudre ou reformuler ta demande.
J'inscris le résultat du tirage et chacune des sélections
https://www.cjoint.com/c/KGBnTrlwDed

j'ai regardé rapidement ton fichier,
j'ai modifié les valeurs de la ligne D3:J3 et aucune formule n'affiche
#REF!
O͹ est située cette cellule qui retourne une valeur d'erreur?
Quelle manipulation as-tu faite pour provoquer cette erreur?
MichD

Oups. Ce fichier n'est pas celui de Turpitude, le demandeur Í  l'origine
de cette demande. ;)
Avatar
turpitude
Le 27/07/2021 Í  17:06, MichD a écrit :
Merci pour votre aide mais je n'ai pas de solutions Í  mon problème.
Comment rajouter Í  la fonction index la fonction nb.si.
je joins mon fichier pour comprendre la finalité de ma recherche .
En T11 X 11 j'indique un nombre ou plusieurs de 1 Í  49.
J'obtiens le nombre de fois des sorties des nombres associés en colonne AB.
https://www.cjoint.com/c/KGBsZtlPSkX
Le fichier comporte une macro pas de problème de sécurité je l'utilise
depuis plusieurs années.
Merci pour votre aide
Le 27/07/2021 Í  19:42, Pierre Fonds a écrit :
Le 2021-07-27 Í  11:06, MichD a écrit :
Le 27/07/21 Í  09:49, Pierre Fonds a écrit :
Le 2021-07-27 Í  04:22, turpitude a écrit :
Bonjour ; dans un tableau un bloc de 6 colonnes T 12 Y 300  je
recherche dans les tirages lotos, un numéros ou une série de 5
numéros plus le complémentaire tapés  ligne T11 Í  Y 11.
Ma syntaxe de recherche en AB 12 est =NB.SI($T$12:X300;AA12) colonne
AA12 étant les nombres sortis de 1 Í  49 recherchés par tirage.
Si je modifie les recherches sur la ligne  T 11 ͠ Y 11 j'ai l'erreur
syntaxe  suivante
=NB.SI(#REF!;AA12).
Je dois retaper la syntaxe complète =NB.SI($T$12:X300;AA12) pour Í 
nouveau obtenir les bons résultats.
Comment taper la bonne syntaxe de recherche AB 12, pour ne pas avoir
Í  retaper =NB.SI($T$12:X300;AA12) en AB12 Í  chaque modif de
recherche T11 Í  Y 11
Merci pour votre aide je pense si simple pour vous!

Je ne comprend pas bien ta demande mais vois si ceci ne pourrait pas
t'aider Í  résoudre ou reformuler ta demande.
J'inscris le résultat du tirage et chacune des sélections
https://www.cjoint.com/c/KGBnTrlwDed

j'ai regardé rapidement ton fichier,
j'ai modifié les valeurs de la ligne D3:J3 et aucune formule n'affiche
#REF!
O͹ est située cette cellule qui retourne une valeur d'erreur?
Quelle manipulation as-tu faite pour provoquer cette erreur?
MichD

Oups.  Ce fichier n'est pas celui de Turpitude, le demandeur ͠ l'origine
de cette demande.   ;)
Avatar
turpitude
Zut de Zut c'est le bon voyez la difference des resultats
https://www.cjoint.com/c/KGBtd7Hem4X
Le 27/07/2021 Í  21:00, turpitude a écrit :
le fichier joins n'est pas correct c'est celui ci pour les resultats de
la syntaxe
 https://www.cjoint.com/c/KGBs73jf7QX
Le 27/07/2021 Í  20:56, turpitude a écrit :
Le 27/07/2021 Í  17:06, MichD a écrit :
Merci pour votre aide mais je n'ai pas de solutions Í  mon problème.
Comment rajouter Í  la fonction index la fonction nb.si.
je joins mon fichier pour comprendre la finalité de ma recherche .
   En T11 X 11 j'indique un nombre ou plusieurs de 1 ͠ 49.
J'obtiens le nombre de fois des sorties des nombres associés en
colonne AB.
https://www.cjoint.com/c/KGBsZtlPSkX
Le fichier comporte une macro pas de problème de sécurité je l'utilise
depuis plusieurs années.
Merci pour votre aide
Le 27/07/2021 Í  19:42, Pierre Fonds a écrit :
Le 2021-07-27 Í  11:06, MichD a écrit :
Le 27/07/21 Í  09:49, Pierre Fonds a écrit :
Le 2021-07-27 Í  04:22, turpitude a écrit :
Bonjour ; dans un tableau un bloc de 6 colonnes T 12 Y 300  je
recherche dans les tirages lotos, un numéros ou une série de 5
numéros plus le complémentaire tapés  ligne T11 Í  Y 11.
Ma syntaxe de recherche en AB 12 est =NB.SI($T$12:X300;AA12)
colonne AA12 étant les nombres sortis de 1 Í  49 recherchés par
tirage.
Si je modifie les recherches sur la ligne  T 11 ͠ Y 11 j'ai
l'erreur syntaxe  suivante
=NB.SI(#REF!;AA12).
Je dois retaper la syntaxe complète =NB.SI($T$12:X300;AA12) pour Í 
nouveau obtenir les bons résultats.
Comment taper la bonne syntaxe de recherche AB 12, pour ne pas
avoir Í  retaper =NB.SI($T$12:X300;AA12) en AB12 Í  chaque modif de
recherche T11 Í  Y 11
Merci pour votre aide je pense si simple pour vous!

Je ne comprend pas bien ta demande mais vois si ceci ne pourrait
pas t'aider Í  résoudre ou reformuler ta demande.
J'inscris le résultat du tirage et chacune des sélections
https://www.cjoint.com/c/KGBnTrlwDed

j'ai regardé rapidement ton fichier,
j'ai modifié les valeurs de la ligne D3:J3 et aucune formule
n'affiche #REF!
O͹ est située cette cellule qui retourne une valeur d'erreur?
Quelle manipulation as-tu faite pour provoquer cette erreur?
MichD

Oups.  Ce fichier n'est pas celui de Turpitude, le demandeur ͠
l'origine de cette demande.   ;)

Avatar
turpitude
Le 27/07/2021 Í  21:04, turpitude a écrit :
Zut de Zut c'est le bon voyez la difference des resultats
https://www.cjoint.com/c/KGBthWdoeRX
Le 27/07/2021 Í  21:00, turpitude a écrit :
le fichier joins n'est pas correct c'est celui ci pour les resultats
de la syntaxe
  https://www.cjoint.com/c/KGBs73jf7QX
Le 27/07/2021 Í  20:56, turpitude a écrit :
Le 27/07/2021 Í  17:06, MichD a écrit :
Merci pour votre aide mais je n'ai pas de solutions Í  mon problème.
Comment rajouter Í  la fonction index la fonction nb.si.
je joins mon fichier pour comprendre la finalité de ma recherche .
   En T11 X 11 j'indique un nombre ou plusieurs de 1 ͠ 49.
J'obtiens le nombre de fois des sorties des nombres associés en
colonne AB.
https://www.cjoint.com/c/KGBsZtlPSkX
Le fichier comporte une macro pas de problème de sécurité je
l'utilise depuis plusieurs années.
Merci pour votre aide
Le 27/07/2021 Í  19:42, Pierre Fonds a écrit :
Le 2021-07-27 Í  11:06, MichD a écrit :
Le 27/07/21 Í  09:49, Pierre Fonds a écrit :
Le 2021-07-27 Í  04:22, turpitude a écrit :
Bonjour ; dans un tableau un bloc de 6 colonnes T 12 Y 300  je
recherche dans les tirages lotos, un numéros ou une série de 5
numéros plus le complémentaire tapés  ligne T11 Í  Y 11.
Ma syntaxe de recherche en AB 12 est =NB.SI($T$12:X300;AA12)
colonne AA12 étant les nombres sortis de 1 Í  49 recherchés par
tirage.
Si je modifie les recherches sur la ligne  T 11 ͠ Y 11 j'ai
l'erreur syntaxe  suivante
=NB.SI(#REF!;AA12).
Je dois retaper la syntaxe complète =NB.SI($T$12:X300;AA12) pour
Í  nouveau obtenir les bons résultats.
Comment taper la bonne syntaxe de recherche AB 12, pour ne pas
avoir Í  retaper =NB.SI($T$12:X300;AA12) en AB12 Í  chaque modif de
recherche T11 Í  Y 11
Merci pour votre aide je pense si simple pour vous!

Je ne comprend pas bien ta demande mais vois si ceci ne pourrait
pas t'aider Í  résoudre ou reformuler ta demande.
J'inscris le résultat du tirage et chacune des sélections
https://www.cjoint.com/c/KGBnTrlwDed

j'ai regardé rapidement ton fichier,
j'ai modifié les valeurs de la ligne D3:J3 et aucune formule
n'affiche #REF!
O͹ est située cette cellule qui retourne une valeur d'erreur?
Quelle manipulation as-tu faite pour provoquer cette erreur?
MichD

Oups.  Ce fichier n'est pas celui de Turpitude, le demandeur ͠
l'origine de cette demande.   ;)


Avatar
MichD
A ) Le fichier publié n'a pas de macro.
B ) j'ai fait quelques tests, aucune cellule n’affiche #REF!
C ) Quelle est la cellule (adresse) qui affiche la valeur d'erreur?
D ) Quelle manipulation fais-tu pour provoquer cette erreur?
E ) Es-tu certain que ce n'est pas la macro qui déclenche l'erreur?
MichD
Avatar
MichD
A ) Le fichier publié n'a pas de macro.
B ) j'ai fait quelques tests, aucune cellule n’affiche #REF!
C ) Quelle est la cellule (adresse) qui affiche la valeur d'erreur?
D ) Quelle manipulation fais-tu pour provoquer cette erreur?
E ) Es-tu certain que ce n'est pas la macro qui déclenche l'erreur?
MichD
Avatar
turpitude
Le 27/07/2021 Í  22:06, MichD a écrit :
A ) Le fichier publié n'a pas de macro.
B ) j'ai fait quelques tests, aucune cellule n’affiche #REF!
C ) Quelle est la cellule (adresse) qui affiche la valeur d'erreur?
D ) Quelle manipulation fais-tu pour provoquer cette erreur?
E ) Es-tu certain que ce n'est pas la macro qui déclenche l'erreur?
MichD

la cellule AB 12 est modifiée #REF! si je change les valeurs dans les
cellules de recherche en jaune T11 Í  y 11.
Si , il y a une macro pour effectuer les recherches dans la zone jaune T
11 Y 11 mais pas dans ce fichier .
cela ne gêne en rien ma demande d'infos sur la syntaxe.
1 2