Reconnexion DHCP sur la box

Le
Migrec
Bonjour,

Sur ma box personnelle (livebox), j'ai régulièrement des pertes de
synchro qui durent quelques jours.

Si je ne touche à rien, mon serveur qui est branché en filaire sur la
box, perd son IP, attribuée normalement via le DHCP de la box). Et si la
synchro revient, je ne récupère pas d'IP de façon automatique Je suis
obligé de relancer via service networking restart

Est-ce qu'il y a moyen de récupérer une IP automatiquement ? Est-ce lié
à la box ?

Mon /etc/network/interfaces :

# The loopback network interface
auto lo
iface lo inet loopback

# La connexion vers la Box
allow-hotplug eth1
auto eth1
iface eth1 inet dhcp

# La connexion vers le réseau local

# The primary network interface
allow-hotplug eth0
auto eth0
iface eth0 inet static
address 192.168.0.2


--

Migrec
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pierre L.
Le #26448752
This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--DShP0PmEJHdL22FaefWt9KUxq8PlJuadV
Content-Type: multipart/mixed; boundary="bHTjQ5IjAiIwlDFEWPcHE1Vi4HH0T9NKd";
protected-headers="v1"
From: "Pierre L." To:
Message-ID: Subject: Re: Reconnexion DHCP sur la box
References: In-Reply-To: --bHTjQ5IjAiIwlDFEWPcHE1Vi4HH0T9NKd
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable
Content-Language: fr-FR
Bonjour,
Si je peux me permettre, qui dit "serveur", dit IP fixe ;)
Y a-t-il une raison pour laquelle rester sur une configuration du client
en DHCP ?
A voir pour configurer ton interface eth1 en "static", ca devrait
résoudre le souci !
Good luck ;)
Le 22/10/2017 à 23:22, Migrec a écrit :
Si je ne touche à rien, mon serveur qui est branché en filair e sur la
box, perd son IP, attribuée normalement via le DHCP de la box).


--bHTjQ5IjAiIwlDFEWPcHE1Vi4HH0T9NKd--
--DShP0PmEJHdL22FaefWt9KUxq8PlJuadV
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEEqp6CU/crahjY2x3n6briFe8NSUUFAlntjcIACgkQ6briFe8N
SUUEPA//V5GWe1BlACspfyH3sugJZCrtlq7gzK+BXu0lIKQ63MnVoXPnUAlGC6yX
XOjhJVANEOA8UFokvwv+PndAeWv9pz51PzKHsqU4nh4YLS8c0sonC9LWR877k0ig
3xxintwEgWBrUeYryvxAR9dr2cmso9GZ8Y/kkMmaw0jW5zWcK8DZE4JD+25Ah+WR
9IlZy0cyzsB/JlwUxr51kCaYm3cTTikuITIs/qu6e8lHY/RuBlmTpE7o+lzNr4Sl
nw7rDLB0Tot4Sfnu5lRnjx9mAN0p1920RBERZannmpccogEpNYc5O2Fo801kCy8d
jP5ntACI/08N01RfxRiJanT9tgVN7zD0mmyB41z4GodPEV8eoo120Fk1t9zCAvXa
bz3yomRbs8u4AeQxlrbuCWpCWut9i2ItU/3yFTwDJAaWGVNXaX2b5quO4Vk1IJrB
ZGrcrn8kVudPo0dUFe+i5lycIbCQqWd+Kv1U4wjIZIlP10jqOaD4BUC3L5l8kNHh
rLH4drWYMW2A67T2iJE7WbFN+PDbpYMmGCmzhmvFUCfkSHwCHKGKuR8QUamc/Idu
Mhm9FkBwRCt9lltPlKVOgMJwm6fmss6nDl354V8MP/AC19/+sa9vlbyW3nr/StKA
DKV19iWuaj+Q1d7Py6Q7rndBmsG0TvgQdNGnmsJXCL7gSggEH+o =W3J7
-----END PGP SIGNATURE-----
--DShP0PmEJHdL22FaefWt9KUxq8PlJuadV--
Christophe De Natale
Le #26448751
Le 22/10/2017 à 23:22, Migrec a écrit :
Bonjour,

Bonjour,
Sur ma box personnelle (livebox), j'ai régulièrement des pertes de
synchro qui durent quelques jours.

Perte de synchro adsl ou perte de la configuration ?
Si je ne touche à rien, mon serveur qui est branché en filaire sur la
box, perd son IP, attribuée normalement via le DHCP de la box). Et si
la synchro revient, je ne récupère pas d'IP de façon automatique... Je
suis obligé de relancer via service networking restart

En référence à la configuration que vous donnez ci-dessous, le serveur
possède deux cartes ?
Le mieux serait de lui attribuer une ip fixe puis lui réserver cette
adresse dans le service dhcp de la LB
Exemple de configuration /etc/network/interfaces :
# Configuration statique IPv4
auto eth0
allow-hotplug eth0
iface eth0 inet static
  address 192.168.1.11
  netmask 255.255.255.0
  broadcast 192.168.1.255
  network 192.168.1.0
  gateway 192.168.1.1
  name-servers 192.168.1.1
Mon /etc/network/interfaces :
# The loopback network interface
auto lo
iface lo inet loopback
# La connexion vers la Box
allow-hotplug eth1
auto eth1
iface eth1 inet dhcp

Est-ce vraiment eth1 sur le réseau de la LB ?
# La connexion vers le réseau local
# The primary network interface
allow-hotplug eth0
auto eth0
iface eth0 inet static
       address 192.168.0.2

Si second réseau, reprendre l'exemple de configuration ci-dessus car il
manque des paramètres pour eth0
Il n'y a pas de service dhcp activé sur le serveur ?
Bon courage
Pierre L.
Le #26448832
This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--s5CVUDT0ek94XopboX5X2UJrGbnt7V31P
Content-Type: multipart/mixed; boundary="cf8cA2vDAhDd72FdNA9dR0vcivNrhnR3o";
protected-headers="v1"
From: "Pierre L." To:
Message-ID: Subject: Re: Reconnexion DHCP sur la box
References: In-Reply-To: --cf8cA2vDAhDd72FdNA9dR0vcivNrhnR3o
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable
Content-Language: fr
Bonsoir,
C'est vrai, il est tout à fait possible de configurer le DHCP de la box
pour des baux statiques.
Le souci énoncé dans ce post m'était aussi arrivé pou r une raison
similaire, le seul serveur DHCP sur le LAN ne répondait plus car bug gé
aléatoirement. 1 machine (client DHCP) en serveur Linux restait alor s
déconnectée suite à son non-renouvellement DHCP, et le pas sage en IP
fixe a résolu le problème (avant d'avoir enfin résolu le s ouci du
serveur DHCP !)
Haa, c'est une histoire de gout probablement, mais j'avoue que j'aime
bien savoir derrière quelle IP se trouvent mes petits :) et surtout les
savoir toujours ok malgré un service DHCP down ;)

Le 23/10/2017 à 08:53, Eric Degenetais a écrit :
Le 23 oct. 2017 8:44 AM, "Pierre L."
Si je peux me permettre, qui dit "serveur", dit IP fixe ;)
Bonjour, ce n'est pas nécessairement incompatible avec le DHCP. J' ai
des IP (locales)  fixes avec une livebox. Il suffit de configurer le
service DHCP en ce sens. 


--cf8cA2vDAhDd72FdNA9dR0vcivNrhnR3o--
--s5CVUDT0ek94XopboX5X2UJrGbnt7V31P
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2
iQIcBAEBCAAGBQJZ7lxoAAoJEOm64hXvDUlFs8EQAMKkRXt/s6e8gqSMjZ5IztxX
zpab4fUU0YVbhiRr+gzPd7pjzTeRGzEQayiC0Xsq+uO6hwHnNbHYxM84s9N6t1oB
Qam5aXCr7dP8AZp3IwWAutOSTuaU65SbOUz1+NbIxYU+pgK/d9mQD9U6fFIzluy1
iG5QEkxTgbM7tXx3nf2bxvAf0Mv0Mdl0LF+pumoTRcIgRrvJlHKja9rcsw7s7kfz
jqcrSszUfM+Ko+QcECSvZzb2UEJuZ2IPts3B7ZDLhKThrhe5TiSdy5WfYBWfgMV8
HkmWy7jxwd0ivxKg2vTR6fIUh9RYKsNVlRYoIRTKDvPkI3pjnGNVAOwNTGD3goxb
ELk85dp6OoE0+rY9bidIoK1CwpygACiYgFAnJmKKkyfrjb10et+JUzmzjpjjwlaR
92pJqtc/Ppxa+QMxmDa+fCKQ7cyGRBM0OFCo68Mz1rMizVLhJVr497poeg1FKvh/
bNxof0/Eq+Sgcz1jrHwy7hWiPfQT/wQ/fwHmp1TgW8Wmz4a14K9h0Wj+p7nzYo1M
MYbS6Aklu7dHE2+Ke2CAb35jTaoWqlKqusPv0/umPxqYaLMmR8u7f9TC2Z/9bei8
injR2iIDVbKIBRsMN4aoomarEuaxjSjczUcT+ArgpF6C2/zcMa33zaFH5nMri3Z5
7X0lNmMUpd8vn4XPDVnZ
=MOKN
-----END PGP SIGNATURE-----
--s5CVUDT0ek94XopboX5X2UJrGbnt7V31P--
Thierry Bugier
Le #26448846
Bonjour
Le lundi 23 octobre 2017 à 23:17 +0200, Pierre L. a écrit :
Bonsoir,
C'est vrai, il est tout à fait possible de configurer le DHCP de la
box
pour des baux statiques.
Le souci énoncé dans ce post m'était aussi arrivé pour une raison
similaire, le seul serveur DHCP sur le LAN ne répondait plus car
buggé
aléatoirement. 1 machine (client DHCP) en serveur Linux restait alors
déconnectée suite à son non-renouvellement DHCP, et le passage en IP
fixe a résolu le problème (avant d'avoir enfin résolu le souci du
serveur DHCP !)
Haa, c'est une histoire de gout probablement, mais j'avoue que j'aime
bien savoir derrière quelle IP se trouvent mes petits :) et surtout
les
savoir toujours ok malgré un service DHCP down ;)


Si le serveur DHCP de la box est instable, et si une machine fait
office de serveur, pourquoi carrément ne pas désactiver le DHCP de la
box, et monter un serveur DHCP sur le serveur ? Au final l'ensemble du
réseau serait fiabilisé en ce qui concerne le service DHCP.
Migrec
Le #26448862
Le 23/10/2017 à 08:54, Christophe De Natale a écrit :
Sur ma box personnelle (livebox), j'ai régulièrement des pertes de
synchro qui durent quelques jours.

Perte de synchro adsl ou perte de la configuration ?

Perte de synchro ADSL. Je suis loin du central (3,8km) et la ligne est
régulièrement oxydée.
Si je ne touche à rien, mon serveur qui est branché en filaire sur la
box, perd son IP, attribuée normalement via le DHCP de la box). Et si
la synchro revient, je ne récupère pas d'IP de façon automatique...
Je suis obligé de relancer via service networking restart

En référence à la configuration que vous donnez ci-dessous, le serveur
possède deux cartes ?
Le mieux serait de lui attribuer une ip fixe puis lui réserver cette
adresse dans le service dhcp de la LB

Effectivement le serveur possède 2 cartes : une qui part vers la livebox
et une autre qui part vers le réseau local.
Oui j'y avais pensé à mettre en statique mais j'aimerai comprendre
pourquoi l'adresse "saute"...
Exemple de configuration /etc/network/interfaces :
# Configuration statique IPv4
auto eth0
allow-hotplug eth0
iface eth0 inet static
address 192.168.1.11
netmask 255.255.255.0
broadcast 192.168.1.255
network 192.168.1.0
gateway 192.168.1.1
name-servers 192.168.1.1

Si second réseau, reprendre l'exemple de configuration ci-dessus car
il manque des paramètres pour eth0
Il n'y a pas de service dhcp activé sur le serveur ?

Si j'ai aussi un serveur dhcp sur mon serveur (qui tourne que sur eth0).
Merci pour vos réponses.
Pierre L.
Le #26448867
This is an OpenPGP/MIME signed message (RFC 4880 and 3156)
--3PC4lnFVkBORpxL8Dmx1JdcpkAcLagfJa
Content-Type: multipart/mixed; boundary="njC1XSVdmEPHFmasphi6HvcLrkFx5neFj";
protected-headers="v1"
From: "Pierre L." To:
Message-ID: Subject: Re: Reconnexion DHCP sur la box
References: In-Reply-To: --njC1XSVdmEPHFmasphi6HvcLrkFx5neFj
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: quoted-printable
Content-Language: fr-FR
Je n'ai plus mes logs sous la main.
Mais de tête, j'ai souvenir que l'état (state) de l'interface p assait en
DOWN lorsque le serveur DHCP n'était plus accessible.
Pourquoi, c'était aussi la question qui m'avait titillé à l'époque !
[râleur] Je pense qu'un gugusse qui tape dans le code a du se dire q ue
s'il n'y a plus de serveur DHCP pour renouveler l'IP qu'on a depuis des
mois 24/24, il fallait absolument "éteindre" l'interface physique qu i ne
sait plus qui elle est ? [/râleur]
Donc oui la commande "ifconfig ethX" affichait cette interface DOWN.
(remplacée aujourd’hui par "ip a" par exemple)
Et une fois que c'est DOWN, bin c'est DOWN pour toujours :'(
Peut-être suis-je à coté de la plaque et que mes souvenirs sont erronés...?
Le 24/10/2017 à 11:58, Migrec a écrit :
Oui j'y avais pensé à mettre en statique mais j'aimerai compr endre
pourquoi l'adresse "saute"...


--njC1XSVdmEPHFmasphi6HvcLrkFx5neFj--
--3PC4lnFVkBORpxL8Dmx1JdcpkAcLagfJa
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"
-----BEGIN PGP SIGNATURE-----
iQIzBAEBCAAdFiEEqp6CU/crahjY2x3n6briFe8NSUUFAlnvIqkACgkQ6briFe8N
SUVfeg/8C8VXy4RNVsUx6uQOGOzgaNlElamAopLjNklhiWdI6qy+c0c5FrpNC4nx
90Y/kkfIM46ZqkXit40ey0bg8dcDVX46oWo1o0VY6+izzT9f4bTuexs7YbinbSo1
ESdcehqAPhS8QSJEJKkvD15Rbtjqi1E8hdvcAbyMQfFehQ+3vsMayEwhys4b0S0I
FWtDzTBAdO2uOWcyakfyvm3H4TpzKL2/CBNghVR6vpvIyOLwN5cCw+GhE4LHhHG0
CtizbBsQrtPsU1xG7202nLIUU+Zwt9gTIGGqrxaNTSpQ8D6r30fCrP9Vu2+jiq01
QlkhD+sUkn/zRDknpxEQ4vD9ygM+hLAH+VsnSO0Mtnp3cjKqN9AbBlv8bXfJ/n6d
D1NhEK3mNKerXU+34CzqOee0xeBhhaK1AQ3vSKEkk85kT754fCMwU0NWlFZXocRB
LXgCLK923mpEtt3BQfNsTEeWyIOmbQ5OVm3n+ekG5+o7nr3UCtkfq3FhOZZohyv9
N3ULlWzGntjklcJdQKAOGykQxmQ1NrbUqVaNPiaCD1J2Uh3NRD4GZaTt4YfJkXoq
M7PkLBOiukfsZ9Ygj4GlvEO3c/Af8VOyYjnrLMmHi9Lv45jpHmY0CzjEARnguTsL
Sx67b0aBMsrHrn507WhHIcXQFPJv7TnjyrOiWFt2zpOgC3v/tNc =wZZl
-----END PGP SIGNATURE-----
--3PC4lnFVkBORpxL8Dmx1JdcpkAcLagfJa--
Migrec
Le #26448872
Le 24/10/2017 à 13:23, Pierre L. a écrit :
Je n'ai plus mes logs sous la main.
Mais de tête, j'ai souvenir que l'état (state) de l'interface passait en
DOWN lorsque le serveur DHCP n'était plus accessible.
Pourquoi, c'était aussi la question qui m'avait titillé à l'époque !
[râleur] Je pense qu'un gugusse qui tape dans le code a du se dire que
s'il n'y a plus de serveur DHCP pour renouveler l'IP qu'on a depuis des
mois 24/24, il fallait absolument "éteindre" l'interface physique qui ne
sait plus qui elle est ? [/râleur]
Donc oui la commande "ifconfig ethX" affichait cette interface DOWN.
(remplacée aujourd’hui par "ip a" par exemple)
Et une fois que c'est DOWN, bin c'est DOWN pour toujours :'(
Peut-être suis-je à coté de la plaque et que mes souvenirs sont erronés...?

Bonjour,
En tout cas ça correspond furieusement au comportement que j'ai.
Je vais regarder de ce coté pour essayer de forcer l'interface à rester UP.
Et sinon, je passe en IP fixe.
Merci.
Christophe De Natale
Le #26448929
Le 24/10/2017 à 11:58, Migrec a écrit :
Le 23/10/2017 à 08:54, Christophe De Natale a écrit :
Sur ma box personnelle (livebox), j'ai régulièrement des pertes de
synchro qui durent quelques jours.

Perte de synchro adsl ou perte de la configuration ?

Perte de synchro ADSL. Je suis loin du central (3,8km) et la ligne est
régulièrement oxydée.

Ah l'air de la mer :D
Blague à part, j'ai connu, 4.9 kms à l'époque, le prestataire de FT qui
vient remplacer un câble tout seul dans la neige à qui je dois filer un
coup de main...
C'est une LB blanche, les vieilles qui ont plus de 15 ans ?
Vous pouvez demander un remplacement à votre service client (gratuit)
Si je ne touche à rien, mon serveur qui est branché en filaire sur
la box, perd son IP, attribuée normalement via le DHCP de la box).
Et si la synchro revient, je ne récupère pas d'IP de façon
automatique... Je suis obligé de relancer via service networking
restart

En référence à la configuration que vous donnez ci-dessous, le
serveur possède deux cartes ?
Le mieux serait de lui attribuer une ip fixe puis lui réserver cette
adresse dans le service dhcp de la LB

Effectivement le serveur possède 2 cartes : une qui part vers la
livebox et une autre qui part vers le réseau local.
Oui j'y avais pensé à mettre en statique mais j'aimerai comprendre
pourquoi l'adresse "saute"...

On est d'accord sur ceci :
LB (dhcp,...)
Il serait possible d'avoir la sortie de "ifconfig -a" ainsi que "cat
/etc/network/interfaces" ?
Bonne soirée,
Migrec
Le #26448994
Le 24/10/2017 à 19:31, Christophe De Natale a écrit :
Ah l'air de la mer :D
Blague à part, j'ai connu, 4.9 kms à l'époque, le prestataire de FT
qui vient remplacer un câble tout seul dans la neige à qui je dois
filer un coup de main...
C'est une LB blanche, les vieilles qui ont plus de 15 ans ?
Vous pouvez demander un remplacement à votre service client (gratuit)

Non, c'est une noire Livebox play qui n'est pas très vieille (1 ou 2 an max)
Si je ne touche à rien, mon serveur qui est branché en filaire sur
la box, perd son IP, attribuée normalement via le DHCP de la box).
Et si la synchro revient, je ne récupère pas d'IP de façon
automatique... Je suis obligé de relancer via service networking
restart

En référence à la configuration que vous donnez ci-dessous, le
serveur possède deux cartes ?
Le mieux serait de lui attribuer une ip fixe puis lui réserver cette
adresse dans le service dhcp de la LB

Effectivement le serveur possède 2 cartes : une qui part vers la
livebox et une autre qui part vers le réseau local.
Oui j'y avais pensé à mettre en statique mais j'aimerai comprendre
pourquoi l'adresse "saute"...

On est d'accord sur ceci :
LB (dhcp,...)
Il serait possible d'avoir la sortie de "ifconfig -a" ainsi que "cat
/etc/network/interfaces" ?

oui c'est ça !
# cat /etc/network/interfaces | grep ^[^#]
auto lo
iface lo inet loopback
allow-hotplug eth1
auto eth1
iface eth1 inet dhcp
allow-hotplug eth0
auto eth0
iface eth0 inet static
address 192.168.0.2
netmask 255.255.255.0
name Carte Ethernet
broadcast 192.168.0.255
network 192.168.0.0
dns-nameservers 192.168.0.2
dns-search homeg.lan

# ifconfig -a
eth0: flagsA63<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.2 netmask 255.255.255.0 broadcast 192.168.0.255
inet6 fe80::d685:64ff:fe6a:7260 prefixlen 64 scopeid 0x20<link>
ether d4:85:64:6a:72:60 txqueuelen 1000 (Ethernet)
RX packets 4399995 bytes 1575826827 (1.4 GiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 6297814 bytes 7849690859 (7.3 GiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 18
eth1: flagsA63<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.92 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 fe80::222:64ff:fe8a:4c7b prefixlen 64 scopeid 0x20<link>
ether 00:22:64:8a:4c:7b txqueuelen 1000 (Ethernet)
RX packets 5614443 bytes 7487836092 (6.9 GiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 3395345 bytes 522112832 (497.9 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
device interrupt 18 memory 0xfe8e0000-fe900000
lo: flagss<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1 (Boucle locale)
RX packets 293603 bytes 17936475 (17.1 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 293603 bytes 17936475 (17.1 MiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0
--
Migrec
Christophe De Natale
Le #26449024
Le 25/10/2017 à 09:50, Migrec a écrit :
Le 24/10/2017 à 19:31, Christophe De Natale a écrit :
Ah l'air de la mer :D
Blague à part, j'ai connu, 4.9 kms à l'époque, le prestataire de FT
qui vient remplacer un câble tout seul dans la neige à qui je dois
filer un coup de main...
C'est une LB blanche, les vieilles qui ont plus de 15 ans ?
Vous pouvez demander un remplacement à votre service client (gratuit)

Non, c'est une noire Livebox play qui n'est pas très vieille (1 ou 2
an max)
Si je ne touche à rien, mon serveur qui est branché en filaire sur
la box, perd son IP, attribuée normalement via le DHCP de la box).
Et si la synchro revient, je ne récupère pas d'IP de façon
automatique... Je suis obligé de relancer via service networking
restart

En référence à la configuration que vous donnez ci-dessous, le
serveur possède deux cartes ?
Le mieux serait de lui attribuer une ip fixe puis lui réserver
cette adresse dans le service dhcp de la LB

Effectivement le serveur possède 2 cartes : une qui part vers la
livebox et une autre qui part vers le réseau local.
Oui j'y avais pensé à mettre en statique mais j'aimerai comprendre
pourquoi l'adresse "saute"...

On est d'accord sur ceci :
LB (dhcp,...)
Il serait possible d'avoir la sortie de "ifconfig -a" ainsi que "cat
/etc/network/interfaces" ?

oui c'est ça !
# cat /etc/network/interfaces | grep ^[^#]
auto lo
iface lo inet loopback
allow-hotplug eth1
auto eth1
iface eth1 inet dhcp
allow-hotplug eth0
auto eth0
iface eth0 inet static
       address 192.168.0.2
       netmask 255.255.255.0
       name Carte Ethernet
       broadcast 192.168.0.255
       network 192.168.0.0
       dns-nameservers 192.168.0.2
       dns-search homeg.lan

# ifconfig -a
eth0: flagsA63<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.2  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::d685:64ff:fe6a:7260  prefixlen 64  scopeid 0x20<link>
        ether d4:85:64:6a:72:60  txqueuelen 1000  (Ethernet)
        RX packets 4399995  bytes 1575826827 (1.4 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 6297814  bytes 7849690859 (7.3 GiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 18
eth1: flagsA63<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.92  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::222:64ff:fe8a:4c7b  prefixlen 64  scopeid 0x20<link>
        ether 00:22:64:8a:4c:7b  txqueuelen 1000  (Ethernet)
        RX packets 5614443  bytes 7487836092 (6.9 GiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 3395345  bytes 522112832 (497.9 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 18  memory 0xfe8e0000-fe900000
lo: flagss<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1  (Boucle locale)
        RX packets 293603  bytes 17936475 (17.1 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 293603  bytes 17936475 (17.1 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
--
Migrec

En admettant que vous désirez conserver l'ip 192.168.1.92 sur eth1
(modifiable selon votre souhait 192.168.1.2 par exemple) :
####################
auto lo
iface lo inet loopback
#Configuration côté LiveBox
auto eth1
allow-hotplug eth1
iface eth1 inet static
       address 192.168.1.92/24
       gateway 192.168.1.1
       #dns-nameservers 192.168.1.1 => #optionnel si resolvconf installé
#Configuration côté LAN
auto eth0
allow-hotplug eth0
iface eth0 inet static
       address 192.168.0.2/24
       dns-nameservers 192.168.0.2
       dns-search homeg.lan
####################
Redémarrage du serveur afin de constater que la configuration est bien
prise en compte.
Dans l'interface web de la LB > onglet configuration avancée > dhcp,
vérifiez que le dhcp est bien activé, que la plage d'adresse est celle
qui convient (style 192.168.1.2 à 192.168.1.254 ou moins d'adresses
dispo, au choix),  et que l'adresse attribuée à eth1 apparaît dans la
rubrique "baux valides" ; si ok, réservez cette adresse dans "baux
statiques"
--
Christophe
Publicité
Poster une réponse
Anonyme