Slackware 10.1, problème d'installation (nouveau problème, nouveau post...)

Le
H.
Bonsoir

Désolé pour le re-post, mais comme l'ancien fil devenait un peu chargé,
et comme il s'agit d'un autre problème, je me permets de ré-écrire.

Avec vos conseils, j'ai finalement compris le principe des partitions
J'ai formaté mon disque, et j'ai réinstallé Slackware correctement (enfin
euh).

Quand je démarre le PC, LILO s'exécute, et je lance Linux. Mais pendant
les vérifications, il m'affiche le message d'erreur suivant :
sh-2021 : reiserfs_read_super : can not find reiserfs on ide0(3,0)
Kernel Panic : VFS : unable to mount root fs on 03:00
message que j'ai l'heur de ne pas comprendre !
A noter : j'ai déjà eu des messages d'erreur avec le format REISERFS,
donc pendant cette nouvelle installation, j'ai choisi le format EXT3.

(Pour ceux qui ont suivi l'autre fil, j'avais déjà obtenu ce message
après les modifs conseillées, donc a priori, j'avais corrigé les bugs. Mais
j'ai quand même tout réinstallé, puisque j'ignorais que j'étais dans le
bon)

Si quelqu'un pouvait m'éclairer sur la procédure à suivre (Après 6
mois de galère, je dois quand même approcher du but, non ^^)


Bien cordialement,
Christophe
  • Partager ce contenu :
Vos réponses Page 1 / 3
Trier par : date / pertinence
Emmanuel Florac
Le #1798869
Le Fri, 23 Jun 2006 23:38:25 +0200, H. a écrit :


Si quelqu'un pouvait m'éclairer sur la procédure à suivre... (Après 6
mois de galère, je dois quand même approcher du but, non ^^)


Il ne trouve pas de partition reiserfs sur ton disque. Si tu as reformaté
en ext3, ce n'est pas très surprenant. Par contre ça signifie qu'il
recherche un / en reiser, donc tu as du oublier de modifier /etc/fstab je
suppose.

--
In girum imus nocte ecce et consumimur igni

H.
Le #1798858
Emmanuel Florac :

Si quelqu'un pouvait m'éclairer sur la procédure à suivre... (Après 6
mois de galère, je dois quand même approcher du but, non ^^)


Il ne trouve pas de partition reiserfs sur ton disque. Si tu as reformaté
en ext3, ce n'est pas très surprenant. Par contre ça signifie qu'il
recherche un / en reiser, donc tu as du oublier de modifier /etc/fstab je


Houlà dites... pour une simple installation à partir d'un CD... Ce n'est
quand même pas si compliqué ? Enfin, je veux dire - vous me demandez de
modifier des fichiers qui tombent de nulle part, ce n'est pas dans la
procédure standard ?


Amicalement,
Christophe


H.
Le #1798847
Pff ^^ Après deux jours de galère (et deux semaines d'essais infructueux
il y a quelques mois), j'ai enfin réussi à installer Slackware 10.1.
Je redémarre, lilo se lance, je démare linux (il n'y a que cet OS sur la
machine)... Super, tout bien. J'arrive en mode console, je me logue en ROOT.
Je tape "startx" pour lancer le bureau KDE que j'ai installé.

Hop, écran noir.
La machine n'a pas planté. Le clavier répondait, quand je faisais
ENTREE, le pc tournait... mais rien à l'affichage.
J'éteins l'ordinateur et je le rallume. Depuis, j'ai un message d'erreur
"filesystem error" à chaque redémarrage après avoir lancé linux...
Apparamment, c'est fsck 1.35 qui pose problème (même si je ne comprends pas
ce que c'est...)
Sans rire, il y a un moyen d'en avoir un jour fini :?)


Amicalement,
Christophe
Ploc
Le #1798844
H. wrote:
Pff ^^ Après deux jours de galère (et deux semaines d'essais infructueux
il y a quelques mois), j'ai enfin réussi à installer Slackware 10.1.
Je redémarre, lilo se lance, je démare linux (il n'y a que cet OS sur la
machine)... Super, tout bien. J'arrive en mode console, je me logue en ROOT.
Je tape "startx" pour lancer le bureau KDE que j'ai installé.

Hop, écran noir.
La machine n'a pas planté. Le clavier répondait, quand je faisais
ENTREE, le pc tournait... mais rien à l'affichage.
J'éteins l'ordinateur et je le rallume. Depuis, j'ai un message d'erreur
"filesystem error" à chaque redémarrage après avoir lancé linux...
Apparamment, c'est fsck 1.35 qui pose problème (même si je ne comprends pas
ce que c'est...)
Sans rire, il y a un moyen d'en avoir un jour fini :?)



La slack demande un peu plus d'investissement au debut que ses camarades.
Question: est-ce que le serveur X est configure? (ca pourrait expliquer
l'ecran noir)

Pour fsck, c'est un outil pour verifier les systemes de fichier,
typiquement, quand la machine a ete arretee violamment. Normalement, si
c'est du ext3, ca devrait se passer assez bien.
Si ca se passe mal pendant le reboot, normalement, il propose de se
connecter en tant que root pour le lancer manuellement. Est-ce que ca a
ete fait?
Pour le lancer manuellement : fsck /dev/hda1 (si hda1 est la partition a
verifier).

Christian
Le #1796196
H. a écrit:

Super, tout bien. J'arrive en mode console, je me logue en ROOT.
Je tape "startx" pour lancer le bureau KDE que j'ai installé.


avant de lancer startx il faut configurer X à l'aide de la commande
xorgsetup (en tant que root)

lis le manuel avant de te lancer
http://www.slackbook.org/html/x-window-system.html

--
Christian

Emmanuel Florac
Le #1796191
Le Sat, 24 Jun 2006 11:54:03 +0200, H. a écrit :


Houlà dites... pour une simple installation à partir d'un CD... Ce n'est
quand même pas si compliqué ?


Je ne pense pas, mais d'un autre côté je n'ai pas installé la slack
depuis longtemps (elle marche très bien depuis des années sans rien
réinstaller chez moi :)
Il faut savoir que la slack c'est une distrib d'homme, de vrai, avec des
poils. Si tu veux un truc qui s'installe tout seul en 3 clics, prends une
Ubuntu, une Mandriva... Par contre avec la slack tu vas apprendre tout de
suite à entrer dans le coeur du sujet. Par exemple, dans la slack il n'y
a RIEN pour la détection automatique de la carte vidéo... Faire marcher
Xwindow implique donc d'apprendre à éditer /etc/XF86Config-4 à la main!

--
L'esprit qu'on veut avoir gâte celui qu'on a.
Jean-Baptiste Louis Grisset.

Emmanuel Florac
Le #1796190
Le Sat, 24 Jun 2006 14:09:09 +0200, H. a écrit :

Je redémarre, lilo se lance, je démare linux (il n'y a que cet OS sur la
machine)... Super, tout bien. J'arrive en mode console, je me logue en ROOT.
Je tape "startx" pour lancer le bureau KDE que j'ai installé.


Erreur fatale! voir mon post précédent, il faut d'abord configurer X à
la main! et oui, c'est ça la slack! C'est pour les champions, pas pour
les adeptes du clic-clic et du plug-and-play :) Une rude école de la vie :)

--
entia non sont multiplicanda praeter necessitatem.
John Ponce of Cork.

Emmanuel Florac
Le #1796037
Le Sat, 24 Jun 2006 14:09:09 +0200, H. a écrit :

J'éteins l'ordinateur et je le rallume. Depuis, j'ai un message d'erreur
"filesystem error" à chaque redémarrage après avoir lancé linux...
Apparamment, c'est fsck 1.35 qui pose problème (même si je ne comprends pas
ce que c'est...)


À l'invite LILO, tu appuies sur tabulation, et tu bootes avec la commande

Linux single

Pour démarrer en mode single-user.
Attention, au prompt le clavier sera QWERTY! donc là tu te logges en
root, tu passes ton clavier en fr (enfin si tu es un vrai brutal,
tu connais par coeur la disposition US standard :)

loadkeys fr

tu démontes tous les filesystems avec

umount -a

Ce qui aura aussi pour effet de remonter / en lecture seule. Après, tu
peux réparer ton filesystem avec

e2fsck -p /dev/hda1

(ou /dev/hda2 je ne sais plus trop où est ton /) si ton root est bien en
ext3. après ça tu rebootes et c'est bon.

Si par malheur ton root est trop endommagé pour booter même en single
user, tu peux faire la même manipulation en démarrant sur le 2e CD de la
slack (c'est un live CD fruste).

--
Si non confectus non reficiat.

H.
Le #1796034
Emmanuel Florac :

Je ne pense pas, mais d'un autre côté je n'ai pas installé la slack
depuis longtemps (elle marche très bien depuis des années sans rien
réinstaller chez moi :)
Il faut savoir que la slack c'est une distrib d'homme, de vrai, avec des
poils. Si tu veux un truc qui s'installe tout seul en 3 clics, prends une
Ubuntu, une Mandriva... Par contre avec la slack tu vas apprendre tout de
suite à entrer dans le coeur du sujet. Par exemple, dans la slack il n'y
a RIEN pour la détection automatique de la carte vidéo... Faire marcher
Xwindow implique donc d'apprendre à éditer /etc/XF86Config-4 à la main!


Heum...
C'est bien sympathique votre truc ^^ mais quand on ne sait pas ce qu'est
une carte vidéo (enfin, quand on sait à quoi ça ressemble et vaguement à
quoi ça sert), quand on ne sait pas ce qu'est Xwindow... est-ce que c'est
pertinent de continuer avec cette distribution ?
Disons que ce que je cherche, c'est une distribution qui tourne sans
faire d'histoire (je ne pense même pas aller sur internet avec, donc la
sécurité, je m'en moque même un peu) et sur laquelle je peux bidouiller
APRES. Mais après que ça marche... pas aller m'amuser dans la console AVANT
que ça soit installer... ^^

Bon... Je vais aller voir s'il y a autre chose de disponible...


Amicalement,
Christophe

H.
Le #1796031
(pleure)

La slack demande un peu plus d'investissement au debut que ses camarades.


Euphémisme ^^


Question: est-ce que le serveur X est configure? (ca pourrait expliquer
l'ecran noir)


(re-pleure) Qu'est-ce que le serveur X ?
J'ai installé XINITRC.KDE (window manager) et KDE, mais je n'ai rien
paramétré.


Pour fsck, c'est un outil pour verifier les systemes de fichier,
typiquement, quand la machine a ete arretee violamment. Normalement, si
c'est du ext3, ca devrait se passer assez bien.


J'ai pris EXT2.


Si ca se passe mal pendant le reboot, normalement, il propose de se
connecter en tant que root pour le lancer manuellement. Est-ce que ca a
ete fait?


Oui, et je me suis logué. Mais la machine me dit que je suis en RO, donc
je ne peux de toute façon rien modifier ?
Par contre, non : j'ai un message d'erreur, FSCK se lance, autre message
d'erreur, il me propose de me loguer. Si je fais "démarrer" à ce moment, il
y a encore des vérifs et des messages d'erreur...


Pour le lancer manuellement : fsck /dev/hda1 (si hda1 est la partition a
verifier).


Il se lance tout seul...


Amicalement,
Christophe

Poster une réponse
Anonyme