du son ou pas ? La suite

Le
Jo Engo
Bon, j'ai sucré pulse et tout ce qui en dépend (comme j'avais tendance à
installer tout et n'importe quoi ça a fait du ménage, pour le moment rien
ne me manque)

abdallah@poupon-la-peste:~$ cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xd1220000 irq 129

****************************************************************

abdallah@poupon-la-peste:~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC236 Analog [ALC236
Analog]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 7: HDMI 1 [HDMI 1]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 8: HDMI 2 [HDMI 2]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 9: HDMI 3 [HDMI 3]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 10: HDMI 4 [HDMI 4]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0

****************************************************************

abdallah@poupon-la-peste:~$ aplay /dev/random
Lecture données brutes '/dev/random' : Unsigned 8 bit, Fréquence 8000 Hz,
Mono
^CInterrompu par le signal Interrompre
aplay: pcm_write:2061: erreur en écriture: Appel système interrompu

Je n'ai ni erreur (avant d'avoir tapé ^C) ni son
Bon je fais quoi maintenant ? À l'aide !


--
On ne loue d'ordinaire que pour être loué.
-+- François de La Rochefoucauld (1613-1680), Maximes 146 -+-
  • Partager ce contenu :
Vos réponses Page 1 / 2
Trier par : date / pertinence
Marc SCHAEFER
Le #26553261
Jo Engo
:~$ aplay /dev/random

/dev/random n'a pas forcément un débit fantastique, exemple 10
secondes d'audio en G.711/alaw: 80'000 octets.
Utilise un vrai fichier au ou /dev/urandom.
aplay: pcm_write:2061: erreur en écriture: Appel système interrompu

D'un autre côté c'est le write qui buggue, bizarre.
Je n'ai ni erreur (avant d'avoir tapé ^C) ni son

même avec sudo dmesg ?
Bon je fais quoi maintenant ? À l'aide !

Je dois dire que je ne connais pas grand chose à l'audio sous Linux,
ça a trop facilement marché ces derniers 15 à 20 ans :->
Ce que je trouve bizarre est que ton chip (cf lien précédent)
semble n'être supporté que dès le kernel version 5, et moi j'ai
encore du 4 avec Debian buster p.ex. Mais c'est peut-être un bug
du site.
Marc SCHAEFER
Le #26553260
Jo Engo
:~$ aplay /dev/random

/dev/random n'a pas forcément un débit fantastique, exemple 10
secondes d'audio en G.711/alaw: 80'000 octets, chez moi en 30 secondes
(et j'ai dû vider mon entropie).
Utilise un vrai fichier au ou /dev/urandom.
aplay: pcm_write:2061: erreur en écriture: Appel système interrompu

D'un autre côté c'est le write qui buggue, bizarre.
Je n'ai ni erreur (avant d'avoir tapé ^C) ni son

même avec sudo dmesg ?
Bon je fais quoi maintenant ? À l'aide !

Je dois dire que je ne connais pas grand chose à l'audio sous Linux,
ça a trop facilement marché ces derniers 15 à 20 ans :->
Ce que je trouve bizarre est que ton chip (cf lien précédent)
semble n'être supporté que dès le kernel version 5, et moi j'ai
encore du 4 avec Debian buster p.ex. Mais c'est peut-être un bug
du site.
Nicolas George
Le #26553267
Marc SCHAEFER , dans le message écrit :
aplay: pcm_write:2061: erreur en écriture: Appel système interrompu

D'un autre côté c'est le write qui buggue, bizarre.

C'est le ctrl-c, tout à fait normal.
Jo Engo
Le #26553266
Le Sun, 23 Aug 2020 08:43:27 +0000, Jo Engo a écrit :
:~$ aplay /dev/random

À tout hasard, mais je n'ai toujours pas de son
:~$ aplay -D hw:0,0 -f S16_LE -c 2 -r 48000 /dev/
urandom
Lecture données brutes '/dev/urandom' : Signed 16 bit Little Endian,
Fréquence 48000 Hz, Stéréo
^CInterrompu par le signal Interrompre...
:~$ aplay -D hw:0,1 -f S16_LE -c 2 -r 48000 /dev/
urandom
aplay: main:830: erreur à l'ouverture audio: Aucun fichier ou dossier de
ce type
:~$ aplay -D hw:0,2 -f S16_LE -c 2 -r 48000 /dev/
urandom
aplay: main:830: erreur à l'ouverture audio: Aucun fichier ou dossier de
ce type
:~$ aplay -D hw:0,3 -f S16_LE -c 2 -r 48000 /dev/
urandom
Lecture données brutes '/dev/urandom' : Signed 16 bit Little Endian,
Fréquence 48000 Hz, Stéréo
^CInterrompu par le signal Interrompre...
:~$ aplay -D hw:0,4 -f S16_LE -c 2 -r 48000 /dev/
urandom
aplay: main:830: erreur à l'ouverture audio: Aucun fichier ou dossier de
ce type
:~$ aplay -D hw:0,5 -f S16_LE -c 2 -r 48000 /dev/
urandom
aplay: main:830: erreur à l'ouverture audio: Aucun fichier ou dossier de
ce type
:~$ aplay -D hw:0,6 -f S16_LE -c 2 -r 48000 /dev/
urandom
aplay: main:830: erreur à l'ouverture audio: Aucun fichier ou dossier de
ce type
:~$ aplay -D hw:0,7 -f S16_LE -c 2 -r 48000 /dev/
urandom
Lecture données brutes '/dev/urandom' : Signed 16 bit Little Endian,
Fréquence 48000 Hz, Stéréo
^CInterrompu par le signal Interrompre...
:~$ aplay -D hw:0,8 -f S16_LE -c 2 -r 48000 /dev/
urandom
Lecture données brutes '/dev/urandom' : Signed 16 bit Little Endian,
Fréquence 48000 Hz, Stéréo
^CInterrompu par le signal Interrompre...
:~$ aplay -D hw:0,9 -f S16_LE -c 2 -r 48000 /dev/
urandom
Lecture données brutes '/dev/urandom' : Signed 16 bit Little Endian,
Fréquence 48000 Hz, Stéréo
^CInterrompu par le signal Interrompre...
En résumé 0,0 0,3 0,7 0,8 et 0,9 «marchent» (pas vraiment vu que je n'ai
pas de bruit) les autres non (aucun fichier de ce type)
--
23:56 :q fille q effqce pqr erreur le fichier /bin/loqdkeys< Je n4qi
rien trouve dqns lq poubelle< Aui pourrqit ;e ;qiler son
loqdkeysM
Jo Engo
Le #26553265
Le Sun, 23 Aug 2020 11:22:19 +0200, Marc SCHAEFER a écrit :
Utilise un vrai fichier au ou /dev/urandom.

Oui c'est fait voir vvvvvv ci-dessous

--
Les relations si attendrissantes entre un maître
et son chien sont odieuses entres humains.
-+- Gilbert Cesbron (1913-1979), de petites choses. -+-
Nicolas George
Le #26553264
Jo Engo , dans le message
Bon, j'ai sucré pulse et tout ce qui en dépend (comme j'avais tendance à
installer tout et n'importe quoi ça a fait du ménage, pour le moment rien
ne me manque)

Tu n'avais pas besoin de virer ce qui en dépend, parce que ce ne sont que
des bibliothèques. Mais au moins, là, on est tranquille.
:~$ cat /proc/asound/cards
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xd1220000 irq 129

Bon signe.
:~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC236 Analog [ALC236
Analog]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 7: HDMI 1 [HDMI 1]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 8: HDMI 2 [HDMI 2]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 9: HDMI 3 [HDMI 3]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 10: HDMI 4 [HDMI 4]
Sous-périphériques: 1/1
Sous-périphérique #0: subdevice #0

Ça semble normal.
:~$ aplay /dev/random

Comme signalé, /dev/urandom est à préférer.
Je conseillerais un bon « export LC_MESSAGES=C » pour ne pas se farcir la
traduction approximative des termes techniques le temps de débugger.
J'imagine que tu as vérifié que le haut-parleur est branché sur la bonne
sortie ?
As-tu vérifié dans alsamixer que les sorties ne sont pas muettes ou
désactivés ? À tout hasard, la sortie de `amixer` serait intéressante.
Et en dernier recours, ajouter l'option -v à aplay. Ça nous dira exactement
à quelle sortie ça va.
Jo Engo
Le #26553263
Le Sun, 23 Aug 2020 11:22:19 +0200, Marc SCHAEFER a écrit :
aplay: pcm_write:2061: erreur en écriture: Appel système interrompu

D'un autre côté c'est le write qui buggue, bizarre.
Je n'ai ni erreur (avant d'avoir tapé ^C) ni son

même avec sudo dmesg ?

J'ai ça : [190107.433574] audit: type00 audit(1598018829.560:230):
apparmor="DENIED" operation="mknod" profile="/usr/bin/evince-thumbnailer"
name="/home/abdallah/.thumbnails/normal/
ed9f99521981725de4f7096351536f0f.png" pid85041 comm="evince-thumbnai"
requested_mask="c" denied_mask="c" fsuid00 ouid00
que je met pour mémoire et qui est antérieur à l'appel à aplay (j'ai
vérifié)

--
Quand on aime, ou bien l'on n'a point de peine, ou bien l'on aime
jusqu'à sa peine.
-+- Saint Augustin (354-430) -+-
Marc SCHAEFER
Le #26553269
Jo Engo
J'ai ça : [190107.433574] audit: type00 audit(1598018829.560:230):
apparmor="DENIED" operation="mknod" profile="/usr/bin/evince-thumbnailer"
name="/home/abdallah/.thumbnails/normal/
ed9f99521981725de4f7096351536f0f.png" pid85041 comm="evince-thumbnai"
requested_mask="c" denied_mask="c" fsuid00 ouid00
que je met pour mémoire et qui est antérieur à l'appel à aplay (j'ai
vérifié)

Ton evince-thumbnailer as essayé de faire un mknod (peut-être une pipe?
un lock-file?) sous /home/abdallah/.thumbnails/normal/ (je crois), c'est
app-armor qui râle.
Si cela n'a rien fait planter, laisse comme ça, sinon, une adaptation
du profile d'app-armor pour cette application pourrait être utile.
Voir aussi: https://bugs.launchpad.net/ubuntu/+source/evince/+bug/1798091
Toutefois rien à voir avec le problème courant.
Jo Engo
Le #26553273
Le Sun, 23 Aug 2020 09:41:47 +0000, Nicolas George a écrit :
J'imagine que tu as vérifié que le haut-parleur est branché sur la bonne
sortie ?

Ce sont les HP internes, je n'ai pas accès aux branchements. IL faudrait
que j'esssaie avec un casque.
As-tu vérifié dans alsamixer que les sorties ne sont pas muettes ou
désactivés ?

Oui.
À tout hasard, la sortie de `amixer` serait intéressante.

ça fait du monde !
$ amixer
Simple mixer control 'Master',0
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 87
Mono: Playback 84 [97%] [-2.25dB] [on]
Simple mixer control 'Headphone',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 87
Mono:
Front Left: Playback 85 [98%] [-1.50dB] [off]
Front Right: Playback 85 [98%] [-1.50dB] [off]
Simple mixer control 'Speaker',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right
Limits: Playback 0 - 87
Mono:
Front Left: Playback 84 [97%] [-2.25dB] [on]
Front Right: Playback 84 [97%] [-2.25dB] [on]
Simple mixer control 'PCM',0
Capabilities: pvolume
Playback channels: Front Left - Front Right
Limits: Playback 0 - 255
Mono:
Front Left: Playback 246 [96%] [-1.80dB]
Front Right: Playback 246 [96%] [-1.80dB]
Simple mixer control 'Mic Boost',0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 2 [67%] [20.00dB]
Front Right: 2 [67%] [20.00dB]
Simple mixer control 'IEC958',0
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'IEC958',1
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'IEC958',2
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'IEC958',3
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'IEC958',4
Capabilities: pswitch pswitch-joined
Playback channels: Mono
Mono: Playback [on]
Simple mixer control 'Capture',0
Capabilities: cvolume cswitch
Capture channels: Front Left - Front Right
Limits: Capture 0 - 63
Front Left: Capture 61 [97%] [28.50dB] [on]
Front Right: Capture 61 [97%] [28.50dB] [on]
Simple mixer control 'Auto-Mute Mode',0
Capabilities: enum
Items: 'Disabled' 'Enabled'
Item0: 'Enabled'
Simple mixer control 'Internal Mic Boost',0
Capabilities: volume
Playback channels: Front Left - Front Right
Capture channels: Front Left - Front Right
Limits: 0 - 3
Front Left: 2 [67%] [20.00dB]
Front Right: 2 [67%] [20.00dB]
Et en dernier recours, ajouter l'option -v à aplay. Ça nous dira
exactement à quelle sortie ça va.

$ aplay -v -f S16_LE -c 2 -r 48000 /dev/urandom
Playing raw data '/dev/urandom' : Signed 16 bit Little Endian, Rate 48000
Hz, Stereo
Plug PCM: Linear conversion PCM (S32_LE)
Its setup is:
stream : PLAYBACK
access : RW_INTERLEAVED
format : S16_LE
subformat : STD
channels : 2
rate : 48000
exact rate : 48000 (48000/1)
msbits : 16
buffer_size : 16384
period_size : 1024
period_time : 21333
tstamp_mode : NONE
tstamp_type : MONOTONIC
period_step : 1
avail_min : 1024
period_event : 0
start_threshold : 16384
stop_threshold : 16384
silence_threshold: 0
silence_size : 0
boundary : 4611686018427387904
Slave: Soft volume PCM
Control: PCM Playback Volume
min_dB: -51
max_dB: 0
resolution: 256
Its setup is:
stream : PLAYBACK
access : MMAP_INTERLEAVED
format : S32_LE
subformat : STD
channels : 2
rate : 48000
exact rate : 48000 (48000/1)
msbits : 32
buffer_size : 16384
period_size : 1024
period_time : 21333
tstamp_mode : NONE
tstamp_type : MONOTONIC
period_step : 1
avail_min : 1024
period_event : 0
start_threshold : 16384
stop_threshold : 16384
silence_threshold: 0
silence_size : 0
boundary : 4611686018427387904
Slave: Direct Stream Mixing PCM
Its setup is:
stream : PLAYBACK
access : MMAP_INTERLEAVED
format : S32_LE
subformat : STD
channels : 2
rate : 48000
exact rate : 48000 (48000/1)
msbits : 32
buffer_size : 16384
period_size : 1024
period_time : 21333
tstamp_mode : NONE
tstamp_type : MONOTONIC
period_step : 1
avail_min : 1024
period_event : 0
start_threshold : 16384
stop_threshold : 16384
silence_threshold: 0
silence_size : 0
boundary : 4611686018427387904
Hardware PCM card 0 'HDA Intel PCH' device 0 subdevice 0
Its setup is:
stream : PLAYBACK
access : MMAP_INTERLEAVED
format : S32_LE
subformat : STD
channels : 2
rate : 48000
exact rate : 48000 (48000/1)
msbits : 32
buffer_size : 16384
period_size : 1024
period_time : 21333
tstamp_mode : ENABLE
tstamp_type : MONOTONIC
period_step : 1
avail_min : 1024
period_event : 0
start_threshold : 1
stop_threshold : 4611686018427387904
silence_threshold: 0
silence_size : 4611686018427387904
boundary : 4611686018427387904
appl_ptr : 0
hw_ptr : 1084
… et toujours pas de son :(

--
Aux jeunes gens pour l'ordinaire
L'adresse et le savoir-faire
Valent mieux que des biens acquis.
-+- Charles Perrault, Le Chat botté, Moralité -+-
Jo Engo
Le #26553272
Le Sun, 23 Aug 2020 11:54:50 +0000, Jo Engo a écrit :
Front Left: Playback 85 [98%] [-1.50dB] [off]
Front Right: Playback 85 [98%] [-1.50dB] [off]

WTF ??

--
Il n'est pas nécessaire d'être gros pour être un gros con. Il suffit
d'être con.
-+- Philippe Geluck, Le chat -+-
Poster une réponse
Anonyme