Test de php4wd

Le
Pascal
bonjour
Après quelques tests, globalement la classe a l'air de bien fonctionner en
accès natif .
J'ai juste un problème de retour sur les champs vides qui contiennent :
Ø
et sur les caractères spéciaux qui eux ne sont pas correctement renvoyés :
JÚr¶me - Franþaise ect
Si les données transitent via une URL voir peut-être la fonction php
rawurlencode
fonction de la classe testées : Mysqlexec avec INSERT, SELECT, DELETE et
MysqlTable
avec un fichier de 150 enregistrements et 33 rubriques / enregistrement

J'ai essayé avec SQLmanagerX et là il a l'air d'avoir un problème sur les
requetes SELECT avec WHERE qui renvoient le nombre d'enregistrement -1

Bonne continuation

Pascal
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
William
Le #13288881
bonjour

--
JoindreWilliam at hotmail.com
C'est mon adresse mail et chat :-)

"Pascal" news:c76055$9l2$

J'ai essayé avec SQLmanagerX et là il a l'air d'avoir un problème sur les
requetes SELECT avec WHERE qui renvoient le nombre d'enregistrement -1



Si tu as mis effectivement Where dans la synthaxe c'est normal

William

Bonne continuation

Pascal






Firetox
Le #13288871
bonjour,

et sur les caractères spéciaux qui eux ne sont pas correctement renvoyés :
JÚr¶me - Franþaise ect...



je vais voir mais avec le script sur mon site
j'ai bien françois qui revient et qui est ecrit dans la base

J'ai essayé avec SQLmanagerX et là il a l'air d'avoir un problème sur les
requetes SELECT avec WHERE qui renvoient le nombre d'enregistrement -1


pas de souci avec ce code :
ADDR1:m_lnotes = "françois je fais un 'test"
ADDR1:SQLEcranVersTable()
ADDR1:SQLUpdate()

je vais regarer le script qui est en zip et celui que j'utilise sur mon site
en test

Bon dev
@+

"Pascal" c76055$9l2$
bonjour
Après quelques tests, globalement la classe a l'air de bien fonctionner en
accès natif .
J'ai juste un problème de retour sur les champs vides qui contiennent :
Ø
et sur les caractères spéciaux qui eux ne sont pas correctement renvoyés :
JÚr¶me - Franþaise ect...
Si les données transitent via une URL voir peut-être la fonction php
rawurlencode
fonction de la classe testées : Mysqlexec avec INSERT, SELECT, DELETE et
MysqlTable
avec un fichier de 150 enregistrements et 33 rubriques / enregistrement

J'ai essayé avec SQLmanagerX et là il a l'air d'avoir un problème sur les
requetes SELECT avec WHERE qui renvoient le nombre d'enregistrement -1

Bonne continuation

Pascal






Samuel MONTAGNE
Le #13288791
> bonjour,


Bonjour

> et sur les caractères spéciaux qui eux ne sont pas correctement renvoyés


:
> JÚr¶me - Franþaise ect...

je vais voir mais avec le script sur mon site
j'ai bien françois qui revient et qui est ecrit dans la base



J'ai également des pb avec les accents. Rien ne passe correctement

> J'ai essayé avec SQLmanagerX et là il a l'air d'avoir un problème sur


les
> requetes SELECT avec WHERE qui renvoient le nombre d'enregistrement -1
pas de souci avec ce code :
ADDR1:m_lnotes = "françois je fais un 'test"
ADDR1:SQLEcranVersTable()
ADDR1:SQLUpdate()

je vais regarer le script qui est en zip et celui que j'utilise sur mon


site
en test

Bon dev
@+

"Pascal" c76055$9l2$
> bonjour
> Après quelques tests, globalement la classe a l'air de bien fonctionner


en
> accès natif .
> J'ai juste un problème de retour sur les champs vides qui contiennent :
> Ø
> et sur les caractères spéciaux qui eux ne sont pas correctement renvoyés


:
> JÚr¶me - Franþaise ect...
> Si les données transitent via une URL voir peut-être la fonction php
> rawurlencode
> fonction de la classe testées : Mysqlexec avec INSERT, SELECT, DELETE et
> MysqlTable
> avec un fichier de 150 enregistrements et 33 rubriques / enregistrement
>
> J'ai essayé avec SQLmanagerX et là il a l'air d'avoir un problème sur


les
> requetes SELECT avec WHERE qui renvoient le nombre d'enregistrement -1
>
> Bonne continuation
>
> Pascal
>
>
>
>




William
Le #13288781
bonjour

Pour les accents pas de souci dans les champs, uniquement dans les lignes de
la table
William

--
JoindreWilliam at hotmail.com
Firetox
Le #13288771
ca y est j'ai compris pourqoui dans vos version ca marche pas

en fait il y a un petit bug :
il faut virer les oemversAnsi qui se trouve dans la classe php4Wd

ou alors retelecharger la version beta : j'ai fait les modifs
desolé

mais je comprenais pas pourquoi, car il a fallut que j'aille voir dans le
zip pour me rendre compte que j'avais laisser les oemVersAnsi enfin ......

voila

Bon dev
@+


"William" 40977e4c$0$27683$
bonjour

Pour les accents pas de souci dans les champs, uniquement dans les lignes


de
la table
William

--
JoindreWilliam at hotmail.com






William
Le #13288761
Re Firetox
vous avez recu mon mail ou pas pour une correction??

William

--
JoindreWilliam at hotmail.com
C'est mon adresse mail et chat :-)
"Firetox" news:c780h5$spc$
ca y est j'ai compris pourqoui dans vos version ca marche pas

en fait il y a un petit bug :
il faut virer les oemversAnsi qui se trouve dans la classe php4Wd

ou alors retelecharger la version beta : j'ai fait les modifs
desolé

mais je comprenais pas pourquoi, car il a fallut que j'aille voir dans le
zip pour me rendre compte que j'avais laisser les oemVersAnsi enfin ......

voila

Bon dev
@+


"William" 40977e4c$0$27683$
> bonjour
>
> Pour les accents pas de souci dans les champs, uniquement dans les


lignes
de
> la table
> William
>
> --
> JoindreWilliam at hotmail.com
>
>
>
>




Firetox
Le #13288751
oui j'ai repondu 2 fois


"William" 409788fd$0$27684$
Re Firetox
vous avez recu mon mail ou pas pour une correction??

William

--
JoindreWilliam at hotmail.com
C'est mon adresse mail et chat :-)
"Firetox" news:c780h5$spc$
> ca y est j'ai compris pourqoui dans vos version ca marche pas
>
> en fait il y a un petit bug :
> il faut virer les oemversAnsi qui se trouve dans la classe php4Wd
>
> ou alors retelecharger la version beta : j'ai fait les modifs
> desolé
>
> mais je comprenais pas pourquoi, car il a fallut que j'aille voir dans


le
> zip pour me rendre compte que j'avais laisser les oemVersAnsi enfin


......
>
> voila
>
> Bon dev
> @+
>
>
> "William" > 40977e4c$0$27683$
> > bonjour
> >
> > Pour les accents pas de souci dans les champs, uniquement dans les
lignes
> de
> > la table
> > William
> >
> > --
> > JoindreWilliam at hotmail.com
> >
> >
> >
> >
>
>




William
Le #13288741
Re
--
JoindreWilliam at hotmail.com
C'est mon adresse mail et chat :-)

"Firetox" news:c780h5$spc$
> ca y est j'ai compris pourqoui dans vos version ca marche pas
>
> en fait il y a un petit bug :
> il faut virer les oemversAnsi qui se trouve dans la classe php4Wd
>
> ou alors retelecharger la version beta : j'ai fait les modifs
> desolé
>
> mais je comprenais pas pourquoi, car il a fallut que j'aille voir dans


le
> zip pour me rendre compte que j'avais laisser les oemVersAnsi enfin


......
>
> voila
>
> Bon dev
> @+
>



Marche nikel sans les oemversansi

Merci
William
Samuel MONTAGNE
Le #13288731
> > ca y est j'ai compris pourqoui dans vos version ca marche pas


Merci d'avoir cherché !

> en fait il y a un petit bug :


Ca peut arriver

> il faut virer les oemversAnsi qui se trouve dans la classe php4Wd
>
> ou alors retelecharger la version beta : j'ai fait les modifs


J'aimerai bien mais le liens download > php4WD est mort (Comme de nombreux
autres liens, ce qui est bien domage)

> desolé


Y a pas de raison de l'être ;)
Firetox
Le #13288721
et sur www.SQLMAnagerX.com

partie windev / download
je viens de le telecharger

ou essayer directement ce lien :

http://www.sqlmanagerx.com/php4wd/php4wd.zip

Bon dev
@+


"Samuel MONTAGNE" c782bp$n4$
> > ca y est j'ai compris pourqoui dans vos version ca marche pas
Merci d'avoir cherché !

> > en fait il y a un petit bug :
Ca peut arriver

> > il faut virer les oemversAnsi qui se trouve dans la classe php4Wd
> >
> > ou alors retelecharger la version beta : j'ai fait les modifs
J'aimerai bien mais le liens download > php4WD est mort (Comme de nombreux
autres liens, ce qui est bien domage)

> > desolé
Y a pas de raison de l'être ;)




Publicité
Poster une réponse
Anonyme