Vivaldi et Google

Le
siger
Bonjour,

Google refuse Vivaldi 3.5 quand j'entre mes identifiants. Navigateur
non compatible :

"Pour protéger votre compte, Google ne vous autorise pas Í  vous
connecter Í  partir de certains navigateurs. Nous pouvons bloquer les
connexions depuis les navigateurs répondant aux caractéristiques
suivantes :

- Non compatibles avec JavaScript ou dans lesquels JavaScript est
désactivé
- Comportant des extensions non sécurisées ou non compatibles
- ContrÍ´lés automatiquement par un logiciel plutÍ´t que par une
personne
- Intégrés Í  une autre application"

Je ne vois rien Í  propos de JavaScript
Je n'ai pas ajouté d'extension depuis longtemps
Je ne suis pas sͻr de comprendre les 2 derniers points, mais je suppose
que je ne suis pas concerné.

--
siger
  • Partager ce contenu :
Vos réponses Page 1 / 3
Trier par : date / pertinence
rm
Le #26563447
Le mercredi 23 décembre 2020 Í  14:42, siger a écrit :
Bonjour,

Salut,
Google refuse Vivaldi 3.5 quand j'entre mes identifiants. Navigateur
non compatible :

Vérifie que c'est pas juste un délit de sale gueule (ça serait étonnant
puisque Vivaldi s'identifie, depuis un an au moins, exactement comme un
navigateur Google Chrome pour justement ne plus être discriminé sur des
sites Í  la con comme ça !).
Donc lance Vivaldi avec l'argument --user-agent="Mozilla/5.0 (Windows NT
6.1; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0" par exemple...
et retourne te connecter Í  Google avec ce faux Firefox.
Si ça fonctionne, Vivaldi n'y est pour rien Í  priori, c'est une mauvaise
détection de User-Agent, et avec Google ça sera ni la première, ni la
dernière. Contacte leur support technique pour voir...
@+
--
rm - https://fr.vivaldi.net
siger
Le #26563457
rm vient de nous annoncer :
Le mercredi 23 décembre 2020 Í  14:42, siger a écrit :
Bonjour,

Salut,
Google refuse Vivaldi 3.5 quand j'entre mes identifiants. Navigateur
non compatible :

Vérifie que c'est pas juste un délit de sale gueule (ça serait étonnant
puisque Vivaldi s'identifie, depuis un an au moins, exactement comme un
navigateur Google Chrome pour justement ne plus être discriminé sur des
sites Í  la con comme ça !).
Donc lance Vivaldi avec l'argument --user-agent="Mozilla/5.0 (Windows NT
6.1; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0" par exemple...

J'écris ça o͹ ?
--
siger
rm
Le #26563458
Le mercredi 23 décembre 2020 Í  22:19, siger a écrit :
rm vient de nous annoncer :
Le mercredi 23 décembre 2020 Í  14:42, siger a écrit :
Bonjour,

Salut,
Google refuse Vivaldi 3.5 quand j'entre mes identifiants. Navigateur
non compatible :

Vérifie que c'est pas juste un délit de sale gueule (ça serait étonnant
puisque Vivaldi s'identifie, depuis un an au moins, exactement comme un
navigateur Google Chrome pour justement ne plus être discriminé sur des
sites Í  la con comme ça !).
Donc lance Vivaldi avec l'argument --user-agent="Mozilla/5.0 (Windows NT
6.1; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0" par exemple...

J'écris ça o͹ ?

Dans le champ cible d'un raccourci lançant déjÍ  un vivialdi.exe sous
Windows
ou
en ligne de commande (cmd.exe)
ou
dans le champ "Exécuter" de Windows (Touche Win+R)
si tu préfères lancer Vivaldi comme ça :
vivaldi.exe --user-agent="Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:86.0)
Gecko/20100101 Firefox/86.0"
--
rm - https://fr.vivaldi.net
siger
Le #26563535
rm avait énoncé :
Le mercredi 23 décembre 2020 Í  14:42, siger a écrit :
Bonjour,

Salut,
Google refuse Vivaldi 3.5 quand j'entre mes identifiants. Navigateur
non compatible :

Vérifie que c'est pas juste un délit de sale gueule (ça serait étonnant
puisque Vivaldi s'identifie, depuis un an au moins, exactement comme un
navigateur Google Chrome pour justement ne plus être discriminé sur des
sites Í  la con comme ça !).
Donc lance Vivaldi avec l'argument --user-agent="Mozilla/5.0 (Windows NT
6.1; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0" par exemple...
et retourne te connecter Í  Google avec ce faux Firefox.
Si ça fonctionne, Vivaldi n'y est pour rien Í  priori, c'est une mauvaise
détection de User-Agent, et avec Google ça sera ni la première, ni la
dernière. Contacte leur support technique pour voir...

Ça marche. Il y a dÍ» y avoir un changement avec la v3.5 car ça marchait
avant. Ce qui, bien sͻr, n'innocente pas Google...
--
siger
rm
Le #26563559
Le jeudi 24 décembre 2020 Í  18:58, siger a écrit :
rm avait énoncé :
Le mercredi 23 décembre 2020 Í  14:42, siger a écrit :
Bonjour,

Salut,
Google refuse Vivaldi 3.5 quand j'entre mes identifiants. Navigateur
non compatible :

Vérifie que c'est pas juste un délit de sale gueule (ça serait étonnant
puisque Vivaldi s'identifie, depuis un an au moins, exactement comme un
navigateur Google Chrome pour justement ne plus être discriminé sur des
sites Í  la con comme ça !).
Donc lance Vivaldi avec l'argument --user-agent="Mozilla/5.0 (Windows NT
6.1; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0" par exemple...
et retourne te connecter Í  Google avec ce faux Firefox.
Si ça fonctionne, Vivaldi n'y est pour rien Í  priori, c'est une mauvaise
détection de User-Agent, et avec Google ça sera ni la première, ni la
dernière. Contacte leur support technique pour voir...

Ça marche. Il y a dÍ» y avoir un changement avec la v3.5 car ça marchait
avant. Ce qui, bien sͻr, n'innocente pas Google...

Tu as peut-être testé le client mail de Vivaldi avec un compte Google sans
passer par l'authentification imposée par Google pour considérer qu'une
application est assez sécurisée pour lui... Donc, si tu accèdes avec cette
version Í  des serveurs IMAP/SMTP de GMail, il aura sÍ»rement identifié, je
ne sais trop comment mais on lui fait confiance pour ça, Vivaldi comme
étant une application pas sécurisée, d'o͹ peut-être un traitement
particulier du User-Agent en question (bien que le client mail lui-même ne
s'identifie pas encore auprès des serveurs de mail et que le navigateur
possède un User-Agent chromé).
--
rm - https://fr.vivaldi.net
Sergio
Le #26563560
Le 25/12/2020 Í  17:51, rm a écrit :
Le jeudi 24 décembre 2020 Í  18:58, siger a écrit :
Tu as peut-être testé le client mail de Vivaldi avec un compte Google sans
passer par l'authentification imposée par Google pour considérer qu'une
application est assez sécurisée pour lui... Donc, si tu accèdes avec cette
version Í  des serveurs IMAP/SMTP de GMail, il aura sÍ»rement identifié, je
ne sais trop comment mais on lui fait confiance pour ça, Vivaldi comme
étant une application pas sécurisée, d'o͹ peut-être un traitement
particulier du User-Agent en question (bien que le client mail lui-même ne
s'identifie pas encore auprès des serveurs de mail et que le navigateur
possède un User-Agent chromé).

Il suffit de le dire dans son compte Gmail... C'est aussi valable pour Thunderbird !
--
Serge http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
siger
Le #26563563
Dans son message précédent, rm a écrit :
Le jeudi 24 décembre 2020 Í  18:58, siger a écrit :
rm avait énoncé :
Le mercredi 23 décembre 2020 Í  14:42, siger a écrit :
Bonjour,

Salut,
Google refuse Vivaldi 3.5 quand j'entre mes identifiants. Navigateur
non compatible :

Vérifie que c'est pas juste un délit de sale gueule (ça serait étonnant
puisque Vivaldi s'identifie, depuis un an au moins, exactement comme un
navigateur Google Chrome pour justement ne plus être discriminé sur des
sites Í  la con comme ça !).
Donc lance Vivaldi avec l'argument --user-agent="Mozilla/5.0 (Windows NT
6.1; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0" par exemple...
et retourne te connecter Í  Google avec ce faux Firefox.
Si ça fonctionne, Vivaldi n'y est pour rien Í  priori, c'est une mauvaise
détection de User-Agent, et avec Google ça sera ni la première, ni la
dernière. Contacte leur support technique pour voir...

Ça marche. Il y a dÍ» y avoir un changement avec la v3.5 car ça marchait
avant. Ce qui, bien sͻr, n'innocente pas Google...

Tu as peut-être testé le client mail de Vivaldi avec un compte Google

Je n'ai pas testé le clien mail de Vivaldi :-)
--
siger
rm
Le #26563565
Salut,
Le vendredi 25 décembre 2020 Í  18:09, Sergio a écrit :
Le 25/12/2020 Í  17:51, rm a écrit :
Le jeudi 24 décembre 2020 Í  18:58, siger a écrit :

Tu as peut-être testé le client mail de Vivaldi avec un compte Google sans
passer par l'authentification imposée par Google pour considérer qu'une
application est assez sécurisée pour lui... Donc, si tu accèdes avec cette
version Í  des serveurs IMAP/SMTP de GMail, il aura sÍ»rement identifié, je
ne sais trop comment mais on lui fait confiance pour ça, Vivaldi comme
étant une application pas sécurisée, d'o͹ peut-être un traitement
particulier du User-Agent en question (bien que le client mail lui-même ne
s'identifie pas encore auprès des serveurs de mail et que le navigateur
possède un User-Agent chromé).

Il suffit de le dire dans son compte Gmail... C'est aussi valable pour Thunderbird !

Oui, j'ai vu que Thunderbird supportait l'authentification Google via OAuth
et n'avait donc pas besoin forcément de passer pour "une application moins
sécurisée".
Je teste GMail avec Opera M2 depuis toujours, si ma mémoire est bonne, et
jamais j'ai eu Í  supporter ces popups Web (OAuth) pour faire de l'IMAP ou
du SMTP sur serveur _mail_ de Google. Opera n'est même pas déclaré comme
appli pas sécurisée et la seule action que Google m'a imposé il y a bien
longtemps, a été d'activer l'IMAP sur son site GMail (et le POP, puisque je
testais ça aussi).
Ma réponse Í  siger n'était qu'une hypothèse pour expliquer, peut-être, la
discrimination via User-Agent que certains utilisateurs de Vivaldi doivent
encore supporter sur certains sites Google :)
--
rm - https://fr.vivaldi.net
rm
Le #26563564
Le vendredi 25 décembre 2020 Í  22:42, siger a écrit :
Dans son message précédent, rm a écrit :
Le jeudi 24 décembre 2020 Í  18:58, siger a écrit :
rm avait énoncé :
Le mercredi 23 décembre 2020 Í  14:42, siger a écrit :
Bonjour,

Salut,
Google refuse Vivaldi 3.5 quand j'entre mes identifiants. Navigateur
non compatible :

Vérifie que c'est pas juste un délit de sale gueule (ça serait étonnant
puisque Vivaldi s'identifie, depuis un an au moins, exactement comme un
navigateur Google Chrome pour justement ne plus être discriminé sur des
sites Í  la con comme ça !).
Donc lance Vivaldi avec l'argument --user-agent="Mozilla/5.0 (Windows NT
6.1; Win64; x64; rv:86.0) Gecko/20100101 Firefox/86.0" par exemple...
et retourne te connecter Í  Google avec ce faux Firefox.
Si ça fonctionne, Vivaldi n'y est pour rien Í  priori, c'est une mauvaise
détection de User-Agent, et avec Google ça sera ni la première, ni la
dernière. Contacte leur support technique pour voir...

Ça marche. Il y a dÍ» y avoir un changement avec la v3.5 car ça marchait
avant. Ce qui, bien sͻr, n'innocente pas Google...

Tu as peut-être testé le client mail de Vivaldi avec un compte Google

Je n'ai pas testé le clien mail de Vivaldi :-)

Donc je n'ai strictement aucune explication au fait que Google refuse la
connexion avec Vivaldi (déguisé, par défaut/dépit, en Google Chrome !) et
l'accepte quand tu déguises manuellement le même Vivaldi en Firefox :-D
Si le support technique de Google te donne une réponse un jour, je serais
curieux de la connaitre ^_^
--
rm - https://fr.vivaldi.net
MELMOTH
Le #26563566
siger a formulé ce vendredi :
Je n'ai pas testé le clien mail de Vivaldi :-)

Il fonctionne farpaitement, Ma Foi...
Poster une réponse
Anonyme